Subject: CALSCH Action Items

From: Doug Royer <[email-masked]>
Date: Sun, 16 Jan 2000 00:00:03 -0800 (PST)

This is a list of action items for the CALSCH Working Group.
This list will be sent out once a week and updated as often
as practical (That means if I am not available it may take
an extra week or two before you see your changes).

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked] .

There are three parts to this action list:

	(W) Working group action items.
	(C) CAP editor action items.
	(I) iCalendar action items (Frank Dawson)

Each action item will be assigned a unique ID that will aid in
tracking the items.

------------------------------------------------------------------------------

			Working Group Action Items   

Where Resolution is one of:

	U - undecided.
	Y - Chair determined consensus is in favor of the proposal.
	N - Chair determined consensus is NOT in favor of the proposal.
	D - Dropped. Chair has decided that it may never reach consensus.

 The following are a list of proposals and their status in the WG:
 
 WG Action Item					Resolution
 --------------					----------

 W-1 CAP Use HTTP as transport			N
 
 W-2 CAP If all booked and scheduled		U
     appointments are in same table
 
 W-3 CAP Use SASL as authentication method	Y
 
 W-4 Add UID and COUNTER to VFREEBUSY		N 

 W-5 CAP Should CAPABILITY reply be sent	N
     as result of successful AUTHENTICATE
     and IDENTITY 

 W-6 Do we need to handle 'unscheduled
     event' as described by the SKI project?	N

 W-7 CAP Auto-logout Timer issues		
      Do we need one?				Y
      How long?					<variable>
      Can the server decide not to do this?	Y
  
 W-8 CAP Bounded Latency Issues			D
     <there were issues - I can't remember
     them>

 W-9 CAP MOVE method. Issues with VCARs.	U
     [see note in CAP 7.2.1.5]
 
 W-10 CAP Text mandatory in all response	N
      codes
 
 W-11 CAP Text optional in response codes	Y
      (some response codes may have 
       mandatory data that follows)
       
 W-12 CAP Should parts of response code be	Y
      separated by ';'
      
 W-13 CAP Store Schema				U
 
 W-14 CAP VEVENT Schema				U
 
 W-15 CAP VTODO Schema				U
 
 W-16 CAP VJOURNAL Schema			U
 
 W-17 CAP VCAR Schema				U

 W-18 CAP UPN definition, including anonymous	U
      user and how UPN's are used in LDAP and
      certificates.
 
 W-19 CAP Group definitions, dynamic and	U
      static and how groups are used in VCARs.
      Policy definitions, in a VCAR format.

 W-20 Associating UPN values with CREATED	U
      and LAST-MODIFIED properties.

 W-21 CAP Get/Set calendar user properties	N

 W-22 VTIMEZONE and IANA			U

 W-23 CAP Calendar property to allow/disallow	U
      overlapped booking OPAQUE entries?

 W-24 CAP Calendar CHARSET property issues	U

 W-25 Remove MUST from UID in 4.8.4.7		Y

 W-26 Write/Submit information draft/rfc	Y

 W-27 How a query can specify if the recurrence	Y
      rules are to be expanded by the CS.

 W-28 Cal-Props - PATH				U
      (CAP-00 - 12.2)
      Will there need to be one?		U
      Optional?					U

 W-29 Import/Export				U

 W-30 Transport protocol name (transport vs	U
      application layer)

 W-31 NOOP command?				U

 W-32 NOOP advisory only?			U

 W-33 Should DISCONNECT be called QUIT?		U

 W-34 Format following error codes. Are		U
      they well defined? If not they
      need to be machine determinable. 

------------------------------------------------------------------------------

 The following are a list of action items for the CAP draft editors:
 
 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------
	
 C-1 Remove unused definitions				N

 C-2 Fix up changes in authentication		Alex	N
     text as commented on the list		Paul

 C-3 Text for 2.7 [Finding CAP Servers]		Doug	N
 
 C-4 VCAR examples				Doug?	N
 
 C-5 PUBLISH text
 
 C-6 REQUEST text
 
 C-7 REPLY text

 C-8 ADD text
 
 C-9 CANCEL text 
 
 C-10 REFRESH text
 
 C-11 COUNTER text
 
 C-12 DECLINECOUNTER Text

 C-13 Post CAP-00.txt					Y

 C-14 Redo state diagram to include STARTTLS
      and IDENTIFY command.

 C-15 Document the 'CALMASTER' calendar property

 C-16 (2.11)  Query Schema

	I'll send this out next week.

 C-17 (7.2.1.5) MOVE Method

	More text needed - Who?

 C-18 (12.1) Calendar Store Properties

	Editors note. (Per W-27)

 C-19 (12.2) SCHEDULABLE-HOURS

	Format? Text needs to be written.

 C-20 (13.) Security Considerations

	See editors note - more text.

------------------------------------------------------------------------------

 The following are a list of action items for the iCalendar-2 draft:

 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------

 I-1 MIME alternate/related			Frank	?
     MUST be supported.

 I-2 Remove ordering of properties and		Frank	?
     parameters in draft.

 I-3 S/MIME and RFC1847.			U
     [CAP] 2.2.3

------------------------------------------------------------------------------

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked]

--------------------------------------------------------------------------
Work: [email-masked]              Home    801 Woodside Rd #14-244
      530 E. Montecito St.                 Office: Redwood City, CA 94061
      Santa Barbara, CA 93103
      805-957-1790 x541                    Personal Email: [email-masked]

---

From: David Madeo <[email-masked]>
Date: Fri, 21 Jan 2000 18:14:36 -0500

As some of you may have noticed, Paul Hill of MIT is hosting a CAP
editors meeting next week in Boston.  In an effort to make the time
there as productive as possible and properly involve the mailing list,
I'd like to suggest that we work out the agenda for the meeting NOW and
on the list.  

Doug Royer's list of action items appears to be the best starting
point.  I've removed any "N" or "D" entries from the list.  I have a
question about the "Y"'s  Can we differentiate between the Y's which are
done and the Y's which are not done?

For the rest, I've gone through and indicated either my personal 
interest level or a position on each of the U's.  The number in
parantheseis is a ranking of whether it should be on the agenda in
Boston (1 = yes, 2 = maybe, 3 = later)  The fundamental question is what
will it take to resolve the "U"'s into "Y|N" and then turn that into CAP
text.

If everyone on the list can help by replying to this message and putting
your own levels of interest/positions down, we can pick an agenda that's
worth doing and start identifying who should be stepping up to the
plate.

Thanks,

dmadeo

>  WG Action Item                                 Resolution

dmadeo - not interested

>      [see note in CAP 7.2.1.5]

dmadeo - interested (1)

>  W-16 CAP VJOURNAL Schema                       U

dmadeo - not interested (yet)

>       user and how UPN's are used in LDAP and

dmadeo - interested (2)

>       Policy definitions, in a VCAR format.

dmadeo - interested (2)

>       and LAST-MODIFIED properties.

dmadeo - interested (2)

>  W-22 VTIMEZONE and IANA                        U

dmadeo - interested (2)

>       overlapped booking OPAQUE entries?

dmadeo -  Yes (1) 

>  W-24 CAP Calendar CHARSET property issues      U

dmadeo - not interested unless its not UTF-8

>       Will there need to be one?                U

dmadeo - not interested

>  W-29 Import/Export                             U

dmadeo - interested (1) 

>  W-30 Transport protocol name (transport vs     U

dmadeo - interested (3) 

>  W-32 NOOP advisory only?                       U

dmadeo - interested (3) 

>  W-33 Should DISCONNECT be called QUIT?         U

dmadeo - not interested

>       need to be machine determinable.

dmadeo - not interested

>  Draft Action Item                              Who     Done (Y/N)

Didn't Steve Mansour already do this?