Subject: Re: XML DTD update proposition

From: Michael Krivoruchko <[email-masked]>
Date: Fri, 07 Jan 2000 21:44:25 +0000

Frank:

> I agree with you (and so has the mailing list) that the alternative XML representation for standard
> iCalendar doesn't make much sense, since conformant iCalendar products will understand the standard
> format. After all, multiple representations will present interoperability problems. We may want to take this
> to a XML iCalendar mailing list. I can ask IMC if they would host this.
>

Probably no one CUA will use XML to talk CS. Why we need additional
coding for the same functionality which we have got from iCalendar native
data format parser anyway. More over, you are right, the interoperability
issues could rise.

> This just doesn't make sense. No one would think about redefining in XML the RFC822 address data
> type (i.e., "MAILTO:" local part "@" domain part). After all this is a part of an IETF standard. Like wise,
> it doesn't make much sense to create new formats for already existing proposed standards for iCalendar
> data model components.
>

Surprise! I need such kind of decomposition of URL. Why? Users are lazy.
They type only "local part" and press "Send" button. Than mailer has to
parse the address and find out is it complete. We can receive the same
result using XML parser for nothing:
<MAILTO><local-part>misha</local-part></MAILTO>

The question is: When to stop? It is possible to represent an integer as
an array of digits. It does not sounds good even to me. ;-)

Seriously. XML without native iCalendar data types could be quite useful
when CU want to save something (event, to-do,...) locally in a file and than
use some non-iCalendar XML tool to add these data, say, to weekly report.
Such scenario sounds to me quite possible, but "save as..." is CUA
functionality and, perhaps, you are right, it should not be discussed here.
Only thing I am worry about is: each CUA will define own DTD for iCalendar
data.

Michael

--
---------------------------------------------------------------
Michael Krivoruchko                 CDE Group, Sun Microsystems
    Bool House, East Point Business Park, Dublin 3, Ireland
Ph: +353 1 819 9272               E-mail: [email-masked]
---------------------------------------------------------------

---

From: "Greg FitzPatrick" <[email-masked]>
Date: Tue, 18 Jan 2000 10:15:52 +0100

Frank 

How are we doing on this?  Sounds like a very good idea (necessity).  Have you talked to Paul about this - do you want me to do it?

I have the entire SKiCal draft in a DTD/Schema  and I am really in need of agile minds to volley with.

Greg

> We may want to take this