Subject: Re: SEQUENCE number on recurrences

From: [email-masked]
Date: Tue, 15 Feb 2000 12:26:59 -0500

Doug:
Agree that the recurrence instance has changed. So, the SEQUENCE value for 
the instance would be monotonically incremented. But it is a leap, in my 
mind, to say that the SEQUENCE for any of the other instances MUST also be 
incremented.
I say the specification is correct. It is ambiguous about the other 
instances, which means "implementation dependent".
-- Frank

---

From: Doug Royer <[email-masked]>
Date: Tue, 15 Feb 2000 09:53:06 -0800 (PST)

> From: [email-masked]
> Subject: Re: SEQUENCE number on recurrences
> Date: Tue, 15 Feb 2000 12:26:59 -0500
> 
> Doug:

There is only ONE component. So if you (or anyone) could please
send me a VEVENT that has TWO sequence numbers, one for the
old value and the other for the new instance that has changed.

I could see how a component could exist with TWO VEVENTS, one
with an EXDATE or EXRULE. The other with METHOD:ADD and the
new DTSTART. However BOTH would have changed, so both would
need sequence numbers, the old one with the new EXDATE/EXRULE,
and the new one.

But how could you ever show it on the wire if only one instance
had a new DTSTART, and the sequence number did not change?

I really do not see how one could ever be describe it in iCalendar
without the entire objects sequence number being changed.

> instances, which means "implementation dependent".

Perhaps when I see how it would look on the wire I could agree.

---

From: [email-masked]
Date: Tue, 15 Feb 2000 13:25:24 -0500

Doug:
Why do you say there is only one component?
How do you know that the recurrence isn't composed of an initial REQUEST 
and a subsequent ADD to add in the recurrence?
Plus, why do you make the assumption that recurring events aren't stored 
as separate components?
Certainly, neither iCalendar nor iTIP presume this. CAP drafts don't 
presume this, do they. So where do we have the dogma that recurring 
calendar components MUST BE defined by a single calendar component?
-- Frank