Subject: SEQUENCE number on recurrences

From: [email-masked] (Steve Mansour)
Date: Mon, 14 Feb 2000 16:38:45 -0800

Folks,

Say that you create a recurring event. Now let's say that you update the
DTSTART value of a single instance of that recurring event. Do you need
to bump the sequence number of just the single instance you changed or
do you bump the sequence number for all instances?

I wasn't clear on this after reading the Sequence Number text in RFC
2445.

-Steve

---

From: Doug Royer <[email-masked]>
Date: Tue, 15 Feb 2000 08:46:45 -0800

> I wasn't clear on this after reading the Sequence Number text in RFC

Ether way the component as a whole is not the same. It would need a new sequence
number.
As I recall, you were going to expand the instances and then store them, however
that
is not iCalendar, its just your storage method.

The object instance changed, and via iTIP you would need to be able to tell
something
important changed.

-Doug

---

From: [email-masked] (Steve Mansour)
Date: Tue, 15 Feb 2000 11:22:49 -0800

Doug Royer wrote:

> number. As I recall, you were going to expand the instances and then store them,
> however that is not iCalendar, its just your storage method.

Right. Some implementations will expand, some will not. The question is, what does
it look like? It should look the same to a client regardless of the implementation.

Let's say that the recurrence rule expanded to 3 instances to keep things simple.
When we create the event initially, we have:

     Instance 1  Sequence 0
     Instance 2  Sequence 0
     Instance 3  Sequence 0

Now, I make a change to instance number 2, that would cause its sequence number to
bump up to 1.  If a client now asked for ALL instances of the event, what should it
should it be?  I see two possibilities:

     Instance 1  Sequence 0
     Instance 2  Sequence 1
     Instance 3  Sequence 0

or

     Instance 1  Sequence 1
     Instance 2  Sequence 1
     Instance 3  Sequence 1

Which one should it be?

> something important changed.

yep. So, when I resend the updated event, which of the two options above is correct?

-Steve