Subject: Re: SEQUENCE number on recurrences

From: [email-masked]
Date: Tue, 15 Feb 2000 13:35:56 -0500

First component to set a Thursday PR telecon:
BEGIN:VCALENDAR
...
METHOD:REQUEST
BEGIN:VEVENT
DTSTART:20000217T160000Z
DTEND:20000217T170000Z
SUMMARY:Press Conference
UID:123
ORGANIZER:[email-masked]
ATTENDEE;RSVP=FALSE:[email-masked]
END:VEVENT
END:VCALENDAR
Second component to add a Friday follow-on:
BEGIN:VCALENDAR
...
METHOD:ADD
BEGIN:VEVENT
DTSTART:20000218T160000Z
DTEND:20000218T170000Z
SUMMARY:Press Conference
UID:123
SEQUENCE:1
ORGANIZER:[email-masked]
ATTENDEE;RSVP=FALSE:[email-masked]
END:VEVENT
END:VCALENDAR
Third component to change the time of Friday's follow-on:
BEGIN:VCALENDAR
...
METHOD:REQUEST
BEGIN:VEVENT
DTSTART:20000217T170000Z
DTEND:20000217T173000Z
SUMMARY:Press Conference
UID:123
RECURRENCE-ID:20000217T170000Z
SEQUENCE:2
ORGANIZER:[email-masked]
ATTENDEE;RSVP=FALSE:[email-masked]
END:VEVENT
END:VCALENDAR
At this point (read Frank with green face, I now agree!) all of the 
recurrence instances for VEVENT, UID:123, RECURRENCE-ID:whatever have 
SEQUENCE:2. Any iTIP for this VEVENT with a SEQUENCE < 2 will be stale and 
can be ignored.
We had discussed this precise case when progressing iTIP. Thanks for the 
patience, Doug!
-- Frank

---

From: [email-masked] (Steve Mansour)
Date: Tue, 15 Feb 2000 11:29:14 -0800

So, to summarize, the sequence number is always the same for all
instances, and it must always be the highest sequence number. Right?

-Steve

[email-masked] wrote:

> SEQUENCE:2. Any iTIP for this VEVENT with a SEQUENCE < 2 will be stale
> and can be ignored.
>
> We had discussed this precise case when progressing iTIP. Thanks for
> the patience, Doug!
>
> -- Frank
>
>