Subject: Re: Simple Constraints between Events?

From: [email-masked]
Date: Sun, 21 May 2000 21:44:20 -0400

Manuel:
The RELATED-TO property is intended to show relationships between calendar 
events. For example:
BEGIN:VCALENDAR
VERSION:2.0
blah, blah..
BEGIN:VEVENT
UID:123
RELATED-TO;RELTYPE=CHILD:321
DTSTART:20000521T133000Z
DTEND:20000521T143000Z
blah, blah..
END:VEVENT
BEGIN:VEVENT
UID:321
RELATED-TO;RELTYPE=PARENT:123
DTSTART:20000521T200000Z
DTEND:20000521T210000Z
blah, blah..
END:VEVENT
can be used to show that the event 123 is the parent of event 321 and 
event 321 is the child of event 123.
According to RFC2445, "Change sto a calendar component referenced by this 
property can have an implicit impact on the related calendar component. 
For example, if a group event changes its start or end date or time, the 
the related, dependent events will need to have their start and end dates 
changed in a corresponding way.
So, I think that this is what you want.
However, you may have more relationship implications that you want to 
convey than is codified in RFC2445 within this property.
-- Frank

---

From: [email-masked]
Date: Mon, 22 May 2000 11:21:31 -0400

Greg FitzPatrick wrote, in part:
>This property resembles the
>RELATED-TO;RELTYPE=parent property of RFC-2445, but that property
>defines a relationship between calendar objects and not between
>events themselves.

RELATED-TO specifies a relationship between calendar components (i.e., 
VEVENT, VTODO, VJOURNAL). Isn't this the same semantics as this new SkiCal 
property? I am confused.
-- Frank