Subject: CALSCH Action Items

From: Doug Royer <[email-masked]>
Date: Sun, 30 Jul 2000 00:00:05 -0700 (PDT)

This is a list of action items for the CALSCH Working Group.
This list will be sent out once a week and updated as often
as practical (That means if I am not available it may take
an extra week or two before you see your changes).

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked] .

There are three parts to this action list:

	(W) Working group action items.
	(C) CAP editor action items.
	(I) iCalendar action items (Frank Dawson)

Each action item will be assigned a unique ID that will aid in
tracking the items.

------------------------------------------------------------------------------

			Working Group Action Items   

Where Resolution is one of:

	U - undecided.
	Y - Chair determined consensus is in favor of the proposal.
	N - Chair determined consensus is NOT in favor of the proposal.
	D - Dropped. Chair has decided that it may never reach consensus.

 The following are a list of proposals and their status in the WG:
 
 WG Action Item					Resolution
 --------------					----------

 W-1 CAP Use HTTP as transport			N
 
 W-2 CAP If all booked and scheduled		Y
     appointments are in same table
 
 W-3 CAP Use SASL as authentication method	Y
 
 W-4 Add UID and COUNTER to VFREEBUSY		N 

 W-5 CAP Should CAPABILITY reply be sent	N
     as result of successful AUTHENTICATE
     and IDENTITY 

 W-6 Do we need to handle 'unscheduled
     event' as described by the SKI project?	N
     (In CAP - 'N', SKI to be a seperate
      project/draft as it will effect
      RFC2445,6,7)

 W-7 CAP Auto-logout Timer issues		
      Do we need one?				Y
      How long?					<variable>
      Can the server decide not to do this?	Y
  
 W-8 CAP Bounded Latency Issues			D
     <there were issues - I can't remember
     them>

 W-9 CAP MOVE method. Issues with VCARs.	Y
     [see note in CAP 7.2.1.5]
 
 W-10 CAP Text mandatory in all response	N
      codes
 
 W-11 CAP Text optional in response codes	Y
      (some response codes may have 
       mandatory data that follows)
       
 W-12 CAP Should parts of response code be	Y
      separated by ';'
      
 W-13 CAP Store Schema				Y
 
 W-14 CAP VEVENT Schema				Y
 
 W-15 CAP VTODO Schema				Y
 
 W-16 CAP VJOURNAL Schema			Y
 
 W-17 CAP VCAR Schema				Y

 W-18 CAP UPN definition, including anonymous	Y
      user and how UPN's are used in LDAP and
      certificates.
 
 W-19 CAP Group definitions, dynamic and	Y
      static and how groups are used in VCARs.
      Policy definitions, in a VCAR format.

 W-20 Associating UPN values with CREATED	N
      and LAST-MODIFIED properties.

 W-21 CAP Get/Set calendar user properties	N

 W-22 VTIMEZONE and IANA			Y in process

 W-23 CAP Calendar property to allow/disallow	N
      overlapped booking OPAQUE entries?

 W-24 CAP Calendar CHARSET property issues	Y

 W-25 Remove MUST from UID in 4.8.4.7		Y

 W-26 Write/Submit information draft/rfc	Y

 W-27 How a query can specify if the recurrence	Y
      rules are to be expanded by the CS.

 W-28 Cal-Props - PATH				N
      (CAP-00 - 12.2)
      Will there need to be one?		N
      Optional?					N

 W-29 Import/Export				Y - sync only

 W-30 Transport protocol name (transport vs	Y
      application layer)

 W-31 NOOP command?				Y

 W-32 NOOP advisory only?			Y

 W-33 Should DISCONNECT be called QUIT?		U

 W-34 Format following error codes. Are		Y
      they well defined? If not they
      need to be machine determinable. 

 W-35 Move DNS and SLP to seperate draft?	Y

------------------------------------------------------------------------------

 The following are a list of action items for the draft editors:
 
 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------
	
 C-1 Remove unused definitions				N

 C-2 Fix up changes in authentication		Alex	Y
     text as commented on the list		Paul

 C-3 Text for 2.7 [Finding CAP Servers]		Doug	D
 
 C-4 VCAR examples				Doug?	Y
 
 C-5 PUBLISH text					Y
 
 C-6 REQUEST text					Y
 
 C-7 REPLY text						Y

 C-8 ADD text						Y
 
 C-9 CANCEL text 					Y
 
 C-10 REFRESH text					Y
 
 C-11 COUNTER text					Y
 
 C-12 DECLINECOUNTER Text				Y

 C-13 Post CAP-00.txt					Y

 C-14 Redo state diagram to include STARTTLS		Y
      and IDENTIFY command.

 C-15 Document the 'CALMASTER' calendar property	Y

 C-16 (2.11)  Query Schema				Y

 C-17 (7.2.1.5) MOVE Method

	More text needed - Who?

 C-18 (12.1) Calendar Store Properties			Y

	Editors note. (Per W-27)

 C-19 (12.2) SCHEDULABLE-HOURS				D

	Format? Text needs to be written.

 C-20 (13.) Security Considerations			Y

	See editors note - more text.

 C-21 Resubmit REQUIREMENTS draft.			Y
 
------------------------------------------------------------------------------

 The following are a list of action items for the iCalendar-2 draft:

 Draft Action Item				Who	Done (Y/N)
 -----------------				---	----------

 I-1 MIME alternate/related			Frank	?
     MUST be supported.

 I-2 Remove ordering of properties and		Frank	?
     parameters in draft.

 I-3 S/MIME and RFC1847.			U
     [CAP] 2.2.3

 I-4 Add ALARMID to VALARM ?			Y

------------------------------------------------------------------------------

Updates should be sent to mailto:[email-masked] or to myself
mailto:[email-masked]

--------------------------------------------------------------------------
Work: [email-masked]              Home    801 Woodside Rd #14-244
      530 E. Montecito St.                 Office: Redwood City, CA 94061
      Santa Barbara, CA 93103
      805-957-1790 x541                    Personal Email: [email-masked]

---

From: [email-masked]
Date: Mon, 31 Jul 2000 10:56:54 -0400

> I-1 MIME alternate/related Frank               ?

Doug:
I have mentioned this before, but it has not been corrected in the Action 
Items yet. This is not an iCalendar item. This is an iTIP and iMIP item. 
The RFC2445 just specifies a format definition and text/calendar MIME 
media type registration. However, this requirement is germaine to the iTIP 
and iMIP specs. 
This Action Item should be changed to an iTIP/iMIP action item. FYI.
-- Frank