Subject: Re: Registration of text/calendar MIME property GEO_BOUNDS

From: [email-masked]
Date: Mon, 21 Aug 2000 17:31:42 -0400

Doug in part wrote:
>> Most of the time, yes.  Are there any weird cases out there, with
>> overlapping time zones? For example, a country where some
>> religious minority doesn't observe DST; then which time zone you
>> want will depend on the user's religion.
>
>Correct time zones can overlap. If you get > 1, choose.

I was with ya up until the "If you get > 1, choose" bit.  This is a recipe for interop disaster/nightmare.  If I use CUA 1 I 
get 1 set of date/times and if I use CUA 2 to view the same entry I get 
another because it guessed differently?!?  Argh!  Dont do it!! 

Propose a methodology to resolve this so we dont have another multipart/* 
scenario on our hands at the next CalConnect.  Otherwise this just adds 
mud to the water instead of filtering the interop waters...

Bruce
===========================================================================
Bruce Kahn                                INet: [email-masked]
Iris Associates                          Phone: 978.392.5335
Westford, MA, USA 01886                    FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Doug Royer <[email-masked]>
Date: Mon, 21 Aug 2000 15:24:00 -0700

[email-masked] wrote:
> I was with ya up until the "If you get > 1, choose" bit.  This is a
> recipe for interop disaster/nightmare.  If I use CUA 1 I get 1 set of
> date/times and if I use CUA 2 to view the same entry I get another
> because it guessed differently?!?  Argh!  Dont do it!!

As you recall from RFC2445-7, a VTIMEZONE MUST be included
in a VCALENDAR when any component uses a TZID.

Adding GEO_BOUNDRY simply specifies (if included) in addition to
what alredy MUST be sent, the physical boundry of the TZID
supplied.

The only time a user must choose is when a CUA would query a CS
to get a TZID or list of TZID's to use. If they get > 1, then
the CU or CUA chooses which TZID MUST be sent
with the object. One VTIMEZONE for each unique TZID.

I have not proposed eliminating a VTIMEZONE as a MUST
in a VCALENDAR.