Subject: Re: CAP Restriction Table: CREATE

From: [email-masked] (Steve Mansour)
Date: Thu, 31 Aug 2000 20:56:33 -0700

[email-masked] wrote:

>
> Second quick observation:
>
> VALARM               0
>
>    RESPONSE-STATUS  0       if not creating a calendar
>                     1+      if creating a calendar
>
> Why is 1+ creating a calendar if it is in a VALARM?  I think this is a
> typo (or Im just not groking vAlarms anymore).

The indentation is wrong and the order is reversed. What it's trying to
say is that there are 0 VALARMs in the response.  Then, disjoint and
separate, there may be one or more RESPONSE-STATUS values if you create
a calendar.

This is better:

     Component/Property  Presence Comment
     ------------------- --------
     --------------------------------------

     VCALENDAR            1+
     TARGET               1

     VERSION              1       MUST be 2.0

     CMDID                0 or 1  MUST be returned if the request
     contained
                                  a CMDID

     RESPONSE-STATUS      0       if not creating a calendar
                          1+      if creating a calendar

     VALARM               0

     VCAR                 0+
       RESPONSE-STATUS    1+
       *                  0       No other VCAR properties are
     present

     VCOMMAND             0

     VEVENT               0+
       RESPONSE-STATUS    1+
       *                  0       No other VEVENT properties are
     present

etc.

As I look at it, there's probably another mistake. Since VALARMs can be
in VEVENTs and VTODOs, we should probably allow one or more
RESPONSE-STATUS values to come back.  So VEVENT should probably look
like this:

     VEVENT               0+
       RESPONSE-STATUS    1+
       *                  0       No other VEVENT properties are
     present
       VALARM             0+
         RESPONSE-STATUS  1+
         *                0       No other VEVENT properties are
     present

Man, we really need something to show the indent levels. It's getting
pretty hard to follow.

-Steve

---

From: [email-masked]
Date: Fri, 1 Sep 2000 14:14:18 -0400

>> Man, we really need something to show the indent levels. It's getting 
pretty hard to follow

Can we number the tables so that indents then can show up as subsets.

I.e.        1.0  Vcommand
              1.1 Vquery
                1.1.1

etc. etc.....
___________________
Patricia Egen Consulting
www.egenconsulting.com
423-875-2652