Subject: iTIP Common Component Restriction Tables

From: [email-masked]
Date: Wed, 6 Sep 2000 14:10:40 -0400

In doing some more technical diving on the RFCs I ran across an apparent 
oversight (gasp!).  In particular, in 3.1 Common Component Restriction Tables I found:

   Component/Property  Presence
   ------------------- ----------------------------------------------
   CALSCALE            0 or 1
   PRODID              1
   VERSION             1       Value MUST be "2.0"
   X-PROPERTY          0+

Of the 4 'root level' properties defined in RFC 2445, 3 are listed along 
with X-PROPERTY.  It seems we forgot to include METHOD.  Im not sure if 
this is an oversight or if there were technical reasons for it (I dont 
recall any) so I would like to add a new line to the table in the update 
that we are compiling:

   METHOD              0 or 1

Any disagreement?

Bruce
===========================================================================
Bruce Kahn                                INet: [email-masked]
Iris Associates                          Phone: 978.392.5335
Westford, MA, USA 01886                    FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: [email-masked] (Steve Mansour)
Date: Wed, 06 Sep 2000 21:14:52 -0700

Yipes!

Well it turns out that METHOD is actually called out explicitly in each
of the restriction tables for the methods. But I see no problem in
adding the line stating that there can be 0 or 1 method.

Hey wait. Isn't METHOD always present?  Can anyone think of a situation
in iTIP where it's not?

-Steve

[email-masked] wrote:

>
> In doing some more technical diving on the RFCs I ran across an
> apparent oversight (gasp!).  In particular, in 3.1 Common Component
> Restriction Tables I found:
>
> Of the 4 'root level' properties defined in RFC 2445, 3 are listed
> along with X-PROPERTY.  It seems we forgot to include METHOD.  Im not
> sure if this is an oversight or if there were technical reasons for it
> (I dont recall any) so I would like to add a new line to the table in
> the update that we are compiling:
>
>    METHOD              0 or 1
>
> Any disagreement?
>
> Bruce
>
> ==========================================================================
>