Subject: CAP 10: delete-vreply ABNF omission

From: [email-masked]
Date: Fri, 24 Jan 2003 13:59:00 -0500

In looking at the new draft 10 12-Jan-2003 I noticed that the ABNF for 
delete-vreply is incomplete:

delete-vreply  = "BEGIN" ":" "VREPLY" CRLF
                 deleted-id
                 request-status
                 "END" ":" "VREPLY" CRLF

                ; Where the id is appropriate for the 
                ; type of object deleted:
                ;
                ; VAGENDA = calid
                ; VCAR = carid
                ; VEVENT, VFREEBUSY, VJOURNAL, VTODO = uid
                ; VQUERY = queryid
                ; ALARM = sequence
                ; x-component = x-id
                ;
deleted-id    = ( calid / carid / uid / uid dtstamp
               / queryid / tzid / sequence / x-id )

the comment for delete-vreply should include:

                ; VTIMEZONE = tzid

Also, its unclear when a delete-id of uid dtstamp would be used so is that 
cruft or is there some case Im not seeing?

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: Doug Royer <[email-masked]>
Date: Fri, 24 Jan 2003 12:42:07 -0700

> the comment for delete-vreply should include:

Thanks

> Also, its unclear when a delete-id of uid dtstamp would be used so is 
> that cruft or is there some case Im not seeing?

When deleting an instance. I'll add text.

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: [email-masked]
Date: Mon, 27 Jan 2003 16:36:55 -0500

> When deleting an instance. I'll add text.

Umm, wouldn't you use the RECURRENCE-ID to identify the target instance 
instead (along w/the UID, etc)??  The DTSTAMP is only good for identifying 
the date-time stamp that the object was written out.

Bruce

---

From: Doug Royer <[email-masked]>
Date: Mon, 27 Jan 2003 16:18:26 -0700

[email-masked] wrote:
> instead (along w/the UID, etc)??  The DTSTAMP is only good for 
> identifying the date-time stamp that the object was written out.

Yes :-)

Let me think more and search the archives. I seem
to remember a conversation that added it. I think
it was Patrice that started the thread.

--