Subject: error in rfc2445 (fwd)

From: Libby Miller <[email-masked]>
Date: Wed, 22 Jan 2003 14:38:00 +0000 (GMT)

A friend not on this list noticed this apparent error.
is there an errata document for RFC 2445, or is it updated?

Libby

---------- Forwarded message ----------
Date: Wed, 22 Jan 2003 15:33:33 +0100
From: Max Froumentin <[email-masked]>
To: [email-masked]
Subject: error in rfc2445

RFC1445 says:

> UNTIL= must be followed by enddate (4.3.10)
>
> 2223:                ( ";" "UNTIL" "=" enddate ) /
>
> 2253:     enddate    = date
> 1899:     date               = date-value
> 1901:     date-value         = date-fullyear date-month date-mday

But the prose (line 2341) and all the examples show that UNTIL= must
followed by a date-time:

> UNTIL=19980404T070000Z

Is this an error?

Max.

---

From: Andrea Campi <[email-masked]>
Date: Thu, 23 Jan 2003 14:03:27 +0100

> is there an errata document for RFC 2445, or is it updated?

RFC2445 has this text:

     enddate    = date
     enddate    =/ date-time            ;An UTC value

So, while I think this is a typo (the 'endate =' part on the second
line), the intent is quite clear:

     enddate    = date / date-time

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A. - BT Ignite                  http://www.inet.it
Technical Dept. - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy