Subject: When to specify TARGET property

From: "Mike Higginbottom" <[email-masked]>
Date: Mon, 20 Jan 2003 14:34:30 -0000

I'm just trying to get to grips with CAP and am not sure how 'drafty' the current draft is since I seem to be finding quite a few inconsistencies which I can't resolve.  Quoting from Doug's recent posting of cap-12-jan-2003

<quote>

8.36 TARGET Property

   Property Name: TARGET

   Purpose: This property defines the container that the command that is
   issued will act upon.  Its value is a capurl as defined in Section 5.
   The "TARGET" property MUST BE supplied when the CUA sends a command
   to the CS.

</quote>

which seems to imply the TARGET property must be supplied for ABORT commands for example.  Is this correct?

Regards

Mike Higginbottom

---

From: Doug Royer <[email-masked]>
Date: Mon, 20 Jan 2003 12:58:11 -0700

Mike Higginbottom wrote:
> I'm just trying to get to grips with CAP and am not sure how 'drafty' 
> the current draft is since I seem to be finding quite a few 
> inconsistencies which I can't resolve.

PLEASE post - thanks!

   Quoting from Doug's recent
> posting of cap-12-jan-2003
>  
> <quote>
>  
> 8.36 TARGET Property
>  
>    Property Name: TARGET
>  

Good point - I'll tweak the text. I do not think it is needed
with the ABORT command.

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: "Mike Higginbottom" <[email-masked]>
Date: Mon, 20 Jan 2003 23:12:06 -0000

----- Original Message -----
From: "Doug Royer" <[email-masked]>
To: <[email-masked]>
Sent: Monday, January 20, 2003 7:58 PM
Subject: Re: When to specify TARGET property

> > inconsistencies which I can't resolve.
Will do.  Just wanted to check that there are still errors like this in the
document rather than it just being my lack of a grasp of the content.  There
are also some trivial typos.  Shall I post these direct to you off list
rather than causing pollution for little gain?

> Good point - I'll tweak the text. I do not think it is needed
Ditto some other commands.  IMO, the only commands that require a TARGET
property are CREATE, DELETE, MODIFY, MOVE and SEARCH.  REPLY commands
require a TARGET property only if the original request command required one
(e.g. a REPLY to a CREATE command does but not a REPLY to an ABORT command).

Regards

Mike Higginbottom

---

From: [email-masked]
Date: Wed, 22 Jan 2003 16:27:28 -0500

> Good point - I'll tweak the text. I do not think it is needed

The cited text is at odds with the actual ABNF in the draft:

2.  Additions to iCalendar:
...
calprops   = 2*(

           ; 'prodid' and 'version' are both REQUIRED,
           ; but MUST NOT occur more than once.
           ;
             prodid /version /

           ; These are optional, but MUST NOT occur
           ; more than once.
           ;
             calscale        /
             method          /
             cmd             /

           ; These are optional, and may occur more
           ; than once.
           ;
             target / other-props

Thus TARGET is optional for all commands according to this ABNF, not 
required.  Striking the cited line is probably the right thing to do.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...