Subject: DTD on the draft

From: "Benjamin Sonntag" <[email-masked]>
Date: Thu, 9 Jan 2003 17:38:00 +0100 (CET)

Hi all,

I found some problems/remarks in the latest CAP draft. Can you please
check/confirm/modify ?
---------------------------------------------------
1. the CAP DTD seems to be incorrect (or just outdated...) :

<!ATTLIST modify (max-time?,select,add,delete,update)>
<!ATTLIST modify id %CMDID; #IMPLIED>

<!ELEMENT itip (max-time?,data)>
<!ATTLIST itip id %CMDID; #IMPLIED>

should be replaced by :

<!ELEMENT modify (max-time?,select,add,remove,update)>
<!ATTLIST modify id %CMDID; #IMPLIED>

<!ELEMENT schedule (max-time?,target+,data)>
<!ATTLIST schedule id %CMDID; #IMPLIED>

- the 'add' element is not defined at all (this is a sub-element of
modify) ! And there is no example of this element in 6.2.4.3 (modify
command).
- the max-result and max-size elements (used by the search CAP command)
are not defined in the search command paragraph (6.2.4.5). We don't know
how it works, and there is no example.
- in 6.1.1 (generateuid command), there is the following example :
   C: MSG 1 5 . 2837 60
   C: Content-Type: application/beep+xml
   C:
   C: <generateuid num=5/>
   C: END

XML attributes MUST be enclosed with ' or " :
(as specified in XML Specifications)

   C: MSG 1 5 . 2837 60
   C: Content-Type: application/beep+xml
   C:
   C: <generateuid num="5"/>
   C: END

(note : this error appears in other places in the draft)

- in 6.2.4.1 (create command), the example is :

(...)
   C: --boundary-foo321
   C: Content-Type: application/beep+xml
   C: Content-ID: [email-masked]
   C:
   C: <create id="creation01">
(...)
   C: --boundary-foo321
   C: Content-Type: text/calendar
   C: Content-ID: [email-masked]
   C:
   C: BEGIN:VCALENDAR
(...)

RFC822 says that Content-ID MUST be enclosed in < > so the correct example
MUST be :
(...)
   C: --boundary-foo321
   C: Content-Type: application/beep+xml
   C: Content-ID: <[email-masked]>
   C:
   C: <create id="creation01">
(...)
   C: --boundary-foo321
   C: Content-Type: text/calendar
   C: Content-ID: <[email-masked]>
   C:
   C: BEGIN:VCALENDAR
(...)

(note : ALL the content-id in CAP are incorrect...)

- in 6.2.4.3 (modify command), the example is incorrect :

   C: <modify id="modify01"/>
   C:    <select>
(...)
   C:    <update remove-missing=false>
   C:       <data content="cid:[email-masked]"/>
   C:    </update>
   C: </modify>

on line 1 :  <modify /> the / is irrelevant ...
(I don't check the other examples)

---------------------------------------------------
2. I think that the DTD is not very clear (when a human read it) :
  - Elements that corresponds to CAP commands may be separated from
  sub-elements. (create,modify,delete visually separated from max-result,
  target,data...)  - 'CAP request' element can be separated from 'CAP answer' elements.
  (create,delete,modify separated from request-status, error...)
Today, all the elements are in a random order in the DTD. I can send you a
'human compliant' version if you want. This will allow a more clean
reading of this document. It is not very important, but this kind of
document should be easy to read (I am developping a CAP server, that's why
I found this DTD hard to read.).

--
Regards,

Benjamin Sonntag
<[email-masked]>

---

From: Doug Royer <[email-masked]>
Date: Thu, 09 Jan 2003 10:18:29 -0700

Where did you get this DTD? It is not in the CAP draft or the xCal draft?

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: "Benjamin Sonntag" <[email-masked]>
Date: Thu, 9 Jan 2003 18:34:02 +0100 (CET)

> Where did you get this DTD? It is not in the CAP draft or the xCal

http://calsch.org/ietf/cap.html#cap_dtd

--
Cordialement,

Benjamin Sonntag
<[email-masked]>

---

From: Doug Royer <[email-masked]>
Date: Thu, 09 Jan 2003 11:30:46 -0700

The latest released is (not that it is better or not):
	
	http://www.ietf.org/internet-drafts/draft-ietf-calsch-many-xcal-02.txt

I have set the REPLY-TO to the xCal mailing list.

> http://calsch.org/ietf/cap.html#cap_dtd

-- http://www.ietf.org/internet-drafts/draft-ietf-calsch-many-xcal-02.txt

---

From: John Stracke <[email-masked]>
Date: Fri, 10 Jan 2003 09:25:22 -0500

>http://calsch.org/ietf/cap.html#cap_dtd
Ah--I think that's from when we had a misunderstanding about BEEP;
someone revised the draft on the assumption that using BEEP meant we had
to encode CAP in XML.  We're no longer doing that; we're back to using
text/calendar.

-- 
/==============================================================\
|John Stracke      [email-masked]                       |
|Principal Engineer|http://www.centive.com                     |
|Centive           |My opinions are my own.                    |
|==============================================================|
|Never mind the GUIs--Unix won't be for the masses until we fix|
|backspace & delete.                                           |
\==============================================================/

---

From: "Benjamin Sonntag" <[email-masked]>
Date: Fri, 10 Jan 2003 23:51:50 +0100 (CET)

Hi,

DAMNED !!!

Why the calsch.org web site is so outdated ???
Is it an OFFICIAL page about CAP or not ?
If it is not, is there an official website ?

I'm quite angry ...

> someone revised the draft on the assumption that using BEEP meant we
> had to encode CAP in XML.  We're no longer doing that; we're back to
> using text/calendar.

I did not heard about it in the list, nor in the latest cap draft in
calsch.org (I thought the latest was here...)
--
Regards,

Benjamin Sonntag
<[email-masked]>