Subject: Re: iTIP REPLY question

From: "Preston Stephenson" <[email-masked]>
Date: Thu, 24 Apr 2003 13:57:18 -0600

Thanks for your response.

I just want to make sure I understand.
CUA1 (Organizer) creates the METHOD:REQUEST in the CS (calendar store)
for CUA2 (Attendee).
CUA2 processes the request and puts the reply in the CS of CUA1.
He can put it there directly if the URI is CAP or he can send the reply
with iMIP if the URI is a MAILTO address.

This model would also work for the VFREEBUSY REQUEST.
The reply VFREEBUSY REPLY is placed back in the Organizer's CS.

Thanks.
Preston

>>> [email-masked] 4/24/2003 1:32:32 PM >>>

Preston Stephenson wrote:
> I need a clarification on where the iTIP REPLY object is created in
a
> reply to an iTIP REQUEST in CAP.
> 
> Given CUA1 with CS1 and CUA2 with CS2.
> 
> CUA1 creates a METHOD:REQUEST object for CUA2 in CS2.
> CUA2 reads the METHOD:REQUEST object in CS2.
> CUA2 creates the METHOD:REPLY object for CUA1.
> 
> In which CS is the METHOD:REPLY object created, CS1 or CS2?

Nether, it is created in CUA2.

> The iMIP logic says it gets sent back to CS1. There is no way for
iMIP
> to get the reply back from CUA2 in any other way than for CUA2 to
send
> the REPLY back in an email message.

If the ORGANIZER property in the REQUEST is a CAP uri, then CUA2
deposits
the REPLY into CS1. If the ORGANIZER property is a mailto uri,
then CUA2 e-mail's the REPLY to that e-mail address.

> In CAP there is a CARID:REQUESTONLY VCAR to deposit METHOD:REQUEST
> objects in another CUA's CS.
> There is also the CARID:UPDATEPARTSTATUS VCAR to update PARTSTAT
> information.
> 
> How do I get the rights to place METHOD:REPLY objects in another
CUA's
> CS?

They must give it to you in advance. If they have not given you the
rights to deposit a REPLY into their CS, then they broke iTIP - ignore
them
and throw away the REQUEST.

It is possible that they want you to connect anonymously.

> How do I access the other CS?

If the ORGANIZER property is a CAP uri, then open a connection
to that uri.

> If I have to create METHOD:REPLY objects in my own CS and have other
> people query for METHOD:REPLY objects then that breaks the
functionality
> with iMIP. iTIP is suppose to be transport independent, so I would
> expect the METHOD:REPLY to back in CS1.

No query needed from CUA1 into CS2. It is a push model.

-- 

  Doug Royer                     |   http://INET-Consulting.com 
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: [email-masked]
Date: Thu, 24 Apr 2003 22:23:11 +0200 (MET DST)

Personen ni söker har avslutat sin anställning på Safe-Care. Vill ni komma i kontakt med oss når ni oss på [email-masked].

---

From: [email-masked]
Date: Fri, 25 Apr 2003 19:22:05 +0200 (MET DST)