Subject: Re: CAP & busytime? - CUA-BOT

From: "Preston Stephenson" <[email-masked]>
Date: Tue, 01 Apr 2003 14:20:04 -0700

In section 2.2 of the CAP spec. it says: "All scheduling operations
(and) are as define(d) in [iTIP]. This memo makes no changes to any of
the workflow described in [iTIP]." I implied by that I could do the iTIP
functionality of returning the iTIP VFREEBUSY REPLY in the reply of the
CAP create of the iTIP VFREEBUSY REQUEST. I have the problem that I
can't store/save free/busy information.
 
Separate question. I don't understand the first sentence. Should it be
"All scheduling operations are as defined in [iTIP]."?
Thanks.
 
Preston Stephenson
[email-masked]

>>> [email-masked] 4/1/2003 1:45:04 PM >>>

Preston Stephenson wrote:
> I'm confused.
> Doesn't the iTIP spec say that the response to the VFREEBUSY REQUEST
is
> the VFREEBUSY REPLY with the FREEBUSY information?
> 
> Is the following the way CAP is suppose to work then?
>    CAP can't return the VFREEBUSY REPLY in response to the VFREEBUSY
> REQUEST.
>    CAP can only return success or failure of the creation of the
> VFREEBUSY REQUEST.
>    The CUA would need to use CAP to search for the VFREEBUSY REPLY
> using the UID returned from the VFREEBUSY REQUEST at a later time?

CAP can save VFREEBUSY objects.
CAP can fetch VFREEBUSY objects.

How the objects themselves get populated is not part of
the CUA <-> CS protocol - CAP.

I agree it would be nice to automate the creation of
VFREEBUSY objects in the CS. However this WG  has not
yet specified how this is done. It is not specified in
the CUA <-> CS protocol - CAP.

-- 

  Doug Royer                     |   http://INET-Consulting.com 
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards

---

From: Doug Royer <[email-masked]>
Date: Tue, 01 Apr 2003 15:41:06 -0700

> can't store/save free/busy information.

You can store all iTIP messages in a CS. Including VFREEBUSY. They
have methods so they are stored in the UNPROCESSED state waiting
like all other UNPROCESSED iTIP messages for a CUA to act on them.

With a CUA-BOT, then you can have it automatically respond to METHOD:REQUEST
for VFREEBUSY and other iTIP messages.

> "All scheduling operations are as defined in [iTIP]."?

Yes - thanks.

--