Subject: Re: How do you get the METHOD property on a SEARCH

From: "Preston Stephenson" <[email-masked]>
Date: Mon, 07 Apr 2003 07:05:05 -0600

I'm still a little confused.
On the query, I used an ID on the SEARCH command.
How do I match up multiple VCALENDAR objects to one SEARCH command
VCALENDAR object?
How do I know there are multiple REPLY commands with the same ID?
How do I know when there won't be any more REPLY commands to the one
ID?
Thanks.
Preston

>>> Andrea Campi <[email-masked]> 4/7/2003 2:48:31 AM >>>
Hi all,

first of all: I'm replying considering just my experience and
my interpretation, I didn't check archives.

On Thu, Apr 03, 2003 at 02:36:12PM -0700, Preston Stephenson wrote:
> I have two users with two CUA's, CUA1 and CUA2.
> 
> CUA1 creates a VEVENT with METHOD:REQUEST in CUA2's calendar.
> How does CUA2 get the METHOD property with that VEVENT?
> The search logic only returns VEVENT's.
> How do you associate the METHOD with the VEVENT since it is outside
the
> VEVENT?
> 
> For example in section 6.1.1.18 there is the query:
>    BEGIN:VQUERY
>    QUERYID:Fetch VEVENT and VTODO iTIP components
>    QUERY:SELECT * FROM VEVENT WHERE
>    STATE() = 'UNPROCESSED'
>    QUERY:SELECT * FROM VTODO WHERE
>    STATE() = 'UNPROCESSED'
>    END:VQUERY
> 
> The query would return the VEVENT's and the VTODO's.
> 

This query looks appropriate to me, yes. I'd expect the CAP to
reply with something like:

BEGIN:VCALENDAR
METHOD:REQUEST
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

BEGIN:VCALENDAR
METHOD:REPLY
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

and so on.

So you have all the information you need; it's your choice how to
keep that information around.

Bye,
    Andrea

-- 
Andrea Campi                              mailto:[email-masked] 
I.NET S.p.A. - BT Ignite                  http://www.inet.it 
Technical Dept. - R&D              phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019              fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Mon, 07 Apr 2003 10:31:14 -0600

> How do I match up multiple VCALENDAR objects to one SEARCH command

If the original command contained 'ID=xxx' then
they contain 'CMD;ID=xxx:REPLY'.

In draft...-10:

            reply-cmd    = replyparam ":" "REPLY"

           replyparam   = *(

                      ; The 'id' parameter value MUST BE exactly the
                         ; same as the value sent in the original
                         ; CMD property. If the original CMD did
                         ; not have an 'id' parameter, then the 'id'
                         ; MUST NOT be supplied in the REPLY.

                         id-param

                         ; the following is optional,
                         ; and MAY occur more than once

                         / other-params

                         )

 > How do I know when there won't be any more REPLY commands to the one

It is valid ABNF to include multiple VCALENDAR objects as one
MIME body part. It is specified in 2445. We have not modified that
syntax. So, then can be in the same MIME body part

Or:

I for one do not see it as a problem to just keep reading until the
end of the BEEP exchange. When the BEEP exchange is done, you have
all of the replies.

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards