Subject: RE: CAP & busytime? - not CAP reqirement - CUA-BOT

From: "Preston Stephenson" <[email-masked]>
Date: Wed, 02 Apr 2003 06:06:44 -0700

5
Preston

>>> "Paul B. Hill" <[email-masked]> 4/1/2003 4:04:02 PM >>>

OK, we're up to 4. Keep those "votes" coming :)

-----Original Message-----
From: [email-masked] 
[mailto:[email-masked]]On Behalf Of Dan Winship
Sent: Tuesday, April 01, 2003 4:58 PM
To: [email-masked] 
Subject: Re: CAP & busytime? - not CAP reqirement - CUA-BOT

On Tue, 2003-04-01 at 14:58, Doug Royer wrote:
> [email-masked] wrote:
>
>
> > The only reasonble source for keeping the VFREEBUSY accurate is to
have
> > it done by the CS as changes are made to the calendar.  _Assuming_
that
> > an unspecified "Bot" mechanism  is the way that it should/would/MAY
be
> > done is NOT sufficient here if we want that key functionality in
CAP.
> >  CAP 1.0 needs to provide that basic functionality in it or we
severly
> > risk loosing user adoption.
>
> Need told me and Pat repeated that we can not add features to CAP
> unless 20 people on this list insist tht it must be done.

Well, I agree with Bruce, so there's 2...

-- Dan

---

From: [email-masked]
Date: Thu, 3 Apr 2003 17:07:55 -0500

On 4/1/2003 Doug started a sub-thread with the claim that busytime is NOT 
a requirement of CAP (See Subject above).

This is NOT true.  The CAP requirements on this are pretty clear:

4.5.1   Lookup

   CAP MUST specify, subject to access control:
...
     - How the CUA can retrieve all the free/busy data for a calendar.

and

4.5.3   Specific Queries

   These are specific scenarios required by calendaring operations which
   may require special attention to ensure that they can be done with
   the querying and lookup functionality of CAP.

   CAP MUST allow, subject to access control:
...
     - The CUA to discover conflicts given a list of calendars and a
     time period

       This feature is to allow the CUA to schedule a group of
       attendees for a meeting at a particular time; the CUA MUST be
       able to find out if those attendees are free at that time. 

Perhaps I misinterpreted them but I dont think so.  So far Ive heard 2 
different answers how to query for busytime.  Yet there is no text in CAP 
to satisfy this requirement. 

I think there should be some prose added so that the way to do busytime 
lookups is 100% unambiguious and that all CUAs implement it the same way 
("Remember Multipart!!").   So far Ive seen ~5 votes for this too (wake up 
your ~290 others out there!)

The rest of the flurry of late seems to dive on who should be responsible 
for the busytime information and on that the CAP requirements seem to have 
a hole in them.  There is a requirement to be able to query for busytime 
and there is a deferral of busytime rollup that Doug did mentinoed:

4.5.5   Deferred Requirements for Search

   CAP is not required to specify:

     - How to roll up free/busy information for a number of calendars
     (perhaps sub-calendars) into a single free/busy component.

However there seems to be 1 oversight in the CAP requirements: WHO is 
responsible for maintaining busytime data? 

So far the majority of comments seem to concur that dynamic busytime 
generation is the way to go but Doug has maintained that its the CUAs job 
or a combination of the CUA and some unspecified CS mechanism.  I for one 
think that we need to step back, take a deep breath (or sigh) and refocus 
on first issue: There is no text in CAP 1.0 to fulfill the requirements 
above. 

Then I think we need to fix the oversight on busytime maintenance and get 
that in to CAP 1.0 and not leave it for interpretation by each reader. 
Only then can we expect successful interoperabilty using CAP.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: [email-masked]
Date: Fri, 4 Apr 2003 10:24:28 -0500

Ok, we're up to 7 people.  That is an all time record for votes.  Cool. 

Now, on to what we do.  I know our AD said only if 20 people responded 
would we be allowed to "resurface" a problem. 
I'm making an executive decision here and re-opening this topic.  It 
appears it may indeed be an issue and broken in the spec. 
 However, that being said, I'd like to put a deadline on how quickly we 
get it resolved. 
So....., stepping into the pit of alligators.....I'd like to see this 
resolved, with text, within the next two weeks. 
I think that's doable.  Anyone care to try to start this off.

Martin Jackson <[email-masked]>
Sent by: [email-masked]
04/03/2003 14:45

        To:     ietf-calendar <[email-masked]>
        cc: 
        Subject:        Re: Fw: CAP & busytime? - not CAP reqirement - CUA-BOT

7

Martin Jackson

On Thu, 2003-04-03 at 16:49, [email-masked] wrote:
> 6
> Tom Ransdell
> 
> ----- Forwarded by Robert Ransdell/Westford/IBM on 04/03/2003 10:46 AM
> -----
> "Preston Stephenson"
> <[email-masked]>
> Sent by:
> [email-masked]
> 
> 04/02/2003 08:06 AM
>                To
> "<"
>                cc
> 
>           Subject
> RE: CAP &
> busytime? - not
> CAP reqirement -
> CUA-BOT
> 
> 
> 
> 
> 5 
> Preston
> 
> [mailto:[email-masked]]OnBehalf Of Dan Winship
> > > an unspecified "Bot" mechanism  is the way that it
> should/would/MAY be
-- 
Martin Jackson <[email-masked]>

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.