Subject: [Ietf-calsify] Umlaute in Organizer field

From: camerost at exchange.microsoft.com (Cameron Stillion)
Date: Thu Jul 28 08:56:02 2005

I'm looking into this, but if you have ical samples with variously encoded non-ascii characters, I'd be very happy to take attachments that will help my investigation.

Thanks,

cameron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Helge Hess
Sent: Thursday.28.July.2005 07.40
To: Reinhold Kainhofer
Cc: [email-masked]; Till Adam
Subject: Re: [Ietf-calsify] Umlaute in Organizer field

On Jul 28, 2005, at 16:03, Reinhold Kainhofer wrote:
>> Are you absolutely sure that the utf-8 charset is listed on the 
>> invitation?
> Sorry, I don't understand this. The invitation (the iCalendar part
> itself)
> doesn't list any encoding, it's by default in utf-8.

The encoding of the invitation is the encoding given in the mime-type of the mail message as for all text/* MIME types. In the case of Outlook 2002 this is:
---snip---
Content-Type: text/calendar; method=REQUEST;
	charset="utf-8"
---snap---
I'm not sure what takes precedence if no charset is specified (iCal default or MIME default), which is why you should always specify the encoding explicitly.

> The encoding of the message is the crucial thing here. Outlook doesn't 
> like it if the message is 8bit, but with 7bit you can't use umlauts at 
> all...

Don't know what you mean by that. If you can only use ASCII at the transport (as usual with SMTP) you would just need to apply some content-transfer encoding (QP or base64).

Notably OL 2002 uses 8bit:
---snip---
Content-Transfer-Encoding: 8bit
---snap---

>> Have you tried doing the reverse? i.e. create an event in Outlook 
>> where the organiser or an attendee's name contains non-ascii and see 
>> how Outlook 'exports' that to iCalendar?
> Outlook simply doesn't send the CN in that case... Which is bad if the 
> email address doesn't tell you the name of the person.

I've tried with Outlook 2002 and it sends the CN, with one major bug.

It does both:

a) properly encode the CN in the To/From header
---snip---
From: "Guizmo G" <[email-masked]>
To: "=?utf-8?B?SMO2bGdlIEhlw58=?=" <[email-masked]>
---snap---
This is really base64 encoded UTF-8 (checked with recode).

b) embed the CN in the iCalendar request:
---snip---
BEGIN:VEVENT
ATTENDEE;CN="H?lge He?
([email-masked])";ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO: 
[email-masked]
ORGANIZER:MAILTO:[email-masked]
---snap---
BUT: even though OL specifies the content to be UTF-8, it actually sends the iCalendar body in Latin-1 ...

So, how do you like that? ;->

Greets,
   Helge
--
http://docs.opengroupware.org/Members/helge/
OpenGroupware.org

_______________________________________________
Ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

---

From: helge.hess at opengroupware.org (Helge Hess)
Date: Thu Jul 28 09:04:41 2005

On Jul 28, 2005, at 17:53, Cameron Stillion wrote:
> I'm looking into this, but if you have ical samples with variously 
> encoded non-ascii characters, I'd be very happy to take attachments 
> that will help my investigation.

Attached is a .zip containing one meeting request sent by OL 2002 
(incorrect body encoding) and another one with Evolution 2.0 (proper 
UTF-8 encoding).

The CN with umlauts used is
   "H?lge He?"

In HTML entity encoding: "H&ouml;lge He&szlig;"

-------------- next part --------------
A non-text attachment was scrubbed...
Name: iCal-invites.zip
Type: application/zip
Size: 2804 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050728/936e77a5/iCal-invites.zip
-------------- next part --------------

Helge

---

From: Arnaud.Quillaud at Sun.COM (Arnaud Quillaud)
Date: Thu Jul 28 09:13:55 2005

I'm quite off topic here but from my experience, for the same event, iCal invitations generated by Outlook + Exchange 2000 and above are usually correct when invitations generated directly by Outlook XP/2003 (in IMAP+SMTP mode) are bogus (especially in terms of rescheduling e.g. Recurrence-id).

Arnaud

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de 
> Cameron Stillion
> Envoy? : jeudi 28 juillet 2005 17:54
> ? : Helge Hess; Reinhold Kainhofer
> Cc : [email-masked]; Till Adam
> Objet : RE: [Ietf-calsify] Umlaute in Organizer field
> 
> 
> I'm looking into this, but if you have ical samples with 
> variously encoded non-ascii characters, I'd be very happy to 
> take attachments that will help my investigation.
> 
> Thanks,
> 
> cameron
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Helge Hess
> The encoding of the invitation is the encoding given in the 
> mime-type of the mail message as for all text/* MIME types. 
> In the case of Outlook 2002 this is:
> ---snip---
> I'm not sure what takes precedence if no charset is specified 
> (iCal default or MIME default), which is why you should 
> always specify the encoding explicitly.
> 
> Don't know what you mean by that. If you can only use ASCII 
> at the transport (as usual with SMTP) you would just need to 
> apply some content-transfer encoding (QP or base64).
> 
> BUT: even though OL specifies the content to be UTF-8, it 
> actually sends the iCalendar body in Latin-1 ...
>

---

From: adam at kde.org (Till Adam)
Date: Thu Jul 28 12:06:44 2005

On Thursday 28 July 2005 17:53, Cameron Stillion wrote:
> I'm looking into this, but if you have ical samples with variously encoded
> non-ascii characters, I'd be very happy to take attachments that will help
> my investigation.

Thanks, Cameron, and pleased to make your acquaintance. :) I've sent you an 
iTip invitation which is quoted-printable encoded utf8 and has various 
umlauts in the CN paramter of the ATTENDEE property. Does that do?

Till
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050728/6573857a/attachment.pgp