Subject: [Ietf-calsify] Umlaute in Organizer field

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Thu Jul 28 03:45:04 2005

Hi guys,
It may be a bit off-topic, but still, since here are all you guys who might 
also have had this problem:

AFAICS, rfc 2445 allows special characters like the German Umlaute ??????? in 
the CN field of the organizer or the attendee (since iCalendar is UTF-8 by 
default). Is this correct? Or am I wrong in my interpretation of the rfc 
here?
Now, the problem is that Outlook 2003 refuses to accept any such invitation if 
the CN of an attendee or the organizer contains Umlauts. 

Now, clearly you want the name of the attendee in your event (only the email 
alone doesn't really tell you anything if the email is 
[email-masked] or the like), but you also want outlook to accept 
your invitations. Does anyone know if there is any way (i.e. using a 
different encoding, somehow escaping the special letters, etc.) to make 
outlook accept the invitation, while still staying rfc-compliant and keep 
interopability of iTIP with other clients?
Or is the only way to send out invitations with the CN omitted if the name 
contains special letters?

Thanks a lot,
Reinhold
-- 
------------------------------------------------------------------
Reinhold Kainhofer, Vienna University of Technology, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at/
 * K Desktop Environment, http://www.kde.org, KOrganizer / KPilot maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050728/49b25cd9/attachment.pgp

---

From: daboo at isamet.com (Cyrus Daboo)
Date: Thu Jul 28 06:49:55 2005

Hi Reinhold,

--On July 28, 2005 12:44:49 PM +0200 Reinhold Kainhofer 
<[email-masked]> wrote:

> It may be a bit off-topic, but still, since here are all you guys who
> might  also have had this problem:
>
> AFAICS, rfc 2445 allows special characters like the German Umlaute
> ??????? in  the CN field of the organizer or the attendee (since
> iCalendar is UTF-8 by  default). Is this correct? Or am I wrong in my
> interpretation of the rfc  here?
> Now, the problem is that Outlook 2003 refuses to accept any such
> invitation if  the CN of an attendee or the organizer contains Umlauts.

Are you absolutely sure that the utf-8 charset is listed on the invitation?

> Now, clearly you want the name of the attendee in your event (only the
> email  alone doesn't really tell you anything if the email is
> [email-masked] or the like), but you also want outlook to
> accept  your invitations. Does anyone know if there is any way (i.e.
> using a  different encoding, somehow escaping the special letters, etc.)
> to make  outlook accept the invitation, while still staying rfc-compliant
> and keep  interopability of iTIP with other clients?
> Or is the only way to send out invitations with the CN omitted if the
> name  contains special letters?

I know for a fact that my implementation treats the text in CN as text 
without any special encoding etc. So if there were an encoding that worked 
with Outlook (e.g. MIME header style encoding) that would certainly break 
my client, and I suspect many others.

Have you tried doing the reverse? i.e. create an event in Outlook where the 
organiser or an attendee's name contains non-ascii and see how Outlook 
'exports' that to iCalendar?

I think this issue clearly sure that we need an area of interop dealing 
with non-ascii characters to verify proper handling of those in all 
products.

-- 
Cyrus Daboo

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Thu Jul 28 07:03:35 2005

> Are you absolutely sure that the utf-8 charset is listed on the invitation?

Sorry, I don't understand this. The invitation (the iCalendar part itself) 
doesn't list any encoding, it's by default in utf-8. The encoding of the 
message is the crucial thing here. Outlook doesn't like it if the message is 
8bit, but with 7bit you can't use umlauts at all...

Till can give you the details (he's the kmail guy).

> 'exports' that to iCalendar?

Outlook simply doesn't send the CN in that case... Which is bad if the email 
address doesn't tell you the name of the person.

> with non-ascii characters to verify proper handling of those in all

Yes, definitely.

Cheers,
Reinhold
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050728/30254ae6/attachment.pgp

---

From: daboo at isamet.com (Cyrus Daboo)
Date: Thu Jul 28 07:07:32 2005

Hi Reinhold,

--On July 28, 2005 4:03:21 PM +0200 Reinhold Kainhofer 
<[email-masked]> wrote:

> Sorry, I don't understand this. The invitation (the iCalendar part
> itself)  doesn't list any encoding, it's by default in utf-8. The
> encoding of the  message is the crucial thing here. Outlook doesn't like
> it if the message is  8bit, but with 7bit you can't use umlauts at all...

You are sending the iCal data via email, right? In which case what, if any, 
charset parameter is listed on the Content-Type header of the MIME part 
containing the iCal data?

>> Have you tried doing the reverse? i.e. create an event in Outlook where
>> the organiser or an attendee's name contains non-ascii and see how
>> Outlook 'exports' that to iCalendar?
>
> Outlook simply doesn't send the CN in that case... Which is bad if the
> email  address doesn't tell you the name of the person.

Hmm, OK.

-- 
Cyrus Daboo

---

From: daboo at isamet.com (Cyrus Daboo)
Date: Thu Jul 28 07:13:53 2005

Hi Till,

--On July 28, 2005 3:54:16 PM +0200 Till Adam <[email-masked]> wrote:

> Right, this issue is not about charsets, it's about transfer encoding.
> The  characters are proper utf8, and the mime header states that
> correctly. But as  soon as non-7bit characters are detected in a mail, we
> send it using either  quoted-printable or 8bit content transfer encoding,
> depending on a user  config setting. That seems to throw OL.
> Interestingly umlauts in the summary,  which also trigger the same
> q.p./8bit content transfer encoding behavior seem  to be parsed without
> problems, by OL.

Well I guess at this point we need someone from Microsoft to step in and 
explain what's happening...

-- 
Cyrus Daboo

---

From: helge.hess at opengroupware.org (Helge Hess)
Date: Thu Jul 28 07:38:55 2005

On Jul 28, 2005, at 16:03, Reinhold Kainhofer wrote:
> itself)
> doesn't list any encoding, it's by default in utf-8.

The encoding of the invitation is the encoding given in the mime-type  
of the mail message as for all text/* MIME types. In the case of  
Outlook 2002 this is:
---snip---
Content-Type: text/calendar; method=REQUEST;
	charset="utf-8"
---snap---
I'm not sure what takes precedence if no charset is specified (iCal  
default or MIME default), which is why you should always specify the  
encoding explicitly.

> The encoding of the message is the crucial thing here. Outlook doesn't  
> like it if the message is 8bit, but with 7bit you can't use umlauts at  
> all...

Don't know what you mean by that. If you can only use ASCII at the  
transport (as usual with SMTP) you would just need to apply some  
content-transfer encoding (QP or base64).

Notably OL 2002 uses 8bit:
---snip---
Content-Transfer-Encoding: 8bit
---snap---

>> Have you tried doing the reverse? i.e. create an event in Outlook  
>> where the organiser or an attendee's name contains non-ascii and see  
>> how Outlook 'exports' that to iCalendar?

I've tried with Outlook 2002 and it sends the CN, with one major bug.

It does both:

a) properly encode the CN in the To/From header
---snip---
From: "Guizmo G" <[email-masked]>
To: "=?utf-8?B?SMO2bGdlIEhlw58=?=" <[email-masked]>
---snap---
This is really base64 encoded UTF-8 (checked with recode).

b) embed the CN in the iCalendar request:
---snip---
BEGIN:VEVENT
ATTENDEE;CN="H?lge He?  
([email-masked])";ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO: 
[email-masked]
ORGANIZER:MAILTO:[email-masked]
---snap---
BUT: even though OL specifies the content to be UTF-8, it actually  
sends the iCalendar body in Latin-1 ...

So, how do you like that? ;->

Greets,
   Helge
-- 
http://docs.opengroupware.org/Members/helge/
OpenGroupware.org

---

From: adam at kde.org (Till Adam)
Date: Thu Jul 28 12:06:43 2005

On Thursday 28 July 2005 16:03, Reinhold Kainhofer wrote:
> message is the crucial thing here. Outlook doesn't like it if the message
> is 8bit, but with 7bit you can't use umlauts at all...
>

Right, this issue is not about charsets, it's about transfer encoding. The 
characters are proper utf8, and the mime header states that correctly. But as 
soon as non-7bit characters are detected in a mail, we send it using either 
quoted-printable or 8bit content transfer encoding, depending on a user 
config setting. That seems to throw OL. Interestingly umlauts in the summary, 
which also trigger the same q.p./8bit content transfer encoding behavior seem 
to be parsed without problems, by OL.

> email address doesn't tell you the name of the person.

And it's also what I would very much like to avoid being forced into 
duplicating, in Kontact.

Cheerio,

Till

(Please keep me in CC, I'm not on the list, thanks)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050728/258085dd/attachment.pgp