Subject: [Ietf-calsify] Fwd: I-D ACTION:draft-cstoner-rfc2445bis-00.txt

From: lisa at osafoundation.org (Lisa Dusseault)
Date: Tue Jul 19 13:16:47 2005

This is the first draft updating RFC2445 for Draft Standard.  No  
substantive features have been removed yet although that's a big part of  
the work ahead of us in CALSIFY.  The first stab at revising RFC2445  
focused on reordering the spec (top-down rather than bottom up) and  
getting it published in time to discuss in Paris (and it will be on the  
agenda, as will interop results relating to future work on this draft).

The XML and HTML versions can be found here:
http://ietf.webdav.org/calsify/rfc2445bis/

Thanks to Chris for taking this on,
Lisa

------- Forwarded message -------
From: [email-masked]
To: [email-masked]
Cc:
Subject: I-D ACTION:draft-cstoner-rfc2445bis-00.txt
Date: Fri, 15 Jul 2005 12:50:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts  
directories.

	Title		: Internet Calendaring and Scheduling Core Object Specification  
(iCalendar)
	Author(s)	: C. Stoner
	Filename	: draft-cstoner-rfc2445bis-00.txt
	Pages		: 165
	Date		: 2005-7-15
	
    Calendar systems export, transport and sometimes even store calendar
    information in a standard, interoperable format.  This memo defines
    the common format for openly exchanging calendaring and scheduling
    information across the Internet, known as the iCalendar object
    format.  An iCalendar object may represent an event, to-do or task,
    or journal entry (note).

    Comments are solicited and should be addressed to the working group's
    mailing list at [email-masked] and/or the editor.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-cstoner-rfc2445bis-00.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of the  
message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the  
username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-cstoner-rfc2445bis-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-cstoner-rfc2445bis-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

-- 
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: attachment4244.tmp
Type: application/octet-stream
Size: 142 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050719/88e6c5b2/attachment4244.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: attachment4245.tmp
Type: application/octet-stream
Size: 152 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050719/88e6c5b2/attachment4245.obj

---

From: reinhold at kainhofer.com (Reinhold Kainhofer)
Date: Tue Jul 19 14:05:56 2005

Hello Lisa,

Am Dienstag, 19. Juli 2005 22:16 schrieb Lisa Dusseault:
> This is the first draft updating RFC2445 for Draft Standard.  

That's really great news! 
One particular field that needs a lot of care are recurrence rules. While 
implementing a full rrule system (implementing all BY* rule parts, multiple 
RRULEs and EXRULEs, RDATEs, EXDATEs, etc.), I found lots of places where rfc 
2445 is really unclear and leaves things quite open for interpretation. Since 
recurrence rules are such an integral part of calendar data exchange (betwen 
apps, attendees and also between client and server), rfc2445bis should really 
make this a lot clearer. 

Where will the discussion on the rfc2445bis happen? Here on calsify or on 
ietf-calendar?
I'll try to generate a list of issues I think should be cleared to make the 
rfc unambiguous as far as recurrences are concerned. 

Cheers,
Reinhold

-- 
------------------------------------------------------------------
Reinhold Kainhofer, Vienna, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at
 * K Desktop Environment, http://www.kde.org/, KOrganizer / KPilot maintainer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050719/8f203bae/attachment.pgp

---

From: Chris_Stoner at notesdev.ibm.com ([email-masked])
Date: Wed Jul 20 06:38:14 2005

Reinhold:

I'd love to see your list, as I agree, the RRULE parts of the standard are
rather confusing and have been interpreted in many different ways.
-Chris Stoner

> [attachment "att6elqo.dat" deleted by Chris Stoner/Westford/IBM]
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify