Subject: [calsify] draft-ietf-calext-availability-02

From: Daniel Migault <[email-masked]>
Date: Mon, 6 Jun 2016 19:48:28 +0000

Hi Cyrus,

I reviewed the document  draft-ietf-calext-availability, and here are my comments. Please let me know if you think that some clarification can be added.

BR,
Daniel

Section 4 Combining VAVAILABILITY components

"""
It is up o the creator of such components to ensure that combining them produces a consistent and expected result.
"""
I am not sure it makes a lot of sense here, but I would like to know if that would be possible to provide some recommendations for the priority to set for the default VAVAILABILITY. For example, when I say I am available Monday - Friday 9:00 5:00 pm is it recommended I set a priority of 0, 9, ..7 -- of course not 1. ;-) My point is that it is easy to understand why not 1, it is less obvious whether setting tool low priority level would not leave to similar issues.

Section 5 Calculating Free-Busy Time

Item 2:
"""
For each "VAVAILABILITY" component ordered by PRIORITY
"""
I guess the priority order is from highest to lowest PRIORITY. Shouldn't we mention is explicitly for clarity?

Item 3:
"""
For each remaining "VAVAILABILITY" component in order:
"""

I am not very clear of what "in order means". Do you mean ordered by priority  as in item 2? My understanding is that the VAVAILABILITY components are those of step Item 2.3 "For the time...". If I am correct don't you think we could explicitly mention it?

[Ericsson]<http://www.ericsson.com/>

DANIEL MIGAULT
Researcher
Research

Ericsson
8500 Boulevard Decarie
H4P 2N2 Montreal, Canada
Phone +1 514 345 7900 46628
Mobile +1 514 452 2160
[email-masked]
www.ericsson.com

[http://www.ericsson.com/current_campaign]<http://www.ericsson.com/current_campaign>

Legal entity: Ericsson Canada Inc., registered office in Montreal. This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Daniel Migault <[email-masked]>
Date: Tue, 7 Jun 2016 13:28:45 -0400

Hi,

In order to pass the ABNF check, I would suggest to replace:

OLD:
                 ; the following are OPTIONAL,
                 ; and MAY occur more than once
                 ;
                 categories / comment / contact / exdate /
                 rdate / x-prop / iana-prop

                 )

NEW:
                 ; the following are OPTIONAL,
                 ; and MAY occur more than once
                 ;
                 categories / comment / contact / exdate /
                 rdate / x-prop / iana-prop
                 ;
                 )

On Mon, Jun 6, 2016 at 3:48 PM, Daniel Migault <[email-masked]>
wrote:

> Hi Cyrus,
>
>
>
> I reviewed the document  draft-ietf-calext-availability, and here are my
> comments. Please let me know if you think that some clarification can be
> added.
>
>
>
> BR,
> Daniel
>
>
>
> It is up o the creator of such components to ensure that combining them
> produces a consistent and expected result.
>
> """
>
> I am not sure it makes a lot of sense here, but I would like to know if
> that would be possible to provide some recommendations for the priority to
> set for the default VAVAILABILITY. For example, when I say I am available
> Monday - Friday 9:00 5:00 pm is it recommended I set a priority of 0, 9,
> ..7 -- of course not 1. ;-) My point is that it is easy to understand why
> not 1, it is less obvious whether setting tool low priority level would not
> leave to similar issues.
>
>
>
>
>
> I am not very clear of what "in order means". Do you mean ordered by
> priority  as in item 2? My understanding is that the VAVAILABILITY
> components are those of step Item 2.3 "For the time...". If I am correct
> don't you think we could explicitly mention it?
>
>
>
>
>
>
>
>
>
>
>
>  <http://www.ericsson.com/>
>
> *DANIEL MIGAULT *
> Researcher
> Research
>
>
> *Ericsson*
> 8500 Boulevard Decarie
> H4P 2N2 Montreal, Canada
> <http://www.ericsson.com/current_campaign>
>
>
>
> Legal entity: Ericsson Canada Inc., registered office in Montreal. This
> Communication is Confidential. We only send and receive email on the basis
> of the terms set out at www.ericsson.com/email_disclaimer
>
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify
>
>

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 22 Jun 2016 11:55:00 -0400

Hi Daniel,
Thanks for your review. Sorry I have not been able to address your comments 
until now. All changes described below have been made to my working copy 
and will be published in a new draft once I have addressed comments from 
other reviewers.

--On June 6, 2016 at 7:48:28 PM +0000 Daniel Migault 
<[email-masked]> wrote:

> produces a consistent and expected result. """
> that would be possible to provide some recommendations for the priority
> to set for the default VAVAILABILITY. For example, when I say I am
> available Monday - Friday 9:00 5:00 pm is it recommended I set a priority
> of 0, 9, ..7 -- of course not 1. ;-) My point is that it is easy to
> understand why not 1, it is less obvious whether setting tool low
> priority level would not leave to similar issues.

I think it is reasonable to recommend that a user's "default" availability 
should have PRIORITY:0 (or absence of PRIORITY property). Here is new text 
I have added:

    Typically, a calendar user's "default" availability (e.g., business
    hours of Monday through Friday, 9:00 am to 5:00 pm) would use the
    lowest level of priority: zero. Any overrides to the "default" would
    use higher levels as needed. To avoid having to keep readjusting the
    "PRIORITY" property value when an override has to be "inserted" between
    two existing components, priority values SHOULD be "spaced out" over
    the full range of values. e.g., the "default" availability is created
    with priority zero, then the first override created with priority 5, a
    subsequent availability can be inserted between the two by using
    priority 7, and another, taking precedence over all existing ones, with
    priority 3.

> we mention is explicitly for clarity?

Bernard suggested that too, and I have added text to clarify that. However, 
the correct way is to order and process them from lowest to highest, so 
that you can "layer" the higher priority items over the lower ones.OK,

> don't you think we could explicitly mention it?

To clarify this I have added a new item 2 (d):

    d. Append the "VAVAILABILITY" component to a list of components for
    further processing in step 3, if it has not been ignored.

and adjusted the text to item 3 to:

    3. For each "VAVAILABILITY" component in the list resulting from step 2,
    in order from the first item to the last item:

I think that clarifies the proper order for the steps in 3.

-- 
Cyrus Daboo

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 22 Jun 2016 11:58:08 -0400

Hi Daniel,

>                  rdate / x-prop / iana-prop

Fixed.

-- 
Cyrus Daboo

---

From: Daniel Migault <[email-masked]>
Date: Thu, 23 Jun 2016 09:38:35 -0500

Thanks for addressing this issues.
BR,
Daniel

On Wed, Jun 22, 2016 at 10:58 AM, Cyrus Daboo <[email-masked]> wrote:

> Hi Daniel,
>
> --On June 7, 2016 at 1:28:45 PM -0400 Daniel Migault <
> [email-masked]> wrote:
>

---

From: Daniel Migault <[email-masked]>
Date: Thu, 23 Jun 2016 09:38:55 -0500

On Wed, Jun 22, 2016 at 10:55 AM, Cyrus Daboo <[email-masked]> wrote:

> Hi Daniel,
> Thanks for your review. Sorry I have not been able to address your
> comments until now. All changes described below have been made to my
> working copy and will be published in a new draft once I have addressed
> comments from other reviewers.
>
>
> --On June 6, 2016 at 7:48:28 PM +0000 Daniel Migault <
> Bernard suggested that too, and I have added text to clarify that.
> However, the correct way is to order and process them from lowest to
> highest, so that you can "layer" the higher priority items over the lower
> ones.OK,
>
> Item 3:
>> """