Subject: RE: [Capwap] CAPWAP Arch. Taxonomy Draft Available

From: "Yang, Lily L" <[email-masked]>
Date: Wed, 21 Apr 2004 16:54:38 -0700

Hi, Tyan-Shu Jou --

I think you are right that SSID uniquely identifies ESS instead of BSS. We should correct that.

Thanks for your comments,
Lily

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Tyan-Shu Jou
> Sent: Thursday, April 08, 2004 9:31 PM
> To: [email-masked]
> Subject: RE: [Capwap] CAPWAP Arch. Taxonomy Draft Available
> 
> 
> Hi,
>   It's nice to read the taxonomy draft especially knowing it 
> was done in
> a very short period of time. Thanks for the work.
> 
>   I have a comment on the definition of "SSID" in the draft:
> 
> In Section 2.1, it reads:
> "A BSS is identified by a common service set identifier 
> (SSID) or name.
> An SSID is an arbitrary byte string ..." 
> And then, "When more than one AP is connected via a broadcast layer 2
> network and all are using the same SSID, an extended service set (ESS)
> is created."
> 
> In fact, a BSS should be uniquely identified by the "BSSID" (basic
> service set identifier). See Section 7.1.3.3.3 of 802.11-1999 for the
> format of it on infrastructure BSS and IBSS. Basically that's the MAC
> address of the AP's interface, or the created address in an IBSS.
> 
> My understanding of SSID of 802.11 is to identify an ESS (in
> infrastructure mode), rather than a BSS. As in 7.3.2.1 of 802.11:
> "The SSID element indicates the identity of an ESS or IBSS"
> 
> In a common isolated AP deployment (as the "Autonomous Architecture"
> mentioned in the draft), one BSS forms one ESS. In this case SSID can
> also  be used to refer to the BSS, hence one can argue the draft is
> still correct. However, I think it will be better if we can 
> clarify the
> definitions.
> 
> I personally have experienced the problem on my laptop when it can see
> multiple APs/WTPs using the same SSID in the same channel. If the
> observation is correct, this can be a potential obstacle for CAPWAP
> function deployment. Unfortunately this is not included in the vendor
> survey. Don't know whether any vendor is willing to share their
> experience.
> 
> Thanks.
> 
> Tyan-Shu Jou
> Janusys Networks, Inc.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mani, Mahalingam (Mahalingam)
> Sent: Thursday, April 08, 2004 8:58 PM
> To: [email-masked]
> Subject: [Capwap] CAPWAP Arch. Taxonomy Draft Available
> Importance: High
> 
> Hi All,
>  
> The architecture taxonomy draft has been submitted to the IETF and
> should be available from the IETF website very soon (less than a few
> days).
>  
> Meanwhile this draft (draft-ietf-capwap-arch-01) is also available now
> from the CAPWAP Central Website.
>  
> It is also available on Petros' webpage:
> http://www.cs.ucla.edu/~pzerfos/draft-ietf-capwap-arch-01.txt
>  
> Do go over in detail and provide your review comments. 
>  
> Thanks, Dave & Petros.
>  
> Thanks,
> -mani
> 
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
> 
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Yang, Lily L" <[email-masked]>
Date: Wed, 21 Apr 2004 17:08:58 -0700

Hi, Nehru --
 
Thanks so much for your comments. Sorry that we didn't respond to you sooner. But as you can see, we heard you and immediately incorporated most of your comments into v02 that was published a few days ago. We were just too busy with revising the draft itself that we can hardly find time to respond and thank you for your comments :-)
 
Lily

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Nehru Bhandaru
Sent: Saturday, April 10, 2004 11:06 AM
To: Mani, Mahalingam (Mahalingam); [email-masked]  
Subject: RE: [Capwap] CAPWAP Arch. Taxonomy Draft Available

Hi,

I enjoyed and thank the CAPWAP team for the fairly comprehensive taxonomy of current WLAN/802.11 architectures contained in the document. Few questions/comments came to mind - perhaps already considered by the team, but I want to share them anyway.

A tree/hierarchy diagram of the taxonomy would be helpful in the document. For example

  All--> Autonomous

      --> Centralized

              --> Local MAC

              --> Split MAC

              --> Remote MAC

      --> Distributed

We added such a diagram in the conclusion section 6.1 in v02, per your suggestion.     

The term STB is used in Figure 11, but was not in the glossary at the beginning. It became only clear what this meant when I was reading the architecture submissions in the Appendices. 

It is now fixed in v02. 

As I understand, WTP refers to the physical entity containing the RF Antenna, and some or all 802.11/CAPWAP functionality. In the diagrams only a single BSS is shown with each WTP. Perhaps it will add to clarity if more than one BSS is shown in a WTP, since WLAN architectures may support multiple BSSs in a WTP. 

Yes, you are right that multiple BSSs are commonly offered by vendors to support virtual AP (WTP).The diagram is not meant to cover every possible configuration, rather, it is meant to cover the most basic points. If some complications arise from multiple BSSs (virtual WTP), we can discuss it separately.

A CAPWAP supported function (e.g. mobility, load balancing) may span multiple ACs. Is communication among ACs within the scope of this document? Also, a given WTP may communicate with multiple ACs - a simple example would be for failover.  

Yes, for failover, redundancy, or load balancing, multiple ACs are often necessary and many vendors do support that. So we added one paragraph in Section 4 (after Figure 2) in v02 to briefly cover this.  

Some of the CAPWAP functions and much of the architectural taxonomy could be independent of 802.11 MAC/PHY. For the long term, this work could be leveraged in such environments.  

That may very well be true. However, as being said many times by the chairs and others, lets get this problem solved for 802.11 first. We can learn a great deal from this exercise.

 Also some WTPs may implement both a Local MAC and Split MAC.  

Yes, some flexibility (optional mapping) is foreseeable.  

Thanks,

- Nehru

_______________________________

Nehru Bhandaru

Legra Systems, Inc.

(781) 743-3216

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mani, Mahalingam (Mahalingam)
Sent: Thursday, April 08, 2004 8:58 PM
To: [email-masked]
Subject: [Capwap] CAPWAP Arch. Taxonomy Draft Available
Importance: High

Hi All,

The architecture taxonomy draft has been submitted to the IETF and should be available from the IETF website very soon (less than a few days).

Meanwhile this draft ( draft-ietf-capwap-arch-01 <http://www.capwap.org/draft-ietf-capwap-arch-01.txt> ) is also available now from the CAPWAP  <http://www.capwap.org/> Central Website.

It is also available on Petros' webpage: http://www.cs.ucla.edu/~pzerfos/draft-ietf-capwap-arch-01.txt

Thanks, Dave & Petros.

Thanks,

-mani