Subject: GSS in (something like) TLS?

From: "Mike Spreitzer" <[email-masked]>
Date: Thu, 3 Feb 2000 00:08:47 PST

[Trying again, as my first message was bounced from the TLS list and misunderstood on the CAT list.]

It seems natural to me for someone who's using the GSS-API to want a stream filter protocol similar to TLS to transport the tokens
that the GSS-API is defined to produce and consume.

If I've decided to use the GSS-API as my framework for selecting and engaging security mechanisms, I don't need another one in TLS
(indeed, relating the two frameworks would involve breaking the abstraction that is central to the GSS-API).  What I need is to add
what's missing to make a complete protocol.  Something like the record protocol of TLS plus a few GSS-oriented message types (one to
carry GSS setup tokens, another to carry GSS data tokens, perhaps one for GSS shutdown tokens, perhaps a few more for context
switching and/or alerts).

Creating a GSS mechanism that does TLS misses the point; the point is to make a stream filter that can use the full spectrum of GSS
mechanisms now and later defined, managed and extended in the way that they are through the GSS.

Does this sound to you like something that should be produced (and if so, where)?

Thanks,
Mike

-++**==--++**==--++**==--++**==--++**==--++**==--++**==
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Matt Hur <[email-masked]>
Date: Mon, 7 Feb 2000 10:13:49 -0800

In response to 1,2,3 below:
1) Right - GSS is used to authenticate and wrap the premaster secret.  Just
as in RFC 2712, this is just another authentication component of a
ciphersuite.

2) The GssKbr5Wrapper should contain the authentication token and the wrap
token (with encrypted premaster secret).  Sorry that wasn't clear.

3) Right - the GSS setup phase needs one message to authenticate and protect
the premaster secret.

--Matt

> -----Original Message-----
> From: Mike Spreitzer [mailto:[email-masked]]
> Sent: Thursday, February 03, 2000 4:52 PM
> To: Matt Hur
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; 'Mayank
> Upadhyay'; [email-masked]; [email-masked]
> Subject: RE: GSS in (something like) TLS?
> 
> 
> If I understand you correctly, you're suggesting a hybrid 
> approach: use the GSS to wrap the premaster secret, and then 
> proceed with
> the rest of TLS as if you had done RSA-based key exchange.  
> Is that right?
> 
> (1) That doesn't apply the selected GSS mechanism to the data 
> conversation, only the key exchange.
> 
> (2) Why did you make your GssKbr5Wrapper include two 
> InitialContextTokens?  gss_wrap doesn't emit an 
> InitialContextToken, it emits a
> SealedMessage (right?).  Can you be a little more explicit 
> about what's in a GssKrb5Wrapper?
> 
> (3) This is not exactly specific to Kerberos; what's critical 
> is that the GSS mechanism's setup phase needs just one message ---
> right?
> 
> 
> Thanks,
> Mike
>