Subject: RE: Initiating WG Last-Call: draft-ietf-cat-gssv2-javabind-04.txt

From: "Linn, John" <[email-masked]>
Date: Mon, 7 Feb 2000 15:50:18 -0500

Thanks for this note and the recently-issued
draft-ietf-cat-gssv2-javabind-05.txt, which also updates references from
RFCs 1509/2078 to RFCs 2743/2744. Since no objections were posted to the
list in response to this message, and no objections to the predecessor
document were made to the list during the WG Last-Call, my assumption is
that this version is ready to be forwarded to the IESG on behalf of the WG
to be considered for Proposed Standard, and I'll plan to do so later this
week.

--jl 

> -----Original Message-----
> From: Jack Kabat [mailto:[email-masked]]
> Sent: Monday, January 24, 2000 2:45 AM
> To: Linn, John; 'CAT-WG List'
> Subject: RE: Initiating WG Last-Call:
> draft-ietf-cat-gssv2-javabind-04.txt
> 
> 
> 
> Mayank and I have received feedback from several implementers 
> and reviewers
> regarding the JGSS draft.
> 
> Based on the feedback, additional text is required when describing the
> credential and context creation calls. The text needs to 
> specify to supply a
> lifetime of 0 to obtain the default credential and context 
> lifetime. The
> effected sections are listed below. A constant within the 
> GSSContext and
> GSSCredential classes will be added to represent the default lifetime.
> 
> In addition several typos and code sample mis-prints have 
> been brought to
> our attention.
> 
> thanks,
> 
> jack
> 
> 
> 
> 6.1.10 createCredential
> public abstract GSSCredential createCredential (int usage)
>            throws GSSException
> 
> Here INDEFINITE should be changed to default.
> 
> 6.1.11.  createCredential
> 
>    public abstract GSSCredential createCredential (GSSName aName,
>                    int lifetime, Oid mechOid, int usage)
>                    throws GSSException
> 
> Here the description of lifetime parameter will include 0 as 
> a value to
> obtain default credential lifetime.
> 
> 6.1.12.  createCredential
> 
>    public abstract GSSCredential createCredential(GSSName aName,
>                    int lifetime, Oid mechs[], int usage)
>                    throws GSSException
> 
> Same as above.
> 
> 
> 6.1.13.  createContext
> 
>    public abstract GSSContext createContext(GSSName peer, Oid mechOid,
>                    GSSCredential myCred, int lifetime)
>                    throws GSSException
> 
> Same as above.
> 
> 
> 6.3.12.  add
> 
>    public void add(GSSName aName, int initLifetime, int 
> acceptLifetime,
>                    Oid mech, int usage) throws GSSException
> 
> The description of initLifetime and acceptLifetime should include the
> previous clarification.
> 
> 
> 6.4.26.  requestLifetime
> 
>    public void requestLifetime(int lifetime) throws GSSException
> 
> Here 0 should have the special meaning of default lifetime.
> 
> 
> > -----Original Message-----
> > From: Linn, John [mailto:[email-masked]]
> > Sent: Monday, January 17, 2000 1:05 PM
> > To: Linn, John; 'CAT-WG List'
> > Subject: RE: Initiating WG Last-Call:
> > draft-ietf-cat-gssv2-javabind-04.txt
> > 
> > 
> > CAT-WG:
> > 
> > Just a reminder that draft-ietf-cat-gssv2-javabind-04.txt is 
> > in WG Last Call
> > through 25 January.  If anyone wishes to post comments before 
> > the document
> > is forwarded to the IESG to be considered for Proposed 
> > Standard, please do
> > so within this period. 
> > 
> > --jl
> > 
> > -----Original Message-----
> > From: Linn, John [mailto:[email-masked]]
> > Sent: Tuesday, January 04, 2000 11:31 AM
> > To: 'CAT-WG List'
> > Subject: Initiating WG Last-Call: 
> draft-ietf-cat-gssv2-javabind-04.txt
> > 
> > 
> > CAT WG:
> > 
> > This message is to initiate a CAT-WG Last-Call on
> > draft-ietf-cat-gssv2-javabind-04.txt, "Generic Security 
> > Service API Version
> > 2: Java Bindings". I thank the document editors for their 
> > submission of this
> > updated version. To support review of this lengthy 
> > specification, I propose
> > to open a three week WG Last-Call period, ending 25 January 
> > 2000.  If anyone
> > wishes to comment on this document with respect to its prospective
> > recommendation to the IESG on behalf of the CAT-WG for 
> advancement to
> > Proposed Standard, please do so within this period. 
> > 
> > --jl
> > 
> > ==============================================================
> > ============
> > This message was posted through the Stanford campus mailing list
> > server.  If you wish to unsubscribe from this mailing list, send the
> > message body of "unsubscribe ietf-cat-wg" to 
> > [email-masked]
> > -++**==--++**==--++**==--++**==--++**==--++**==--++**==
> > This message was posted through the Stanford campus mailing list
> > server.  If you wish to unsubscribe from this mailing list, send the
> > message body of "unsubscribe ietf-cat-wg" to 
> > [email-masked]
> > 
> 
-++**==--++**==--++**==--++**==--++**==--++**==--++**==
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Jack Kabat <[email-masked]>
Date: Mon, 7 Feb 2000 21:05:06 -0800

John,

The updated document addresses all the outstanding
comments that Mayank and I have received.

draft-ietf-cat-gssv2-javabind-05.txt incorporates
the following changes:
1) list of changes send previously
2) changes to reflect RFC status of the GSS-API V2
   C-bindings and GSS-API V2 references
3) description has been added to GSSContext.getMech()
   method to indicate it may be called before context
   establishment as specified in RFC 2743.
4) Since we added the DEFAULT_LIFETIME constant to
   both GSSCredential and GSSContext, we have also
   renamed the INDEFINITE constant to INDEFINITE_LIFETIME.

Regards,

Jack

> Sent: Monday, February 07, 2000 12:50 PM
> To: 'Jack Kabat'; Linn, John; 'CAT-WG List'