Subject: Re: Draft minutes, Adelaide CAT session

From: Bill Sommerfeld <[email-masked]>
Date: Tue, 11 Apr 2000 18:53:40 -0400

I don't have any references at hand; I'll see what I can dig up.

I'd dig through the CAT archives for messages from Marc Horowitz and
Uri Blumenthal starting at around june/july of 1996, which was about
when work on key derivation got underway.  I haven't seen Uri at an
IETF in a while.. he was one of the IBM folks who were calling for it
and who convinced me and Marc and a few others of its necessity at the
Montreal IETF..

					- Bill
-++**==--++**==--++**==--++**==--++**==--++**==--++**==
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the
message body of "unsubscribe ietf-cat-wg" to [email-masked]

---

From: Tony Andrea <[email-masked]>
Date: Tue, 11 Apr 2000 15:42:06 -0700

where can i find documentation on the added security
of key derivation as it relates to kerberos? i certainly
agree that ignoring someone who knows what they are
talking about (a cryptographer in this case) would be a
bad plan.... 

thanks,
tony.

> -----Original Message-----
> From: Bill Sommerfeld [mailto:[email-masked]]
> Sent: Tuesday, April 11, 2000 2:25 PM
> To: Tony Andrea
> Cc: 'CAT-WG List'
> Subject: Re: Draft minutes, Adelaide CAT session 
> 
> 
> I've been largely ignoring CAT for a while, but I'll butt in here
> since I was around for some of the early discussions of key
> derivation.
> 
> Key derivation was designed to eliminate one of the cryptographic
> "sins" from the original kerberos design: namely, the use of a single
> key with multiple algorithms for multiple purposes.  If you assume the
> algorithms you're using are perfect, this doesn't add any real
> strength, but well, we're living in the real world, and the algorithms
> aren't perfect, so you do key derivation to add a margin of safety.
> 
> For the most part, we here in CAT-land are plumbers who use
> cryptography, not cryptographers.  When real cryptographers have
> things to say, and say them strongly, we should listen to them.
> I believe it would be unwise to discard their contribution.
> 
> I'll go back to lurking now..
> 
> 						- Bill
>

---

From: Assar Westerlund <[email-masked]>
Date: 12 Apr 2000 12:18:00 +0200

> talking about (a cryptographer in this case) would be a

I think this is the most relevant paper that I've seen referenced
about this:

http://www.research.att.com/~smb/papers/ides.ps

And then there are the Horowitz-drafts on key derivation, but that's
more on howto rather than why.

But then I guess Marc (hi there) is the person to ask about this.

/assar