Subject: Re: IANA assignments

From: Ben Mack-Crane <[email-masked]>
Date: Fri, 16 Jan 2004 09:05:25 -0600

Adrian and all,

After checking with the OIF, I understand that UNI1.0r2 has passed Straw 
Ballot but
not Principal Ballot.  The value in question could be adjusted as an 
editorial change before
going to Principal Ballot.  The OIF is meeting next week and UNI1.0r2 is 
likely to go
to Principal Ballot soon.

Regards,
Ben

[email-masked] wrote:

> Adrian,
>
> Initially OIF used the value (4) in UNI1.0.  I do not know how this value
> was chosen, or who chose it, but this is probably how it came into 
> common use, since UNI
> interop was done quite a while ago.
>
> While making minor corrections and updates to conform with IETF RFCs 
> (since UNI1.0
> was based on drafts) we consulted the IANA assignments and found (3), 
> so that value
> was used as the corrected value in UNI1.0r2.
>
> So, OIF has followed the official IANA assignment.
>
> Regards,
> Ben
>
> Adrian Farrel wrote:
>
>>Erm,
>>Which order this happen Ben?
>>
>>IANA or OIF first?
>>
>>Thanks,
>>Adrian
>>----- Original Message ----- 
>>From: "Ben Mack-Crane" <[email-masked]>
>>To: <[email-masked]>
>>Cc: <[email-masked]>
>>Sent: Wednesday, January 14, 2004 4:02 PM
>>Subject: Re: IANA assignments
>>
>>
>>  
>>
>>>To add to Andy's factual response on Tellabs' implementations,
>>>I would like to support Bert's messages on following the process
>>>and also state that we are willing to update our implementation
>>>to support the "right" codepoint.
>>>
>>>Other standards organizations depend on the stability of the
>>>IANA process.  For example, the recently approved OIF UNI1.0r2 IA
>>>specifies the IANA assigned C-Type (3) for SONET/SDH TSPEC/FLOWSPEC.
>>>This will be a problem if the IANA assignment is changed.
>>>
>>>Regards,
>>>Ben Mack-Crane
>>>
>>>[email-masked] wrote:
>>>
>>>    
>>>
>>>>Ditto for Tellabs (the same as Kireeti's answer).
>>>>
>>>>Andy
>>>>
>>>>------------
>>>>
>>>>At 1/9/2004 11:48 AM -0800, Kireeti Kompella wrote:
>>>>
>>>>      
>>>>
>>>>>On Fri, 9 Jan 2004, Kireeti Kompella wrote:
>>>>>
>>>>>For the record, here is the answer from Juniper's implementation:
>>>>>
>>>>>        
>>>>>
>>>>>>a) do you use the FLOWSPEC C-Type 3 for CoS?
>>>>>>          
>>>>>>
>>>>>We parse this, but don't really use it.
>>>>>
>>>>>        
>>>>>
>>>>>>b) have you implemented the SONET/SDH FLOWSPEC?  If so, what value did
>>>>>>   you use for the C-Type?
>>>>>>          
>>>>>>
>>>>>Yes. Value 4.
>>>>>
>>>>>        
>>>>>
>>>>>>c) do you use the TSPEC C-Type 3 for CoS?
>>>>>>          
>>>>>>
>>>>>We parse this, but don't really use it.
>>>>>
>>>>>        
>>>>>
>>>>>>d) have you implemented the SONET/SDH TSPEC?  If so, what value did
>>>>>>   you use for the C-Type?
>>>>>>          
>>>>>>
>>>>>Yes. Value 4.
>>>>>
>>>>>Kireeti.
>>>>>-------
>>>>>        
>>>>>
>>>>      
>>>>
>>>-----------------------------------------
>>>============================================================
>>>The information contained in this message may be privileged 
>>>and confidential and protected from disclosure.  If the 
>>>reader of this message is not the intended recipient, or an 
>>>employee or agent responsible for delivering this message to 
>>>the intended recipient, you are hereby notified that any 
>>>reproduction, dissemination or distribution of this 
>>>communication is strictly prohibited. If you have received 
>>>this communication in error, please notify us immediately by 
>>>replying to the message and deleting it from your computer.
>>>
>>>Thank you.
>>>Tellabs
>>>============================================================
>>>
>>>
>>>
>>>
>>>    
>>>
>>
>>  
>>
>
> ------------------------------------------------------------------------
>
> ============================================================
> The information contained in this message may be privileged
> and confidential and protected from disclosure. If the
> reader of this message is not the intended recipient, or an
> employee or agent responsible for delivering this message to
> the intended recipient, you are hereby notified that any
> reproduction, dissemination or distribution of this
> communication is strictly prohibited. If you have received
> this communication in error, please notify us immediately by
> replying to the message and deleting it from your computer.
>
> Thank you.
> Tellabs
> ============================================================
>

-----------------------------------------
============================================================
The information contained in this message may be privileged 
and confidential and protected from disclosure.  If the 
reader of this message is not the intended recipient, or an 
employee or agent responsible for delivering this message to 
the intended recipient, you are hereby notified that any 
reproduction, dissemination or distribution of this 
communication is strictly prohibited. If you have received 
this communication in error, please notify us immediately by 
replying to the message and deleting it from your computer.

Thank you.
Tellabs
============================================================

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 16 Jan 2004 10:28:53 -0800 (PST)

> to Principal Ballot soon.

Thanks for the update, Ben.  We'll try to resolve this quickly.

Kireeti.
-------