Subject: draft-dachille: Comments on CAC issues

From: "Vishal Sharma" <[email-masked]>
Date: Sun, 18 Apr 2004 00:27:43 -0700

Hi Arthi,

Thanks for your feedback on our draft/scheme during the
Seoul IETF.

As mentioned in the email to the ML and to JL,
before addressing people's comments, we are summarizing them
ensure that (a) we rightly understood the comments, and (b) to
help people on the ML follow and contribute to the subsequent
discussions.

Upon looking at my notes from our discussions, I see that
your main comments related to aspects of CAC in our scheme,
and have summarized them below.

Please let me know if you had any additional comments
as well. We will take these into account in providing our
responses, and, later, in updating the document.

Best regards,
-Vishal

****************************************************************

i) What happens to bandwidth accounting during path set up?
Since the border router that is the entry point for the primary path
into an area/AS is the one that also computes the secondary path, how does
bandwidth accounting work to minimize CAC failures during the actual setting
up of the secondary?
(Note that other nodes in the area would not immediately learn of the amount
of bandwidth that primary and secondary paths have consumed.)

ii) What happens if the diverse path setup fails due to a
CAC failure? (Namely, the set up of the second path fails.)
To what does the scheme default then?

iii) If I recall correctly, you also had a comment on the
security of such schemes. That is, the problem of hiding info.
about one area from other (remote) areas.

---

From: Arthi Ayyangar <[email-masked]>
Date: Wed, 21 Apr 2004 11:53:15 -0700 (PDT)

Hi Vishal,

Your summary regarding the CAC issues that I had raised basically looks
fine. I think for ii) I meant any kind of setup failure, I suspected CAC
failure to be more common due to i). I will also check my notes to see if
there were any other issues and get back to you.

thanks,
-arthi

---

From: "Vishal Sharma" <[email-masked]>
Date: Thu, 22 Apr 2004 22:51:35 -0700

Hi Arthi,

Thanks for your note. I've made a note of ii) referring to
a general setup failure, and not just CAC failure.

We'll take this into account when we post the responses in
the next day or two.

And, if you see any other points when reviewing your notes
please do let us know.

Thanks,
-Vishal

> -----Original Message-----
> From: Arthi Ayyangar [mailto:[email-masked]]
> Sent: Wednesday, April 21, 2004 11:53 AM
> To: Vishal Sharma
> Cc: CCAMP; Fabio Ricciato; Ugo Monaco; Alessio D'Achille; Marco Listanti
> Subject: Re: draft-dachille: Comments on CAC issues 
> 
> 
> Hi Vishal,
>