Subject: RE : RE : Proposed strategy for Inter-area/AS

From: "LE ROUX Jean-Louis FTRD/DAC/LAN" <[email-masked]>
Date: Mon, 26 Apr 2004 18:15:15 +0200

Hi Fabio,

Advertising only a subset would improve scalability, but
this would not be enough to correclty select the best path.

Let's assume that there are three paths from a given ABR X to a given destination D
Path 1: bw 100M admin group {green;blue}
Path 2: bw 50M admin group {red; blue}
Path 3: bw 5M admin group {red;green}

and a TE-LSP L : Destination D, bw= 4M, affinity= exlude blue

If you advertise only Path 1 and Path 2 as virtual links, ABR X will never be selected as next ABR for this TE-LSP, while path 3 is a feasible path.

Regards

JL 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de ricciato
> Envoyé : lundi 26 avril 2004 09:48
> À : LE ROUX Jean-Louis FTRD/DAC/LAN
> Cc : [email-masked]; [email-masked]
> Objet : Re: RE : Proposed strategy for Inter-area/AS
> 
> 
> Hi JL,
> 
> just a quick remark: would it make sense in this case to 
> advertise only 
> a selected subset of the N virtual links (say the two with 
> most residual 
> bw) ?
> 
> ciao
> fabio
> 
> LE ROUX Jean-Louis FTRD/DAC/LAN wrote:
> 
> >Let's assume that there are N distinct paths from ABR A to a 
> >destination X, each with a distinct bandwidth and distinct 
> admin-group 
> >(a path admin group being expressed as a logical AND of the 
> link admin 
> >groups along the path) How can you summarize such topology ? 
> Actually 
> >you need to advertise N virtual links, each with a distinct 
> admin-group 
> >and available bandwidth.
> >
> >
> >  
> >
> >  
> >
> 
> 
>

---

From: ricciato <[email-masked]>
Date: Mon, 26 Apr 2004 18:58:42 +0200

Dear JL,

you´re right.

Just a quick proposal.
In an attempt to limit the number of virtual link advertised,
would it make sense to advertise only K virtual links, where K={number 
of colors}, and for each of them  (say j) advertise the maximum 
bandwdith over all links that have color j into their admin_group ?

For example, in your example (with Path 4 added)

Path 1: bw 100M admin group {green;blue}
Path 2: bw 50M admin group {red; blue}
Path 3: bw 5M admin group {red;green}
Path 4: bw 50M admin group {red}

One should advertise 
Virtual Link 1: bw 100M admin group {green} --->max(100M,5M)
Virtual Link 2: bw 50M admin group {red} --->max(50M,5M,50M)
Virtual Link 3: bw 100M admin group {gblue} --->max(100M,50M)

Assuming that the number of colors << number of possible links, this approach might cap the amount of advertisement.

But I´m not sure it works ... 

ciao
fabio

---

From: "Vishal Sharma" <[email-masked]>
Date: Mon, 26 Apr 2004 13:26:44 -0700

Hi Fabio, JL, et al

I think Fabio may have a good idea here. It provides the flexibility
of having info. about all affinities, with the scalability of advertizing
only limited information.

Perhaps we can explore a bit where there might be issues, and refine
this initial solution to get something that we believe is appropriate.

-Vishal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ricciato
> Sent: Monday, April 26, 2004 9:59 AM
> To: LE ROUX Jean-Louis FTRD/DAC/LAN
> Cc: [email-masked]; [email-masked]
> Subject: Re: RE : RE : Proposed strategy for Inter-area/AS
>
>
> Dear JL,
>
> you´re right.
>
> Just a quick proposal.
> Assuming that the number of colors << number of possible links,
> this approach might cap the amount of advertisement.
>
> >If you advertise only Path 1 and Path 2 as virtual links, ABR X
> will never be selected as next ABR for this TE-LSP, while path 3
> is a feasible path.
> >
> >Regards
> >
> >JL
> >
> >
> >
> >
> >

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Thu, 29 Apr 2004 13:24:47 -0400

Hi Vishal,

>only limited information.

This problem has been investigated for a while and there many constraints 
that cannot be aggregated in a simple/efficient manner, leading to the 
constraint of having to flood a un-reasonable amount of TE-related info to 
make it useful enough to compute an optimal (shortest) path with some good 
chance of set up success.

Cheers

JP.