Subject: Draft agenda for San Diego

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jul 2004 17:08:44 +0100

Hi,

Here is an early draft agenda for CCAMP in San Diego.

As usual there is a high volume of drafts that people want to 'present'. Of necessity,
therefore, some of you must be disappointed. The usual comments apply:

- The main place for presentation of your draft is the mailing list
- Discussion of your draft needs to be on the mailing list
  (discussions at the meetings don't carry much weight)

In order to make sure that drafts that do not get explicit slots on the agenda are not
forgotten, the chairs will attempt to mention some of the key ones, give status, and
encourage debate on the mailing list.

(The larger amounts of time dedicated to inter-domain is in anticipation of a healthy
degree of debate.)

Thanks,
Adrian

===

CCAMP 60 - San Diego - Draft Agenda
[running total 150 / 150]

Group Admin (Chairs)
  Admin and agenda bash (5 mins)
  Status of WG and drafts (5 mins)
        http://www.ietf.org/internet-drafts/draft-vasseur-ccamp-te-router-info-00.txt
        http://www.ietf.org/internet-drafts/draft-vasseur-isis-te-caps-00.txt
        http://www.ietf.org/internet-drafts/draft-vasseur-ospf-te-caps-00.txt
        http://www.ietf.org/internet-drafts/draft-vasseur-ccamp-loose-path-reopt-02.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-alarm-spec-00.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-crankback-02.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-rsvp-te-exclude-route-02.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-tc-mib-05.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-lsr-mib-05.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-te-mib-05.txt
        http://www.ietf.org/internet-drafts/draft-ietf-ccamp-tunproto-00.txt

http://www.ietf.org/internet-drafts/draft-dimitri-ccamp-gmpls-rsvp-te-bundled-links-00.txt
        http://www.ietf.org/internet-drafts/draft-oki-ccamp-gmpls-ip-interworking-03.txt

http://www.ietf.org/internet-drafts/draft-shiomoto-ccamp-misconnection-analysis-00.txt
        http://www.ietf.org/internet-drafts/draft-rabbat-ccamp-carrier-survey-00.txt

  Milestones and objectives (5 mins)

ASON Requirements and Solutions
  ASON Signaling and Routing Requirements and other cooked drafts (Adrian) (2 mins)
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-ason-reqts-06.txt
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-ason-routing-reqts-04.txt
    http://www.ietf.org/internet-drafts/draft-berger-gmpls-egress-control-02.txt

  ASON Signaling Solutions (Dimitri Papadimitriou) (5 mins)
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-rsvp-te-ason-01.txt

  ASON Routing Solutions Design Team status (Dimitri Papadimitriou) (10 mins)
    - charter & team
    - plans
    - drafts

  A Transport Network View of LMP (Don Fedyk) (5 minutes)
    http://www.ietf.org/internet-drafts/draft-aboulmagd-ccamp-transport-lmp-02.txt
    - why this draft?
    - adopt as WG draft?

  SG15 liaison (Wesam Alanqar 5 mins)

Protection and Restoration
  Drafts in AD review (Adrian) (2 mins)
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-analysis-02.txt
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-functional-01.txt
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-recovery-terminology-03.txt

  End-to-end recovery (Dimitri Papadimitriou) (5 mins)

http://www.ietf.org/internet-drafts/draft-lang-ccamp-gmpls-recovery-e2e-signaling-02.txt
    - ready for last call?

  Segment Recovery (Lou Berger) (5 mins)
    http://www.ietf.org/internet-drafts/draft-berger-ccamp-gmpls-segment-recovery-00.txt
    - ready for last call?

Hello Protocol and Graceful Restart
  Graceful restart (Lou Berger) (10 minutes)
    http://www.ietf.org/internet-drafts/draft-aruns-ccamp-rsvp-restart-ext-01.txt
    - good ideas?
    - adopt as WG draft?
  Node-id-based Hello (Zafar Ali) (5 minutes)
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-rsvp-node-id-based-hello-00.txt
    - implementation status
    - ready for last call
  Graceful restart (Zafar Ali / Anca Zamfir) (5 minutes)
    http://www.ietf.org/internet-drafts/draft-ali-ccamp-mpls-graceful-shutdown-00.txt
    - good ideas?
    - adopt as WG draft?

Inter-Area/AS
  Strategy (Kireeti) (10 minutes)
  - definitions and overview
  - simple requirements first
  - protection and other diverse path requirements later
  - PCE BOF

  Inter-domain Framework (Adrian) (15 minutes)
    http://www.ietf.org/internet-drafts/draft-farrel-ccamp-inter-domain-framework-01.txt
    - generality of "domain"
    - separation of routing, path computation and signaling
    - no attention to diverse paths at this stage
    - WG adopt?

  Inter-domain RSVP-TE (Arthi Ayyangar) (15 minutes)
    http://www.ietf.org/internet-drafts/draft-ayyangar-ccamp-inter-domain-rsvp-te-00.txt
    - Purpose of draft?
    - Main issues
    - WG adopt?

  Inter-domain TE LSP path computation methods (JP Vasseur) (15 minutes)
    http://www.ietf.org/internet-drafts/draft-vasseur-ccamp-inter-domain-path-comp-00.txt
    - Purpose of draft?
    - Main issues
    - Overlap with PCE BOF?
    - WG adopt?

  GMPLS Inter-AS requirements (Tomohiro Otani) (10 minutes)
    http://www.ietf.org/internet-drafts/draft-otani-ccamp-interas-gmpls-te-00.txt
    - Why a separate draft?
    - What are the main features?

Summary of other work
  Layer 2 GMPLS (Dimitri Papadimitriou) (5 mins)
    http://www.ietf.org/internet-drafts/draft-papadimitriou-ccamp-gmpls-l2sc-lsp-02.txt
    - what's it about?
    - adopt as WG draft?

  Layer 1 VPNs (Tomonori Takeda) (5 mins)
  - status and plans
    - still progressing "under the care of CCAMP"
    - mailing list
    http://www.ietf.org/internet-drafts/draft-takeda-l1vpn-framework-01.txt
    http://www.ietf.org/internet-drafts/draft-takeda-l1vpn-applicability-00.txt
    http://www.ietf.org/internet-drafts/draft-ouldbrahim-ppvpn-gvpn-bgpgmpls-05.txt
    http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-overlay-04.txt

---

From: ricciato <[email-masked]>
Date: Thu, 22 Jul 2004 12:11:31 +0200

Hi Adrian,

I think that it would be convenient for the WG to include a slot for 
discussion (not presentation) of the draft on diverse path requirements 
routing
(namely: draft-dachille-diverse-inter-region-path-setup-00.txt ).

In the current  version of the agenda for San Diego I do not see any 
reference to that, despite in the Seoul meeting it was acknowledged to 
be a very important work.
That time it was state that it should be discussed in the list and 
revised. I´m attaching an extract from the Seoul minutes at the end of 
this mail, for reference.
Well, both an _intensive_ discussion and a careful revision have been 
carried on for over 2  months now.
The discussion was fruitful indeed, and in the revision we have 
addressed _all_ the comments issued so far. The feedback were generally 
very positive.
Therefore, considered the very high level of interest that has been 
demonstrated for this topic, I do not see any reson for not having the 
chance to discuss the changes introduced in the revised version in San 
Diego in order to advance it in the WG.

I remark that the draft directly addresses a significant number of 
charter items:

-- Functional specification of extensions for routing (OSPF, ISIS) and 
signalling (RSVP-TE) required for path establishment.
-- Define signaling and routing mechanisms to make possible the creation 
of paths that span multiple IGP areas, multiple ASes, and multiple
providers, including techniques for crankback
-- Specify signalling mechanisms for path protection, diverse routing 
and fast path restoration.

Best regards
Fabio Ricciato

Here is the extract from the minutes:

>********************
>Vishal Sharma talked about work on Inter-area path
>protection
>draft-dachille-inter-area-path-protection-00.txt
>
>  He provided a brief overview of how it works, and showed
>  how it relates to other work in progress. He also listed
>  the next steps.
>
>  He emphasized that this is really a generic mechanism for
>  diverse path computation, and protection is one
>  application of it, so the authors would respin with a new
>  name and emphasis to reflect this."
>
>  Zafar Ali asked how this would work if there is a failure
>  at the time during which the backup path is being setup.
>
>    Vishal replied that the solutions to this were, so far,
>    not discussed in the draft, but that there are several
>    options.
>
>    He then outlined some of the options. E.g. either
>    default in such a case to a sequential computation, and
>    use XRO to exclude the link/node where backup path setup
>    failed, and retry the backup (and optimize both primary
>    and secondary later using the techniques in the draft).
>    Or, set up the primary and the backup again, using the
>    techniques described in the draft.
>
>    Vishal said they would be happy to add some discussion
>    in the document, and welcomed feedback on the list.
>
>  Zafar asked how this work relates to PCS/PCE work.
>
>    Vishal replied that it could actually be made use of by
>    the PCS/PCE approach, and could be viewed as
>    complementary.
>
>  Kireeti asked that further discussion be taken to the
>  list.
>
>  Vishal said he welcomed further feedback on the document.
>
>  Dimitri asked why, knowing that the proposed approach
>  works as expected in the intra-domain case when the
>  number of ABRs (where computation can be executed at each
>  stage) does not increase, this approach is so focused on
>  optimization (since it can't be achieved if this
>  condition is not met).
>
>    Vishal clarified that the focus of the work is to
>    propose a generic mechanism to facilitate diverse path
>    setup by communicating alternate path info, with
>    optimization a desired goal (for reasons explained in
>    the document).
>
>    Vishal added that given the network model (where border
>    nodes are not assumed to have visibility in areas other
>    than their own), the scheme was not trying to be
>    globally optimal.
>
>    Vishal explained that in such cases some selection needs
>    to be performed at each stage.
>
>  Kireeti asked that further discussion on this should be
>  taken to the list.
>
>  Also, he said that Dimitri had a good point - we need to
>  define criteria on which any optimization is based.
>
>  Kireeti concluded by saying that path protection and
>  inter-area are both in the charter, but that this document
>  could only be considered for a WG document after there was
>  discussion about the document on the list.
>
>*******************
>