Subject: draft-ietf-ccamp-rsvp-node-id-based-hello-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 27 Jul 2004 20:20:48 +0100

Hi,

Just a couple of comments.

Cheers,
Adrian

2. Introduction
   Even in the case of packet MPLS, when link failure detection is
   performed by some means other than RSVP Hellos (e.g., [BFD]), the use
   of node-id based Hellos is also optimal for detection of signaling
   adjacency failures for RSVP-TE.
This optimally only applies when there is more than one link between a pair of node,
right?
Say so?
Ditto section 3.

2. Introduction
   This document also clarifies the use of node-id based Hellos when all
   or a sub-set of TE links are unnumbered. This draft also clarifies
   use of node-id based Hellos in these scenarios.
Repeated?

3. Node-id based RSVP Hellos
   When a node receives a Hello packet where the destination IP address
   is its local node-id as advertised in the IGP-TE topology, the node
   MUST use its node-id in replying to the Hello message.
This is an interesting use of MUST when the receiving node knows that the use of node-id
is inappropriate.

I think it is really cute that Danny and Reshad have decided to swap email addresses :-)

---

From: dimitri papadimitriou <[email-masked]>
Date: Thu, 29 Jul 2004 19:25:28 +0200

hi adrian,

sorry for the delayed response - see in-line

> This optimally only applies when there is more than one link between a pair of node,

yes and here also one has to clarify the GMPLS PSC vs MPLS point already 
raised

> This is an interesting use of MUST when the receiving node knows that the use of node-id

yes this part of the text needs to be clarified (this paragraph as well 
as the previous would benefit from this revision

thanks,
- dimitri.
> .