Subject: draft-douville-ccamp-gmpls-waveband-extensions-05.txt

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 23 Jul 2004 14:26:19 +0200

all,

as mentioned in the additional ccamp webpage, this draft plugs a hole however 
interest shown on this list is certainly low

but so at the end of the day one may ask if this is the case

1) how implementations that have been reported in
<http://www.ietf.org/IESG/Implementations/MPLS-SIGNALING-Implementation.txt>

9 supports waveband labels so do we have to make the assumption that all of them
support only inverse multiplexing mechanism and/or wavelength concatenation ?

2) then what about Fiber SC ?

this leaves the impression that the FSC value has been sometimes used when 
switching the whole content of the container (ie the fiber) while following a 
strict interpretation it is meant to only address spatial switching per GMPLS ARCH:

"5. Fiber-Switch Capable (FSC) interfaces:

    Interfaces that switch data based on a position of the data in the
    (real world) physical spaces. An example of such an interface is
    that of a PXC or OXC that can operate at the level of a single or
    multiple fibers."

thanks,
- dimitri.

-------- Original Message --------
Subject: I-D ACTION:draft-douville-ccamp-gmpls-waveband-extensions-05.txt
Date: Thu, 22 Jul 2004 15:33:35 -0400
From: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Extensions to Generalized Multi-Protocol Label Switching
			  in support of Waveband Switching
	Author(s)	: R. Douville, et al.
	Filename	: draft-douville-ccamp-gmpls-waveband-extensions-05.txt
	Pages		: 11
	Date		: 2004-7-22
	
Generalized Multi-Protocol Label Switching (GMPLS) extends the MPLS
    control plane to encompass layer 2, time-division, wavelength and
    spatial switching. Along with the current development on IP over
    optical switching, considerable advances in optical transport
    systems based on the multiple optical switching granularities have
    been developed.

    Currently, GMPLS considers two layers of optical granularity using
    wavelengths and fibers. By introducing an extended definition of
    waveband switching, this document specifies the corresponding GMPLS
    extensions, to further integrate optical multi-granularity and
    benefit from the features of the corresponding switching layers.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-douville-ccamp-gmpls-waveband-extensions-05.txt

To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of the 
message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-douville-ccamp-gmpls-waveband-extensions-05.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-douville-ccamp-gmpls-waveband-extensions-05.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 25 Jul 2004 15:14:05 +0100

Hi Dimitri,

I'm not sure what you are asking.

I think you are asking "Does anyone out there care about waveband switching?"

We might refine this question for:
a. now
b. in the next two years
c. sometime
d. never.

It is slightly interesting to look at the 9/22 respondents to the GMPLS implementation
survey (November 2002).
Of these, two are software vendors and one a test tool manufacturer. All are forced to
implement, by definition.
Of the others, one flagged "future", one was a CR-LDP product, and one a research
implementation.
So I could argue that this leaves us with just three.

But it is probably more important to find out where we stand now.

So, question to the list...

Who believes that we need to complete the work on waveband switching in order to meet real
implementation or deployment requirements?

Thanks,
Adrian

> implementation to automatically retrieve the ASCII version of the

--------------------------------------------------------------------------------

---

From: dimitri papadimitriou <[email-masked]>
Date: Sun, 25 Jul 2004 19:20:45 +0200

hi adrian, see in-line for additional clarifications on the reasoning

> So I could argue that this leaves us with just three.

question is also that i found 9 waveband labels but as implied from existing 
document only inverse mux or concatenated wavelength (i.e. no real band mux/ 
demux) can be supported as no WBSC capability has been defined

> But it is probably more important to find out where we stand now.

agreed

> implementation or deployment requirements?

interestingly i found also 9 implementations supporting FSC, 7 of which were the 
same as those supporting Waveband label (LSC being covered by all of them except 
1) this reinforces the initial assumption

thanks,
- dimitri.

> .