Subject: RE: draft-rabbat-ccamp-carrier-survey-00.txt [Was: Re: Draft agenda for San Diego]

From: "Vishal Sharma" <[email-masked]>
Date: Thu, 22 Jul 2004 20:12:46 -0700

Hi Kensuke, Adrian, and CCAMPers,

I think Kensuke makes a very valid point.

Namely, that the carrier survey, in addition to focusing on specific 
carrier inputs regarding GMPLS and shared mesh, has also become 
a catalyst for a more general discussion of how carriers are 
using/planning to use GMPLS technology in various types of
networks and in various configurations.

This is a question that did come up as we endeavored
to contact the carriers to systematically gather their inputs
on shared mesh aspects, which are reflected in this draft.
We will, however, be posting an update with 
the additional inputs that we have received so far for expanding it (both
on and off the list), and will provide a pointer soon.

Thus, the survey actually relates directly to all of the
CCAMP charter work, and should be discussed in San Diego. 

The purpose of a face-to-face discussion will be
to: discuss the specific points that Kensuke and others have
raised, to evaluate what further aspects should be covered 
in the survey, and discuss how to interpret the current results.

(A mailing list discussion is, of course, important, and we
will continue with that, but there are specific inputs that can 
be obtained in a WG meeting discussion that are simply not possible 
on a ML; if that was not so, we wouldn't need any IETF meetings!)

Given that a vast majority of the CCAMP WG work centers on
GMPLS technology, a discussion of the survey in San Diego
seems very appropriate.

-Vishal

> -----Original Message-----
> From: Kensuke Shindome [mailto:[email-masked]]
> Sent: Thursday, July 22, 2004 6:58 PM
> To: Adrian Farrel
> Cc: Kensuke Shindome; [email-masked]; [email-masked];
> Richard Rabbat; 'Kireeti Kompella'
> Subject: Re: draft-rabbat-ccamp-carrier-survey-00.txt [Was: Re: Draft
> agenda for San Diego]
> 
> 
> Hi Adrian,
> 
> I understand that there are so many drafts and not enough time 
> for discussion.
> Our charter items should be progressed.
> I hope this survey trigger focusing on what carrier use GMPLS for.
> 
> The specific points I wanted to raise (at the next meeting?) are
>  * The survey may contain questions about carrier usage.
>      - model (peer, overlay, integrated)
>      - layers (packet, frame/cell/, TDM, OTN, wavelength, fiber)
>      - control plane activity
>          o path provisioning
>          o recovery
>          o fault management
>  * The survey need to avoid mapping responders and answers 
> opening the name and details.
> # I'm not the responder.
> 
> (hhhm, difficult...)
> 
> 
> IMHO, there are difficulties to handle routers and optical 
> transport equipments using GMPLS.
> I'm earnestly looking for realistic merits compared with IP/MPLS 
> and transport network.
> 
> Thanks,
> 
> 
> At Thu, 22 Jul 2004 15:27:41 +0100,
> "Adrian Farrel" <[email-masked]> wrote:
> > 
> > Hi Kensuke,
> > 
> > I agree that this is an important discussion to have across the 
> community.
> > I think, however, that this is a discussion that needs to be 
> carried out over a longer
> > period and on the mailing list.
> > 
> > What specific points would you want to raise at the meeting 
> that have not already been
> > raised on the list and that need to be aired in a face-to-face meting?
> > 
> > Thanks,
> > Adrian
> > ----- Original Message ----- 
> > From: "Kensuke Shindome" <[email-masked]>
> > To: "Richard Rabbat" <[email-masked]>; <[email-masked]>
> > Cc: "'Adrian Farrel'" <[email-masked]>; <[email-masked]>;
> > <[email-masked]>
> > Sent: Thursday, July 22, 2004 9:45 AM
> > Subject: Re: draft-rabbat-ccamp-carrier-survey-00.txt [Was: Re: 
> Draft agenda for San
> > Diego]
> > 
> > 
> > > Hi, all
> > >
> > > I think it will be a good opportunity to discuss this survey 
> draft in SD
> > > because the discussion leads up to general and individual 
> requirements.
> > > I'm interested in not only GMPLS technical aspects but SP's 
> deployment examples
> > > and motivation.
> > >
> > > Thanks,
> > >
> > >
> > > At Wed, 21 Jul 2004 18:10:49 -0700,
> > > "Richard Rabbat" <[email-masked]> wrote:
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: Adrian Farrel [mailto:[email-masked]]
> > > > > Sent: Wednesday, July 21, 2004 12:39 PM
> > > > > To: Richard Rabbat
> > > > > Cc: [email-masked]
> > > > > Subject: draft-rabbat-ccamp-carrier-survey-00.txt [Was: Re:
> > > > > Draft agenda for San Diego]
> > > > >
> > > > >
> > > > > Hi Richard,
> > > > >
> > > > > > Sorry, I forgot to cc: the mailing list given the interest.
> > > > >
> > > > > >>Hi Adrian,
> > > > > >>
> > > > > >>We would like to get some 2 to 3 minutes to discuss our
> > > > > survey results
> > > > > >>under the P&R section and how they can be used to advance P&R.
> > > > > >>http://www.ietf.org/internet-drafts/draft-rabbat-ccamp-carri
> > > > er-survey-
> > > > >>00.txt
> > > > >>We're getting some good feedback by email about it and 
> would like to
> > > > discuss
> > > > >>the next steps and increase the participation of the 
> carriers in the
> > > > debate.
> > > >
> > > > > You're not going to get any realistic discussion in 2 to 
> 3 minutes.
> > > >
> > > > [Richard] The purpose is to get feedback on the content, 
> format, etc of the
> > > > survey and how to interpret the results. This is carrier 
> feedback that
> > > > should be of high interest to everybody. Let's spend 5-6 
> minutes then to
> > > > have a good discussion in parallel with the ML work.
> > > >
> > > > > A better way to handle this, I think, is that the draft is
> > > > > mentioned from the chair (as shown in the draft agenda) and
> > > > > that discussions are taken to the list. Hopefully by doing
> > > > > this we can build on your work to produce a survey that helps
> > > > > us understand the deployment desires and motivations of
> > > > > GMPLS-using providers.
> > > >
> > > > > Cheers,
> > > > > Adrian
> > > >
> > > > > PS Feedback and thoughts on the draft to follow.
> > > >
> > > -- 
> > > Kensuke Shindome
> > > Inovative IP Architecture Centre, NTT Communications
> > > [email-masked]
> > >
> > >
> > >
> > 
> -- 
> Kensuke Shindome
> Inovative IP Architecture Centre, NTT Communications
> [email-masked]  +81 03 6800 3278(phone)

---

From: "Vishal Sharma" <[email-masked]>
Date: Thu, 22 Jul 2004 20:25:00 -0700

Comments in-line. (Sorry, forgot the relevant message in the
previous email.)

-Vishal