Subject: San Diego Agenda issues

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 22 Jul 2004 12:00:49 +0100

All,

At the risk of seeming petulant...

You CANNOT [RFC2119] have both all drafts discussed and a reasonable length discussion on
any draft.

After Seoul we were told in the strongest terms by WG participants and by the ADs that we
MUST facilitate discussion at the face-to-face meeting. Thirty five-minute slots may fill
the time, but will achieve nothing.

We have made a draft agenda which is now full. We completely understand that the work that
you are doing in your drafts is more important than anything anyone in the world is doing
at the moment, but we do not understand how you propose to cover your drafts on the agenda
as it now stands.

Of course, the chairs are only your humble servants, and if it is the will of the WG to
change the agenda that is fine with us so long as:
- it fits within the priorities and milestones in the charter
- it conforms to the requirements passed to us by the ADs
- we do not end up with tiny slots and no discussion on any draft

So, ask yourselves:
- why does my draft need discussion in SD?
- why can't the discussion be on the list?
- what will I recommend to be axed from the agenda?

It may be of interest that to you to know that the ADs issued some guiding principles:
- don't discuss any 00 draft that was only published a short time before the meeting
- don't discuss any draft that has not had discussion on the list
- only discuss drafts where there are open issues
- build the foundations first
- prioritise charter work above other work
- prioritise meeting the milestones above other charter work

Thanks,
Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Fri, 23 Jul 2004 01:20:28 -0700

Adrian and Kireeti,

Continuing with my previous email.... per your request
below, here are some specific suggestions on how the
agenda for San Diego can be improved to remove the
pressure on it, thus benefitting the WG as a whole.

-Vishal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Adrian Farrel
> Sent: Thursday, July 22, 2004 4:01 AM
> To: [email-masked]
> Subject: San Diego Agenda issues
>
>
> All,
>

I have examined the agenda in the light of the above questions, and
have looked at the drafts currently on it.

The following is meant to be a neutral assessment, based on closely
following the development of a good majority of the work on the agenda.
[Disclaimer: It _should not_ be interpreted as reducing the importance
of any of the work.
Rather, it is a serious attempt to take up the Chairs' request to
solve the agenda crunch (that we seem to be getting into more and more
of late), so that the WG as a whole benefits.]

i) First, I do not believe a mention by the Chairs, in less than
30-odd seconds each, of over 15 drafts buys the WG anything.

By removing this, the WG saves a full 5 minutes right away.

-- If the Chairs, in fact, want to draw attention to these documents, why
not
post your comments/urgings/admonitions with the pointer to these drafts
directly to the ML?
That is the right place to make the majority of the WG aware of these
important documents anyway.

-- Also, I noticed in some of your emails that you intended to "take a sense
of the room" for some of the drafts on this huge list.

I think that _should not_ be done.

It is very difficult, if not impossible, to get a sense of multiple drafts
in under 30 seconds each, and surely no fair sense can be got that way.

It it much better for the sense to be taken on the ML (which is the best
place anyhow) where people have time to think and reflect, and then respond.

ii) Second, given that the ASON Routing Design team has just been
constituted, and has only just begun its work,
it is difficult to see why 10 minutes are being given to discuss this.

Their composition and charter have already been posted to the list and
examined
by all, so none of those bear repeating.

It should suffice for the Chairs to spend 2 minutes or so (if that)
updating the WG on it.

So we are now at +18 minutes (possibly 20).

iii) The end-to-end recovery document was already mature a while back,
and has been discussed at practically every IETF for the past several
IETF's.

The issue of misconnections (for the purposes of this draft) has also been
adequately addressed to the satisfaction of the people who debated this
issue
(which includes me). AFAIK, that was the only substantive addition made.

What other open issues are still left that cannot now be satisfactorily
resolved on the mailing list and that require 5 minutes of the agenda?

It would seem that the last call can easily be done on the list (and is
probably best done there), bringing us to +23 minutes (possibly 25).

iv) The segment recovery document was made a WG document after Seoul,
but I don't recall seeing any discussion on it since.

Clearly, either the WG has not found time to focus its attention on this
work
between Seoul and now, or sufficient discussion has not been initiated on
it by the authors.

Either way, without any debate/discussion on the ML, this draft does not
satisfy multiple criteria listed above, and it seems fair that
the authors should attempt to generate discussion on the list, or summarize
things so it can move forward.

We are now at +28 minutes (possibly 30).

v) I am not sure I saw the graceful shutdown draft discussed (maybe its
a split off of some related work), but if it's new work with no discussion
yet, I would say we do not need 5 minutes for it.

vi) The comments for the L2 GMPLS draft say "what it's about?".

It seems that any draft for which this question needs to be answered at a
WG meeting probably first needs to be discussed on the list,  and
automatically does not meet multiple criteria from those you listed earlier.

Maybe I missed it, but can anyone point out where on the ML this draft
was discussed? And, what the outcome of those discussions was?

So it seems we can save a full 33 minutes (possibly 35, or 38 without
graceful
shutdown) from the agenda with substantial consequent benefit to the WG, by
freeing up time for various other important activities
(debates, discussions of other drafts, issues, etc.)

It would be good to hear if the WG believes that the above suggestions do
not benefit the WG and/or should not be implemented (and why).

Looking forward to seeing a revised agenda.

Thanks,
-Vishal

---

From: "Vishal Sharma" <[email-masked]>
Date: Fri, 23 Jul 2004 01:20:26 -0700

Adrian and Kireeti,

Thanks for initiating this discussion.

I think this is an important topic that the WG as a whole
should probably devote some CPU cycles to, and it would
be good to get more views.

To get things started, I am giving some comments and 
suggestions below, and in the next email.

-Vishal

> the time, but will achieve nothing.

I looked at the Seoul meeting minutes, and do not see any 
lack of discussion on the drafts _that did make it_ to the
agenda and that were discussed there. 
(People may have had opinions about whether everything on the agenda 
should have been there in the first place, but whatever
was there seemed to be adequately discussed.)

http://ops.ietf.org/lists/ccamp/ccamp.2004/msg00336.html

Quite to the contrary, the meeting minutes seem to suggest
that even 5-minute slots, if utilized correctly, provide plenty
of time for discussion of substantive issues.

So, can the participants and AD's who thought there was a 
problem _with the extent of discussion_ at the Seoul WG meeting
share their thoughts with the WG?

(Although, I would agree that _all_ slots being 5-minutes
is probably not a good idea.)

> - we do not end up with tiny slots and no discussion on any draft

I have some specific suggestions on how to improve the
current agenda; please see following email.

Also, I think several people on the ML have given their inputs
in the recent past, but I don't recall seeing any response to those 
notes.

> - what will I recommend to be axed from the agenda?

See comment just above, and my next email.

> - prioritise meeting the milestones above other charter work

Thanks for providing these. It would be good for the AD's to also
provide these guiding principles on the ML, so the WG is aware of
them, as an when they are laid out.

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 23 Jul 2004 11:10:30 +0200

vishal, some hints inline, these may help

Vishal Sharma wrote:
> Adrian and Kireeti,
> 
> Continuing with my previous email.... per your request below, here are some
> specific suggestions on how the agenda for San Diego can be improved to
> remove the pressure on it, thus benefitting the WG as a whole.
> 
> -Vishal
> 
> 
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]]On Behalf Of Adrian Farrel Sent: Thursday,
>> July 22, 2004 4:01 AM To: [email-masked] Subject: San Diego Agenda
>> issues
>> 
>> 
>> All,
>> 
>> You CANNOT [RFC2119] have both all drafts discussed and a reasonable length
>> discussion on any draft.
>> 
>> After Seoul we were told in the strongest terms by WG participants and by
>> the ADs that we MUST facilitate discussion at the face-to-face meeting.
>> Thirty five-minute slots may fill the time, but will achieve nothing.
>> 
>> We have made a draft agenda which is now full. We completely understand
>> that the work that you are doing in your drafts is more important than
>> anything anyone in the world is doing at the moment, but we do not
>> understand how you propose to cover your drafts on the agenda as it now
>> stands.
>> 
>> Of course, the chairs are only your humble servants, and if it is the will
>> of the WG to change the agenda that is fine with us so long as: - it fits
>> within the priorities and milestones in the charter - it conforms to the
>> requirements passed to us by the ADs - we do not end up with tiny slots and
>> no discussion on any draft
>> 
>> So, ask yourselves: - why does my draft need discussion in SD? - why can't
>> the discussion be on the list? - what will I recommend to be axed from the
>> agenda?
>> 
>> It may be of interest that to you to know that the ADs issued some guiding
>> principles: - don't discuss any 00 draft that was only published a short
>> time before the meeting - don't discuss any draft that has not had
>> discussion on the list - only discuss drafts where there are open issues -
>> build the foundations first - prioritise charter work above other work -
>> prioritise meeting the milestones above other charter work
> 
> I have examined the agenda in the light of the above questions, and have
> looked at the drafts currently on it.
> 
> The following is meant to be a neutral assessment, based on closely following
> the development of a good majority of the work on the agenda. [Disclaimer: It
> _should not_ be interpreted as reducing the importance of any of the work. 
> Rather, it is a serious attempt to take up the Chairs' request to solve the
> agenda crunch (that we seem to be getting into more and more of late), so
> that the WG as a whole benefits.]
> 
> i) First, I do not believe a mention by the Chairs, in less than 30-odd
> seconds each, of over 15 drafts buys the WG anything.
> 
> -- If the Chairs, in fact, want to draw attention to these documents, why not
> directly to the ML? That is the right place to make the majority of the WG
> aware of these important documents anyway.
> 

-> i think that the intention was to launch the disucssion on the list (see
    several mails) and wrap-up them during these 5 minutes in order to see how
    to progress

> I think that _should not_ be done.

-> but what you think is not imho the primary intention also keep in mind that
    some of these drafts (such as 
<http://www.ietf.org/internet-drafts/draft-vasseur-ccamp-te-router-info-00.txt>
   have just been made available and discussion just started)

> It is very difficult, if not impossible, to get a sense of multiple drafts in
> under 30 seconds each, and surely no fair sense can be got that way.
> 
> constituted, and has only just begun its work, it is difficult to see why 10
> minutes are being given to discuss this.
> 
> examined by all, so none of those bear repeating.
> 
> It should suffice for the Chairs to spend 2 minutes or so (if that) updating
> the WG on it.

-> there is a first cut of the draft (intent is not to go through all the ml dt
    chartering discussions)

> iii) The end-to-end recovery document was already mature a while back, and
> has been discussed at practically every IETF for the past several IETF's.
> 
> adequately addressed to the satisfaction of the people who debated this issue

-> this time has been provided to wrap-up the work (when adrian says 5 minutes
    it is 2 slides) do this in a clever way would allow to not come back to it
    during next meeting(s)

> iv) The segment recovery document was made a WG document after Seoul, but I
> don't recall seeing any discussion on it since.
> 
> Clearly, either the WG has not found time to focus its attention on this work
> between Seoul and now, or sufficient discussion has not been initiated on it
> by the authors.
> 
> satisfy multiple criteria listed above, and it seems fair that the authors
> should attempt to generate discussion on the list, or summarize things so it
> can move forward.

-> question is always the same there was lot of support to have this topic
    becoming a WG effort so issue

> v) I am not sure I saw the graceful shutdown draft discussed (maybe its a
> split off of some related work), but if it's new work with no discussion yet,
> I would say we do not need 5 minutes for it.

-> <http://ops.ietf.org/lists/ccamp/ccamp.2004/msg00225.html> and follow up

> It seems that any draft for which this question needs to be answered at a WG
> meeting probably first needs to be discussed on the list,  and automatically
> does not meet multiple criteria from those you listed earlier.
> 
> Maybe I missed it, but can anyone point out where on the ML this draft was
> discussed? And, what the outcome of those discussions was?

-> there is an open discussion point since minneapolis here, with the support
    this document received we're waiting for a go ahead

> graceful shutdown) from the agenda with substantial consequent benefit to the
> WG, by freeing up time for various other important activities (debates,
> discussions of other drafts, issues, etc.)
> 
> It would be good to hear if the WG believes that the above suggestions do not
> benefit the WG and/or should not be implemented (and why).

-> this decision is imho at the discretion of the WG chairs imho, this said i 
strongly believe that managing situation in a fairly way is time and effort 
consuming ... no surprise here

> Thanks, -Vishal
> .

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 23 Jul 2004 13:08:57 +0100

Vishal,

> Thanks for initiating this discussion.

Well, I regret it!

> be good to get more views.

If we devoted the same number of cycles to reviewing and progressing the WG work, we would
not need to discuss the agenda.

> suggestions below, and in the next email.

We are all indebted, I'm sure.

> > After Seoul we were told in the strongest terms by WG
> > participants and by the ADs that we MUST facilitate
> > discussion at the face-to-face meeting. Thirty five-
> > minute slots may fill the time, but will achieve nothing.
>
> (People may have had opinions about whether everything
> on the agenda should have been there in the first place, but
> whatever was there seemed to be adequately discussed.)
>

So:
- did you track how many slots went over time?
- did you spot that the meeting overran?
- did you notice that two items were dropped from the end?
- did you notice how often the queue at the mic was cut off
   after just a couple of people?
- can you count the number of times the minutes ask that
  "discussions be carried on on the list"

> share their thoughts with the WG?

They are, of course, welcome to.
It is enough, however, that they have told the chairs.

> in the recent past, but I don't recall seeing any response to those

Remind me.

> them, as an when they are laid out.

The WG is now aware of them and they are laid out.
Why would you want the AD to waste his time cutting and pasting?
Or are you saying something else?

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 23 Jul 2004 13:39:47 +0100

> pressure on it, thus benefiting the WG as a whole.

Hmmm. Makes note not to use irony or rhetoric in future emails.

> have looked at the drafts currently on it.

Before going any further, be ware that the default position will be that we devote the
meeting entirely to satisfying our milestones. No other drafts would be examined, and no
other work done.

As Fred Baker recently said:
  ...the charter of a working group is a contract-of-sorts to accomplish
  something. ... I would like to see working groups held to their
  chartered work plans, and rechartered if the work-plan changes.

I take this very seriously, and would like to dilute it only in support of existing WG
drafts that also need to be progressed. If you look at the agenda you will see
that it spends most of the time of milestones that have a reasonable chance of
advancement, but actually touches on all of the milestones.

I have said before, and will say again and again until I am heard, if you want meeting
time to be spent on your drafts you MUST give time and effort to advance the WG
milestones. When we
have done our work, we have time to play.

Who in the WG has reviewed the GMPLS MIBs?
Who has provided constructive suggestions for the development of GTTP.

And failing that, perhaps the WG would like to open a debate about changing the work-plan.
But I have heard no discussion of that so I assume that the WG is happy with the current
milestones.

> By removing this, the WG saves a full 5 minutes right away.
[SNIP]
> I think that _should not_ be done.

I do not suggest doing it for your benefit. I suggest doing it for the benefit of the
chairs.

I will, however, happily remove your draft from this list if that is what you are asking
me to do.

Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Fri, 23 Jul 2004 15:54:17 -0700

Adrian,

I am very disappointed to see your responses to my two previous
emails, and take serious issue with the rather dismissive tone
of your responses.

It would be nice to put aside rhetoric and clever remarks to 
focus constructively on the feedback at hand.

The reality is that the feedback I provided is a very
serious attempt to advance the WG's goals and milestones.

Not having an overcrowded agenda is one of the keys to 
advancing WG work.

And, as an active and responsible contributing member of this WG and 
the IETF, I believe it is incumbent to help structure what appears 
to be a needlessly overcrowded CCAMP agenda.

I would have provided this feedback regardless of whether or 
not the you asked for it. I don't think the Chairs have to
ask for feedback from WG members, for us to provide it.

(Note: 
I have certainly done my share in contributing to progressing 
several recent WG items, including TE requirements, inter-region TE, 
P&R, ASON aspects, node ID and hellos,  and the like -- one need only 
go to the ML archives and minutes for that -- 
so it is not as if my input is without basis or without the interests 
of the CCAMP WG in mind.

Of course, it is neither possible nor practical for everyone to
provide inputs on every WG item; nor, in my view, is it beneficial
for someone to attempt to do that.)

To address your specific points:

i) It is never possible to finish all discussions during a WG meeting,
(so, of necessisty, many long discussions are transferred to the ML,
many people are left standing at the mike, etc.)
I think we all understand that, and I do not see anything 
particularly unsual in it at Seoul.

But, if that is an issue, then freeing up 30-odd minutes of the
agenda would seem _even more_ important than I initially thought. It
would ensure that whatever is discussed, is, as far as possible,
done so fully.

ii) Towards that end, I provided _six_ specific suggestions (with
reasoning and justification, based on the criteria specified in
your email), on how the agenda can be made less crowded.

http://ops.ietf.org/lists/ccamp/ccamp.2004/msg00761.html

And, I did not see the WG advance any objections or give any 
reasons why my suggestions are not sensible and reasonable.

I see that you have simply <snipped> them in your reply, I'm
afraid that is not good enough.

If the Chairs, as representatives of the WG body politic, draft the agenda,
and a member seriously provides inputs on it, the Chairs are obligated to
respond, as long as the inputs are not "frivolous", which I 
certainly do not think anyone can point to as being the case here.

iii) The "sense of the room" is neither for my benefit nor
that of the Chairs. 
It is for the benefit of the WG as a whole, to help advance its work.

In that context, if the WG is polled in a rushed way, I re-iterate 
that I don't think that it benefits the WG to do so, and that time can
be saved.

Furthermore, I did not see any communications stating that a sense
of _all_ of these drafts will be taken, only some of them. 
I suggested instead that it would be better for the Chairs to
highlight all these drafts on the list, and take a sense there.

(So, I am not sure what you are driving at by suggesting 
dropping "my" draft from the list. In any case, there is none named 
after me, and two on which I am only a co-contributor.)

iv) If there are milestone items that no one in the WG is commenting on,
despite the WG taking them on,
then it is perhaps time to seriously re-examine them, or encourage
and urge those interested in those items to contribute to them. 

However, I don't see how putting them on the agenda 
achieves the cause of advancing those milestones, except taking 
up time.
People listen to the presentation, and nothing happens thereafter.

v) Finally, the request to have the AD guidelines be published
on the ML, was simply to ensure that the WG learnt of them in 
good time, to allow people to plan their work accordingly.

Thanks,
-Vishal

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Friday, July 23, 2004 5:40 AM
> To: Vishal Sharma (E-mail 2); [email-masked]; Kireeti Kompella
> Cc: Alex Zinin; Bill Fenner
> Subject: Re: Specific suggestions to improve San Diego agenda [Was RE:
> San Diego Agenda issues]
> 
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 24 Jul 2004 20:20:30 +0100

Hi,

> emails, and take serious issue with the rather dismissive tone

I'm sorry that you interpret the tone of my response as rather dismissive.

I understand that you are disappointed both that your survey draft has not been allocated
a slot on the agenda and that I have not leapt to embrace your suggested agenda
modifications.

> serious attempt to advance the WG's goals and milestones.

Then I will go through your mail and respond to each point in detail, below.

> Not having an overcrowded agenda is one of the keys to

Agree.

> for someone to attempt to do that.)

All input from all sources is valuable. There is no need for anyone to stop providing
input just because they have already made comments in many fields. In particular, people
implementing or deploying the technology will have sound opinions across most of the
workspace and should be encouraged to comment and contribute.

> particularly unsual in it at Seoul.

Well, my memory of Seoul is that we rarely got beyond the first three in line and that
there was no space for debate or discussion. This certinaly gels with the comments I
received afterwards.

I know from experience that for someone to be moved to go to the mic takes a fair amount
of concern, and that it is hugely frustrating for the queue to be cut off.

> would ensure that whatever is discussed, is, as far as possible,

Indeed. If we could free up agenda time, that would make sense.
The debate (below) is about whether we can free up the time.

> http://ops.ietf.org/lists/ccamp/ccamp.2004/msg00761.html

And I shall respond to each of the six below.

> reasons why my suggestions are not sensible and reasonable.

Silence is taken as consent in this matter?
I hope you will reconsider this. The WG participants are surely all too busy with many
other things to provide instant responses (or indeed any response) to a debate on the
agenda. But I would be happy to be proved wrong.

> afraid that is not good enough.

Oh.
Well, sorry.
The snipping was because I was responding to a sub-set of your points.
I simply did not have time to respond to all of the points that you raised at the time and
thought that you would prefer to receive some response quickly, rather than none. I am now
pursuing every point in your orriginal mail and hope this will satisfy you.

> certainly do not think anyone can point to as being the case here.

Yes, indeed.
And hopefully the chairs are also allowed to go to bed sometimes? And do other work? And
review all of the drafts submitted in advance of the meeting? And review the relevant and
related drafts from other WGs and BOFs?

The aim must surely be to be a little reasonable here. Allow us all a little space to
breathe and write considered and lengthy responses as time allows.

> It is for the benefit of the WG as a whole, to help advance its work.

Wrong.
If the chairs take the sense of the room it is for their benefit. It helps them guide the
working group that carries out all of its meaningful business on the mailing list, but
allows a quick and unscientific gauge for where the WG is with an issue.

> that I don't think that it benefits the WG to do so, and that time can

So, let me give you a concrete example. Is a draft ready for last call? When we want to
know that we send mail to the list (not for a vote, but to get a consensus) and if
consensus is judged (by the chairs) a last call is held.

Authors continually (and I mean continually) ask the chairs for last call. Sometimes it is
obvious that the draft is not ready, sometimes the chairs review the draft and find many
issues, sometimes it looks like the draft is ready. But typically we don't simply send
mail saying "is this draft ready for last call": what we do is get a feeling for whether
the WG is in a position to make the judgement. For example, how many people have read the
draft? who feels that this is an important area? who has implemented? do you feel
confident that this is stable?

We could ask these questions on the mailing list, but it is neither quick nor friendly.
Most people on the CCAMP list are very busy and do not get to read and respond to emails
in a timely manner. It is clearly far more helpful to use a WG gathering to gather this
information and use that as a guide for how to continue.

> highlight all these drafts on the list, and take a sense there.

As above.

But you make a very good point. It might be really helpful if the chairs were to provide a
status (say monthly) to the WG on the progress of drafts and milestones. This would
certainly focus the chairs' activities, might help to drive the editors, and would mean
that a little less time was needed for this type of work at the meetings.

I would be interested to hear from people whether this would be
- useful
- something they would commit to read.

> after me, and two on which I am only a co-contributor.)

The context of the discussion was very clearly one draft for which you are listed as one
of three authors.

> despite the WG taking them on, then it is perhaps time to seriously re-
> examine them, or encourage and urge those interested in those items to
> contribute to them.

I could not agree more.
There are two items that cause me grave concern. These are the GMPLS MIBs and Tunnel
Tracing. Both items have milestones which have passed their sell-by dates, yet the WG
shows very little interest in advancing the work.
The MIB authors (those who still remain working in the area) have made frequent requests
for assitance and implementation experience, but none has been forthcoming.
Yet we (as chairs) are told that these two items *are* important and fundamental to the
success of GMPLS. The chairs have given their time to work on these drafts, but help is
needed or the items must be dropped.

> People listen to the presentation, and nothing happens thereafter.

Then we need another suggestion.
Clearly in the desparation to get something to happen, the chairs wish to raise these
items (no other action seems to have any effect, perhaps raising them at the meeting will
work).
Personally, I would welcome time on the agenda (perhaps 15 minutes for each item) to
debate whether we should abandon them, or how we can achieve the milestones which we as a
working group have committed to yet have failed to meet.
However, I suspect that if I allocated time for such a debate, I would receive even more
of a lashing.

> good time, to allow people to plan their work accordingly.

Well, they are out in the open now. I guess they were mainly intended to focus the way
that the chairs work, but I see no reason why the rest of the WG shouldn't be aware of
them.

= = =

Now your original email with responses...

> of late), so that the WG as a whole benefits.]

No such request was made.
Nevertheless, your input is most valuable.

> 30-odd seconds each, of over 15 drafts buys the WG anything.

This is discussed at some length above, but further comments are provided below for
completeness.

It is worth noting that many of the items in this list of 15 received a request for 5, 10
or 15 minute slots. The list, therefore serves two purposes:
- it flags certain drafts about which the chairs have something very brief to say
- it mentions certain drafts that would otherwise be entirely left off the agenda.

This last point is helpful to and welcomed by some people.

> not post your comments/urgings/admonitions with the pointer to these drafts
> directly to the ML?

Agreed. And you may have noticed that I have been working through the drafts, reviewing
the new ones and sending comments to the list.
Editors and authors have also been receiving private emails to help advance their work.

But this is not an either/or. Bringing the items to the agenda still focuses the authors
and provides a brief *coherent* summary for all WG participants and for those many who
come to the meeting to find out what is going on, but who are not subscribed to the mail
list.

As mentioned above, a WG status email might help to alleviate this problem
*in*the*future*.

> in under 30 seconds each, and surely no fair sense can be got that way.

As mentioned in a previous response and above, this is done by the chairs, for the chairs'
benefit. It is not intended to be fair or easy. It is intended to help the chairs gauge
the feeling of the WG in a very rough but most importantly speedy way.

> place anyhow) where people have time to think and reflect, and then respond.

No-one is suggesting that such a "sense of the room" replaces the mailing list as the
correct place to take consensus. It is just a tool - one that the chairs find useful.

** Thus, I reject this 5 minute saving.

> constituted, and has only just begun its work, it is difficult to see why
> 10 minutes are being given to discuss this.
>

The DT is carrying out a very important piece of work. It is important on four fronts:
- it is providing important function
- it is working on routing protocols that might be easily destabilised
  with dire results
- it requires input from multiple WGs
- it is building bridges with two external bodies with which we have a
  very bad history.

The DT has already started work and produced an outline draft.
They need to report on their achievements and outline the biggest issues and challenges.
They should be asking for any help that they need.

It is possible that they will need more that the ten minutes as I expect some questions
from members of the IGP WGs that are members of the CCAMP mailing list.

** Thus I reject this 8 (or possibly 10) minute saving.

> So we are now at +18 minutes (possibly 20).

5 + 8 = 13

> issue (which includes me). AFAIK, that was the only substantive addition
> made.
>

I am glad to hear that the changes to this draft address your concerns.
The slot is to allow the authors to say what they have done in response to the concerns,
to check that those who were concerned are now happy, to check that everyone else is happy
that the changes are not detrimental, and to see if there are any other issues.

You may recall that the whole misconnection issue was only nailed and committed for
inclusion in this draft as a result of comments made at a similar meeting.

> probably best done there),

There is no intention to do last call at the meeting.
The intention is to discover whether the decks are now clear to ask for last call.

Five minutes does not seem extravagant for this item. In fact I might expect Dimitri,
experienced as he is to skim through this in only 3 minutes, but if there are issues or
questions...

** Thus I reject this saving of five minutes, but might expect to save 2 minutes along the
way.

> bringing us to +23 minutes (possibly 25).

5 + 8 + 5 = 18

> but I don't recall seeing any discussion on it since.

There were at least 7 emails about this draft since Seoul.
There was a debate about the use of the Association object that had some value.

> work between Seoul and now, or sufficient discussion has not been
> initiated on it by the authors.

Or the draft is cooked?
Or perhaps the authors have some additions that they want to propose?
Which is it? How are the chairs to decide?

> should attempt to generate discussion on the list, or summarize

This is a WG draft.
It is our responsibility to drive WG drafts to completion and get them shunted off to the
IESG. This makes room for new work in the future. Note that the authors are not
responsible for WG drafts: they are guardians of the draft for the WG. The WG is
responsible for getting them finished.

I agree that this draft is the most marginal for a mention so far, and if a cut had to be
made in favour of something else then this might be a candidate. It would be useful, but
not essential to cover this draft.

** Thus, hold this five minutes in abeyance pending finding something more important.

> We are now at +28 minutes (possibly 30).

5 + 5 + 8 + 5 = 23

> yet, I would say we do not need 5 minutes for it.

See Dimitri's mail for references to the discussion.

The point here is that we are looking at a bunch of changes to the Hello mechanism (and
other protocol techniques) related to graceful restart. This draft proposes other methods
to take a link out of service and in a graceful way, and since the area is closely related
(and some might argue should be solved in the same way) there is value in bringing the
work together with the previous drafts.

However, I agree that this draft is also a candidate to be shunted out by something more
important.

** Thus, hold this five minutes in abeyance pending finding something more important.

> was discussed? And, what the outcome of those discussions was?

This draft has been around for ever!
I want to clear up once and for all whether this is in scope or out of scope. Whether the
WG believes it is plugging an important hole or simply following a completeness proof.
Will anyone implement it? Would anyone deploy it?
We need to close on this now and either get the draft on board, finished, implemented and
shipped, or else axe it.

I see a brief slot on the agenda as a very good way to force the issue.

For me this slot is more important than many others on the agenda.

** Thus, I reject this five minute saving.

> graceful shutdown) from the agenda with substantial consequent benefit
> to the WG, by freeing up time for various other important activities

Correcting the math, this reads "28 minutes (possibly 30, or 35...)"

I accept that of this sum, 10 minutes are available to make space for something more
important. I am always glad to hear suggestions as to what that might be, but I do not
want to get into a "his draft is less valuable than my draft" debate with anyone.

> not benefit the WG and/or should not be implemented (and why).

A well-phrased question, but since you are asking for / proposing change, it is
conventional to ask the question the other way round.

So...

I would be interested to hear if anyone in the WG believes that Vishal's suggestions would
benefit the WG.
Which of the items listed should we abandon, and in favour of what?

> Looking forward to seeing a revised agenda.

I will not be providing a revised agenda until it is clear what we are proposing to put in
place of things we cut, and until it is clear that that is a beneficial act.

The deadline for agenda submission is Monday, but I will be travelling from Sunday so I
will submit the agenda on Sunday evening UK time.

Please note that the agenda will still be open for revision in the meeting. I would
suggest that it is by far the best idea to get all agenda debates in the open *before* the
meeting. If we spend any significant time within the meeting bashing the agenda, we will
waste the meeting.

Thanks,
Adrian

---

From: "Vishal Sharma" <[email-masked]>
Date: Sat, 24 Jul 2004 14:02:35 -0700

Adrian,

Thanks for your detailed response. I recognize and appreciate the time
you spent replying to it.

At this time, I will reply to just one point, that I think is
important to address.

I will address the others (as appropriate) later, noting for now that
we have identified at least 10 minutes on the current agenda that, if
nothing else, can be devoted simply to a better discussion of remaining
items on it. The drafts taking up that time could be held in abeyance,
and discussed, if there is time remaining at the end to do so.

Now to my point ...

> Sent: Saturday, July 24, 2004 12:21 PM
> To: [email-masked]; [email-masked]; Kireeti Kompella

Just to be absolutely clear, I am _not disappointed_ on either of the
two counts above that you continually seem to attribute my email about
the agenda and the subsequent disappointment to.

[First, my emails did not say anything at all about the carrier survey
draft; they were (and are) purely a discussion of the overly full agenda,
and
how to free it up.

Second, it is not "my" survey draft.
-- Over a dozen people have contributed to it, all aware that they
were giving their time and inputs with the purpose of eventually having
the survey results published as a draft for discussion
within the IETF/CCAMP, and all, the carriers especially, supporting such
a discussion.

-- One carrier representative (who is not a respondent) has already sent
several comments on it to the list, supporting the document and supporting
its disucssion at San Diego, and at least two other people have
commended the draft on the list, and several others off list.

Third, I had made it quite clear in my very first email that my suggested
modifications were designed to facilitate discussion (which we are now
having); there was no implication that they be accepted without
discussion.]

I was disappointed because as professionals engaged in a rational
discourse, and as a Chair, I expected a better response from you
(not necessarily a detailed one, but certainly
a better one).

Indeed, there are time constraints we all work under (Chairs
and members alike), and, as you've observed, it takes non-trivial
time, effort, and dedication to put serious comments/feedback together,
and this is something we all should recognize when responding to
such input.

-Vishal