Subject: draft-rabbat-ccamp-carrier-survey-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jul 2004 21:21:04 +0100

Hi,

Thanks for starting the ball rolling on this.

It is tempting to start analysing the results, but probably too early.

One SP responded that they are already using shared-mesh. It would be hugely interesting
to know the experiences of this operator. Would they be prepared to stand up? If not,
would they be prepared to filter their comments anonymously through the chair?

I have some big and little issues with the draft.

Big issues.

A.

I'm inclined to agree with Tom Petch. Surveys are, of course, very delicate things
especially when they apply to future plans of competitive bodies, but it really would be
useful to have some indication of the responses for each SP.

I suggest you look at the old GMPLS implementation survey format. The draft consisted of a
summarization (like what you have published) but also included all of the questionnaire
responses to that we could see how the responses to each question were correlated. It is
not necessary to force the identification of each responder, but you should allow them to
be identified if they choose.

In any case, it would be useful to understand where the individuals responding fit within
their company organisations. Without casting any aspersions, there is a large difference
between someone in the research department and someone in the operations department.

B.

I would like to see (as I'm sure you intend) a more open invitation to participate in the
survey. Probably refine the survey, post it somewhere, notify the mailing list and through
other channels.

C.

Although the abstract/introduction mentions optical networks, the survey does not appear
to draw any differentiation between the various switching capabilities. I think it is
fundamental to an understanding of what carriers are trying to achieve to know what type
of network they are trying to build (PSC, TDM, WDM etc.).

D. Questions 2 and 3 on the survey seem pretty important, but don't appear in section 5.

E.

Section 5.1 claims that the responses relate to GMPLS, but the question is about "an
IP-based control plane such as GMPLS."

G.

Section 5.2 claims that the responses relate to using GMPLS to provide shared-mesh
restoration, but the survey question does not mention GMPLS.

H.

Section 5.3 is a good example of why we need to provide the responses correlated by
responder. For some responders the answers here may have prevented them from making plans
to deploy, for others they plan to deploy despite their concerns. For others, they have no
plans to deploy for other reasons, but have still voiced concerns.

I.

Section 5.4. It is not clear whether the final comment in this section is your
interpretation, apple-pie, or a specific response to the survey.

J.

Section 5.5 claims that the responses pertain to traffic carried on the responder's
network, but the question makes no reference to this and is general in nature.

K.

Why does question 9 lead the witness? In order to establish the true requirements we
should not discuss specific solution models, but try to understand what the operational
concerns are.

Little issues.

a.

It might be nice if the draft file name gave a little more clue about the content of the
survey. You might consider draft-rabbat-ccamp-gmpls-mesh-carrier-survey-00.txt

b. Please try to avoid spurious characters in the text.

c.

Abstract says that a number of GMPLS routing and signaling standards have been completed.
I think the RFCs are only at Proposed Standard at the moment.

d. Don't think you need section 2

e.

Glad that you have a one paragraph definition of "shared mesh restoration" in the survey.
Probably good to copy it into the main draft.

Cheers,
Adrian

---

From: "Richard Rabbat" <[email-masked]>
Date: Wed, 21 Jul 2004 13:55:04 -0700

Hi Adrian,

Thanks for the extensive review and feedback. I'll answer the little issues
here first. Answers to big issues in an email to follow.

> Little issues.
> 
> a.
> 
> It might be nice if the draft file name gave a little more 
> clue about the content of the survey. You might consider 
> draft-rabbat-ccamp-gmpls-mesh-carrier-survey-00.txt

[Richard] I agree. As you can see from the quoted email from IETF, the
longer filename that I asked for was rejected so I had to shorten it.

> -----Original Message-----
> From: Dinara Suleymanova [mailto:[email-masked]] 
> Sent: Thursday, July 08, 2004 6:46 AM
> To: Richard Rabbat
> Subject: Re: New Internet draft submission
> 
> Too long file name. Please shorten and resubmit.
> 
> At 09:05 PM 7/7/2004, you wrote:
> >Dear IETF draft submission manager,
> >Attached is a copy of a new draft submitted for consideration by the 
> >IETF CCAMP WG.
> >
> >Title: Carrier Survey Results on GMPLS-based Shared-Mesh Transport
> >Restoration Strategies
> >draft-rabbat-ccamp-carrier-survey-sharedmesh-restoration-00.txt

> b. Please try to avoid spurious characters in the text.

[Richard] I can't get bad characters to print here; are there specific
characters that are printing bad? I tested from windows and Unix boxes...
> 
> c.
> 
> Abstract says that a number of GMPLS routing and signaling 
> standards have been completed. I think the RFCs are only at 
> Proposed Standard at the moment.
> 
[Richard] Yes, will update.

> d. Don't think you need section 2
[Richard] Will remove. 

> e.
> 
> Glad that you have a one paragraph definition of "shared mesh 
> restoration" in the survey. Probably good to copy it into the 
> main draft.

[Richard] Sounds good, will do.

> Adrian
See you in SD,
Richard.

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 Jul 2004 22:31:33 +0100

Hi,

> longer filename that I asked for was rejected so I had to shorten it.

Whatever.

> characters that are printing bad? I tested from windows and Unix boxes...

Second line of abstract.
End of second word.

Adrian

---

From: "Richard Rabbat" <[email-masked]>
Date: Wed, 21 Jul 2004 17:51:34 -0700

Answers to the big issues here...

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Wednesday, July 21, 2004 1:21 PM
> To: Richard Rabbat; Vishal Sharma (E-mail 2); [email-masked]
> Cc: [email-masked]
> Subject: draft-rabbat-ccamp-carrier-survey-00.txt
> 
> 
> Hi,
> 
> One SP responded that they are already using shared-mesh. It 
> would be hugely interesting to know the experiences of this 
> operator. Would they be prepared to stand up? If not, would 
> they be prepared to filter their comments anonymously through 
> the chair?
> 
[Richard] I have sent email to my contact at the specific carrier and will
update you and the ML about their preference.

> I'm inclined to agree with Tom Petch. Surveys are, of course, 
> very delicate things especially when they apply to future 
> plans of competitive bodies, but it really would be useful to 
> have some indication of the responses for each SP.
> 
> I suggest you look at the old GMPLS implementation survey 
> format. The draft consisted of a summarization (like what you 
> have published) but also included all of the questionnaire 
> responses to that we could see how the responses to each 
> question were correlated. It is not necessary to force the 
> identification of each responder, but you should allow them 
> to be identified if they choose.
> 
[Richard] Tom's and your comment are to the point. We've actually thought
about this and looked at the old survey. We are still waiting to get
permission from some carriers that have not given us the OK yet to publish
the results in an anonymized fashion just as you suggest. We'll update the
draft as soon as we get the response.

> In any case, it would be useful to understand where the 
> individuals responding fit within their company 
> organisations. Without casting any aspersions, there is a 
> large difference between someone in the research department 
> and someone in the operations department.
> 
[Richard] None of the respondents are from the research departments. They
are from planning, engineering and operations, exactly what you're looking
for.

> B.
> 
> I would like to see (as I'm sure you intend) a more open 
> invitation to participate in the survey. Probably refine the 
> survey, post it somewhere, notify the mailing list and 
> through other channels.
> 
[Richard] Definitely agree. This is exactly one of the purposes of the draft
as stated in my emails and in the draft. 
It has taken us a long time to identify the right people at different
carriers and would love to get more feedback.
We've already had emails from people offering us help in getting more
carriers to respond to it. 
We submitted this one to get the kind of feedback we're now getting so that
we can approach a larger number of carriers with the updated survey.

> C.
> 
> Although the abstract/introduction mentions optical networks, 
> the survey does not appear to draw any differentiation 
> between the various switching capabilities. I think it is 
> fundamental to an understanding of what carriers are trying 
> to achieve to know what type of network they are trying to 
> build (PSC, TDM, WDM etc.).
> 
[Richard] Good point. We'll ask carriers to give us what they're using from
the list of: 1=PSC, 51=L2SC, 100=TDM, 150=LSC, 200=FSC

> don't appear in section 5.
[Richard] We'll add these in the next iteration. 

> E.
> 
> Section 5.1 claims that the responses relate to GMPLS, but 
> the question is about "an IP-based control plane such as GMPLS."
> 
[Richard] Yes, the goal was to be more general in order to get feedback from
carriers that are looking at IP protocols for their control plane. We'll
change the title for consistency.

> G.
> 
> Section 5.2 claims that the responses relate to using GMPLS 
> to provide shared-mesh restoration, but the survey question 
> does not mention GMPLS.
> 
[Richard] All questions were structured in the context of an IP-based
control plane such as GMPLS. I'll clarify this. 

> H.
> 
> Section 5.3 is a good example of why we need to provide the 
> responses correlated by responder. For some responders the 
> answers here may have prevented them from making plans to 
> deploy, for others they plan to deploy despite their 
> concerns. For others, they have no plans to deploy for other 
> reasons, but have still voiced concerns.
> 
[Richard] See answer to A. This should be clarified with the anonymous
responses listed in random order in our update.

> I.
> 
> Section 5.4. It is not clear whether the final comment in 
> this section is your interpretation, apple-pie, or a specific 
> response to the survey.
> 
[Richard] No apple pie and no interpretation. The last comments are literal
copies of responses from the 2 carriers that listed "(f) other".
I will update to show:
Carrier 1: For some applications, 50ms is required. For others a business
case can be made for longer duration restorals. 
Carrier 2: Closer the duct the faster in general, closer the applications
the slower in general.

> J.
> 
> Section 5.5 claims that the responses pertain to traffic 
> carried on the responder's network, but the question makes no 
> reference to this and is general in nature.
> 
[Richard] All the carriers that we contacted are so large as to carry all
these services. We'll clarify this to make sure that new respondents discuss
only their carried traffic.

> K.
> 
> Why does question 9 lead the witness? In order to establish 
> the true requirements we should not discuss specific solution 
> models, but try to understand what the operational concerns are.
> 
[Richard] There is no intention to lead the answer. We'll change this in the
survey to say: "Do you have any concerns in each of the following areas?"

I hope this clarifies all issues you listed. If you have more comments,
please let me know.
Of course, carrier contacts you may have would be great.

Best,
Richard