Subject: questions on draft-vasseur-ccamp-inter-area-as-te-00.txt

From: Kullberg Alan-G19424 <[email-masked]>
Date: Wed, 21 Jul 2004 15:51:48 -0500

Hi JP & Arthi,
I have a couple of questions on draft-vasseur-ccamp-inter-area-as-te-00.txt.
 
1. How are the following 2 flags related:
    0x02: LSP stitching required
    0x04: LSP stitching desired
From my reading of the draft, they may be used for the same purpose, and therefor 1 of them should be removed?

2. Regarding LSP Stitching:
How does the egress of the stitch segment associate the inter-AS LSP and the LSP segment?
To clarify, from the example on page 19:
   "Eventually as the Resv message for the inter-AS TE LSP 
    traverses back from ASBR9 to ASBR7 and reaches ASBR7, ASBR7 will 
    remember to swap the LSP segment label with the label received for the 
    inter-AS LSP from ASBR9. Also, ASBR7 will itself allocate a NULL label 
    in the Resv message for the inter-AS TE LSP and sends the Resv message 
    to ASBR4."
What objects in the Path or Resv messages does ASBR7 use to associate the inter-AS LSP with the LSP segment?
 
Thanks,
Alan

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 22 Jul 2004 00:40:54 +0100

Forwarded to CCAMP

[Arthi, you sent it to me and Kireeti as list owners, not to the mail exploder]

----- Original Message ----- 
From: "Arthi Ayyangar" <[email-masked]>
To: "Kullberg Alan-G19424" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, July 22, 2004 12:24 AM
Subject: Re: questions on draft-vasseur-ccamp-inter-area-as-te-00.txt

> Hi Alan,
> > >From my reading of the draft, they may be used for the same purpose,
> > >and therefor 1 of them should be removed?
> --------->  Yes, this was a mistake in the draft and has been rectified in
> the new doc. draft-vasseur-ccamp-inter-area-as-te-00.txt is the older
> version of the draft. The signaling aspects are now covered in
> draft-ayyangar-ccamp-inter-domain-rsvp-te-00.txt.
> Looks like the draft was not announced here in ccamp.
> 
> 
> > 2. Regarding LSP Stitching: How does the egress of the stitch segment
> > associate the inter-AS LSP and the LSP segment? To clarify, from the
> > example on page 19:
> >     to ASBR4." What objects in the Path or Resv messages does ASBR7 use
> > to associate the inter-AS LSP with the LSP segment?
> --------->  The IF_ID Hop object would be used to identify the LSP
> segment. The signaling procedures are similar to those described in
> section 8.1.1 of the LSP Hierarchy draft for identification of the FA-LSP.
> 
> thanks,
> -arthi
> 
>