Subject: Soliciting comments on moving drafts to WG status

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 10 Aug 2004 13:52:02 +0100

Hi,

In San Diego we had four drafts for immediate consideration as working group drafts.
(There were a few other drafts that needed a little attention first, but will come up for
consideration in the near future.)

Please send your comments to the list or to the chairs. A brief "yes" or "no" will
suffice, but a reason with any "no" would be helpful.

Thanks,
Adrian

1. Loose Path Re-optimization
draft-vasseur-ccamp-loose-path-reopt-02.txt
This draft is stable and has an implementation.
The work is predominantly pertinent to inter-domain signaling, but could also be used
within a domain.
The meeting in San Diego reported relatively few as having read the draft, but no
objection to it becoming a WG draft.

2. A Transport Network View of LMP
draft-aboulmagd-ccamp-transport-lmp-02.txt
There has been a bit of off-list discussion about this draft in which it has become clear
that there are definite differences between the ASON and CCAMP uses and views of LMP. This
is precisely what the draft is intended to expose. That is, the draft is not intended to
unify the views of LMP, but rather to represent the two views within a single document so
as to highlight the differences.
In San Diego, no-one raised objections to this being a WG draft.

3. Graceful restart
draft-aruns-ccamp-rsvp-restart-ext-01.txt
This draft represents a merger of two previous drafts and was created at the specific
request of the WG in Seoul.
There is some more editorial work to be done on the draft, but the main technical content
appears to be stable.
In San Diego there was some support and no opposition to this becoming a WG draft.

4. Inter-domain Framework
draft-farrel-ccamp-inter-domain-framework-01.txt
** I am principal editor. Please take any issues with this to Kireeti **
This draft provides a framework for the multi-domain solutions work that the WG is
chartered to address.
In San Diego there were some questions about whether the draft should be extended to cover
other, more complex, inter-domain functions. There was no conclusion about whether this
should be done before or after becoming a WG draft (if it should be done at all).

---

From: "Igor Bryskin" <[email-masked]>
Date: Tue, 10 Aug 2004 11:39:00 -0400

> objection to it becoming a WG draft.

Yes

> In San Diego, no-one raised objections to this being a WG draft.

Haven't read.

> In San Diego there was some support and no opposition to this becoming a
WG draft.

Yes

> should be done before or after becoming a WG draft (if it should be done
at all).
Yes

---

From: "zafar ali" <[email-masked]>
Date: Tue, 10 Aug 2004 11:44:13 -0400

"yes" to (1), (3) and (4), 

Conditional "yes" to draft-aboulmagd-ccamp-transport-lmp-02.txt, depending
on the answer to the following: 

Does Author plan to address link management solution space between ASON and
GMPLS in the same document? I would prefer that and in which case I think
adaptation of this document as a WG document to be deferred to a later
point.   

Thanks

Regards... Zafar

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Adrian Farrel
>Sent: Tuesday, August 10, 2004 8:52 AM
>To: [email-masked]
>Cc: 'Kireeti Kompella'; Tove Madsen
>Subject: Soliciting comments on moving drafts to WG status
>
>
>Hi,
>
>In San Diego we had four drafts for immediate consideration as 
>working group drafts. (There were a few other drafts that 
>needed a little attention first, but will come up for 
>Please send your comments to the list or to the chairs. A 
>brief "yes" or "no" will suffice, but a reason with any "no" 
>would be helpful.
>
>Thanks,
>Adrian
>
>
>The work is predominantly pertinent to inter-domain signaling, 
>but could also be used within a domain. The meeting in San 
>Diego reported relatively few as having read the draft, but no 
>There has been a bit of off-list discussion about this draft 
>in which it has become clear that there are definite 
>differences between the ASON and CCAMP uses and views of LMP. 
>This is precisely what the draft is intended to expose. That 
>is, the draft is not intended to unify the views of LMP, but 
>rather to represent the two views within a single document so 
>as to highlight the differences. In San Diego, no-one raised 
>objections to this being a WG draft.
>
>3. Graceful restart
>This draft represents a merger of two previous drafts and was 
>created at the specific request of the WG in Seoul. There is 
>some more editorial work to be done on the draft, but the main 
>technical content appears to be stable. In San Diego there was 
>some support and no opposition to this becoming a WG draft.
>
>** I am principal editor. Please take any issues with this to 
>Kireeti ** This draft provides a framework for the 
>multi-domain solutions work that the WG is chartered to 
>address. In San Diego there were some questions about whether 
>the draft should be extended to cover other, more complex, 
>inter-domain functions. There was no conclusion about whether 
>this should be done before or after becoming a WG draft (if it 
>should be done at all).
>
>
>
>
>

---

From: dimitri papadimitriou <[email-masked]>
Date: Tue, 10 Aug 2004 19:05:24 +0200

zafar,

the point has been already asked during the meeting, to summarize, the 
basic idea:

- is to have a "decoder ring" for understanding ITU work and IETF work
   (-> for publication as informational RFC only)

- is NOT to define anything in this document as the intention is first
   to understand the two groups work efforts and then do a series of
   liaisons to determine/assess if any additional work is needed

hope this clarifies,

thanks,
- dimitri.

---
zafar ali wrote:

> .

---

From: "zafar ali" <[email-masked]>
Date: Tue, 10 Aug 2004 13:17:31 -0400

Hi Dimitri, 

Thanks for the clarification; I remembered the discussion but was not 100%
sure of the final take. 

Given this, as I mentioned earlier, I am "in favor" of this document to be a
WG ID. 

Thanks

Regards... Zafar

>[mailto:[email-masked]] On Behalf Of dimitri papadimitriou
>Sent: Tuesday, August 10, 2004 1:05 PM
>To: zafar ali
>Cc: 'Adrian Farrel'; [email-masked]; 'Kireeti Kompella'; 
>'Tove Madsen'
>Subject: Re: Soliciting comments on moving drafts to WG status
>
>
>zafar,
>
>> Conditional "yes" to draft-aboulmagd-ccamp-transport-lmp-02.txt, 
>> depending on the answer to the following:
>> 
>> Does Author plan to address link management solution space between 
>> ASON and GMPLS in the same document? I would prefer that and 
>in which 
>> case I think adaptation of this document as a WG document to 
>be deferred to a later
>> point.   
>> 
>> Thanks
>> 
>> Regards... Zafar
>> 
>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 10 Aug 2004 18:13:24 +0100

> adaptation of this document as a WG document to be deferred to a later

Hi Zafar,

I'm not quite clear what you mean by "address link management solution space". Do you mean
a comparison of the ways that LMP is used and any extensions that may have been made to
the protocol? Or do you mean an analysis of what needs to be "fixed" and the appropriate
new extensions to the protocol?

If the latter, I think a question that led in this direction was asked in SD.

Kireeti's response was to the effect that we have to do the analysis first, identifying
the "secret decoder ring", and showing the differences between the ITU and IETF views.
Then we would start a series of liaisons to SG15 to figure out what needs to be fixed and
by whom. Finally, work could begin on protocol modifications.

This document is targeted at the first step only.

OTOH, if you meant the first option (i.e. a comparison of how the protocol is used and
what extensions have already been made), that seems to me to be valuable in this document.

What do the authors say?

Cheers,
Adrian

---

From: "zafar ali" <[email-masked]>
Date: Tue, 10 Aug 2004 13:47:45 -0400

>Sent: Tuesday, August 10, 2004 1:13 PM
>To: zafar ali; [email-masked]
>Subject: LMP transport [Was: Re: Soliciting comments on moving 
>drafts to WG status]
>
>
>> case I think adaptation of this document as a WG document to be 
>> deferred to a later point.
>
>Hi Zafar,
>
>I'm not quite clear what you mean by "address link management 
>solution space". Do you mean a comparison of the ways that LMP 
>is used and any extensions that may have been made to the 
>protocol? Or do you mean an analysis of what needs to be 
>"fixed" and the appropriate new extensions to the protocol?
>

Both, in that order. But as I mentioned I am ok on however Authors would
like to position this ID. 

>Kireeti's response was to the effect that we have to do the 
>analysis first, identifying the "secret decoder ring", and 
>showing the differences between the ITU and IETF views. Then 
>we would start a series of liaisons to SG15 to figure out what 
>needs to be fixed and by whom. Finally, work could begin on 
>protocol modifications.
>
>OTOH, if you meant the first option (i.e. a comparison of how 
>the protocol is used and what extensions have already been 
>made), that seems to me to be valuable in this document.
>
>What do the authors say?
>
>Cheers,
>Adrian
>
>

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Tue, 10 Aug 2004 21:28:02 -0700

Hi Adrian,

Yes to all.

JP.

---

From: dimitri papadimitriou <[email-masked]>
Date: Wed, 11 Aug 2004 09:36:37 +0200

hi adrian et al.

> objection to it becoming a WG draft.

is it part of the consensus to use this as a common document for further 
work related to "re-optimization" (incl. the delivery of ubiquitous 
signaling solution decoupled from the routing topology) in this case i'd 
be fine

> In San Diego, no-one raised objections to this being a WG draft.

yes (but i'm an author)

> In San Diego there was some support and no opposition to this becoming a WG draft.

yes (but i'm an author)

> should be done before or after becoming a WG draft (if it should be done at all).

yes -

a side question: why this document is entitled "inter-domain" whereas it 
"provides a framework for establishing and controlling Multiprotocol 
Label Switching (MPLS) and Generalized MPLS (GMPLS) Label Switched Paths 
(LSPs) for multi-domain networks" so clearly the scope is *multi-domain* 
there is imho some difference between "inter-domain" that relates to the 
signaling exchange between domain boundaries only while "multi" relates 
to signaling exchange from the source until the destination across 
several domains

---

From: "Richard Rabbat" <[email-masked]>
Date: Wed, 11 Aug 2004 10:28:14 -0700

Please see inline.

> The work is predominantly pertinent to inter-domain 
> signaling, but could also be used within a domain. The 
> meeting in San Diego reported relatively few as having read 
> the draft, but no objection to it becoming a WG draft.
 
Yes. Though I would like the authors to mention GMPLS and drop the focus on
MPLS since they say in the abstract that this applies to "packet and
non-packet TE LSPs".

> objections to this being a WG draft.

Not sure. Adrian mentioned that this would possibly identify items of work
for ITU and IETF. What is the thinking of the authors about the draft after
the protocol modifications are finished? If the expected outcome is an
alignment of the IETF and ITU views on LMP, then the draft would have served
its purpose and would not need publication as Informational. 

> some more editorial work to be done on the draft, but the 
> main technical content appears to be stable. In San Diego 
> there was some support and no opposition to this becoming a WG draft.

Yes.

> this should be done before or after becoming a WG draft (if 
> it should be done at all).

Yes.

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 11 Aug 2004 18:52:47 +0100

Dimitri,

> signaling solution decoupled from the routing topology) in this case i'd 

This was my interpretation of the purpose of this draft.

I would be happy to hear objections to this view point.

Adrian

---

From: Greg Bernstein <[email-masked]>
Date: Wed, 11 Aug 2004 15:27:03 -0700 (PDT)

Yes to the LMP draft. Hopefully this can lead to a
"common view".
The others sound reasonable and probably less
controversial.

Greg B.
--- Adrian Farrel <[email-masked]> wrote:

> signaling, but could also be used
> within a domain.

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail