Subject: RE: ASON Opacity and liaisons

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 7 Oct 2004 13:38:21 -0400

Hi Adrian,

Thank you for the detail information on the history.

Regarding my email, please don't take that as a criticism. 
In particular about the requirements drafts, my intent is just a reminder to send on these more finalized drafts to ITU-T SG15 formally. Regarding the Q14/15 Februrary liaison statement, in deed it was for action about the ASON signalling solutions discussion (not signaling requirements). Nonetheless, liaison responses would have seemed to have been a good springboard for stimulating further joint work. Perhaps we can follow up on this together?

Regards,
Kam

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, October 06, 2004 8:16 PM
> To: Lam, Hing-Kam (Kam)
> Cc: [email-masked]; [email-masked]; Bill Fenner; 'Kireeti Kompella'
> Subject: Re: ASON Opacity and liaisons
> 
> 
> Hello Kam,
> 
> Thanks for the email. Let me go over the history before 
> coming to your specific points.
> 
> The review and liaison in Chicago were in direct response to 
> CCAMP passing the latest
> copies of the drafts to SG15 and soliciting input. They were 
> notified to the CCAMP mailing
> list on 1st March, (and so copied to the ASON signaling and 
> routing requirements design
> teams), published on the CCAMP alternative web pages, and 
> published on the IETF's liaison
> pages.
> 
> The CCAMP design teams responsible for the ASON signaling and 
> routing requirements drafts
> were certainly grateful for the review comments received in a 
> formal liaison from SG15.
> You may be sure that the points raised were fully considered, 
> especially since I was in
> the room in Chicago when drafts were reviewed and the liaison 
> statement was drafted.
> 
> The liaisons were subsequently presented to CCAMP in Seoul by 
> Lyndon Ong and the efforts
> of the ITU-T were recognized from the chair.
> 
> On return from Seoul, the editor of the ASON Signaling 
> Requirements draft was able to
> agree upon the points for inclusion in the draft after 
> discussion with his design team.
> The changes made were largely in line with those suggested by 
> the liaison.
> 
> After Seoul, the editor of the ASON Routing Requirements 
> draft was able to reach agreement
> on all but three points. She quickly took these remaining 
> issues to the CCAMP mailing list
> where they were (hotly) debated. After a while it was 
> possible to separate the requirement
> issues from the discussion of solutions and progress was made 
> thanks to the participation
> of no fewer than seven people who regularly attend and 
> participate in SG15. The debate
> quietened down after March 19th with sufficient consensus for 
> the design team to move
> forward.
> 
> A working group last call was issued for the ASON Routing 
> Requirements draft on April 15th
> and included the text...
> > The ASON Routing Reqts DT has updated the following draft based on
> > ITU Q14/15's Liaison and CCAMP mail list comments.
> This means that the SG15 comments were included as modified 
> by the discussions on the
> CCAMP mailing list, and that the draft had been agreed upon 
> by the whole design team.
> 
> A working group last call was issued for the ASON Signaling 
> Requirements draft on April
> 26th and included the text...
> > The authors of this draft have updated it to reflect the 
> comments on the
> > mailing list and the helpful feedback from ITU-T SG15 Question 14.
> This means that the SG15 comments were included. In fact, the 
> draft had been updated and
> agreed upon by the whole design team. The fact of the last 
> call was circulated to the
> IETF's OSPF, IS-IS and Routing working groups in order to 
> ensure a wide coverage of
> potential reviewers.
> 
> It is unthinkable that either draft would have been published 
> or put up for last call if
> any member of the design team had raised an objection.
> 
> A working group last call is public and is not confined to 
> any particular body. It gives
> an opportunity for everyone who is subscribed to the mailing 
> list to comment. This covers
> a considerable number of participants in SG15 and, of course, 
> includes the whole of the
> design team.
> 
> The ASON Routing Requirements draft completed last call with 
> a few minor comments. It
> turned out that most of these comments were questioning the 
> validity of text in G.7715.1,
> and CCAMP's position was (of course) that the draft must 
> reflect the statements in that
> recommendation and not try to invent different requirements. 
> The other comments were
> editorial nits. The draft was duly updated with agreement 
> from the design team, and
> re-published on May 6th with notification on the CCAMP mailing list.
> 
> The ASON Signaling Requirements draft completed last call 
> with no comments.
> 
> Both drafts were passed to the AD for review.
> 
> On May 10th a further liaison was received from SG15 Q.14/15 
> thanking CCAMP and the
> members of the ASON Routing Requirements Design Team for 
> their efforts to understand and
> capture ASON Routing Requirements for the future work in 
> IETF. This liaison was published
> and notified on the CCAMP mailing list.
> 
> In the run-up to the San Diego IETF, both drafts were 
> reviewed by the AD and were updated
> accordingly. The changes were minor and for clarification 
> only. Again, the design team
> agreed the changes. The drafts were not published before San 
> Diego, but were made publicly
> available.
> 
> In San Diego, both drafts were presented and the plan to 
> forward them to the IESG was
> announced. However, Jonathan Sadler raised an important 
> concern that the drafts did not
> sufficiently capture the notion of subnetwork opacity. This 
> was picked up by a number of
> people attending the meeting and it was immediately agreed 
> that a gathering of the design
> team, working group chairs and other interested parties 
> should be held at once. Although
> the process had already been completed with ample chance for 
> the authors, the design team
> and external reviewers to discover and raise this point, the 
> gathering agreed that
> Jonathan should be deputed to review the drafts in the light 
> of his concerns and raise any
> specific issues with me.
> 
> Over the next couple of months, Jonathan raised a few points 
> with me and I passed them on
> to the design team and to the CCAMP mailing list. A quick 
> analysis revealed that only a
> very minor change was required. This was agreed upon by the 
> design teams and the drafts
> were published.
> 
> The drafts are now on their way to the IESG for review.
> 
> It is worth pointing out that the two design teams concerned 
> are joint design teams of the
> IETF's CCAMP working group and the ITU-T's SG15. The reason 
> for having a joint design team
> is so that the work progresses faster and in tandem. One 
> might reasonably assume that the
> SG15 members of the team were regularly reporting back to the 
> ITU-T on the progress of the
> drafts, as the CCAMP members were required by the working 
> group to do. So, while the
> liaison process was useful for collecting together the formal 
> review comments, it was
> somewhat secondary to the joint development of the drafts by 
> members of both groups.
> 
> Now to your specific email.
> 
> > We very much appreciate to continue the process of exchange 
> and liaison with CCAMP.
> 
> Thank you. On the whole I think it has been valuable and has 
> ensured that the two groups
> are in synch with regard to the requirements on GMPLS 
> networks for the support of ASON.
> Certainly, given the unanimity of support in the design teams 
> for the two drafts, we have
> been successful.
> 
> Of course, i am considerably concerned by the extremely long 
> time that it has taken to
> produce this relatively simple draft. Truly, design by 
> committee is a long-winded process.
> But, in this case, it has been worth it to ensure the 
> complete agreement that we have
> achieved.
> 
> > The second paragraph of your email however reminds me that these
> > drafts have not been formally liaised to SG15 yet.
> 
> This is so, and I am surprised that you expect any different. 
> Certainly the ITU-T is not
> in the habit of liaising its draft recomendations to the IETF 
> and gaiting their progress
> pending a response.
> 
> But recall that the previous version of the draft was liaised 
> ot SG15, and SG15 reviewed
> it thoroughly and rseponded fully.
> Since the review comments were significantly incorporated, a 
> further liaison of the drafts
> was clearly unnecessary. In any case, the design teams had 
> had ample oportunity to review
> the drafts, and many members of the SG15 community had also 
> been afforded that oportunity
> through the normal open and public IETF process.
> 
> >It also reminds me that the Q14/15 Liaison Statement from the
> > Februrary 2004 Chicago meeting to CCAMP
> >
> ftp://sg15opticalt:[email-masked]/tsg15opticaltransport
> /COMMUNICATIONS/ccamp/IETF_ccamp_G.7713.2_comments.html
> > has never been responded by CCAMP yet.
> 
> That is true.
> 
> I'm afraid that I was not aware that a response was either 
> required or desired (although I
> admit that it would have been polite if Kireeti and I had 
> acknowledged the receipt). This
> may be due to the fact that I do not understand ITU-T 
> phrasing, because I see that the
> liaison is marked as "For: Action" with "Deadline: 12th April 
> 2004". This was interpretted
> as meaning that SG15 would like CCAMP and the design teams to 
> act on the liaison before
> 12th April - which they did.
> 
> Had there been a direct request for a response we would have 
> endeavored to reply in the
> specified timescale. (Although we are all human, and have day 
> jobs, so sometimes these
> things do get dropped.)
> 
> If you feel that it would be helpful for CCAMP to generate a 
> liaison about these drafts,
> please let me know and we will be glad to supply one.
> 
> The paragraph from my email that you cite reads as follows.
> 
> > > As you will recall, these drafts (which have been through WG
> > > last call and have had a full process of exchange and liaison
> > > with the ITU-T's Study Group 15) had been reviewed by the
> > > AD and a few comments were raised. These comments were
> > > addressed immediately before the San Diego IETF, but the
> > > editors just missed the publication deadline.
> 
> I think you will agree that the liaison process for these 
> drafts has been very full.
> Probably more extensive than any for a long time. And the 
> fact that the drafts were
> authored by design teams deliberately picked to include 
> members of both groups is evidence
> of the lengths to which this process was taken.
> 
> I hope this answers all of your questions, but please do let 
> me know if there is more
> information that would help you.
> 
> Regards,
> Adrian
> 
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 8 Oct 2004 12:05:50 +0100

Hi Kam,

> In particular about the requirements drafts, my intent is just a reminder to
> send on these more finalized drafts to ITU-T SG15 formally.

Oh, most certainly.
My intention is that whenever we finalize a CCAMP draft we will liaise it to all
interested parties.

> Regarding the Q14/15 Februrary liaison statement, in deed it was
> for action about the ASON signalling solutions discussion (not
> signaling requirements).

Well, I see three separate documents from that date.
wd35r1_liaison_ccamp_sig-req.doc has the title "Liaison Statement To IETF CCAMP WG on
<draft-ietf-ccamp-gmpls-ason-reqts-05.txt"
wd34r3_liaison_ccamp_routing.doc has the title "Response To IETF CCAMP WG on ASON Routing
Requirements"
wd33r3_signalling-liaison-to-ccamp.doc has the title "Response to IETF CCAMP WG regarding
Comments on G.7713.2"

Thus, two liaisons were explicitly about the requirements drafts, and one was in response
to the liaison from CCAMP about G.7713.2. It was the third of these that you pointed to in
your orriginal email and it includes some useful background material that will definitiely
be taken on board by the GMPLS ASON signaling draft authors when they work on the next
revision.

Unfortunately, work on the solutions draft has been blocked pending the completion of the
requirements drafts, but it looks like we are about ready to start moving again.

> Nonetheless, liaison responses would have seemed to have been
> a good springboard for stimulating further joint work.

Yes, and when the authors have the oportunity to work on the draft further, I'm sure they
will generate a response.

> Perhaps we can follow up on this together?

I'm sure we can.

Regards,
Adrian