Subject: Re: [CCAMP] Discussion of multi-stage solutions

From: Rajan Rao <[email-masked]>
Date: Fri, 1 Apr 2011 03:56:07 -0700

Good. We are agreeing on the problem statement (3 bullets below). What this means is that we are not optimizing for a special case (#1 in Adrian's email), we are addressing network wide flexibility & scalability issue.

FA is a solution, no doubt. But to have full grooming flexibility at every node you would require FAs on every link in the network. This will lead to huge scalability issues in large networks.

Operators have 2 choice w.r.t FAs
(a) manually create or
(b) go for induced FA solution

Both these lead to operational complexity. To make life easier for the operators we need a solution that solves scalability issues and simplifies operations.

Multi-stage label is a solution that addresses above issues. 

Please refer to Khuzema's response to Daniele's email (email attached). We will provide more examples.

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Obviously, the answer to all your questions is "YES", because this is the part of the premise for muxing hierarchy and this is why we are talking about FA and non-FA(multi-stage labels). The only disagreement between us is whether non-FA(multi-stage labels) is applicable or not.

I have repeated Daniele's question, and I would like to repeat once more as follows:

=====================================================================================================================
For the example in your slide 9 (Is this specific enough?), for the ODU1 connection request, why GMPLS should allocate the TSs for ODU2->ODU3 besides allocating the TSs for ODU1? In this way, 1:1 mapping is lost. 

Could you give the WG an example to show that when signal type X in Traffic Parameters is requested, GMPLS will allocate the labels for signal type Y additionally?

You should just follow the GMPLS principle to answer this question.

====================================================================================================================

P.S., I will be on the plane to wait for your answers and keep silent for a few days because of my vacations.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Can you be more specific please? Which one of the following are you referring:

- multi-stage muxing is not a reality?
- restricted hierarchy is not a reality?
- network consisting of the above is not a reality?

Every scenario we discussed in the past 4 months for routing-draft-merge was related to the above cases. 

You raise a good point on the practical deployment. This is the feedback we are looking for from the WG. If you have data available please share. May be we don't need IMCDs to begin with.  This will definitely simplify both routing and signaling extensions.

Thanks
Rajan  

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

I think we should focus on the questions to discuss something. It does not make sense to say something by flying in the air. I think all the people are waiting for the scenarios from the practical deployments.

Please answer Daniele's question first.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

If you have fewer such restricted links, yes it is an optimization.  The point you are missing is when you have 100s of such links in the network you gain scaling and ease of operation benefits.  This is our main point.

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

You said you agreed with point #1, so we don't need to optimize for the special cases. 

So the things are very clear, even though you did not answer our other questions directly.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

There is no disagreement on point#1.  The proposal is optimized solution, a scalable solution & an operator friendly solution depending on the deployment scenarios.

With the introduction of IMCDs in routing draft we are admitting that muxing restrictions do exist. This is inevitable in the evolution of OTN. 

If you have muxing restrictions on every hop in your network, you have 2 choice.  (A) have FAs on every segment or in certain parts of the network (B) use the label proposed in the draft.  Option (B) eliminates the need to have FA on every-hop in such scenarios. This is the key point you are missing.

Note that once you have FAs, it restrict the type of service you can carry (pl refer to examples in the draft).

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Actually, you don't answer Daniele's question. We know that you don't assume this ODU2 is a LSP. 

Daniele asked you: for example, in your slide 9, for the ODU1 connection request, why you need to allocate the TSs for ODU2->ODU3 besides allocating the TSs for ODU1? In this way, 1:1 mapping is lost. 

You should just follow the GMPLS principle to answer this question.

In addition, what is your opinion on Adrian's comment 1?

In my presentation, I asked a lot of questions and list a number of the issues about multi-stage labels. These questions and issues should be clarified clearly.

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

If I correctly understand Daniel's example, ODU2 is not a LSP in control plane, it is just a local ODU2 endpoint in data plane. So the ODU0 lsp sets up ODU2<-ODU0 layer because it is mandated by restrictive multiplexing hierarchy on interface.

This is in context of draft draft-khuzema-ccamp-gmpls-signaling-g709-01. The ppt is located @ http://www.ietf.org/proceedings/80/slides/ccamp-24.pptx

Please refer to examples in draft and ppt for better understanding.

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

This question should ask Khuzema, why there are multi labels for ODU0 connection request?

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Can you please explain why would we allocate labels for ODU2 when an ODU-0 LSP is requested?

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

I agree with Adrian. If i correctly understood your proposal, when and ODU0 LSP is requested, the LSRs should allocate the labels for ODU2 besides allocating the labels for ODU0? In such a way the 1:1 mapping is lost.

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

On point#2. I agree with you that a LSP is control plane equivalent of a dataplane connection. But, not all data plane connection need to be modeled in control plane as lsp. We need to model only those dataplane connection in control plane as lsp (or FA), that matters in path computation, or need to be monitored for faults/restoration in control plane.

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

<speaking as an individual>

A couple of thoughts that we didn't have time to talk about in the meeting. The chairs may be right that the framework document can help us understand which scenarios we need to address.

1. We don't generally optimize for special cases.
   That means we should pick a solution that we can apply across the board.
   Separating out a solution that is optimized for a particular case (e.g.
single-
   hop) would only be valuable if the savings are really large.

2. What is an LSP?
   Historically we have ted ourselves in knots by failing to clearly understand
   that an LSP is a data plane thing (a "connection") and also a the control 
   plane representation of the data pane thing (i.e. control plane, signaling
   state). It is helpful to try to maintain a 1:1 mapping between the terms
   in our work.

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

Subject: Re: [CCAMP] Discussion of multi-stage solutions
From: Khuzema Pithewan <[email-masked]>
To: Fatai Zhang <[email-masked]>, Sidd Aanand <[email-masked]>, Daniele Ceccarelli <[email-masked]>, "[email-masked]" <[email-masked]>, 'CCAMP' <[email-masked]>
Date: Thu, 31 Mar 2011 09:09:01 -0700
List-Id: Discussion list for the CCAMP working group <ccamp.ietf.org>

Hi,

If I correctly understand Daniel's example, ODU2 is not a LSP in control plane, it is just a local ODU2 endpoint in data plane. So the ODU0 lsp sets up ODU2<-ODU0 layer because it is mandated by restrictive multiplexing hierarchy on interface.

This is in context of draft draft-khuzema-ccamp-gmpls-signaling-g709-01. The ppt is located @ http://www.ietf.org/proceedings/80/slides/ccamp-24.pptx

Please refer to examples in draft and ppt for better understanding.

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

This question should ask Khuzema, why there are multi labels for ODU0 connection request?

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Can you please explain why would we allocate labels for ODU2 when an ODU-0 LSP is requested?

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

I agree with Adrian. If i correctly understood your proposal, when and ODU0 LSP is requested, the LSRs should allocate the labels for ODU2 besides allocating the labels for ODU0? In such a way the 1:1 mapping is lost.

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

On point#2. I agree with you that a LSP is control plane equivalent of a dataplane connection. But, not all data plane connection need to be modeled in control plane as lsp. We need to model only those dataplane connection in control plane as lsp (or FA), that matters in path computation, or need to be monitored for faults/restoration in control plane.

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

<speaking as an individual>

A couple of thoughts that we didn't have time to talk about in the meeting. The chairs may be right that the framework document can help us understand which scenarios we need to address.

1. We don't generally optimize for special cases.
   That means we should pick a solution that we can apply across the board.
   Separating out a solution that is optimized for a particular case (e.g.
single-
   hop) would only be valuable if the savings are really large.

2. What is an LSP?
   Historically we have ted ourselves in knots by failing to clearly understand
   that an LSP is a data plane thing (a "connection") and also a the control
   plane representation of the data pane thing (i.e. control plane, signaling
   state). It is helpful to try to maintain a 1:1 mapping between the terms
   in our work.

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Mon, 4 Apr 2011 11:03:36 +0200

Hi Rajan,Khuzema,

regarding point 1 from Adrian's mail, we think that Adrian's understanding is that multi-stage multiplexing will not be deployed extensively since the cost of multi-stage board will be high. This why he talked about "specific case ".

For point 2
"2. What is an LSP?
in our work."

Adrian is substantially right and Fatai interpretation is also in line with Adrian's point.

>From a purely technical point of view it may be noticed that G.709 and G.872 define a 1:1:1 correspondence among ODUk:OTUk:Och.
This permit to consider ODUk as having a double nature : or a simple section 1:1 with OTUk or a real LSP and in this caee ODUk is used as ODUj (e.g. we need to restore it: this is customer choice).
In a multi-stage hierarchy you have only the server ODUk that is compelled in the 1:1:1 relationship. Above ODUk this relationship is not present and all layers have to be treated as LSPs.

To illustrate better the concept suppose to have 3 nodes A,B,C and links A-B and B-C are OTU-3 links.

Case 1: ODU1 LSP from A to C switched in B no ODU3 restoration required
Only one signaling session will be provided containing per each link only one label  indicating the ODU3 tributary slots used by the ODU1.
This is because due to the 1:1:1 correspondence no LSP ODU3 is needed (ODU3 is a section).

Case 2: ODU1 LSP from A to C switched in B but ODU3 restoration is required: ODU3 LSP is terminated as in previous case but need to be an LSP to be restored: it is not considered a as a section but a 1 hop path.
First draw ODU3 LSP, with its own signaling session.
Then draw ODU1 LSP as in case 1.

Case 3: ODU3 path from A to C switched in B carrying an ODU1 from A to C (transparent in B).
First draw ODU3 LSP A to C with its own signaling session: the 1:1:1 correspondence is not applicable since it is a multi-hop path.
Then draw ODU1 LSP from A to C with its own signaling session.

This is for single stage. Multistage comes as an extension of this concept.
Suppose to have a multistage ODU1-ODU2-ODU3 over OTU3. Only for the ODU3 it is valid the 1:1:1 relationship.
So only for the ODU3 there is the choice to draw an LSP or not draw it.
ODU2 and ODU1 should be always signaled as LSPs independently from the number of hop.

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution
Terrestrial Optics Product Unit
ALCATEL-LUCENT
+39 039 6863033
+39 039 6863590

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Apr 2011 14:44:07 +0200

> regarding point 1 from Adrian's mail, we think that Adrian's understanding is
that
> multi-stage multiplexing will not be deployed extensively since the cost of
multi-
> stage board will be high. This why he talked about "specific case ".

Oh well, I guess I should reply to say what my understanding is :-)

A special case is not special because it is unusual or unwanted. It is special
because it is a subset of a more general solution.

The more observant amongst you will notice that "G" in "GMPLS" stands for
"Generalized". Historically, we have had a preference for developing generalized
solutions applicable to as wide a set of technologies as possible. We have
specialised only when the technology *requires* a different piece of protocol,
although we also consider specialising when the benefits are sufficiently large.

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 06 Apr 2011 23:26:34 +0800

Hi Rajan,

We don't know why you can not touch the main points for discussion. 

Your problem statement (3 bullets below) does not imply that it needs multi-stage labels (it is just a kind of solution for some special case) and it also does not imply that there is no special case in the reality. FA approach is already there and it is generic for all the cases (including for any special cases).

We think there are lots of issues about multi-stage labels approach. We would like to discuss more on the other key issues, but we should clarify these issues one by one to make the CCAMP WG to understand multi-stage labels approach much clearer.

If you insist on multi-stage label approach, please clarify Daniele's question directly, which is really very important. Please don't igore it.

We would like to repeat the third time and split the question into two simple questions to make it easy for you to answer and clarify:

===========================================================================================================================================
When the signal type X in Traffic Parameters is requested, should GMPLS allocate the labels for the signal type Y additionally? 

When a server tunnel is created by GMPLS, should this tunnel be invisible for GMPLS (however, the bandwidth of the "non-FA" is advertised)?

You can just answer "Yes" or "No", if your answer is "Yes", please give an example from the GMPLS world to prove it?
============================================================================================================================================

After you clarify these simple questions, we would like to discuss other key issues about multi-stage labels including secnarios and the practical OTN networks.

Authors of [draft-zhang]

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 6:56 PM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan  

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 06 Apr 2011 23:37:31 +0800

Hi all,

Right. 

I think FA is this kind of "G" from "GMPLS" and non-FA(multi-stage labels) is this kind of special solution without any (or large) benefits but lots of problems.

Fatai

Thanks

---

From: John E Drake <[email-masked]>
Date: Wed, 6 Apr 2011 08:54:42 -0700

Fatai,

I agree with the comment, but could we please use the term 'hierarchical LSP' rather than 'forwarding adjacency'?  The latter term, defined in RFC4206, describes a hierarchical LSP that is advertised in the same instance of the TE database that was used to create it.  (I'm sorry, but this is a pet peeve.)

Thanks,

John 

Sent from my iPhone

> Sent: Wednesday, April 06, 2011 8:38 AM
> To: [email-masked]; 'BELOTTI, SERGIO (SERGIO)'; 'Rajan Rao';
> 'Khuzema Pithewan'
> Cc: 'Sidd Aanand'; 'CCAMP'
> I think FA is this kind of "G" from "GMPLS" and non-FA(multi-stage
> labels) is this kind of special solution without any (or large)
> benefits but lots of problems.
> 
> 
> 
> Fatai
> 
> Thanks
> To: "'BELOTTI, SERGIO (SERGIO)'" <[email-masked]>;
> "'Rajan Rao'" <[email-masked]>; "'Khuzema Pithewan'"
> <[email-masked]>
> Cc: "'Fatai Zhang'" <[email-masked]>; "'Sidd Aanand'"
> <[email-masked]>; "'Daniele Ceccarelli'"
> <[email-masked]>; "'CCAMP'" <[email-masked]>;
> "'GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)'"
> <[email-masked]>

---

From: Rajan Rao <[email-masked]>
Date: Wed, 6 Apr 2011 10:21:53 -0700

Fatai, et all

Please see response inline.

Thanks
Rajan & Khuzema

From: Fatai Zhang [mailto:[email-masked]]
Sent: Wednesday, April 06, 2011 8:27 AM
To: 'CCAMP'; Adrian Farrel; Daniele Ceccarelli; Sidd Aanand; Khuzema Pithewan; Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Your problem statement (3 bullets below) does not imply that it needs multi-stage labels (it is just a kind of solution for some special case) and it also does not imply that there is no special case in the reality. FA approach is already there and it is generic for all the cases (including for any special cases).
[RR] We are not precluding FAs or H-LSPs.  It is operator's choice to have FAs.  We are giving an alternate solution to FA. The proposal allows operator to create ODU services w/o FAs when scaling and operational simplicity matters the most.

We think there are lots of issues about multi-stage labels approach.
[RR] Please list all the issues.  We will be happy to provide response.

We would like to discuss more on the other key issues, but we should clarify these issues one by one to make the CCAMP WG to understand multi-stage labels approach much clearer.
[RR] no problem.  Please list them so that we go one by one.

If you insist on multi-stage label approach, please clarify Daniele's question directly, which is really very important. Please don't igore it.
[RR] we have responded already.  Pl see the response one more time.

===========================================================================================================================================
When the signal type X in Traffic Parameters is requested, should GMPLS allocate the labels for the signal type Y additionally?
[RR] the  idea is to provide a solution which allows operators to create ODU-LSPs independent of number of mux stages hop by hop.   Clearly you are not getting this point. Please read the draft and examples.  The need for an intermediate ODU layer is a local matter between 2 adjacent nodes.

[RR] We are not precluding FAs or H-LSPs.  It is operator's choice to have FAs.  We are giving an alternate solution to FA. The proposal allows operator to create ODU services w/o FAs when scaling and operational simplicity matters the most.

[RR] I am waiting to hear on practical scenarios. Please share the info.

Authors of [draft-zhang]

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>; "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>; "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, April 01, 2011 6:56 PM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>; "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>; "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>; "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>; "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>; "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>; "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Cc: "Rajan Rao" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>; "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]<mailto:[email-masked]>>
To: "Daniele Ceccarelli" <[email-masked]<mailto:[email-masked]>>; "Khuzema Pithewan" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]<mailto:[email-masked]>; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Rajan Rao <[email-masked]>
Date: Thu, 7 Apr 2011 11:41:49 -0700

Sergio & Pietro,

Thanks for the example.  I think this is a good example to close the gap. Please see response inline.

Summary:   If an LSP works without CP representation at ODUk layer, it should work for other HO-ODUj layers as well.

Thanks

Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2

"2. What is an LSP?

in our work."

[R& K] We agree there is no need for ODU3-LSP.  ODU3 is a path termination. If we go by your argument we would need another LSP at ODU3 layer as there is no control plane representation for ODU3.

If CP works w/o representation for ODU3 layer it should work for ODU2 layer as well.

[R &K]  Agree, here you would require ODU3-LSP as you are expecting restoration at ODU3 layer.  Clearly operator decides whether to have ODU3-LSP or not. Extend the same concept to ODU2 layer, if operators needs restoration, he will setup ODU2-LSP otherwise we treat ODU2 layer similar to ODU3 on the segment.

We don't think this breaks any model.

Hope this clarify.

Thanks

Sergio and Pietro

Sergio Belotti

Portfolio Evolution

ALCATEL-LUCENT

+39 039 6863033

+39 039 6863590

-----Messaggio originale-----

(a) manually create or

Thanks

Rajan & Khuzema

-----Original Message-----

Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Thanks

Rajan

-----Original Message-----

Hi Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Thanks

Rajan

-----Original Message-----

Cc: Rajan Rao

Hi Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Hope this helps.

Thanks

Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----

Hi,

Thanks

Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----

Daniele,

Thanks,

Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR

Daniele

-----Original Message-----

Hi,

Best Regards

Khuzema

-----Original Message-----

To: 'CCAMP'

Hi,

single-

2. What is an LSP?

   in our work.

Cheers,

Adrian

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 12 Apr 2011 16:53:15 +0800

Hi John,

Sure (I had noticed this difference), you are the CCAMP expert, :-)

Thanks
 
Fatai
 
Huawei Technologies Co., LTD.
Huawei Base, Bantian, Longgang,
Shenzhen 518129 P.R.China
Tel: +86-755-28972912
Fax: +86-755-28972935

----- Original Message ----- 
From: "John E Drake" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; <[email-masked]>; "'BELOTTI, SERGIO (SERGIO)'" <[email-masked]>; "'Rajan Rao'" <[email-masked]>; "'Khuzema Pithewan'" <[email-masked]>
Cc: "'Sidd Aanand'" <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Wednesday, April 06, 2011 11:54 PM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks,

John 

Sent from my iPhone

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 12 Apr 2011 11:17:13 +0200

Hi Rajan, Khuzema

It seems as though you did not capture completely our points of the example, which is used to prove that multi-stage labels should not be used.

In all the three cases, GMPLS have the session to manage and control the connection entities (e.g., ODU1, ODU3) . You may have misunderstood  on case 1 and case 2. In case 1, due to 1:1:1, there is wavelength connection session for ODU3.  For your response in case 2, ODU2 LSP can not be treated as ODU3, otherwise there is no session entity for ODU2 and in this way, the operator will lost the capability to control ODU2).

Hope this can clarify your misunderstanding.

Thanks

BR

authors of [draft-zhang]

________________________________
Da: Rajan Rao [mailto:[email-masked]]
Inviato: giovedì 7 aprile 2011 20.42
A: BELOTTI, SERGIO (SERGIO); Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)
Oggetto: RE: [CCAMP] Discussion of multi-stage solutions

Sergio & Pietro,

Thanks

Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2

"2. What is an LSP?

in our work."

Hope this clarify.

Thanks

Sergio and Pietro

Sergio Belotti

Portfolio Evolution

ALCATEL-LUCENT

+39 039 6863033

+39 039 6863590

-----Messaggio originale-----

(a) manually create or

Thanks

Rajan & Khuzema

-----Original Message-----

Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Thanks

Rajan

-----Original Message-----

Hi Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Thanks

Rajan

-----Original Message-----

Cc: Rajan Rao

Hi Rajan,

Fatai

Thanks

----- Original Message -----

Fatai,

Hope this helps.

Thanks

Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----

Hi,

Thanks

Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----

Daniele,

Thanks,

Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR

Daniele

-----Original Message-----

Hi,

Best Regards

Khuzema

-----Original Message-----

To: 'CCAMP'

Hi,

single-

2. What is an LSP?

   in our work.

Cheers,

Adrian

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

CCAMP mailing list

[email-masked]

---

From: [email-masked]
Date: Tue, 12 Apr 2011 19:36:50 +0800

Hi Sergio & Pietro

From a purely technical point of view it may be noticed that G.709 and 
G.872 define a 1:1:1 correspondence among ODUk:OTUk:Och.

[Fei] 

Yeah, I agree. But for the case of ODU0-ODU2-ODU3, do we really need the 
existing of OTU2 and Och for OTU2?

If yeah, why? 

If not, ODU2 can be just used as multiplexing/demultiplexing. In this way, 
although ODU0 LSP is requested, ODU0 is inseted into ODU2 and ODU2 is 
inserted ODU3, I did not see why there SHOULD be some restriction that the 
label for ODU2 can not be returned.

Did I catch the idea of discussion?

Thanks and best regards

Fei

"BELOTTI, SERGIO (SERGIO)" <[email-masked]> 
发件人:  [email-masked]
2011-04-12 17:17

收件人
Rajan Rao <[email-masked]>, Khuzema Pithewan <[email-masked]>
抄送
'CCAMP' <[email-masked]>
主题
[CCAMP] R:  Discussion of multi-stage solutions

Hi Rajan, Khuzema
 
It seems as though you did not capture completely our points of the 
example, which is used to prove that multi-stage labels should not be 
used. 
 
In all the three cases, GMPLS have the session to manage and control the 
connection entities (e.g., ODU1, ODU3) . You may have misunderstood  on 
case 1 and case 2. In case 1, due to 1:1:1, there is wavelength connection 
session for ODU3.  For your response in case 2, ODU2 LSP can not be 
treated as ODU3, otherwise there is no session entity for ODU2 and in this 
way, the operator will lost the capability to control ODU2).

Thanks
 
BR
 
authors of [draft-zhang]

Da: Rajan Rao [mailto:[email-masked]] 
Inviato: giovedì 7 aprile 2011 20.42
A: BELOTTI, SERGIO (SERGIO); Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 
'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)
Oggetto: RE: [CCAMP] Discussion of multi-stage solutions
 
Sergio & Pietro,
 
Thanks for the example.  I think this is a good example to close the gap. 
Please see response inline.
 
Summary:   If an LSP works without CP representation at ODUk layer, it 
should work for other HO-ODUj layers as well.
 
Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 
'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO 
(SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions
 
Hi Rajan,Khuzema,
 
regarding point 1 from Adrian's mail, we think that Adrian's understanding 
is that multi-stage multiplexing will not be deployed extensively since 
the cost of multi-stage board will be high. This why he talked about 
"specific case ".
 
For point 2
"2. What is an LSP?
Historically we have ted ourselves in knots by failing to clearly 
understand
that an LSP is a data plane thing (a "connection") and also a the control
plane representation of the data pane thing (i.e. control plane, signaling
state). It is helpful to try to maintain a 1:1 mapping between the terms
in our work."
 
Adrian is substantially right and Fatai interpretation is also in line 
with Adrian's point.
 
From a purely technical point of view it may be noticed that G.709 and 
G.872 define a 1:1:1 correspondence among ODUk:OTUk:Och.
This permit to consider ODUk as having a double nature : or a simple 
section 1:1 with OTUk or a real LSP and in this caee ODUk is used as ODUj 
(e.g. we need to restore it: this is customer choice).
In a multi-stage hierarchy you have only the server ODUk that is compelled 
in the 1:1:1 relationship. Above ODUk this relationship is not present and 
all layers have to be treated as LSPs.
 
To illustrate better the concept suppose to have 3 nodes A,B,C and links 
A-B and B-C are OTU-3 links.
 
Case 1: ODU1 LSP from A to C switched in B no ODU3 restoration required
Only one signaling session will be provided containing per each link only 
one label  indicating the ODU3 tributary slots used by the ODU1.
This is because due to the 1:1:1 correspondence no LSP ODU3 is needed 
(ODU3 is a section).
[R& K] We agree there is no need for ODU3-LSP.  ODU3 is a path 
termination. If we go by your argument we would need another LSP at ODU3 
layer as there is no control plane representation for ODU3.
 
If CP works w/o representation for ODU3 layer it should work for ODU2 
layer as well. 
 
Case 2: ODU1 LSP from A to C switched in B but ODU3 restoration is 
required: ODU3 LSP is terminated as in previous case but need to be an LSP 
to be restored: it is not considered a as a section but a 1 hop path.
First draw ODU3 LSP, with its own signaling session.
Then draw ODU1 LSP as in case 1.
 
[R &K]  Agree, here you would require ODU3-LSP as you are expecting 
restoration at ODU3 layer.  Clearly operator decides whether to have 
ODU3-LSP or not. Extend the same concept to ODU2 layer, if operators needs 
restoration, he will setup ODU2-LSP otherwise we treat ODU2 layer similar 
to ODU3 on the segment.

We don’t think this breaks any model. 
 
Case 3: ODU3 path from A to C switched in B carrying an ODU1 from A to C 
(transparent in B).
First draw ODU3 LSP A to C with its own signaling session: the 1:1:1 
correspondence is not applicable since it is a multi-hop path.
Then draw ODU1 LSP from A to C with its own signaling session.
 
This is for single stage. Multistage comes as an extension of this 
concept.
Suppose to have a multistage ODU1-ODU2-ODU3 over OTU3. Only for the ODU3 
it is valid the 1:1:1 relationship.
So only for the ODU3 there is the choice to draw an LSP or not draw it.
ODU2 and ODU1 should be always signaled as LSPs independently from the 
number of hop.
 
Hope this clarify.
Thanks
 
Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di 
Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
[email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions
 
Good. We are agreeing on the problem statement (3 bullets below). What 
this means is that we are not optimizing for a special case (#1 in 
Adrian's email), we are addressing network wide flexibility & scalability 
issue.
 
FA is a solution, no doubt. But to have full grooming flexibility at every 
node you would require FAs on every link in the network. This will lead to 
huge scalability issues in large networks.

Both these lead to operational complexity. To make life easier for the 
operators we need a solution that solves scalability issues and simplifies 
operations.

Please refer to Khuzema's response to Daniele's email (email attached). We 
will provide more examples.
 
Thanks
Rajan & Khuzema
 
-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
[email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Rajan,
 
Obviously, the answer to all your questions is "YES", because this is the 
part of the premise for muxing hierarchy and this is why we are talking 
about FA and non-FA(multi-stage labels). The only disagreement between us 
is whether non-FA(multi-stage labels) is applicable or not.
 
I have repeated Daniele's question, and I would like to repeat once more 
as follows:
 
=====================================================================================================================
For the example in your slide 9 (Is this specific enough?), for the ODU1 
connection request, why GMPLS should allocate the TSs for ODU2->ODU3 
besides allocating the TSs for ODU1? In this way, 1:1 mapping is lost.
 
Could you give the WG an example to show that when signal type X in 
Traffic Parameters is requested, GMPLS will allocate the labels for signal 
type Y additionally?

P.S., I will be on the plane to wait for your answers and keep silent for 
a few days because of my vacations.

Fatai
 
Thanks
 
----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 
<[email-masked]>; "Sidd Aanand" <[email-masked]>; 
"Daniele Ceccarelli" <[email-masked]>; 
<[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,
 
Can you be more specific please? Which one of the following are you 
referring:

Every scenario we discussed in the past 4 months for routing-draft-merge 
was related to the above cases.
 
You raise a good point on the practical deployment. This is the feedback 
we are looking for from the WG. If you have data available please share. 
May be we don't need IMCDs to begin with.  This will definitely simplify 
both routing and signaling extensions.

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
[email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi Rajan,
 
I think we should focus on the questions to discuss something. It does not 
make sense to say something by flying in the air. I think all the people 
are waiting for the scenarios from the practical deployments.

Fatai
 
Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 
<[email-masked]>; "Sidd Aanand" <[email-masked]>; 
"Daniele Ceccarelli" <[email-masked]>; 
<[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,
 
If you have fewer such restricted links, yes it is an optimization.  The 
point you are missing is when you have 100s of such links in the network 
you gain scaling and ease of operation benefits.  This is our main point.
 
Thanks
Rajan
 
-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
[email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi Rajan,
 
You said you agreed with point #1, so we don't need to optimize for the 
special cases.
 
So the things are very clear, even though you did not answer our other 
questions directly.

Fatai
 
Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 
<[email-masked]>; "Sidd Aanand" <[email-masked]>; 
"Daniele Ceccarelli" <[email-masked]>; 
<[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,
 
There is no disagreement on point#1.  The proposal is optimized solution, 
a scalable solution & an operator friendly solution depending on the 
deployment scenarios.
 
With the introduction of IMCDs in routing draft we are admitting that 
muxing restrictions do exist. This is inevitable in the evolution of OTN.
 
If you have muxing restrictions on every hop in your network, you have 2 
choice.  (A) have FAs on every segment or in certain parts of the network 
(B) use the label proposed in the draft.  Option (B) eliminates the need 
to have FA on every-hop in such scenarios. This is the key point you are 
missing.
 
Note that once you have FAs, it restrict the type of service you can carry 
(pl refer to examples in the draft).
 
Hope this helps.
 
Thanks
Rajan
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
[email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi Khuzema,
 
Actually, you don't answer Daniele's question. We know that you don't 
assume this ODU2 is a LSP.
 
Daniele asked you: for example, in your slide 9, for the ODU1 connection 
request, why you need to allocate the TSs for ODU2->ODU3 besides 
allocating the TSs for ODU1? In this way, 1:1 mapping is lost.

 
In my presentation, I asked a lot of questions and list a number of the 
issues about multi-stage labels. These questions and issues should be 
clarified clearly.
 
Fatai
 
Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 
<[email-masked]>; "Daniele Ceccarelli" 
<[email-masked]>; <[email-masked]>; "'CCAMP'" 
<[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,
 
If I correctly understand Daniel's example, ODU2 is not a LSP in control 
plane, it is just a local ODU2 endpoint in data plane. So the ODU0 lsp 
sets up ODU2<-ODU0 layer because it is mandated by restrictive 
multiplexing hierarchy on interface.
 
This is in context of draft draft-khuzema-ccamp-gmpls-signaling-g709-01. 
The ppt is located @ 
http://www.ietf.org/proceedings/80/slides/ccamp-24.pptx

Thanks
Khuzema
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; 
[email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi Sidd,
 
This question should ask Khuzema, why there are multi labels for ODU0 
connection request?
 
Fatai
 
Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 
Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" 
<[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,
 
Can you please explain why would we allocate labels for ODU2 when an ODU-0 
LSP is requested?
 
Thanks,
Sidd
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi Khuzema,
 
I agree with Adrian. If i correctly understood your proposal, when and 
ODU0 LSP is requested, the LSRs should allocate the labels for ODU2 
besides allocating the labels for ODU0? In such a way the 1:1 mapping is 
lost.
 
My 2c
 
BR
Daniele
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions
 
Hi,
 
On point#2. I agree with you that a LSP is control plane equivalent of a 
dataplane connection. But, not all data plane connection need to be 
modeled in control plane as lsp. We need to model only those dataplane 
connection in control plane as lsp (or FA), that matters in path 
computation, or need to be monitored for faults/restoration in control 
plane.
 
Best Regards
Khuzema
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions
 
Hi,

A couple of thoughts that we didn't have time to talk about in the 
meeting. The chairs may be right that the framework document can help us 
understand which scenarios we need to address.
 
1. We don't generally optimize for special cases.
   That means we should pick a solution that we can apply across the 
board.
   Separating out a solution that is optimized for a particular case (e.g.
single-
   hop) would only be valuable if the savings are really large.
 
2. What is an LSP?
   Historically we have ted ourselves in knots by failing to clearly 
understand
   that an LSP is a data plane thing (a "connection") and also a the 
control
   plane representation of the data pane thing (i.e. control plane, 
signaling
   state). It is helpful to try to maintain a 1:1 mapping between the 
terms
   in our work.
 
Cheers,
Adrian

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 12 Apr 2011 13:53:05 +0200

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]
________________________________
Da: [email-masked] [mailto:[email-masked]]
Inviato: martedì 12 aprile 2011 13.37
A: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]; Khuzema Pithewan; Rajan Rao
Oggetto: Re: [CCAMP] R: Discussion of multi-stage solutions

Hi Sergio & Pietro

[Fei]

Yeah, I agree. But for the case of ODU0-ODU2-ODU3, do we really need the existing of OTU2 and Och for OTU2?
Obvioulsy not. If i need to have a multiplexing on ODU 3 , only OTU3 is present.

If yeah, why?

If not, ODU2 can be just used as multiplexing/demultiplexing. In this way, although ODU0 LSP is requested, ODU0 is inseted into ODU2 and ODU2 is inserted ODU3, I did not see why there SHOULD be some restriction that the label for ODU2 can not be returned.

Did I catch the idea of discussion?
It seems as though you did not catch the point. There is no 1:1 correspondence between ODUj and ODUk, If you need to multiplex ODU 2 into ODU3 , it is not a simple mapping, in fact you need to have a correct TSs allocation in OPUk. You need to have an ODU2 LSP , and the label has to represent this TS allocation referred to ODUk. You do not have the choice that instead is present in case of ODUk(j)-OTUk(j).

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: John E Drake <[email-masked]>
Date: Tue, 12 Apr 2011 15:44:55 -0700

I wouldn't go that far 8->

Sent from my iPhone

From: Fatai Zhang [mailto:[email-masked]]
Sent: Tuesday, April 12, 2011 1:53 AM
To: John E Drake; [email-masked]; 'BELOTTI, SERGIO (SERGIO)'; 'Rajan Rao'; 'Khuzema Pithewan'
Cc: 'Sidd Aanand'; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi John,

Thanks

Fatai

----- Original Message -----
From: "John E Drake" <[email-masked]<mailto:[email-masked]>>
To: "Fatai Zhang" <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>>; "'BELOTTI, SERGIO (SERGIO)'" <[email-masked]<mailto:[email-masked]>>; "'Rajan Rao'" <[email-masked]<mailto:[email-masked]>>; "'Khuzema Pithewan'" <[email-masked]<mailto:[email-masked]>>
Cc: "'Sidd Aanand'" <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, April 06, 2011 11:54 PM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks,

John

Sent from my iPhone

> To: [email-masked]<mailto:[email-masked]>; 'BELOTTI, SERGIO (SERGIO)'; 'Rajan Rao';
> 'Khuzema Pithewan'
> From: "Adrian Farrel" <[email-masked]<mailto:[email-masked]>>
> To: "'BELOTTI, SERGIO (SERGIO)'" <[email-masked]<mailto:[email-masked]>>;
> "'Rajan Rao'" <[email-masked]<mailto:[email-masked]>>; "'Khuzema Pithewan'"
> <[email-masked]<mailto:[email-masked]>>
> Cc: "'Fatai Zhang'" <[email-masked]<mailto:[email-masked]>>; "'Sidd Aanand'"
> <[email-masked]<mailto:[email-masked]>>; "'Daniele Ceccarelli'"
> <[email-masked]<mailto:[email-masked]>>; "'CCAMP'" <[email-masked]<mailto:[email-masked]>>;
> <[email-masked]<mailto:[email-masked]>>

---

From: [email-masked]
Date: Wed, 13 Apr 2011 09:19:39 +0800

Hi Sergio

Thank you for your quick response. 

See in line.

If there are some misunderstanding about your interpretation, please do 
not hesitate to let me know.

BR

Fei

2011-04-12 19:53

收件人
"[email-masked]" <[email-masked]>
抄送
"'CCAMP'" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Khuzema Pithewan <[email-masked]>, Rajan 
Rao <[email-masked]>, Daniele Ceccarelli 
<[email-masked]>, Fatai Zhang <[email-masked]>, 
"GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" 
<[email-masked]>, "BELOTTI, SERGIO (SERGIO)" 
<[email-masked]>
主题
R: [CCAMP] R:  Discussion of multi-stage solutions

Hi Fei,
 
see in line 
 
Thanks
 
BR
 
authors of [draft-zhang]

Hi Sergio & Pietro 

[Fei] 

Yeah, I agree. But for the case of ODU0-ODU2-ODU3, do we really need the 
existing of OTU2 and Och for OTU2? 
Obvioulsy not. If i need to have a multiplexing on ODU 3 , only OTU3 is 
present.

[Fei]  Great, we have the same understanding about G.709 and G.872. So for 
the solution of multi-stage multiplexing, why the creation of ODU2 
hierarchical LSP SHOULD be the only one?
          Just my two cents, hierarchical LSP works well, but the 
non-hierarchical LSP works also.

If yeah, why? 

Did I catch the idea of discussion? 
It seems as though you did not catch the point. There is no 1:1 
correspondence between ODUj and ODUk

[Fei] Of course, there is no 1:1 relationship between ODUj and ODUk.

 If you need to multiplex ODU 2 into ODU3 , it is not a simple mapping, in 
fact you need to have a correct TSs allocation in OPUk. 

[Fei] Agree, but the correct TSs allocation in OPUk can be carried back by 
the using of multi-stage labels in the context of  "non-FA" solution. 
       Is there any other information lost?

You need to have an ODU2 LSP , and the label has to represent this TS 
allocation referred to ODUk. 

[Fei] Why ODU2 LSP is must (of course, ODU2 LSP works well )?   Let's go 
back to the definition of LSP, and according to my understanding,  ODU2 
LSP means the data plane (forwarding, OAM, protection, the last two is 
optional) and the control plane (the 5-tuple carried in the session and 
template object in signaling state). 
Obvioulsy, the "non-FA solution" did not say that ODU2 is a LSP. The 
multi-stage labels represent  the allocated resources, which can be 
reflected by the routing and signaling processing,  but only the label 
informaion does not indicate that an independent session for the ODU2 is 
MUST. 

You do not have the choice that instead is present in case of 
ODUk(j)-OTUk(j).

[Fei] Totally agree, this point is well written in the corresponding 
document.

Thanks and best regards 

Fei 

收件人

Hi Rajan, Khuzema 

  
  
Thanks 
  
BR 
  
authors of [draft-zhang] 

  
Sergio & Pietro, 

  
Thanks 
Rajan & Khuzema 

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 
  
Hi Rajan,Khuzema, 

For point 2 
"2. What is an LSP? 

  

  

  

Hope this clarify. 
Thanks 
  
Sergio and Pietro 

Sergio Belotti 
Portfolio Evolution 

-----Messaggio originale----- 

  

  
  
Thanks 
Rajan & Khuzema 
  
-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Friday, April 01, 2011 7:19 AM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
  
Rajan, 

  

  

  

Fatai 
  
Thanks 
  
----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

  

Thanks 
Rajan 

-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
  
Hi Rajan, 

  
Fatai 
  
Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

Thanks 
Rajan 
  
-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
  
Hi Rajan, 

Fatai 
  
Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

  

Hope this helps. 
  
Thanks 
Rajan 
  
-----Original Message----- 
  
Hi Khuzema, 

  

  
Fatai 
  
Thanks 

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi, 

  
  
Thanks 
Khuzema 
  
-----Original Message----- 
  
Hi Sidd, 

Fatai 
  
Thanks 

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]> 
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele, 

Thanks, 
Sidd 
  
-----Original Message----- 
  
Hi Khuzema, 

My 2c 
  
BR 
Daniele 
  
-----Original Message----- 
  
Hi, 

Best Regards 
Khuzema 
  
-----Original Message----- 
  
Hi, 

  

single- 
  
2. What is an LSP? 
  
Cheers, 
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 13 Apr 2011 10:26:26 +0800

Hi Fei,

I think you have missed something important. If you did not follow the OTN discussion, please review the previous mails and my presentation slides in Prague meeting.

Thanks
 
Fatai

  ----- Original Message ----- 
  From: [email-masked] 
  To: BELOTTI, SERGIO (SERGIO) 
  Cc: 'CCAMP' ; [email-masked] ; Daniele Ceccarelli ; Khuzema Pithewan ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO) ; Rajan Rao ; BELOTTI, SERGIO (SERGIO) ; Fatai Zhang 
  Sent: Wednesday, April 13, 2011 9:19 AM
  Subject: R: [CCAMP] R: Discussion of multi-stage solutions

  Hi Sergio 

  See in line. 

  If there are some misunderstanding about your interpretation, please do not hesitate to let me know. 

  BR 

  Fei 

        "BELOTTI, SERGIO (SERGIO)" <[email-masked]> 
        2011-04-12 19:53 
       收件人 "[email-masked]" <[email-masked]>  
              抄送 "'CCAMP'" <[email-masked]>, "[email-masked]" <[email-masked]>, Khuzema Pithewan <[email-masked]>, Rajan Rao <[email-masked]>, Daniele Ceccarelli <[email-masked]>, Fatai Zhang <[email-masked]>, "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" <[email-masked]>  
              主题 R: [CCAMP] R:  Discussion of multi-stage solutions 

  Hi Fei, 
    
  see in line 
    
  Thanks 
    
  BR 
    
  authors of [draft-zhang] 

------------------------------------------------------------------------------

  Hi Sergio & Pietro 

  [Fei] 

  [Fei]  Great, we have the same understanding about G.709 and G.872. So for the solution of multi-stage multiplexing, why the creation of ODU2 hierarchical LSP SHOULD be the only one? 
            Just my two cents, hierarchical LSP works well, but the non-hierarchical LSP works also.

  If yeah, why? 

  Did I catch the idea of discussion? 
  It seems as though you did not catch the point. There is no 1:1 correspondence between ODUj and ODUk 

   If you need to multiplex ODU 2 into ODU3 , it is not a simple mapping, in fact you need to have a correct TSs allocation in OPUk. 

  [Fei] Agree, but the correct TSs allocation in OPUk can be carried back by the using of multi-stage labels in the context of  "non-FA" solution. 
         Is there any other information lost? 

  You need to have an ODU2 LSP , and the label has to represent this TS allocation referred to ODUk. 

  [Fei] Why ODU2 LSP is must (of course, ODU2 LSP works well )?   Let's go back to the definition of LSP, and according to my understanding,  ODU2 LSP means the data plane (forwarding, OAM, protection, the last two is optional) and the control plane (the 5-tuple carried in the session and template object in signaling state). 
  Obvioulsy, the "non-FA solution" did not say that ODU2 is a LSP. The multi-stage labels represent  the allocated resources, which can be reflected by the routing and signaling processing,  but only the label informaion does not indicate that an independent session for the ODU2 is MUST. 

  You do not have the choice that instead is present in case of ODUk(j)-OTUk(j). 

  [Fei] Totally agree, this point is well written in the corresponding document. 

  Thanks and best regards 

  Fei 

              收件人 Rajan Rao <[email-masked]>, Khuzema Pithewan <[email-masked]>  
              抄送 'CCAMP' <[email-masked]>  
              主题 [CCAMP] R:  Discussion of multi-stage solutions 

       

  Hi Rajan, Khuzema 

   
   
  Thanks 
   
  BR 
   
  authors of [draft-zhang] 

------------------------------------------------------------------------------

  Sergio & Pietro, 

   
  Thanks 
  Rajan & Khuzema 

  -----Original Message-----
  From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
  Sent: Monday, April 04, 2011 2:04 AM
  To: Rajan Rao; Khuzema Pithewan
  Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
  Subject: R: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Rajan,Khuzema, 

  For point 2 
  "2. What is an LSP? 

   

   

   

  Hope this clarify. 
  Thanks 
   
  Sergio and Pietro 

  Sergio Belotti 
  Portfolio Evolution 

  -----Messaggio originale----- 
  Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao 
  Inviato: venerdì 1 aprile 2011 12.56 
  A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Oggetto: Re: [CCAMP] Discussion of multi-stage solutions 

   

   
   
  Thanks 
  Rajan & Khuzema 
   
  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Friday, April 01, 2011 7:19 AM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Rajan, 

   

   

  Fatai 
   
  Thanks 
   
  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 5:43 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

   

  Thanks 
  Rajan 

  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Thursday, March 31, 2011 7:53 PM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Rajan, 

   
  Fatai 
   
  Thanks 

  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 1:40 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

  Thanks 
  Rajan 
   
  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Thursday, March 31, 2011 7:12 PM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Cc: Rajan Rao 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Rajan, 

  Fatai 
   
  Thanks 

  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Cc: "Rajan Rao" <[email-masked]> 
  Sent: Friday, April 01, 2011 1:00 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

   

  Hope this helps. 
   
  Thanks 
  Rajan 
   
  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang 
  Sent: Thursday, March 31, 2011 6:31 PM 
  To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Khuzema, 

   

   
  Fatai 
   
  Thanks 

  ----- Original Message ----- 
  From: "Khuzema Pithewan" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 12:09 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Hi, 

   
   
  Thanks 
  Khuzema 
   
  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang 
  Sent: Thursday, March 31, 2011 5:44 PM 
  To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Sidd, 

  Fatai 
   
  Thanks 

  ----- Original Message ----- 
  From: "Sidd Aanand" <[email-masked]> 
  To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Thursday, March 31, 2011 11:38 PM 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Daniele, 

  Thanks, 
  Sidd 
   
  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli 
  Sent: Thursday, March 31, 2011 9:06 PM 
  To: Khuzema Pithewan; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi Khuzema, 

  My 2c 
   
  BR 
  Daniele 
   
  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan 
  Sent: giovedì 31 marzo 2011 11.24 
  To: [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 
   
  Hi, 

  Best Regards 
  Khuzema 
   
  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel 
  Sent: Thursday, March 31, 2011 11:10 AM 
  To: 'CCAMP' 
  Subject: [CCAMP] Discussion of multi-stage solutions 
   
  Hi, 

   
   
  2. What is an LSP? 
   
  Cheers, 
  Adrian

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 13 Apr 2011 10:06:49 +0200

Hi Fei,

[Fei]Just my two cents, hierarchical LSP works well, but the non-hierarchical LSP works also.

Quote from RFC 3471 : From par. 3.2 ” A Generalized Label only carries a single level of label, i.e., it is

   non-hierarchical.  When multiple levels of label (LSPs within LSPs)

   are required, each LSP must be established separately, see [MPLS-
   HIERARCHY]”
Our interpretation is that based on Generalized Label Request , RSVP-TE returns only one label per link.
Doing in a different way means to change RSVP-TE standard behaviour. In our opinion “optimization” for specific case is not a strong argument.

See above : if you need an extra label you’re setting up an LSP .

Again, please justify why we should change what reported in the standard RFC 3471

Thanks

Best Regards

authors of [draft-zhang]
________________________________
Da: [email-masked] [mailto:[email-masked]]
Inviato: mercoledì 13 aprile 2011 3.20
A: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]; Daniele Ceccarelli; Khuzema Pithewan; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Rajan Rao; BELOTTI, SERGIO (SERGIO); Fatai Zhang
Oggetto: R: [CCAMP] R: Discussion of multi-stage solutions

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

"'CCAMP'" <[email-masked]>, "[email-masked]" <[email-masked]>, Khuzema Pithewan <[email-masked]>, Rajan Rao <[email-masked]>, Daniele Ceccarelli <[email-masked]>, Fatai Zhang <[email-masked]>, "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" <[email-masked]>

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Wed, 13 Apr 2011 18:06:42 +0800

Hi Sergio

Ok, understand.

Thank you for your clarification.

Best regards

Fei

:)

2011-04-13 16:06

收件人
"[email-masked]" <[email-masked]>
抄送
"'CCAMP'" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Daniele Ceccarelli 
<[email-masked]>, Khuzema Pithewan 
<[email-masked]>, "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" 
<[email-masked]>, Rajan Rao 
<[email-masked]>, Fatai Zhang <[email-masked]>, "BELOTTI, SERGIO 
(SERGIO)" <[email-masked]>, "[email-masked]" 
<[email-masked]>
主题
R: [CCAMP] R:  Discussion of multi-stage solutions

Hi Fei,
 
[Fei]Just my two cents, hierarchical LSP works well, but the 
non-hierarchical LSP works also.
 
Quote from RFC 3471 : From par. 3.2 ” A Generalized Label only carries a 
single level of label, i.e., it is
   non-hierarchical.  When multiple levels of label (LSPs within LSPs)
   are required, each LSP must be established separately, see [MPLS-
   HIERARCHY]”
Our interpretation is that based on Generalized Label Request , RSVP-TE 
returns only one label per link.
Doing in a different way means to change RSVP-TE standard behaviour. In 
our opinion “optimization” for specific case is not a strong argument.

 
 
Again, please justify why we should change what reported in the standard 
RFC 3471
 
Thanks
 
Best Regards
 
authors of [draft-zhang]

Da: [email-masked] [mailto:[email-masked]] 
Inviato: mercoledì 13 aprile 2011 3.20
A: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]; Daniele Ceccarelli; Khuzema Pithewan; 
GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Rajan Rao; BELOTTI, SERGIO 
(SERGIO); Fatai Zhang
Oggetto: R: [CCAMP] R: Discussion of multi-stage solutions

Hi Sergio 

See in line. 

BR 

Fei 

收件人

Hi Fei, 
  
see in line 
  
Thanks 
  
BR 
  
authors of [draft-zhang] 

Hi Sergio & Pietro 

[Fei] 

If yeah, why? 

Thanks and best regards 

Fei 

收件人

 

Hi Rajan, Khuzema 

 
 
Thanks 
 
BR 
 
authors of [draft-zhang] 

 
Sergio & Pietro, 

 
Thanks 
Rajan & Khuzema 

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 
 
Hi Rajan,Khuzema, 

For point 2 
"2. What is an LSP? 

 

 

 

Hope this clarify. 
Thanks 
 
Sergio and Pietro 

Sergio Belotti 
Portfolio Evolution 

-----Messaggio originale----- 

 

 
 
Thanks 
Rajan & Khuzema 
 
-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Friday, April 01, 2011 7:19 AM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
 
Rajan, 

 

 

 

Fatai 
 
Thanks 
 
----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

 

Thanks 
Rajan 

-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
 
Hi Rajan, 

 
Fatai 
 
Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

Thanks 
Rajan 
 
-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 
 
Hi Rajan, 

Fatai 
 
Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

 

Hope this helps. 
 
Thanks 
Rajan 
 
-----Original Message----- 
 
Hi Khuzema, 

 

 
Fatai 
 
Thanks 

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi, 

 
 
Thanks 
Khuzema 
 
-----Original Message----- 
 
Hi Sidd, 

Fatai 
 
Thanks 

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]> 
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele, 

Thanks, 
Sidd 
 
-----Original Message----- 
 
Hi Khuzema, 

My 2c 
 
BR 
Daniele 
 
-----Original Message----- 
 
Hi, 

Best Regards 
Khuzema 
 
-----Original Message----- 
 
Hi, 

 

2. What is an LSP? 

  in our work. 
 
Cheers, 
Adrian

---

From: Steve Balls <[email-masked]>
Date: Thu, 14 Apr 2011 15:18:42 +0100

All

We'd like to take a step back from this debate and offer a different perspective.

The debate about whether a multistage label represents one or multiple LSPs is moot, because there is not an authoritative definition of an LSP that can resolve it one way or another.  We all understand conceptually what a multi-stage label is, and we should focus the debate on its advantages and disadvantages on its own merits.

We do not have a preference here, but think there are some further discussion points to be made, and it would be beneficial to request further viewpoints on the below.

We all understand there are several scenarios (see the examples from the presentations at Prague) where single stage labels are not enough to set up a connection.  We also know that one option to solve this is for operators to pre-provision an FA-LSP.  However, it’s not clear to us whether this is acceptable to operators – would they in fact want such connections to come up automatically?

Assuming they do, there are two options.

i)              Multi-stage labels

ii)             Induced H-LSPs

Solution (i) is not complete because there are still cases that will not work automatically with multistage labels; plus there are functional restrictions that others have pointed out already.  However, they are very significantly easier to implement, and if standardized should be supported by all devices.

Solution (ii) will solve most scenarios (given a suitable routing calculation) but depends on all devices having the capability to induce an H-LSP.  This, as far as we are aware, is not guaranteed and there’s currently no standard way to advertise this capability.

So it seems to us that while multistage labels may have some functional restrictions, they have some operational and implementation benefits that we should weigh dispassionately.  However, we have seen no input from operators (direct or indirect) to say whether they think that the configuration of FA-LSPs will actually be a problem for them, or if they expect connections to be automatic where possible.  Does anyone reading this have any feedback on that point?

Best regards,

Steve & Jon

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 13 April 2011 11:07
To: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]
Subject: [CCAMP] R: R: Discussion of multi-stage solutions

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

"'CCAMP'" <[email-masked]>, "[email-masked]" <[email-masked]>, Daniele Ceccarelli <[email-masked]>, Khuzema Pithewan <[email-masked]>, "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" <[email-masked]>, Rajan Rao <[email-masked]>, Fatai Zhang <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" <[email-masked]>, "[email-masked]" <[email-masked]>

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" <[email-masked]>
Date: Thu, 14 Apr 2011 17:14:33 +0200

Hello, in line..

Sergio & Pietro

============================================
Pietro Vittorio Grandi
Terrestrial Optics Portfolio Evolution
Alcatel-Lucent Vimercate (Italy)
Tel: +39 039 686 4930
Mail: [email-masked]
============================================
Put your hand on a hot stove for a minute, and it seems like an hour.
Sit with a pretty girl for an hour, and it seems like a  minute. That's relativity.
(A. Einstein)

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steve Balls
Sent: giovedì 14 aprile 2011 16.19
To: 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

All

The debate about whether a multistage label represents one or multiple LSPs is moot, because there is not an authoritative definition of an LSP that can resolve it one way or another.

[[ALU]]  Let me quote again RFC 3471 par. 3.2 ” A Generalized Label only carries a single level of label, i.e., it is non-hierarchical.
          When multiple levels of label (LSPs within LSPs)  are required, each LSP must be established separately, see [MPLS- HIERARCHY]”
          This sentence clearly associates multiple labels on link with LSPs.
          Can you please clarify why having a multi-stage label solution is compatible with the previous sentence ?
          If it is not compatible then you mean that RFC3471 (together with GMPLS basic standard behaviour) should be modified ?

We all understand conceptually what a multi-stage label is, and we should focus the debate on its advantages and disadvantages on its own merits.

i)                     Multi-stage labels

ii)                   Induced H-LSPs

[[ALU]] Provided that it is demonstrated that the solution is in line with RFC3471, seen that solution 1) solves only a very specific case and that the same case is solved by solution 2 that is already a standard, then it should be OPTIONALLY supported.

[[ALU]] For the reason I told before, multi-stage label should be optional and depends from all devices implementing a completely new solution.
So, all problems you list for solution 2) are present as well for solution 1).

So it seems to us that while multistage labels may have some functional restrictions, they have some operational and implementation benefits that we should weigh dispassionately.

[[ALU]] I have not understood from your mail which are the operational benefits maybe you can better clarify them ?
Also implementation benefits are not very clear. Being H-LSP a standard I can imagine products that already have implemented it, and
for these products implementing multi-stage labels would just be an extra effort to be paid.

 However, we have seen no input from operators (direct or indirect) to say whether they think that the configuration of FA-LSPs will actually be a problem for them, or if they expect connections to be automatic where possible.

[[ALU]] Solution 2 does not imply configuring  FA-LSP. The configuration of H-LSP would be automatic (or not) dependently from operator preference.

Does anyone reading this have any feedback on that point?

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 15 Apr 2011 10:14:28 +0800

Hi all,

I fully agree with Pietro's response. 

I would like to emphasize the following points:

(1) What is your answer to these two simple questions below? Is it "Yes" or "No"? 

Can you ask yourself hearts why you can not give "Yes" or "No" directly?

I think these two simple questions are related to the GMPLS principle and operator's network managment model. You can also see the evidence from RFC3471 quoted by Pietro below.
========================================================================================================
When the signal type X in Traffic Parameters is requested, should GMPLS allocate the labels for the signal type Y additionally? 

You can just answer "Yes" or "No", if your answer is "Yes", please give an example from the GMPLS world to prove it.

========================================================================================================

(2) You all have admitted that multi-stage labels is not complete and has some functional restrictions (it can not solve the typical cases except some speical case).

(3) Implementation VS standardization
If it is for implementation,  people can do arbitrary things including some bad things. 
However, we are doing the standardization work,  should people bring the uncomplete solution with lots of disadvantages on the standardization work (You know there is already a generic, standardized and well-used solution)?

If you face these problems genuinely, I think you must understand that multi-stage labels should not be used.

Thanks
 
Fatai

  ----- Original Message ----- 
  From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO) 
  To: Steve Balls ; 'CCAMP' 
  Cc: Fatai Zhang ; Daniele Ceccarelli ; Belotti, Sergio ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO) 
  Sent: Thursday, April 14, 2011 11:14 PM
  Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

  Hello, in line..

  Sergio & Pietro

  All

  i)                     Multi-stage labels

  ii)                   Induced H-LSPs

  Best regards,

  Steve & Jon

  Hi Sergio 

  Ok, understand. 

  Best regards 

  Fei 

  :) 

        2011-04-13 16:06 
       收件人
             
              抄送
             
              主题

              

  Hi Fei, 

    

    
  Thanks 
    
  Best Regards 
    
  authors of [draft-zhang] 

  Hi Sergio 

  See in line. 

  BR 

  Fei 

        2011-04-12 19:53 

              收件人
             
              抄送
             
              主题

  Hi Fei, 
   
  see in line 
   
  Thanks 
   
  BR 
   
  authors of [draft-zhang] 

  Hi Sergio & Pietro 

  [Fei] 

  If yeah, why? 

  Thanks and best regards 

  Fei 

        2011-04-12 17:17 

              收件人
             
              抄送
             'CCAMP' <[email-masked]> 
             
              主题

         

       

  Hi Rajan, Khuzema 

  Thanks 

  BR 

  authors of [draft-zhang] 

  Sergio & Pietro, 

  Thanks 
  Rajan & Khuzema 

  -----Original Message-----
  From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
  Sent: Monday, April 04, 2011 2:04 AM
  To: Rajan Rao; Khuzema Pithewan
  Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
  Subject: R: [CCAMP] Discussion of multi-stage solutions 

  Hi Rajan,Khuzema, 

  For point 2 
  "2. What is an LSP? 

  Hope this clarify. 
  Thanks 

  Sergio and Pietro 

  Sergio Belotti 
  Portfolio Evolution 

  -----Messaggio originale----- 
  Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao 
  Inviato: venerdì 1 aprile 2011 12.56 
  A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Oggetto: Re: [CCAMP] Discussion of multi-stage solutions 

  Thanks 
  Rajan & Khuzema 

  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Friday, April 01, 2011 7:19 AM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Rajan, 

  Fatai 

  Thanks 

  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 5:43 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

  Thanks 
  Rajan 

  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Thursday, March 31, 2011 7:53 PM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi Rajan, 

  Fatai 

  Thanks 

  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 1:40 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

  Thanks 
  Rajan 

  -----Original Message----- 
  From: Fatai Zhang [mailto:[email-masked]] 
  Sent: Thursday, March 31, 2011 7:12 PM 
  To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Cc: Rajan Rao 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi Rajan, 

  Fatai 

  Thanks 

  ----- Original Message ----- 
  From: "Rajan Rao" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Cc: "Rajan Rao" <[email-masked]> 
  Sent: Friday, April 01, 2011 1:00 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Fatai, 

  Hope this helps. 

  Thanks 
  Rajan 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang 
  Sent: Thursday, March 31, 2011 6:31 PM 
  To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi Khuzema, 

  Fatai 

  Thanks 

  ----- Original Message ----- 
  From: "Khuzema Pithewan" <[email-masked]> 
  To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Friday, April 01, 2011 12:09 AM 
  Subject: RE: [CCAMP] Discussion of multi-stage solutions 

  Hi, 

  Thanks 
  Khuzema 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang 
  Sent: Thursday, March 31, 2011 5:44 PM 
  To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi Sidd, 

  Fatai 

  Thanks 

  ----- Original Message ----- 
  From: "Sidd Aanand" <[email-masked]> 
  To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]> 
  Sent: Thursday, March 31, 2011 11:38 PM 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Daniele, 

  Thanks, 
  Sidd 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli 
  Sent: Thursday, March 31, 2011 9:06 PM 
  To: Khuzema Pithewan; [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi Khuzema, 

  My 2c 

  BR 
  Daniele 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan 
  Sent: giovedì 31 marzo 2011 11.24 
  To: [email-masked]; 'CCAMP' 
  Subject: Re: [CCAMP] Discussion of multi-stage solutions 

  Hi, 

  Best Regards 
  Khuzema 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel 
  Sent: Thursday, March 31, 2011 11:10 AM 
  To: 'CCAMP' 
  Subject: [CCAMP] Discussion of multi-stage solutions 

  Hi, 

  2. What is an LSP? 

  Cheers, 
  Adrian

---

From: Steve Balls <[email-masked]>
Date: Fri, 15 Apr 2011 13:26:02 +0100

All,

Please let me repeat the statement that we do not have a preference on the label format chosen.  We do, however, believe there are a couple of points that require further discussion.  Our key question is what do operators require – are they happy to pre-provision FA-LSPs or do they expect connection set-up to be automatic where possible?

We do still believe that the question on “what is an LSP” is not resolved by the quoted extract from RFC 3471.  Below is the first paragraph from section 3.2.

   The Generalized Label extends the traditional label by allowing the
   representation of not only labels which travel in-band with
   associated data packets, but also labels which identify time-slots,
   wavelengths, or space division multiplexed positions.  For example,
   the Generalized Label may carry a label that represents (a) a single
   fiber in a bundle, (b) a single waveband within fiber, (c) a single
   wavelength within a waveband (or fiber), or (d) a set of time-slots
   within a wavelength (or fiber).  It may also carry a label that
   represents a generic MPLS label, a Frame Relay label, or an ATM label
   (VCI/VPI).

It is possible to argue that a multi-stage label is still simply setting up “a set of time-slots within a wavelength”.  To be clear, there is nothing wrong with the RFC 3471 text, but we do not believe there is a definition of an LSP for the G.709v3 data plane.  Is it a path where each LSR switches the same number of time-slots?

On the question of implementation VS standardization, please allow us to clarify our point.  The capability of inducing an H-LSP is not mandatory nor is there a defined method to advertise that you have the capability.  You therefore cannot assume a node has that capability.  However, _if_ multi-stage labels are defined as part of eOTN signalling, and a node is advertising a multi-stage hierarchy, it is perfectly reasonable to assume that the node can support multi-stage labels.  This point alters what routing calculations you can perform in all networks with multi-stage hierarchies present.

Again, we have no preference here – our aim is to get more input from others on this mailing list to see if a consensus can be reached.

Regards,

Steve & Jon

From: Fatai Zhang [mailto:[email-masked]]
Sent: 15 April 2011 03:14
To: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Steve Balls; 'CCAMP'
Cc: Daniele Ceccarelli; ALU - Sergio Belotti; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

Mail: [email-masked]<mailto:[email-masked]>

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Steve Balls
Sent: giovedì 14 aprile 2011 16.19
To: 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: "GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)" <[email-masked]>
Date: Fri, 15 Apr 2011 17:02:47 +0200

Please, see in line.

I have the feeling that you are equivocating some important technology point.

________________________________
From: Steve Balls [mailto:[email-masked]]
Sent: venerdì 15 aprile 2011 14.26
To: Fatai Zhang; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); 'CCAMP'
Cc: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

All,

[[ALU]] Of course both alternatives must be possible. The choice will have to be performed independently by each operator and it is not a task of an SDO
to force a one way or another.

[[ALU]]  When allocating two labels in the multi-stage solution the operation performed is not allocating a set of time-slots
   within a wavelength (or fiber).  The operations carried up are :
1)     Decide how structuring the ODUk. (chose the intermediate ODUj container)
2)     Allocate tributary slots to carry an  intermediate ODUj over the ODUk
3)     Structure the intermediate ODUj.
4)     Allocate the tributary slots on the structured intermediate ODUj in order to transport the client ODU.

In doing so resources for two layers are allocated.
Note that if instead of having two ODU layers you have for instance MPLS over a OTN interface,
  then following your line of reasoning  GMPLS should allow returning an MPLS label and at least an OTN label when requesting an MPLS path via generalized label  request. This behaviour is clearly contrary to current GMPLS architecture but is exactly what you are supporting within the OTN region.

It is possible to argue that a multi-stage label is still simply setting up “a set of time-slots within a wavelength”.
[[ALU]] Please see comment above.
 To be clear, there is nothing wrong with the RFC 3471 text, but we do not believe there is a definition of an LSP for the G.709v3 data plane.  Is it a path where each LSR switches the same number of time-slots?
[[PG]]  In OTN the switched entities are ODUs not tributary slots. When allocating two labels for multistage, you are instantiating two ODU containers,
that are the switchable entities for OTN. (hence two LSPs for control plane)

On the question of implementation VS standardization, please allow us to clarify our point.  The capability of inducing an H-LSP is not mandatory nor is there a defined method to advertise that you have the capability.  You therefore cannot assume a node has that capability.
[[ALU]] So we could update standardization if it is the case :-)
 However, _if_ multi-stage labels are defined as part of eOTN signalling, and a node is advertising a multi-stage hierarchy, it is perfectly reasonable to assume that the node can support multi-stage labels.
[[ALU]] It is also perfectly reasonable to assume that a node supports H-LSP for the same reason, with the difference that one is already a standard.

This point alters what routing calculations you can perform in all networks with multi-stage hierarchies present.
[[ALU]] The most general case is when multi-stage is not symmetric. This requires FAs so, this is the calculation that MUST be supported. Every other
thing is optional.

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Mon, 18 Apr 2011 10:26:38 +0800

Hi Steve,

You wrote:
“
 
i)              Multi-stage labels
ii)             Induced H-LSPs
 
Solution (i) is not complete because there are still cases that will not 
work automatically with multistage labels; plus there are functional 
restrictions that others have pointed out already.  However, they are very 
significantly easier to implement, and if standardized should be supported 
by all devices.
”
 [Xihua] Would you like to clarify why it couldn't work automatically with 
multistage labels?

"
So it seems to us that while multistage labels may have some functional 
restrictions, they have some operational and implementation benefits that 
we should weigh dispassionately.  However, we have seen no input from 
operators (direct or indirect) to say whether they think that the 
configuration of FA-LSPs will actually be a problem for them, or if they 
expect connections to be automatic where possible.  Does anyone reading 
this have any feedback on that point?
"

[Xihua] Would you like to clarify what is the functional restrictions?

Xihua Fu

Steve Balls <[email-masked]> 
发件人:  [email-masked]
2011-04-14 下午 10:18

收件人
'CCAMP' <[email-masked]>
抄送

主题
Re: [CCAMP] R:  R:  Discussion of multi-stage solutions

All
 
We'd like to take a step back from this debate and offer a different 
perspective.
 
The debate about whether a multistage label represents one or multiple 
LSPs is moot, because there is not an authoritative definition of an LSP 
that can resolve it one way or another.  We all understand conceptually 
what a multi-stage label is, and we should focus the debate on its 
advantages and disadvantages on its own merits.  
 
We do not have a preference here, but think there are some further 
discussion points to be made, and it would be beneficial to request 
further viewpoints on the below.
 
We all understand there are several scenarios (see the examples from the 
presentations at Prague) where single stage labels are not enough to set 
up a connection.  We also know that one option to solve this is for 
operators to pre-provision an FA-LSP.  However, it’s not clear to us 
whether this is acceptable to operators – would they in fact want such 
connections to come up automatically?

i)              Multi-stage labels
ii)             Induced H-LSPs
 
Solution (i) is not complete because there are still cases that will not 
work automatically with multistage labels; plus there are functional 
restrictions that others have pointed out already.  However, they are very 
significantly easier to implement, and if standardized should be supported 
by all devices.
 
Solution (ii) will solve most scenarios (given a suitable routing 
calculation) but depends on all devices having the capability to induce an 
H-LSP.  This, as far as we are aware, is not guaranteed and there’s 
currently no standard way to advertise this capability.
 
So it seems to us that while multistage labels may have some functional 
restrictions, they have some operational and implementation benefits that 
we should weigh dispassionately.  However, we have seen no input from 
operators (direct or indirect) to say whether they think that the 
configuration of FA-LSPs will actually be a problem for them, or if they 
expect connections to be automatic where possible.  Does anyone reading 
this have any feedback on that point?
 
Best regards,
 
Steve & Jon

[email-masked]

Hi Sergio 

Ok, understand. 

Best regards 

Fei 

:) 

收件人

Hi Fei, 

  

  
Thanks 
  
Best Regards 
  
authors of [draft-zhang] 

Hi Sergio 

See in line. 

BR 

Fei 

收件人

 

Hi Fei, 
 
see in line 
 
Thanks 
 
BR 
 
authors of [draft-zhang] 

Hi Sergio & Pietro 

[Fei] 

If yeah, why? 

Thanks and best regards 

Fei 

收件人

 

Hi Rajan, Khuzema 

Thanks 

BR 

authors of [draft-zhang] 

Sergio & Pietro, 

Thanks 
Rajan & Khuzema 

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 

Hi Rajan,Khuzema, 

For point 2 
"2. What is an LSP? 

Hope this clarify. 
Thanks 

Sergio and Pietro 

Sergio Belotti 
Portfolio Evolution 

-----Messaggio originale----- 

Thanks 
Rajan & Khuzema 

-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Friday, April 01, 2011 7:19 AM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Rajan, 

Fatai 

Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

Thanks 
Rajan 

-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan, 

Fatai 

Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

Thanks 
Rajan 

-----Original Message----- 
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM 
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan, 

Fatai 

Thanks 

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai, 

Hope this helps. 

Thanks 
Rajan 

-----Original Message----- 

Hi Khuzema, 

Fatai 

Thanks 

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]> 
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi, 

Thanks 
Khuzema 

-----Original Message----- 

Hi Sidd, 

Fatai 

Thanks 

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]> 
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele, 

Thanks, 
Sidd 

-----Original Message----- 

Hi Khuzema, 

My 2c 

BR 
Daniele 

-----Original Message----- 

Hi, 

Best Regards 
Khuzema 

-----Original Message----- 

Hi, 

2. What is an LSP? 

Cheers, 
Adrian

---

From: [email-masked]
Date: Mon, 18 Apr 2011 10:38:37 +0800

Hi Sergio,

You wrote:
"
regarding point 1 from Adrian's mail, we think that Adrian's understanding 
is that multi-stage multiplexing will not be deployed extensively since 
the cost of multi-stage board will be high. This why he talked about 
"specific case ".
"
We heard many operators in ITU-T needs multi-stage to  i) facilitate the 
introduction of new ODU0 and ODUflex signals to an existing network 
without having to upgrade every node in the network  and to ii) support 
the multi-domain OTN applications based on the tunnel design. 
I think you just watch on your equipment. Do you have any evidence where 
the cost of multi-stage will be high? 
You should focus on the level of network, for example, in case of ii) 
there are more less low granularity tunnels which have to managed (e.g., 
OAM, Prorection, Management Plane and Control Plane) in core network. The 
cost of whole network may be  cut.
Your statement may mislead ccamp's experts.

Xihua Fu

2011-04-04 下午 05:03

收件人
Rajan Rao <[email-masked]>, Khuzema Pithewan <[email-masked]>
抄送
'CCAMP' <[email-masked]>, Sidd Aanand <[email-masked]>
主题
[CCAMP] R:  Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi,

Thanks
Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele,

Thanks,
Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----

Hi,

Best Regards
Khuzema

-----Original Message-----

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Mon, 18 Apr 2011 11:14:38 +0200

Hi Xihua,

My sentence was already commented by Adrian, underlining the meaning of “special case” as subset of a more general solution. This does not change anyway the fact multi-stage can not be considered a “normal” case as you correctly depicted listing two specific applications, the first one of which was introduced in ITU-T by ZTE.
Moreover about the second application you named, there is no need of multi-stage to support it as described in G.872 par. 9.13 unless we have different interpretation of multi-domain in OTN network
About the cost , I do not watch my equipment only but just raising a logic point when you compare a board that should support a theoretically infinite possible multiplexing capability or a restricted set of them. On the other hand , leaving aside HW implementation, I would reply asking you if you have evidence that “manage” a network with absolute flexible multiplexing wherever is cheaper than  managing a network base on a restricted set of multiplexing. I do not want to say it is not required or useful to have, I’m just talking about operational cost.

So my sentence I do not think may mislead CCAMP’s experts since the real content of discussion in the context of CCAMP is the added value to use not standard solution as “multi-label” to solve special case as multi-stage is.

BR

SERGIO BELOTTI

ALCATEL-LUCENT
Terrestrial System Architect
Optics Portfolio Evolution

via Trento 30 , Vimercate(MI)  Italy
T: +39 0396863033
[email-masked]

________________________________
Da: [email-masked] [mailto:[email-masked]]
Inviato: lunedì 18 aprile 2011 4.39
A: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]; Khuzema Pithewan; Rajan Rao; Sidd Aanand
Oggetto: Re: [CCAMP] R: Discussion of multi-stage solutions

Hi Sergio,

You wrote:
"
regarding point 1 from Adrian's mail, we think that Adrian's understanding is that multi-stage multiplexing will not be deployed extensively since the cost of multi-stage board will be high. This why he talked about "specific case ".
"
We heard many operators in ITU-T needs multi-stage to  i) facilitate the introduction of new ODU0 and ODUflex signals to an existing network without having to upgrade every node in the network  and to ii) support the multi-domain OTN applications based on the tunnel design.
I think you just watch on your equipment. Do you have any evidence where the cost of multi-stage will be high?
You should focus on the level of network, for example, in case of ii) there are more less low granularity tunnels which have to managed (e.g., OAM, Prorection, Management Plane and Control Plane) in core network. The cost of whole network may be  cut.
Your statement may mislead ccamp's experts.

Xihua Fu

2011-04-04 下午 05:03

收件人

抄送

主题

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Steve Balls <[email-masked]>
Date: Mon, 18 Apr 2011 14:22:12 +0100

Hi All,

I’d like to pull out and clarify the side point relating to H-LSP support.  Our understanding is that RFC 6107 specifies the protocol extensions required to “automatically coordinate …[the] use and advertisement” of an H-LSP (see section 1.2 of the RFC).  It does not specify in any way that support for this RFC means that H-LSPs can be _automatically induced_ as a result of a connection request.  Such a feature is not protocol function and is an implementation decision.

I therefore agree that for a complete solution, a new draft is required that defines advertisement of whether a node supports H-LSPs, and more importantly whether it has the capability to automatically induce such LSPs.  This critically affects what paths can be calculated.  It is not reasonable to assume such behaviour simply because RFC 6107 exists.

Thanks,

Steve

From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO) [mailto:[email-masked]]
Sent: 15 April 2011 16:03
To: Steve Balls; Fatai Zhang; 'CCAMP'
Cc: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO)
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Tue, 19 Apr 2011 23:17:06 +0800

Hi Sergio,

For the second application, we may have different interpretation of 
multi-domain in OTN network. 
I quote some example from ITU-T. If there are a large number of circuits 
that share the same endpoints (or even part of an overall path), it may be 
convenient from a management perspective to first multiplex those ODU0, 
ODU1 and ODUflex into ODU2 or ODU3 to minimize the number of connections 
that need to be made in intermediate nodes. 

Multi-Stage is really used in the special place of the network. But it 
doesn't mean it is a special case in the level of control plane. If the 
multi-stage has been deployed in the network, the Control Plane has to 
face it within its whole lifetime. I also quote another example.

You may use other method to elude the usage of multi-stage, but it should 
depend on operator. That means if operator want it, you have to support it 
by you equipment and your control plane product has to face it. When you 
decide to support multi-stage in your control plane, I think you want a 
generic solution to cover the "special" and "normal case" what you have 
said.

I have no any evidence about that “manage” a network with absolute 
flexible multiplexing. So I couldn't give any statement in the SDO. But I 
just suggest that we should not easily state the cost of multi-stage.

Xihua Fu

2011-04-18 下午 05:14

收件人
"[email-masked]" <[email-masked]>
抄送
"'CCAMP'" <[email-masked]>, "[email-masked]" 
<[email-masked]>, Khuzema Pithewan <[email-masked]>, Rajan 
Rao <[email-masked]>, Sidd Aanand <[email-masked]>
主题
R: [CCAMP] R:  Discussion of multi-stage solutions

Hi Xihua,
 
My sentence was already commented by Adrian, underlining the meaning of “
special case” as subset of a more general solution. This does not change 
anyway the fact multi-stage can not be considered a “normal” case as you 
correctly depicted listing two specific applications, the first one of 
which was introduced in ITU-T by ZTE.
Moreover about the second application you named, there is no need of 
multi-stage to support it as described in G.872 par. 9.13 unless we have 
different interpretation of multi-domain in OTN network 
About the cost , I do not watch my equipment only but just raising a logic 
point when you compare a board that should support a theoretically 
infinite possible multiplexing capability or a restricted set of them. On 
the other hand , leaving aside HW implementation, I would reply asking you 
if you have evidence that “manage” a network with absolute flexible 
multiplexing wherever is cheaper than  managing a network base on a 
restricted set of multiplexing. I do not want to say it is not required or 
useful to have, I’m just talking about operational cost.
 
So my sentence I do not think may mislead CCAMP’s experts since the real 
content of discussion in the context of CCAMP is the added value to use 
not standard solution as “multi-label” to solve special case as 
multi-stage is.
 
BR
 
SERGIO BELOTTI 
ALCATEL-LUCENT 

Cc: 'CCAMP'; [email-masked]; Khuzema Pithewan; Rajan Rao; Sidd 
Aanand

Hi Sergio, 

You wrote: 
" 

Xihua Fu 

收件人

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi,

Thanks
Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele,

Thanks,
Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----

Hi,

Best Regards
Khuzema

-----Original Message-----

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Benoit C Tremblay <[email-masked]>
Date: Tue, 19 Apr 2011 13:44:54 -0400

Hello,

I think your example here illustrates perfectly the advantage of using H-LSP instead of using multi-stage labels.
The ODU3 connection from gateway 5 to gateway 7 fits perfectly the H-LSP applicability. An ODU3 LSP can automatically be triggered when the first ODU0 LSP is established.  Once it has been created, the H-LSP can be advertised and reused in the path computation of other LSPs that will pass through gateway 5 and 7.

Moreover, using H-LSP, nodes in the network 6 do not have to be aware of the finer-grain connections (ODU0 and ODUflex) as they are encapsulated in the ODU3 connections.  Using multi-stage labels forces the nodes in network 6 to be aware of all LSPs that will be tunneled in the ODU3 connection.  So instead of managing a single ODU3 LSP, nodes 17,19 and 20 will have to get involved in both the GigE and the ODUflex (and any other LSPs) that are multiplexed in this ODU3 connection.

regards,
Benoit

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: April-19-11 11:17

Hi Sergio,

For the second application, we may have different interpretation of multi-domain in OTN network.
I quote some example from ITU-T. If there are a large number of circuits that share the same endpoints (or even part of an overall path), it may be convenient from a management perspective to first multiplex those ODU0, ODU1 and ODUflex into ODU2 or ODU3 to minimize the number of connections that need to be made in intermediate nodes.
Multi-Stage is really used in the special place of the network. But it doesn't mean it is a special case in the level of control plane. If the multi-stage has been deployed in the network, the Control Plane has to face it within its whole lifetime. I also quote another example.

You may use other method to elude the usage of multi-stage, but it should depend on operator. That means if operator want it, you have to support it by you equipment and your control plane product has to face it. When you decide to support multi-stage in your control plane, I think you want a generic solution to cover the "special" and "normal case" what you have said.

I have no any evidence about that “manage” a network with absolute flexible multiplexing. So I couldn't give any statement in the SDO. But I just suggest that we should not easily state the cost of multi-stage.

Xihua Fu

2011-04-18 下午 05:14

收件人
"[email-masked]" <[email-masked]>
抄送
"'CCAMP'" <[email-masked]>, "[email-masked]" <[email-masked]>, Khuzema Pithewan <[email-masked]>, Rajan Rao <[email-masked]>, Sidd Aanand <[email-masked]>
主题
R: [CCAMP] R:  Discussion of multi-stage solutions

Hi Xihua,

BR

SERGIO BELOTTI

ALCATEL-LUCENT

Hi Sergio,

You wrote:
"

Xihua Fu

2011-04-04 下午 05:03

收件人

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: John E Drake <[email-masked]>
Date: Tue, 19 Apr 2011 10:48:46 -0700

Hi,

You’re right, but I think to be fair, Rajan considers multi-stage labels to be applicable only to the single hop case.

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of Benoit C Tremblay
Sent: Tuesday, April 19, 2011 10:45 AM
To: [email-masked]; BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

Hello,

regards,
Benoit

Hi Sergio,

Xihua Fu

2011-04-18 下午 05:14

收件人

抄送

主题

Hi Xihua,

BR

SERGIO BELOTTI

ALCATEL-LUCENT

Hi Sergio,

You wrote:
"

Xihua Fu

2011-04-04 下午 05:03

收件人

抄送

主题

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Rajan Rao <[email-masked]>
Date: Tue, 19 Apr 2011 11:17:44 -0700

Benoit,

You need to look at all network scenarios.  Here is the scenario breakup and where multi-stage label makes sense:

1)      Nodes 17-20 in Network-6  are not ODU0 switching capable (as shown)

a.       Here you have no choice but to go for ODU3-H-LSP between the gateways.

2)      Nodes 17-20 in Network-6 are ODU0 switching capable

a.       ODU3-H-LSP  perfectly makes sense if all your ODU0s are tunneled across net-6

b.      Take a scenario where you want full ODU0 grooming within net-6.  What would you do here?

If you choose the option of H-LSP, you have to go for  ODU3-H-LSP on every hop as follows to extract ODU0s:

1)      Gateway-5 to Node-17

2)      Node-17 to node-19

3)      Node-19 to Node-20

4)      Node-20 to Gateway-7

The alternative to the above is multi-stage label.  It allows nodes at the end of each Te-Link to decide what layers to use for ODU0 service.  This means, we eliminated the need for 4xODU3-H-LSPs.

Hope this helps
Thanks
Rajan

From: [email-masked] [mailto:[email-masked]] On Behalf Of John E Drake
Sent: Tuesday, April 19, 2011 10:49 AM
To: Benoit C Tremblay; [email-masked]; BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

Hi,

Thanks,

John

Sent from my iPhone

Hello,

regards,
Benoit

Hi Sergio,

Xihua Fu

2011-04-18 下午 05:14

收件人

抄送

主题

Hi Xihua,

BR

SERGIO BELOTTI

ALCATEL-LUCENT

Hi Sergio,

You wrote:
"

Xihua Fu

2011-04-04 下午 05:03

收件人

抄送

主题

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Wed, 20 Apr 2011 09:45:42 +0800

Hi Benoit,

In this case where you create a ODU3 tunnel to carry ODU0/ODUflex, there 
is no necessary to use multi-stage label. I just want to clarify the 
requirement/scenarios of multi-stage.

Xihua Fu

Benoit C Tremblay <[email-masked]> 
2011-04-20 上午 01:44

收件人
"[email-masked]" <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" 
<[email-masked]>
抄送
"'CCAMP'" <[email-masked]>
主题
RE: [CCAMP] R:  R:  Discussion of multi-stage solutions

Hello,
 
I think your example here illustrates perfectly the advantage of using 
H-LSP instead of using multi-stage labels.
The ODU3 connection from gateway 5 to gateway 7 fits perfectly the H-LSP 
applicability. An ODU3 LSP can automatically be triggered when the first 
ODU0 LSP is established.  Once it has been created, the H-LSP can be 
advertised and reused in the path computation of other LSPs that will pass 
through gateway 5 and 7.
 
Moreover, using H-LSP, nodes in the network 6 do not have to be aware of 
the finer-grain connections (ODU0 and ODUflex) as they are encapsulated in 
the ODU3 connections.  Using multi-stage labels forces the nodes in 
network 6 to be aware of all LSPs that will be tunneled in the ODU3 
connection.  So instead of managing a single ODU3 LSP, nodes 17,19 and 20 
will have to get involved in both the GigE and the ODUflex (and any other 
LSPs) that are multiplexed in this ODU3 connection.
 
regards,
Benoit 

[email-masked]

Hi Sergio,

Xihua Fu 

收件人

Hi Xihua, 

  
BR 
  
SERGIO BELOTTI 
ALCATEL-LUCENT 

Hi Sergio, 

You wrote: 
" 

Xihua Fu 

收件人

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi,

Thanks
Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele,

Thanks,
Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----

Hi,

Best Regards
Khuzema

-----Original Message-----

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Wed, 20 Apr 2011 10:39:19 +0800

Hi Rajan,

You wrote:
"
2)      Nodes 17-20 in Network-6 are ODU0 switching capable
a.       ODU3-H-LSP  perfectly makes sense if all your ODU0s are tunneled 
across net-6
b.      Take a scenario where you want full ODU0 grooming within net-6. 
What would you do here?

"

In this case, Gateway-5 and Gateway-7 don't need to support multi-stage 
because the 40G network support ODU0/ODUflex switching capability. Within 
Gateway-5 and Gateway-7 could map ODU0/ODUflex into ODU4 directly.

Xihua Fu

Rajan Rao <[email-masked]> 
2011-04-20 上午 02:17

收件人
John E Drake <[email-masked]>, Benoit C Tremblay 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, "BELOTTI, SERGIO (SERGIO)" 
<[email-masked]>
抄送
'CCAMP' <[email-masked]>
主题
RE: [CCAMP] R:  R:  Discussion of multi-stage solutions

Benoit,
 
You need to look at all network scenarios.  Here is the scenario breakup 
and where multi-stage label makes sense:
 
1)      Nodes 17-20 in Network-6  are not ODU0 switching capable (as 
shown)
a.       Here you have no choice but to go for ODU3-H-LSP between the 
gateways.
 
2)      Nodes 17-20 in Network-6 are ODU0 switching capable
a.       ODU3-H-LSP  perfectly makes sense if all your ODU0s are tunneled 
across net-6
b.      Take a scenario where you want full ODU0 grooming within net-6. 
What would you do here?
 
If you choose the option of H-LSP, you have to go for  ODU3-H-LSP on every 
hop as follows to extract ODU0s:
1)      Gateway-5 to Node-17
2)      Node-17 to node-19
3)      Node-19 to Node-20
4)      Node-20 to Gateway-7
 
The alternative to the above is multi-stage label.  It allows nodes at the 
end of each Te-Link to decide what layers to use for ODU0 service.  This 
means, we eliminated the need for 4xODU3-H-LSPs. 
 
Hope this helps
Thanks
Rajan

John E Drake
 
Hi,
 
You’re right, but I think to be fair, Rajan considers multi-stage labels 
to be applicable only to the single hop case.
 
Thanks,
 
John
 
Sent from my iPhone
 
Benoit C Tremblay
 
Hello,

 
regards,
Benoit 

Hi Sergio,

Xihua Fu 

收件人

Hi Xihua, 

  
BR 
  
SERGIO BELOTTI 
ALCATEL-LUCENT 

Hi Sergio, 

You wrote: 
" 

Xihua Fu 

收件人

  

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; 

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" 

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" 

Hi,

Thanks
Khuzema

-----Original Message-----

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 

Daniele,

Thanks,
Sidd

-----Original Message-----

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----

Hi,

Best Regards
Khuzema

-----Original Message-----

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 20 Apr 2011 09:40:49 +0200

Hi Steve,

i partially agree with you, let me explain why.

The IMCD advertising e.g. ODU3->ODU2->ODU1 capability, implicitly advertises the capability of an interface of supporting an H-LSP with ODU1 over ODU2 over ODU3.
This is a data plane capability, not a control plane capability. In other words the IMCD does not tell whether the H-LSP can be dynamically set up or the manual setup of the H-LSP is required. This would lead me to agree with you on the fact that there is the need to specify if an H-LSP on such interface can be "automatically induced" or needs to be preconfigured.

However, i believe that the presence of such capability in the advertisement is useless if there is no way to dinamically set up an H-LSP, so it could be possible to "deduce" that the presence of an IMCD indicating ODU3->ODU2->ODU1 capability means that an H-LSP can be created and the absence of the IMCD means that such H-LSP either cannot be created or can only manually created.

Nevertheless, in case the distinction between the latter 2 cases is needed, i tend to say that is better "wasting" a bit for the explicit advertisement rather than losing information.

Cheers,
Daniele

________________________________
From: Steve Balls [mailto:[email-masked]]
Sent: lunedì 18 aprile 2011 15.22
To: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Cc: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO)
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hi All,

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 20 Apr 2011 12:33:03 +0200

Hi Xihua,

You mentionbed examples coming from specific company contribution, I  quoted what an ITU-T Rec (g.872) says.
Anyway I have no problem with your examples . These are cases that in principle can exists and we have to address “general” control plane solution to cope also with the scenario, possible using as much as possible
standard IETF GMPLS mechanisms already existing.

BR

sergio

SERGIO BELOTTI

ALCATEL-LUCENT

________________________________
Da: [email-masked] [mailto:[email-masked]]
Inviato: martedì 19 aprile 2011 17.17
A: BELOTTI, SERGIO (SERGIO)
Cc: 'CCAMP'; [email-masked]; Khuzema Pithewan; Rajan Rao; Sidd Aanand
Oggetto: Re: R: [CCAMP] R: Discussion of multi-stage solutions

Hi Sergio,

Xihua Fu

2011-04-18 下午 05:14

收件人

抄送

主题

Hi Xihua,

BR

SERGIO BELOTTI

ALCATEL-LUCENT

Hi Sergio,

You wrote:
"

Xihua Fu

2011-04-04 下午 05:03

收件人

抄送

主题

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: John E Drake <[email-masked]>
Date: Wed, 20 Apr 2011 04:39:11 -0700

Daniele,

Perhaps we should explicitly state that the advertisement of an IMCD means the advertiser supports induced hierarchical LSPS?

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Wednesday, April 20, 2011 12:41 AM
To: Steve Balls; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 20 Apr 2011 14:08:11 +0200

Hi John,

that's option A.
Option B on the other side foresees advertising the IMCD both in case of supported induced H-LSPs and in case of only manually configured H-LSP with the addition of one bit in the OSPF-TE Node Cabability Descriptor TLV to indicate wheter the advertised capability can be dinamically induced or not.

Given that a single bit can avoid loosing information, i'd preferer Option B.

Thanks,
Daniele

________________________________
From: John E Drake [mailto:[email-masked]]
Sent: mercoledì 20 aprile 2011 13.39
To: Daniele Ceccarelli; Steve Balls; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Daniele,

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: John E Drake <[email-masked]>
Date: Wed, 20 Apr 2011 05:14:15 -0700

Daniele,

Option C would be a bit in the IMCD itself.

Thanks,

John

Sent from my iPhone

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, April 20, 2011 5:08 AM
To: John E Drake; Steve Balls; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 20 Apr 2011 14:19:24 +0200

That's true  :-)

Daniele

Sent: mercoledì 20 aprile 2011 14.14

Daniele,

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Benoit C Tremblay <[email-masked]>
Date: Wed, 20 Apr 2011 09:13:59 -0400

Hi John,

The advantage of putting the bit in the node capability is that it can also be used in all switching types supported by GMPLS, not only in OTN.

Regards,
Benoit

Sent: April-20-11 8:14

Daniele,

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: John E Drake <[email-masked]>
Date: Wed, 20 Apr 2011 06:17:40 -0700

Benoit,

I don’t really care.  The only question is whether a node level capability provides sufficient granularity.

Thanks,

John

Sent from my iPhone

From: Benoit C Tremblay [mailto:[email-masked]]
Sent: Wednesday, April 20, 2011 6:14 AM
To: John E Drake; Daniele Ceccarelli; Steve Balls; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hi John,

Regards,
Benoit

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Steve Balls <[email-masked]>
Date: Wed, 20 Apr 2011 15:21:38 +0100

Hi Daniele, John

I prefer something like option B - I think it is more architectural to keep the properties independent.

That is, the IMCD specifies the Interface Multiplexing Capabilities – it does not specify router capability.  The ability to automatically induce an H-LSP is a router capability which needs to be advertised independently.  Further one could envisage a common control plane where H-LSPs can be automatically induced for some switching types (such as ODU) but not for others (such as OCh), so I think this is a little more complex than a single bit and may merit its own TLV.

Thanks,

Steve
From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: 20 April 2011 13:19
To: John E Drake; Steve Balls; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

That's true  :-)

Daniele

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: John E Drake <[email-masked]>
Date: Wed, 20 Apr 2011 07:48:53 -0700

Steve,

I don’t really care, but options A & C allow per interface granularity which is more in line with what you describe in your last sentence.

Also, the advertisement of an IMCD indicates that the advertising node has the ability to terminate a hierarchical LSP on the advertised interface.  To me,  the ability to dynamically instantiate a hierarchical LSP on this interface is tightly coupled to the advertisement.

But again, I don’t really care.

Thanks,

John

Sent from my iPhone

From: Steve Balls [mailto:[email-masked]]
Sent: Wednesday, April 20, 2011 7:22 AM
To: Daniele Ceccarelli; John E Drake; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hi Daniele, John

Thanks,

Steve

That's true  :-)

Daniele

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Benoit C Tremblay <[email-masked]>
Date: Wed, 20 Apr 2011 11:40:01 -0400

Hi John,

I think we need both informations.
The first is to know if the data plane supports the termination of hierarchical LSP  (link information).
The second is if the control plane is able to handle the automatically triggered H-LSP procedure (node information).

If the data plane supports then we can create a H-LSP from that node, otherwise we need to find another path for the LSP.
If the control plane supports it then we can use the automatically triggered H-LSP procedure, otherwisee we need to manually create the H-LSP first and then create the end-to-end LSP.

Regards,
Benoit

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of John E Drake
Sent: April-20-11 10:49
To: Steve Balls; Daniele Ceccarelli; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); Fatai Zhang; 'CCAMP'
Subject: Re: [CCAMP] R: R: Discussion of multi-stage solutions

Steve,

Thanks,

John

Sent from my iPhone

Hi Daniele, John

Thanks,

Steve

That's true  :-)

Daniele

Thanks,

John

Sent from my iPhone

Hi John,

that's option A.

Thanks,
Daniele

Thanks,

John

Sent from my iPhone

Hi Steve,

Cheers,
Daniele

Thanks,

Steve

Please, see in line.

All,

Regards,

Steve & Jon

Hi all,

Thanks

Fatai

----- Original Message -----
From: GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
To: Steve Balls<mailto:[email-masked]> ; 'CCAMP'<mailto:[email-masked]>
Cc: Fatai Zhang<mailto:[email-masked]> ; Daniele Ceccarelli<mailto:[email-masked]> ; Belotti, Sergio<mailto:[email-masked]> ; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO)<mailto:[email-masked]>
Sent: Thursday, April 14, 2011 11:14 PM
Subject: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hello, in line..

Sergio & Pietro

All

i)                     Multi-stage labels

ii)                   Induced H-LSPs

Best regards,

Steve & Jon

Hi Sergio

Ok, understand.

Best regards

Fei

:)

2011-04-13 16:06

收件人

抄送

主题

Hi Fei,

Thanks

Best Regards

authors of [draft-zhang]

Hi Sergio

See in line.

BR

Fei

2011-04-12 19:53

收件人

抄送

主题

Hi Fei,

see in line

Thanks

BR

authors of [draft-zhang]

Hi Sergio & Pietro

[Fei]

If yeah, why?

Thanks and best regards

Fei

2011-04-12 17:17

收件人

抄送

'CCAMP' <[email-masked]>

主题

Hi Rajan, Khuzema

Thanks

BR

authors of [draft-zhang]

Sergio & Pietro,

Thanks
Rajan & Khuzema

-----Original Message-----
From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, April 04, 2011 2:04 AM
To: Rajan Rao; Khuzema Pithewan
Cc: Fatai Zhang; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'; GRANDI, PIETRO VITTORIO (PIETRO VITTORIO); BELOTTI, SERGIO (SERGIO)
Subject: R: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Rajan Rao <[email-masked]>
Date: Wed, 20 Apr 2011 14:44:40 -0700

Xihua,

If nodes in network-6 force you to use ODU3 intermediate layer (ODU4-ODU3-ODU0) then you have no choice but to start your ODU0-LSPs over ODU3 layer on the gateways at two end.

Thanks
Rajan

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 19, 2011 7:39 PM
To: Rajan Rao
Cc: Benoit C Tremblay; 'CCAMP'; John E Drake; BELOTTI, SERGIO (SERGIO)
Subject: RE: RE: [CCAMP] R: R: Discussion of multi-stage solutions

Hi Rajan,

You wrote:
"

"

In this case, Gateway-5 and Gateway-7 don't need to support multi-stage because the 40G network support ODU0/ODUflex switching capability. Within Gateway-5 and Gateway-7 could map ODU0/ODUflex into ODU4 directly.

Xihua Fu

2011-04-20 上午 02:17

收件人

John E Drake <[email-masked]>, Benoit C Tremblay <[email-masked]>, "[email-masked]" <[email-masked]>, "BELOTTI, SERGIO (SERGIO)" <[email-masked]>

抄送

'CCAMP' <[email-masked]>

主题

Benoit,

Hope this helps
Thanks
Rajan

Hi,

Thanks,

John

Sent from my iPhone

Hello,

regards,
Benoit

Hi Sergio,

Xihua Fu

2011-04-18 下午 05:14

收件人

抄送

主题

Hi Xihua,

BR

SERGIO BELOTTI

ALCATEL-LUCENT

Hi Sergio,

You wrote:
"

Xihua Fu

2011-04-04 下午 05:03

收件人

抄送

主题

Hi Rajan,Khuzema,

For point 2
"2. What is an LSP?

Hope this clarify.
Thanks

Sergio and Pietro

Sergio Belotti
Portfolio Evolution

-----Messaggio originale-----
Da: [email-masked] [mailto:[email-masked]] Per conto di Rajan Rao
Inviato: venerdì 1 aprile 2011 12.56
A: Fatai Zhang; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Oggetto: Re: [CCAMP] Discussion of multi-stage solutions

Thanks
Rajan & Khuzema

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Friday, April 01, 2011 7:19 AM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message -----
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai

Thanks

----- Original Message -----
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian