Subject: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

From: [email-masked]
Date: Mon, 06 Jun 2011 20:42:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Common Control and Measurement Plane Working Group of the IETF.

	Title           : Link Management Protocol Behavior Negotiation and Configuration Modifications
	Author(s)       : Dan Li
                          Daniele Ceccarelli
                          Lou Berger
	Filename        : draft-ietf-ccamp-lmp-behavior-negotiation-04.txt
	Pages           : 11
	Date            : 2011-06-06

   The Link Management Protocol (LMP) is used to coordinate the
   properties, use, and faults of data links in Generalized
   Multiprotocol Label Switching (GMPLS) networks. This document
   defines an extension to LMP to negotiate capabilities and indicate
   support for LMP extensions. The defined extension is compatible
   with non-supporting implementations.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

---

From: Dan Li <[email-masked]>
Date: Tue, 07 Jun 2011 15:05:56 +0800

Hi all,

We have updated this draft according to the comments we have received during last Prague meeting and the follow up discussions in the mailing list.
1) Added a new section (section 2--LMP Message Modifications) to address the multiple config object issue. And introduced the config object to ConfigAck and ConfigNack to allow explicit identification of non-supporting nodes;
2) Renamed BEHAVIOR_CONFIG to BehaviorConfig to be consistent with 4240 naming style;
3) Introduced separate format and procedures sub-sections in section 2 and 3;
4) Slightly changed the format of BehaviorConfig, "B" bit was dropped;
5) Revised backward compatibility section based on above changes;
6) Added Lou as a co-author.

We believe the draft (04 version) is in a good shape, all the comments have been addressed, and it's ready for WG LC.

Thanks,

Authors of lmp-behavior-negotiation draft

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 07, 2011 11:42 AM
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Dan Li <[email-masked]>
Date: Wed, 08 Jun 2011 08:11:27 +0800

Hello,

To clarify my previous mail: The authors believe that the document is ready for additional review from the WG in preparation for WG LC. Please review and comment.

Thanks,

Dan

---

From: Sirish Vadloori <[email-masked]>
Date: Thu, 9 Jun 2011 07:00:37 +0300

Hello,

I have read the draft. I have a suggestion, please let me know if that makes sense here.

There are 3 bits here which have got a significance.

0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |S|D|C|                   Must Be Zero (MBZ)                    |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Could we dedicate a bit to specify the support of OTN specific ports (OTUk/ ODUk).
We are working on a product which is OTN based and we are on the high tide in implementing LMP for OTN.

Best Regards,
-Sirish

-----Original Message-----
From: Dan Li [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2011 5:41 AM
To: [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hello,

Thanks,

Dan

----- Original Message ----- 
From: "Dan Li" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 07, 2011 3:05 PM
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Dan Li <[email-masked]>
Date: Thu, 09 Jun 2011 13:59:09 +0800

Hi Sirish,

Thanks for the comment. 

The negotiaed behaviors (such as S, D and C bits) defined in this draft only reflect the behaviors already defined in the published RFCs. For the future extensions to LMP for other functions or technologies will require the definition of further LMP messages.

You may also noticed that one of the references in this draft:
[LMP TEST] D. Ceccarelli, Ed., "Link Management Protocol (LMP) Test Messages Extensions for Evolutive Optical Transport Networks (OTN)" draft-ceccarelli-ccamp-gmpls-g709-lmp-test-02.txt, May, 2010.

With respect to OTN case, the negotiated behavior can be defined in [LMP TEST] draft.

Thanks,

Dan
 
----- Original Message ----- 
From: "Sirish Vadloori" <[email-masked]>
To: "Dan Li" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 09, 2011 12:00 PM
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hello,

0                   1                   2                   3

Best Regards,
-Sirish

-----Original Message-----
From: Dan Li [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2011 5:41 AM
To: [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hello,

Thanks,

Dan

---

From: Sirish Vadloori <[email-masked]>
Date: Thu, 9 Jun 2011 10:53:32 +0300

Hello Dan,

Thank you for the clarification.
As you said - Yes - With respect to OTN case the negotiated behavior can be a part of [LMP TEST] draft.

Best Regards,
-Sirish

-----Original Message-----
From: Dan Li [mailto:[email-masked]] 
Sent: Thursday, June 09, 2011 11:29 AM
To: Sirish Vadloori; [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hi Sirish,

Thanks for the comment. 

Thanks,

Dan
 
----- Original Message ----- 
From: "Sirish Vadloori" <[email-masked]>
To: "Dan Li" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 09, 2011 12:00 PM
Subject: RE: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hello,

0                   1                   2                   3

Best Regards,
-Sirish

-----Original Message-----
From: Dan Li [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2011 5:41 AM
To: [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-lmp-behavior-negotiation-04.txt

Hello,

Thanks,

Dan