Subject: [CCAMP] Transcoding factor in OTN signaling in draft-zhang-ccamp-gmpls-evolving-g709

From: "Gruman, Fred" <[email-masked]>
Date: Fri, 7 Oct 2011 14:07:17 -0500

Hello,

G.709 ODUflex(CBR) has transcoding factor T in the calculation of the
number of TS. Does the transcoding factor need to be explicitly signaled
as part of the OTN traffic parameters for ODUflex(CBR)?

I don't know if there are any currently defined ODUflex(CBR) clients
that would use a transcoding factor other than 1, but if this exists now
or in the future, the intermediate nodes would need to know the
transcoding factor in order to calculate the correct number of TS.
Perhaps this could be inferred based on GPID but then intermediate nodes
would need to interpret GPID (I seem to recall another thread that GPID
should be used at end nodes plus maybe penultimate hop).

Best Regards,

Fred

---

From: Zhangfatai <[email-masked]>
Date: Sun, 09 Oct 2011 09:09:29 +0000

Hi Fred,

We are planning to refine some description about the formula, which will take into account transcoding factor.

=======================================================================================================
-The Bit_Rate field indicates the nominal bit rate of ODUflex(CBR) expressed in bytes per second, encoded as a 32-bit IEEE single-precision floating-point number (referring to [RFC4506] and [IEEE]).The value contained in the Bit Rate field has to take into account both 239/238 factor and the Transcoding factor.

ODUflex(CBR) nominal bit rate = CBR client bit rate * (239/238) / T
===========================================================================================================

So, the head node will put the caculated value (ODUflex(CBR) nominal bit rate) into the Bit_Rate filed, and then the intermediated nodes do not need to care about Transcoding factor.

Thanks

Fatai

From: Gruman, Fred [mailto:[email-masked]]
Sent: 2011年10月8日 3:07
To: [email-masked]
Cc: Zhangfatai
Subject: Transcoding factor in OTN signaling in draft-zhang-ccamp-gmpls-evolving-g709

Hello,

G.709 ODUflex(CBR) has transcoding factor T in the calculation of the number of TS. Does the transcoding factor need to be explicitly signaled as part of the OTN traffic parameters for ODUflex(CBR)?

I don’t know if there are any currently defined ODUflex(CBR) clients that would use a transcoding factor other than 1, but if this exists now or in the future, the intermediate nodes would need to know the transcoding factor in order to calculate the correct number of TS. Perhaps this could be inferred based on GPID but then intermediate nodes would need to interpret GPID (I seem to recall another thread that GPID should be used at end nodes plus maybe penultimate hop).

Best Regards,
Fred

---

From: Lou Berger <[email-masked]>
Date: Mon, 10 Oct 2011 06:31:05 -0400

Fred,
	Thank you for the additional information.  G-PID usage is still being
discussed.  In general, factors that impact resource/label allocation
are reflected in traffic parameters.

Lou

On 10/7/2011 3:07 PM, Gruman, Fred wrote:
> I don’t know if there are any currently defined ODUflex(CBR) clients
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp