Subject: [CCAMP] Question on RFC6107, Procedures for Dynamically Signaled Hierarchical Label Switched Paths

From: Alan Davey <[email-masked]>
Date: Wed, 19 Oct 2011 12:47:29 +0000

Folks

I have a question on RFC6107; is it permitted to have more than one Target IGP Identification TLV in a single LSP_TUNNEL_INTERFACE_ID object?

I cannot find a definitive statement in the RFC as to whether or not multiple Target IGP Identification TLVs are permitted in a single object.  However, I think that this should NOT be permitted.

My thinking is as follows.

-          Section 3.4 states that "It is possible that an LSP will be used to offer capacity and connectivity to multiple other networks.  In this case, multiple instances of the LSP_TUNNEL_INTERFACE_ID object are permitted in the same Path and Resv messages."

-          My reading of this is that if multiple Target IGP Identification TLVs are required then they should each appear in a separate LSP_TUNNEL_INTERFACE_ID object.

-          However, if multiple Target IGP Identification TLVs are permitted in a single LSP_TUNNEL_INTERFACE_ID object then there are two protocol constructs with the same meaning, which could lead to interoperability problems.

-          Therefore RFC6107 should state that at most one Target IGP Identification TLV may appear in a single LSP_TUNNEL_INTERFACE_ID object, but I cannot find any such statement.

Please let me know what you think.

Thanks
Alan Davey

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 28 Oct 2011 18:23:51 +0100

Hi Alan,

Nice to be made to read stuff because you come across typos. I think that
Section 3.2

   If the P-flag in the Actions field in the LSP_TUNNEL_INTERFACE_ID
   object in a Resv message is set (i.e., one) indicating that the LSP
   is not to be advertised as a link, this TLV SHOULD NOT be present and
   MUST be ignored if encountered.

s/Resv/Path/   !

That merits an erratum if anyone can be bothered.

> I have a question on RFC6107; is it permitted to have more than one
> Target IGP Identification TLV in a single LSP_TUNNEL_INTERFACE_ID object?
>
> I cannot find a definitive statement in the RFC as to whether or not multiple 
> Target IGP Identification TLVs are permitted in a single object. 

Agreed. No such statement found.

> However, I think that this should NOT be permitted.
>
> - Section 3.4 states that “It is possible that an LSP will be used to offer
>   capacity and connectivity to multiple other networks.  In this case,
>   multiple instances of the LSP_TUNNEL_INTERFACE_ID object are
>   permitted in the same Path and Resv messages.”
>- My reading of this is that if multiple Target IGP Identification TLVs
>   are required then they should each appear in a separate 
>   LSP_TUNNEL_INTERFACE_ID object.
>- However, if multiple Target IGP Identification TLVs are permitted
>   in a single LSP_TUNNEL_INTERFACE_ID object then there are two
>   protocol constructs with the same meaning, which could lead to
>   interoperability problems.
>- Therefore RFC6107 should state that at most one Target IGP 
>   Identification TLV may appear in a single LSP_TUNNEL_INTERFACE_ID
>   object, but I cannot find any such statement.

i wouldn't object to imposing this limitation, but I don't see it as
particularly necessary: why would there be interop problems if both multiple
TLVs and multiple objects are allowed? Conservative on what you send, liberal on
what you receive. Since the RFC does not (currently) prohibit either option,
there would be no reason for an implementation to not be able to receive either.

I don't read "are permitted" to mean "required"

There would seem to be a (minor) saving of bits on the wire in the case that
multiple uses share the settings of the common part of the object. However,
since this is pretty unlikely:
1. The chance of multiple TLVs being present is small
2. The hardship of banning multiple TLVs is small

This could probably (just about) qualify for an erratum. Really it is a
technical change, not a typographical fix, but we might squeeze it in as a one
line change.

Cheers,
Adrian

---

From: Alan Davey <[email-masked]>
Date: Mon, 31 Oct 2011 11:41:21 +0000

Hi Adrian

Thank you for your response, and for spotting another erratum in RFC6107.  I propose raising the following technical errata against the RFC, both in section 3.2.  Please let me know whether or not you agree.

1.  State that at most one Target IGP Identification TLV may appear in a single LSP_TUNNEL_INTERFACE_ID object.

Original text:
   The TLV has meaning only in a Path message.  It SHOULD NOT be
   included in the LSP_TUNNEL_INTERFACE_ID object in a Resv message and
   MUST be ignored if found.

Corrected text:
   The TLV has meaning only in a Path message.  At most one TLV
   MAY appear in a single LSP_TUNNEL_INTERFACE_ID object.

   The TLV SHOULD NOT be included in the LSP_TUNNEL_INTERFACE_ID object 
   in a Resv message and MUST be ignored if found.

2.  Section 3.2, change Resv message to Path message.

Original text:   

Corrected text:
   If the P-flag in the Actions field in the LSP_TUNNEL_INTERFACE_ID
   object in a Path message is set (i.e., one) indicating that the LSP
   is not to be advertised as a link, this TLV SHOULD NOT be present and
   MUST be ignored if encountered.

Regards
Alan Davey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 28 October 2011 18:24
To: Alan Davey; [email-masked]
Subject: Re: [CCAMP] Question on RFC6107, Procedures for Dynamically Signaled Hierarchical Label Switched Paths

Hi Alan,

s/Resv/Path/   !

> - Section 3.4 states that "It is possible that an LSP will be used to offer
>   permitted in the same Path and Resv messages."

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 31 Oct 2011 13:20:02 -0000

Looks fine, but I would like to hear agreement from the WG.

Thanks,
Adrian

> From: Alan Davey [mailto:[email-masked]]
> Sent: 31 October 2011 11:41
> To: Adrian Farrel Personal
> Cc: [email-masked]
> Subject: RE: [CCAMP] Question on RFC6107, Procedures for Dynamically Signaled
> Hierarchical Label Switched Paths
> 
> Hi Adrian
> 
> Thank you for your response, and for spotting another erratum in RFC6107.  I
> propose raising the following technical errata against the RFC, both in
section 3.2.
> Please let me know whether or not you agree.
> 
> 1.  State that at most one Target IGP Identification TLV may appear in a
single

---

From: Ramon Casellas <[email-masked]>
Date: Mon, 31 Oct 2011 14:58:58 +0100

>>     in a Resv message and MUST be ignored if found.
Hi Adrian, Alan, all

I'm a bit confused about this part. If :
- several LSP_TUNNEL_INTERFACE_ID are used in the Path message to 
announce the same link in different instances (say N), and
- a TLV is used in each LSP_TUNNEL_INTERFACE_ID within such Path message 
(with the instance), and
- the TLVs SHOULD be suppressed in Resv,

do we end up with 1 or N identical LSP_TUNNEL_INTERFACE_ID in the Resv 
(assuming no other TLVs)?

It seems that they could be coalesced  into 1, in order not to be in 
contradiction with section 3.4 ("Each instance MUST have a different IGP
    Instance Identifier", which could be understood to preclude 
identical copies. but probably I am missing something)

So either there are N instances with the TLV (which it shouldn't by the 
above text but must according to 3.4) or 1 without TLV?. I would say the 
latter, but I would like your comments

R.

----------------------------------
Section 3.4 quote

    It is possible that an LSP will be used to offer capacity and
    connectivity to multiple other networks.  In this case, multiple
    instances of the LSP_TUNNEL_INTERFACE_ID object are permitted in the
    same Path and Resv messages.  Each instance MUST have a different IGP
    Instance Identifier.