Subject: [CCAMP] The hat trick

From: Igor Bryskin <[email-masked]>
Date: Mon, 28 Jan 2013 16:45:04 +0000

John,

You said:

          I disagree.  Airing dirty laundry in public is too entertaining to stop.

All right then, here is another topic for you. 

You are very respectable IETFer and seem to be here forever (certainly since I can remember myself). I wonder what do you (and other CCAMPers) think about these cute little "My hat on/off" statements? That's  right, the ones that IETF ADs and WG Chairs do with a coquettish smile quite often at IETF meetings and on the mailing lists. The assumption is, of course, that the things must be said by ADs/Chairs and interpreted by the audience differently depending on whether the hat is said to be in "on" or "off" position. This is a quite safe and reasonable assumption, if one designs a signaling protocol for network elements, for which it is possible to set proper filters, program processing rules and maintain a separate independent state for each conversation. However, ADs, Chairs and the audience are humans, i.e. they are not very good at compartmentalizing the information in non-overlapping memory spaces. When I, for one, hear or read an AD's/Chair's statement, the statement always carries the AD/Chair weight. 

Let's take an example. Consider in a middle of a heated technical discussion on a CCAMP WG session,  Adrian comes up to the mike and makes his hat-off comment. What does this exactly mean? Does it mean that Adrian may have a separate hat-on opinion, that is opposite or perpendicular to what he just said? I don't think so. The way I see it, Adrian, being an excellent expert in many areas, has developed an opinion that he genuinely believes may help the discussion.  But, being also very professional, Adrian believes that at this level of discussion (or for whatever other reasons) it is somewhat inappropriate for an AD to influence the discussion. The end result of the statement is as follows. I, Igor Bryskin, am sitting in the audience and just heard a statement that might very well influence the discussion and its outcome. The statement came from Adrian Farrel, who happens to be one of the Routing Area ADs (and I don't forget about this for a second) at the precise moment when according to Adrian himself it is inappropriate for an AD to influence the discussion. I might remember the statement for quite a while, and I may communicate the statement to other some 37 people. What I will immediately forget is what Adrian has said about his hat, and this information will be lost on me and these 37 poor souls. I am sure that the same happens to most (if not all) of the crowd. I have never read, for example,  emails like:

" Dear Adrian (with your AD hat on)! Thank you very much for your thoughtful comments on our draft...." or
"Adrian (with his AD hat off) suggested to use his favorite LSP_ATTRIBUTES object, but I don't hate this idea and since it was suggested with the hat off, I think it is Ok to simply ignore the suggestion".
Nor I remember a conversation like:
"Igor, listen, I am about to make my XYZ draft last call vote. When Lou made this comment on the ASSOCIATION object, could you tell me where his hat was?" "Sorry, John, I have to come back to you with that: I have to go through the meetings minutes as well as through some 1013 emails that Lou has posted on the list since then. I am afraid, you will be late with your vote"

Furthermore, ADs and Chairs do not talk just on the sessions and mailing lists. There are also private emails, telephone calls, face-to-face meetings even bar conversations. Call me a pessimist, but I doubt that in all these circumstances ADs/Chairs do not forget to update their hat status (especially in the bar). So, the point is that the "Hat on/off" thing does not really work as intended, which is not a problem per-se. The problem is that intentionally or unintentionally this opens up ways for quite unfair play.

I don't know what you, John, know about football (soccer), but imagine a match between two teams - one in red, one in white - and there is a guy on the pitch with a hat: when the hat is on, the guy is the umpire of the game, when the hat is off, he is a striker for the reds. You can imagine a lot of funny things happening in such a game. For example, the guy with his umpire hat on can pick up a proper situation and moment, stop the game and grant a penalty against whites. Then, with the hat off, he can take the penalty and score for the reads. And when it looks like the whites are about to score the equalizer, the guy can put his umpire hat back, blow the whistle and say: "Time is up, game is over, reds won". Fortunately such a thing cannot happen in soccer: not only a guy cannot be in the same game an umpire and a player of one of the teams, an umpire cannot be associated in any way with one team more than with the other (an umpire cannot be even from the same city or country as one team but not the other). Why is that? Simple, to ensure fair play, so that a better, more deserving team wins and moves into the next round, while the bad team loses and gets kicked out of the competition. That's what makes soccer such a beautiful game, by far the most popular in the world: simple well thought through rules and fair play".

If you don't like my analogy with soccer, consider a criminal case trial in the court of law, where the judge is saying something like this: " With my judge hat off I have to say that I agree completely with the defense. Also in my previous life I was both defense and district attorney, and my experience of being involved in such or similar cases tells me that in 80% of the cases the defendant ends up verdicted as not guilty. Now, with my judge hat back on, please, proceed ...."

You may disagree with any of these analogies, but I hope you see where I am getting at. With the hat trick It is quite possible to influence the IETF game (which is creating RFCs) with the end result that it is possible for poor architectures and bad solutions to make into useless RFCs, while for good ideas to be killed and forgotten.
Here is a simple question: When a WG Chair systematically pushes one solution while vigorously fights off an alternative one, does it matter whether the Chair is doing this with his hat on or off, considering that at the end of the day the Chair is the only one (along with co-Chairs) who gets to make a call on rough consensus and hence to decide which solution wins?

 I say, no it does not matter, and this is unfair to you, John, because while the Chair can take off his hat at any time, you, as a potential (co-)author of the alternative solution, cannot put the WG Chair hat on and overrule the call on the consensus. I suggest we nail down the hats to AD/Chair heads and outlaw the hat trick to be used as an excuse. In my opinion, WG chair is, figuratively speaking, 75% soccer umpire and 25% soccer coach, but never a soccer player.

Does this make sense? Sorry for the long email.

Cheers,
Igor

---

From: John E Drake <[email-masked]>
Date: Mon, 28 Jan 2013 19:37:09 +0000

Igor,

I don't think Lou or Adrian would approve of my replying to your email.

Seriously, I think they would be the first to tell you that I have a rather jaundiced opinion of anything they say, regardless of what hat they are wearing.  If you remember, I pushed back against both Lou and Julien regarding their desire to have multiple switching type values for the same switching technology and they eventually agreed.

When listening to a WG chair or AD speak, the trick is to imagine them doing so wearing a dunce hat.

Irrespectively Yours,

John

> -----Original Message-----
> From: Igor Bryskin [mailto:[email-masked]]
> Sent: Monday, January 28, 2013 8:45 AM
> To: John E Drake; BRUNGARD, DEBORAH A
> Cc: CCAMP; [email-masked]; Lou Berger ([email-masked])
> Subject: The hat trick
> 
> John,
> 
> You said:
> 
> You are very respectable IETFer and seem to be here forever (certainly
> since I can remember myself). I wonder what do you (and other CCAMPers)
> think about these cute little "My hat on/off" statements? That's
> right, the ones that IETF ADs and WG Chairs do with a coquettish smile
> quite often at IETF meetings and on the mailing lists. The assumption
> is, of course, that the things must be said by ADs/Chairs and
> interpreted by the audience differently depending on whether the hat is
> said to be in "on" or "off" position. This is a quite safe and
> reasonable assumption, if one designs a signaling protocol for network
> elements, for which it is possible to set proper filters, program
> processing rules and maintain a separate independent state for each
> conversation. However, ADs, Chairs and the audience are humans, i.e.
> they are not very good at compartmentalizing the information in non-
> overlapping memory spaces. When I, for one, hear or read an
> AD's/Chair's statement, the statement always carries the AD/Chair
> weight.
> 
> Let's take an example. Consider in a middle of a heated technical
> discussion on a CCAMP WG session,  Adrian comes up to the mike and
> makes his hat-off comment. What does this exactly mean? Does it mean
> that Adrian may have a separate hat-on opinion, that is opposite or
> perpendicular to what he just said? I don't think so. The way I see it,
> Adrian, being an excellent expert in many areas, has developed an
> opinion that he genuinely believes may help the discussion.  But, being
> also very professional, Adrian believes that at this level of
> discussion (or for whatever other reasons) it is somewhat inappropriate
> for an AD to influence the discussion. The end result of the statement
> is as follows. I, Igor Bryskin, am sitting in the audience and just
> heard a statement that might very well influence the discussion and its
> outcome. The statement came from Adrian Farrel, who happens to be one
> of the Routing Area ADs (and I don't forget about this for a second) at
> the precise moment when according to Adrian himself it is inappropriate
> for an AD to influence the discussion. I might remember the statement
> for quite a while, and I may communicate the statement to other some 37
> people. What I will immediately forget is what Adrian has said about
> his hat, and this information will be lost on me and these 37 poor
> souls. I am sure that the same happens to most (if not all) of the
> crowd. I have never read, for example,  emails like:
> 
> " Dear Adrian (with your AD hat on)! Thank you very much for your
> thoughtful comments on our draft...." or "Adrian (with his AD hat off)
> suggested to use his favorite LSP_ATTRIBUTES object, but I don't hate
> this idea and since it was suggested with the hat off, I think it is Ok
> to simply ignore the suggestion".
> "Igor, listen, I am about to make my XYZ draft last call vote. When Lou
> made this comment on the ASSOCIATION object, could you tell me where
> his hat was?" "Sorry, John, I have to come back to you with that: I
> have to go through the meetings minutes as well as through some 1013
> emails that Lou has posted on the list since then. I am afraid, you
> will be late with your vote"
> 
> Furthermore, ADs and Chairs do not talk just on the sessions and
> mailing lists. There are also private emails, telephone calls, face-to-
> face meetings even bar conversations. Call me a pessimist, but I doubt
> that in all these circumstances ADs/Chairs do not forget to update
> their hat status (especially in the bar). So, the point is that the
> "Hat on/off" thing does not really work as intended, which is not a
> problem per-se. The problem is that intentionally or unintentionally
> this opens up ways for quite unfair play.
> 
> I don't know what you, John, know about football (soccer), but imagine
> a match between two teams - one in red, one in white - and there is a
> guy on the pitch with a hat: when the hat is on, the guy is the umpire
> of the game, when the hat is off, he is a striker for the reds. You can
> imagine a lot of funny things happening in such a game. For example,
> the guy with his umpire hat on can pick up a proper situation and
> moment, stop the game and grant a penalty against whites. Then, with
> the hat off, he can take the penalty and score for the reads. And when
> it looks like the whites are about to score the equalizer, the guy can
> put his umpire hat back, blow the whistle and say: "Time is up, game is
> over, reds won". Fortunately such a thing cannot happen in soccer: not
> only a guy cannot be in the same game an umpire and a player of one of
> the teams, an umpire cannot be associated in any way with one team more
> than with the other (an umpire cannot be even from the same city or
> country as one team but not the other). Why is that? Simple, to ensure
> fair play, so that a better, more deserving team wins and moves into
> the next round, while the bad team loses and gets kicked out of the
> competition. That's what makes soccer such a beautiful game, by far the
> most popular in the world: simple well thought through rules and fair
> play".
> 
> If you don't like my analogy with soccer, consider a criminal case
> trial in the court of law, where the judge is saying something like
> this: " With my judge hat off I have to say that I agree completely
> with the defense. Also in my previous life I was both defense and
> district attorney, and my experience of being involved in such or
> similar cases tells me that in 80% of the cases the defendant ends up
> verdicted as not guilty. Now, with my judge hat back on, please,
> proceed ...."
> 
> You may disagree with any of these analogies, but I hope you see where
> I am getting at. With the hat trick It is quite possible to influence
> the IETF game (which is creating RFCs) with the end result that it is
> possible for poor architectures and bad solutions to make into useless
> RFCs, while for good ideas to be killed and forgotten.
> Here is a simple question: When a WG Chair systematically pushes one
> solution while vigorously fights off an alternative one, does it matter
> whether the Chair is doing this with his hat on or off, considering
> that at the end of the day the Chair is the only one (along with co-
> Chairs) who gets to make a call on rough consensus and hence to decide
> which solution wins?
> 
>  I say, no it does not matter, and this is unfair to you, John, because
> while the Chair can take off his hat at any time, you, as a potential
> (co-)author of the alternative solution, cannot put the WG Chair hat on
> and overrule the call on the consensus. I suggest we nail down the hats
> to AD/Chair heads and outlaw the hat trick to be used as an excuse. In
> my opinion, WG chair is, figuratively speaking, 75% soccer umpire and
> 25% soccer coach, but never a soccer player.
>

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Mon, 28 Jan 2013 20:02:51 +0000

In case you missed Adrian's mail, this list is for CCAMP (technical) discussion.
Refer to RFCs: 1855, 2026, 2418, 3184, and 3934.

This thread is closed.

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Monday, January 28, 2013 2:37 PM
To: Igor Bryskin; BRUNGARD, DEBORAH A
Cc: CCAMP; [email-masked]; Lou Berger ([email-masked])
Subject: RE: The hat trick

Igor,

Irrespectively Yours,

John