Subject: [CCAMP] FW: I-D Action: draft-ietf-ccamp-gmpls-ospf-g709v3-06.txt

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 4 Apr 2013 15:46:07 +0000

Dear OTNers,

Info model and OSPF drafts have been updated accordingly to the discussion in Orlando. The OSPF draft also includes some last call comments that had not been addressed in v05 and suggestions received on the list.

On the other side the framework draft doesn't need any change, while the signaling will be updated soon.

BR
Daniele, Sergio, Fatai

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of [email-masked]
>Sent: giovedì 4 aprile 2013 17.40
>To: [email-masked]
>Cc: [email-masked]
>Subject: [CCAMP] I-D Action: draft-ietf-ccamp-gmpls-ospf-g709v3-06.txt
>
>
>A New Internet-Draft is available from the on-line 
>Internet-Drafts directories.
> This draft is a work item of the Common Control and 
>Measurement Plane Working Group of the IETF.
>
>	Title           : Traffic Engineering Extensions to 
>OSPF for Generalized MPLS (GMPLS) Control of Evolving G.709 
>OTN Networks
>	Author(s)       : Daniele Ceccarelli
>                          Diego Caviglia
>                          Fatai Zhang
>                          Dan Li
>                          Sergio Belotti
>                          Pietro Vittorio Grandi
>                          Rajan Rao
>                          Khuzema Pithewan
>                          John E Drake
>	Filename        : draft-ietf-ccamp-gmpls-ospf-g709v3-06.txt
>	Pages           : 35
>	Date            : 2013-04-04
>
>Abstract:
>   ITU-T Recommendation G.709 [G.709-2012] has introduced new fixed and
>   flexible Optical Data Unit (ODU) containers, enabling optimized
>   support for an increasingly abundant service mix.
>
>   This document describes Open Shortest Path First - Traffic
>   Engineering (OSPF-TE) routing protocol extensions to support
>   Generalized MPLS (GMPLS) control of all currently defined ODU
>   containers, in support of both sub-lambda and lambda level routing
>   granularity.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-ccamp-gmpls-ospf-g709v3
>
>There's also a htmlized version available at:
>http://tools.ietf.org/html/draft-ietf-ccamp-gmpls-ospf-g709v3-06
>
>A diff from the previous version is available at:
>http://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-gmpls-ospf-g709v3-06
>
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>CCAMP mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: "Gruman, Fred" <[email-masked]>
Date: Sun, 14 Apr 2013 16:02:46 +0000

Hi Daniele,

Thanks for making the update to the TSG examples in Section 5.2

I have a one additional comments regarding TSG:

1) during an OIF conference call, Stephen Shew indicated that ITU may be considering additional tributary slot granularity in the future (in addition to 1.25 and 2.5G).  There was a concern about handling more complex combinations in the future.  

It was suggested that perhaps instead of enumerating each combination, the TSG be treated as bit flags where the first bit could indicate 1.25G, second bit indicates 2.5G, third bit and beyond (perhaps into the reserve fields in the future) could indicate future TSG rates.  The encoding could then be:
 00 - ignored
 10 - 1.25G only
 01 - 2.5G only
 11 - Both 1.25G and 2.5G supported

This may make it easier to understand the encoding if additional TSGs are added later.

I realize this comment may be coming in late so you might prefer to not make any changes (this is ok with me as the current encodings are technically correct).

Best Regards,
Fred

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, April 04, 2013 10:46 AM
To: [email-masked]
Subject: [CCAMP] FW: I-D Action: draft-ietf-ccamp-gmpls-ospf-g709v3-06.txt

Dear OTNers,

BR
Daniele, Sergio, Fatai