Subject: [CCAMP] Proposed CCAMP Liaison to ITU-T SG15's Q6 on WSON

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 21 Jun 2013 19:11:38 +0000

CCAMP,

One of the items which we identified during our WSON meeting discussion was to ask Q6's input regarding parameters for use to do impairment-aware path computation. Here's a proposal, the parameters listed are from one of the drafts. If any additional suggestions, let us know.

Let us know if any concerns/comments.

Deborah and Lou

----

The CCAMP Working Group of IETF would like to thank the experts of Q.6 that were able to participate in our recent March meeting in Orlando. We believe the discussion was very helpful in progressing our work on WSON (Wavelength Switched Optical Networks) and Flexible Grids.

During the discussion regarding improving the ability to do impairment-aware path computation for path activation, it was noted that ITU-T G.697 defines optical monitoring parameters for performing various activities. While some of the ITU-T G.697 parameters may be useful for path computation, not all parameters may be needed, and other non-G.697 parameters may be useful. We would like to ask for your expert review of a potential list of parameters which may be of use in computation to improve the choice of an optical path to activate when multiple choices are present. We understand this list would not be exhaustive and it would be system dependent. The aim for this work is to provide a basis for defining protocol encoding aspects for the parameters. It is outside of the scope of CCAMP's work to define the computational models used by a system vendor or operator.

Currently, we have noted the following parameters:
*       OSNR
o       Power Input (required by OSNR)
*       Chromatic Dispersion
*       Differential Group Delay

We would appreciate any input which you can provide regarding this list.

We would appreciate if you would keep us informed of your progress on ITU-T G.680 and Flexible Grids.

Best regards,
Lou Berger and Deborah Brungard
IETF CCAMP Working Group Co-Chairs

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Tue, 25 Jun 2013 20:50:24 +0000

Hi Deborah / Lou,

here my comments:

1/ I'm generally ok with the text. As mentioned, not all parameters listed in G.680 reference model are available in G.697 (DGD and PDL are missing), so here below my proposed little change.

old:
"Currently, we have noted the following parameters:

  *   OSNR

  *   Power Input (required by OSNR)

  *   Chromatic Dispersion

"
new:
"Currently, we have noted the following parameters from the G.680 reference models:"

  *   OSNR

  *   Power Input (required by OSNR)

  *   Chromatic Dispersion
  *   PMD
  *   PDL"

2/ I'm wondering if it worth asking about progress on models for new coherent modulation formats since they may change optical network design and hence influence path computation. A minimal proposed text change could be:
old:
"We would appreciate if you would keep us informed of your progress on ITU-T G.680 and Flexible Grids."
new:
"We would appreciate if you would keep us informed of your progress on ITU-T G.680, coherent modulation formats and Flexible Grids."

3/ Application Code vs Optical Interface Classes
This is not for the impairment case but for the wson-rwa case.
We defined the optical interface class as IETF concept that can implement ITU application codes. ITU application code are used as the canonical way to assess the signal compatibility (required by RWA).
As such, within the draft-ietf-ccamp-rwa-wson-encode-20 section 4.2, we provide an encoding for the application codes.  It would worth to ask ITU a double check and/or review of such encoding. Could it be done through this liaison or do we need a specific one?

Cheers
G

On Jun 21, 2013, at 21:11 , "BRUNGARD, DEBORAH A" <[email-masked]<mailto:[email-masked]>> wrote:

CCAMP,

One of the items which we identified during our WSON meeting discussion was to ask Q6’s input regarding parameters for use to do impairment-aware path computation. Here’s a proposal, the parameters listed are from one of the drafts. If any additional suggestions, let us know.

Deborah and Lou

----

During the discussion regarding improving the ability to do impairment-aware path computation for path activation, it was noted that ITU-T G.697 defines optical monitoring parameters for performing various activities. While some of the ITU-T G.697 parameters may be useful for path computation, not all parameters may be needed, and other non-G.697 parameters may be useful. We would like to ask for your expert review of a potential list of parameters which may be of use in computation to improve the choice of an optical path to activate when multiple choices are present. We understand this list would not be exhaustive and it would be system dependent. The aim for this work is to provide a basis for defining protocol encoding aspects for the parameters. It is outside of the scope of CCAMP’s work to define the computational models used by a system vendor or operator.

  *   OSNR

  *   Power Input (required by OSNR)

  *   Chromatic Dispersion

Best regards,

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp