Subject: [CCAMP] The thing I forgot about draft-ali-ccamp-rsvp-te-include-route

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 30 Jul 2013 16:47:31 +0100

Hi,

Sorry about my senility just now.

The point I made was please rename the new ERO subobject to avoid confusion
about using the referenced LSP as a tunnel or a stitching segment.

The point I forgot was to wonder whether there is a category of "best effort"
that follows most of the referenced LSP but not all hops?
Following that, what if there are specific hops in the referenced LSP that MUST
be followed and others that only SHOULD be followed?

Cheers,
Adrian

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 31 Jul 2013 09:53:26 +0000

Hi Adrian- 

Thanks for your feedback. Please see in-line.

Thanks

Regards Š Zafar

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Tuesday, July 30, 2013 11:47 AM
To: "[email-masked]" <[email-masked]>
Subject: [CCAMP] The thing I forgot
about	draft-ali-ccamp-rsvp-te-include-route

>about using the referenced LSP as a tunnel or a stitching segment.

Yes, we can change the name of subobject. I read the minutes and guessed
George assumed an AI on this :)

>that follows most of the referenced LSP but not all hops?

Yes, current definition of inclusion (copying from draft) is:

0x02 = Best-effort inclusion
This flag is used to indicate that the route of the
LSP being signaled SHOULD follow the path
specified by the LSP subobject.

>be followed and others that only SHOULD be followed?

In this case the Ingress can divide the loose hop into two loose hops: one
with "lsp/ inclusion" subobject with mandatory inclusion and another one
with   "lsp/ inclusion" subobject with best-effort inclusion.

>
>Cheers,
>Adrian
>
>_______________________________________________
>CCAMP mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ccamp