Subject: [CCAMP] Fwd: I-D Action: draft-helvoort-ccamp-fs-priority-00.txt

From: Huub van Helvoort <[email-masked]>
Date: Fri, 12 Jul 2013 10:22:06 +0200

Hello CCAMP,

Based on the messages on the MPLS list:
http://www.ietf.org/mail-archive/web/mpls/current/msg09913.html
http://www.ietf.org/mail-archive/web/mpls/current/msg09916.html

I have created and uploaded the draft below.
Comments are appreciated.

Best regards, Huub.

-------- Original Message --------
Subject: I-D Action: draft-helvoort-ccamp-fs-priority-00.txt
Date: Fri, 12 Jul 2013 01:01:39 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title           : Update Forced Switch Priority
	Author(s)       : Huub van Helvoort
	Filename        : draft-helvoort-ccamp-fs-priority-00.txt
	Pages           : 4
	Date            : 2013-07-12

Abstract:
    This document clarifies the definitions related to Manual Switch and
    Forced Switch. This document updates RFC 4427.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-helvoort-ccamp-fs-priority

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-helvoort-ccamp-fs-priority-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Yaacov Weingarten <[email-masked]>
Date: Mon, 29 Jul 2013 13:11:13 +0300

Hi,

While I understand (and to a certain extent support) the purpose of this
document, I am not sure that the note that you are proposing in Section 2
of the document really clarifies the definitions of what are the priorities.

Based on the Rosetta Stone document - a "Communication Channel" is any
logical connection between NEs that may be used for management or control
plane applications. In theory this includes (to my understanding) any use
of the GACH as defined for MPLS-TP (e.g. any OAM functionality).

Your note states: "For 1+1 protection schemes (which do not use a
communication channel)" -

   - what are these? Is there a protection scheme for MPLS-TP that do not
   use a communication channel - for example for CC or CV messages? If you
   meant to say that they are not dependent upon a coordination protocol
   (similar to the statement in the ITU documentation that refers to APS) then
   I suggest that you clearly state this.
   - However, are you adding a blanket statement that 1+1 protection
   schemes do not use a coordination protocol? This is news to me, since to
   the best of my recollection both ITU Ethernet Linear Protection and RFC6378
   define support for 1+1 protection, don't they?

Might I suggest that you adhere more closely to the language of the ITU
definition and state that if a coordination protocol is being used then
SF-P priority is higher than FS.

Hope this helps,
yaacov weingarten

On Mon, Jul 29, 2013 at 11:26 AM, Huub van Helvoort <[email-masked]>wrote:

> Hello MPLS,
>
> I noticed that I did not send this notification to the MPLS
> list at the same time as I sent it to CCAMP.
>
> This concerns/addresses priorities in linear protection.
>
> Best regards, Huub.
>
> Subject: Fwd: I-D Action: draft-helvoort-ccamp-fs-**priority-00.txt
> Date: Fri, 12 Jul 2013 10:22:06 +0200
> From: Huub van Helvoort <[email-masked]>
> Reply-To: [email-masked]
> To: CCAMP <[email-masked]>
>
> Hello CCAMP,
>
> http://www.ietf.org/mail-**archive/web/mpls/current/**msg09913.html<http://www.ietf.org/mail-archive/web/mpls/current/msg09913.html>
> http://www.ietf.org/mail-**archive/web/mpls/current/**msg09916.html<http://www.ietf.org/mail-archive/web/mpls/current/msg09916.html>
>
> Subject: I-D Action: draft-helvoort-ccamp-fs-**priority-00.txt
>         Filename        : draft-helvoort-ccamp-fs-**priority-00.txt
>         Pages           : 4
>         Date            : 2013-07-12
>
> Abstract:
> https://datatracker.ietf.org/**doc/draft-helvoort-ccamp-fs-**priority<https://datatracker.ietf.org/doc/draft-helvoort-ccamp-fs-priority>
>
> http://tools.ietf.org/html/**draft-helvoort-ccamp-fs-**priority-00<http://tools.ietf.org/html/draft-helvoort-ccamp-fs-priority-00>
>
>
> ftp://ftp.ietf.org/internet-**drafts/<ftp://ftp.ietf.org/internet-drafts/>
>
> ______________________________**_________________
> https://www.ietf.org/mailman/**listinfo/i-d-announce<https://www.ietf.org/mailman/listinfo/i-d-announce>
> Internet-Draft directories: http://www.ietf.org/shadow.**html<http://www.ietf.org/shadow.html>
> or ftp://ftp.ietf.org/ietf/**1shadow-sites.txt<ftp://ftp.ietf.org/ietf/1shadow-sites.txt>
>
>
>
>
> ______________________________**_________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/mpls<https://www.ietf.org/mailman/listinfo/mpls>
>

-- 
Thanx and BR,
yaacov

*Still looking for new opportunity*

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 29 Jul 2013 16:33:29 +0200

Yaacov, hi,

You wrote:

> document, I am not sure that the note that you are proposing in Section
> 2 of the document really clarifies the definitions of what are the
> priorities.

OK, I hope you mean that more clarification is needed for when
the priority FS over SF-P or SF-P over FS are used.

> logical connection between NEs that may be used for management or
> control plane applications. In theory this includes (to my
> understanding) any use of the GACH as defined for MPLS-TP (e.g. any OAM
> functionality).

I think I understand the confusion.
I wanted to make a difference between protection switching
applications that rely on a control plane, and protection
switching applications that rely on an in-band protocol
which fate shares with the protection path.

>   * what are these? Is there a protection scheme for MPLS-TP that do not
>     use a communication channel - for example for CC or CV messages? If
>     you meant to say that they are not dependent upon a coordination
>     protocol (similar to the statement in the ITU documentation that
>     refers to APS) then I suggest that you clearly state this.

As I explained above I wanted to differentiate between a coordination
protocol that uses a control plane, and one that fate shares with the
protection path.

>   * However, are you adding a blanket statement that 1+1 protection
>     schemes do not use a coordination protocol? This is news to me,
>     since to the best of my recollection both ITU Ethernet Linear
>     Protection and RFC6378 define support for 1+1 protection, don't they?

This was not my intention.

> SF-P priority is higher than FS.

I will try to captuture this more clearly.

> Hope this helps,

It did, thanks, Huub.

=======
> On Mon, Jul 29, 2013 at 11:26 AM, Huub van Helvoort
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello MPLS,
>
>     Subject: Fwd: I-D Action: draft-helvoort-ccamp-fs-__priority-00.txt
>     From: Huub van Helvoort <[email-masked]
>     <mailto:[email-masked]>>
>     Reply-To: [email-masked] <mailto:[email-masked]>
>     To: CCAMP <[email-masked] <mailto:[email-masked]>>
>
>     Hello CCAMP,
>
>     http://www.ietf.org/mail-__archive/web/mpls/current/__msg09913.html
>     <http://www.ietf.org/mail-archive/web/mpls/current/msg09913.html>
>     http://www.ietf.org/mail-__archive/web/mpls/current/__msg09916.html
>     <http://www.ietf.org/mail-archive/web/mpls/current/msg09916.html>
>
>     Subject: I-D Action: draft-helvoort-ccamp-fs-__priority-00.txt
>     From: [email-masked] <mailto:[email-masked]>
>     Reply-To: [email-masked] <mailto:[email-masked]>
>     To: [email-masked] <mailto:[email-masked]>
>
>
>              Filename        : draft-helvoort-ccamp-fs-__priority-00.txt
>              Pages           : 4
>              Date            : 2013-07-12
>
>     Abstract:
>     https://datatracker.ietf.org/__doc/draft-helvoort-ccamp-fs-__priority <https://datatracker.ietf.org/doc/draft-helvoort-ccamp-fs-priority>
>
>     http://tools.ietf.org/html/__draft-helvoort-ccamp-fs-__priority-00
>     <http://tools.ietf.org/html/draft-helvoort-ccamp-fs-priority-00>
>
>
>     ftp://ftp.ietf.org/internet-__drafts/
>     <ftp://ftp.ietf.org/internet-drafts/>
>
>     _________________________________________________
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/i-d-announce
>     <https://www.ietf.org/mailman/listinfo/i-d-announce>
>     Internet-Draft directories: http://www.ietf.org/shadow.__html
>     <http://www.ietf.org/shadow.html>
>     or ftp://ftp.ietf.org/ietf/__1shadow-sites.txt
>     <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>
>
>
>
>
>     _________________________________________________
>     mpls mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/mpls
>     <https://www.ietf.org/mailman/listinfo/mpls>
>
>
>
>
> --
> Thanx and BR,
> yaacov
>
> /Still looking for new opportunity/

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样