Subject: [CCAMP] Gen-ART review of draft-ietf-ccamp-oam-configuration-fwk-12

From: "Black, David" <[email-masked]>
Date: Thu, 16 Jan 2014 18:30:09 -0500

The -12 version of this draft addresses the nits and editorial items
noted in the Gen-ART review of the -11 version.  It's ready for
RFC publication.

Thanks,
--David

> -----Original Message-----
> From: Gen-art [mailto:[email-masked]] On Behalf Of Black, David
> Sent: Sunday, December 29, 2013 9:51 PM
> To: General Area Review Team ([email-masked]); [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Gen-art] Gen-ART review of draft-ietf-ccamp-oam-configuration-
> fwk-11
> 
> One additional nit - Don Fedyk's email address listed in the draft does not
> work.
> 
> Thanks,
> --David
> 
> > -----Original Message-----
> > From: Black, David
> > Sent: Sunday, December 29, 2013 9:46 PM
> > To: General Area Review Team ([email-masked]); [email-masked];
> > [email-masked]; [email-masked]
> > Cc: Black, David; [email-masked]; [email-masked]; [email-masked]
> > Subject: Gen-ART review of draft-ietf-ccamp-oam-configuration-fwk-11
> >
> > I am the assigned Gen-ART reviewer for this draft. For background on
> > Gen-ART, please see the FAQ at
> >
> > <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> >
> > Please resolve these comments along with any other Last Call comments
> > you may receive.
> >
> > Document: draft-ietf-ccamp-oam-configuration-fwk-11
> > Reviewer: David L. Black
> > Review Date: December 29, 2013
> > IETF LC End Date: January 5, 2014
> >
> > Summary: This draft is basically ready for publication, but has nits that
> > should be fixed before publication.
> >
> > This draft describes the GMPLS framework for signaling OAM configuration,
> > and specifies additional RSVP elements to support that signaling.  Knowledge
> > of RSVP, and specifically RSVP-TE is assumed; beyond that, the draft is
> > complete, although it is very detailed - see editorial comment below on
> > Section 3.
> >
> > Nits/editorial comments:
> >
> > Sections 3.1-3.3 dive into the details very quickly.  They would be easier
> to
> > understand if there was an overview paragraph near the start of Section 3
> that
> > describes the roles of the two ADMIN_STATUS flags and the two LSP Attributes
> > flags in OAM configuration (establishment, change/adjustment, deletion)
> before
> > the current text that contains the details of RSVP message processing.
> >
> > There are a number of instances of "(IANA to assign)" in section 4 that the
> > RFC Editor will need to remove - an RFC Editor note to that effect should
> > be inserted at the start of Section 4.
> >
> > Section 4.5 is necessarily incomplete on P2MP considerations, because (as
> > it says) "P2MP OAM mechanisms are very specific to the data plane
> technology".
> > It would be helpful if section 4.5 contained language indicating what a
> > specific data plane specification should include to completely specify
> > P2MP OAM configuration for that data plane.
> >
> > idnits 2.13.01 didn't find anything that needs attention.
> >
> > Thanks,
> > --David
> > ----------------------------------------------------
> > David L. Black, Distinguished Engineer
> > EMC Corporation, 176 South St., Hopkinton, MA  01748
> > +1 (508) 293-7953             FAX: +1 (508) 293-7786
> > [email-masked]        Mobile: +1 (978) 394-7754
> > ----------------------------------------------------
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Jari Arkko <[email-masked]>
Date: Wed, 22 Jan 2014 00:05:44 +0200

Thanks for your review & re-review, David! I have balloted no-obj, for this Thursday's IESG telechat.

Jari