Subject: Re: [CCAMP] FW: [Editorial Errata Reported] RFC4803 (3831)

From: Jonathan Hardwick <[email-masked]>
Date: Thu, 9 Jan 2014 16:47:28 +0000

We have an implementation of this, which conforms with the corrected text below.
Sorry for the late reply.
Jon

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 13 December 2013 16:25
To: [email-masked]; 'CCAMP WG'
Subject: Re: [CCAMP] FW: [Editorial Errata Reported] RFC4803 (3831)

This correction looks fine to me, but I haven't implemented it myself.

Implementors? Anyone care to comment?

Thanks,
Lou

On 12/12/2013 01:55 PM, Adrian Farrel wrote:
> BTW, I have passed this to Stewart for resolution, so any comments should be
> copied to him.
> 
> Adrian
> 
>> -----Original Message-----
>> From: RFC Errata System [mailto:[email-masked]]
>> Sent: 12 December 2013 15:22
>> To: [email-masked]; [email-masked]; [email-masked];
>> [email-masked]; [email-masked]; [email-masked]
>> Cc: [email-masked]; [email-masked]; [email-masked]
>> Subject: [Editorial Errata Reported] RFC4803 (3831)
>>
>> The following errata report has been submitted for RFC4803,
>> "Generalized Multiprotocol Label Switching (GMPLS) Label Switching Router
> (LSR)
>> Management Information Base".
>>
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata_search.php?rfc=4803&eid=3831
>>
>> --------------------------------------
>> Type: Editorial
>> Reported by: Adrian Farrel <[email-masked]>
>>
>> Section: 6
>>
>> Original Text
>> -------------
>>    In mplsXCTable:
>>    {
>>       mplsXCIndex                = 0x01,
>>       mplsXCInSegmentIndex       = 0x00000015,
>>       mplsXCOutSegmentIndex      = 0x00000012,
>>       mplsXCLspId                = 0x0102 -- unique ID
>>       mplsXCLabelStackIndex      = 0x00, -- only a single outgoing label
>>       mplsXCRowStatus            = createAndGo(4)
>>    }
>>
>>    In mplsXCTable:
>>    {
>>       mplsXCIndex                = 0x02,
>>       mplsXCInSegmentIndex       = 0x00000016,
>>       mplsXCOutSegmentIndex      = 0x00000013,
>>       mplsXCLspId                = 0x0102 -- unique ID
>>       mplsXCLabelStackIndex      = 0x00, -- only a single outgoing label
>>       mplsXCRowStatus            = createAndGo(4)
>>    }
>>
>>
>> Corrected Text
>> --------------
>>    In mplsXCTable:
>>    {
>>       mplsXCIndex                = 0x01,
>>       mplsXCInSegmentIndex       = 0x00000015,
>>       mplsXCOutSegmentIndex      = 0x00000012,
>>       mplsXCLspId                = 0x0102 -- unique ID
>>       mplsXCLabelStackIndex      = 0x00, -- only a single outgoing label
>>       mplsXCRowStatus            = createAndGo(4)
>>    }
>>
>>    In mplsXCTable:
>>    {
>>       mplsXCIndex                = 0x01,
>>       mplsXCInSegmentIndex       = 0x00000016,
>>       mplsXCOutSegmentIndex      = 0x00000013,
>>       mplsXCLspId                = 0x0102 -- unique ID
>>       mplsXCLabelStackIndex      = 0x00, -- only a single outgoing label
>>       mplsXCRowStatus            = createAndGo(4)
>>    }
>>
>>
>> Notes
>> -----
>> The entries in the mplsXCTable are indexed by {mplsXCIndex,
>> mplsXCInSegmentIndex, mplsOutSegmentIndex}. All XC entries for the same LSP
>> should share a common value of mplsXCIndex because mplsTunnelXCPointer can
>> be set to point to the first entry and then all of the other entries can be
> found.
>>
>> The error in the example in Section 6 is that it shows a different value of
>> mplsXCIndex for the reverse direction cross-connects. It should be set to the
>> same value as is used for the forward direction cross-connect.
>>
>> Instructions:
>> -------------
>> This errata is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party (IESG)
>> can log in to change the status and edit the report, if necessary.
>>
>> --------------------------------------
>> RFC4803 (draft-ietf-ccamp-gmpls-lsr-mib-15)
>> --------------------------------------
>> Title               : Generalized Multiprotocol Label Switching (GMPLS) Label
> Switching
>> Router (LSR) Management Information Base
>> Publication Date    : February 2007
>> Author(s)           : T. Nadeau, Ed., A. Farrel, Ed.
>> Category            : PROPOSED STANDARD
>> Source              : Common Control and Measurement Plane
>> Area                : Routing
>> Stream              : IETF
>> Verifying Party     : IESG
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
> 

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 9 Jan 2014 17:01:04 -0000

Thanks John,
I forwarded this to Stewart.
Adrian

> From: Jonathan Hardwick [mailto:[email-masked]]
> Sent: 09 January 2014 16:47
> To: labn - Lou Berger; [email-masked]
> Cc: 'CCAMP WG'
> Subject: RE: [CCAMP] FW: [Editorial Errata Reported] RFC4803 (3831)
>