Subject: [CCAMP] [Technical Errata Reported] RFC7139 (3945)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Apr 2014 11:21:19 -0700 (PDT)

The following errata report has been submitted for RFC7139,
"GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport Networks".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7139&eid=3945

--------------------------------------
Type: Technical
Reported by: Fred Gruman <[email-masked]>

Section: 7

Original Text
-------------
For the ingress node, a Path message with SE style SHOULD also be
sent for decreasing the ODUflex bandwidth.

Corrected Text
--------------
For the ingress node, a Path message with SE style MUST also be
sent for decreasing the ODUflex bandwidth.

Notes
-----
Section 7 requires that Shared Explicit (SE) MUST be used at the beginning when creating a resizable ODUflex connection. Thus, the SE style MUST also be used when signaling for bandwidth increase or decrease.  The increase procedure mandates the use of SE style; however, the decrease procedure uses SHOULD.  The decrease procedure should also make the SE signaling mandatory.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7139 (draft-ietf-ccamp-gmpls-signaling-g709v3-12)
--------------------------------------
Title               : GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport Networks
Publication Date    : March 2014
Author(s)           : F. Zhang, Ed., G. Zhang, S. Belotti, D. Ceccarelli, K. Pithewan
Category            : PROPOSED STANDARD
Source              : Common Control and Measurement Plane
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 2 Apr 2014 21:07:09 +0100

With this report as well, I need to know whether the use of "SHOULD" was
intentional or a typographic error.

Thanks,
Adrian

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: 02 April 2014 19:21
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Technical Errata Reported] RFC7139 (3945)
> 
> Section 7 requires that Shared Explicit (SE) MUST be used at the beginning
when
> creating a resizable ODUflex connection. Thus, the SE style MUST also be used
> when signaling for bandwidth increase or decrease.  The increase procedure
> mandates the use of SE style; however, the decrease procedure uses SHOULD.
> The decrease procedure should also make the SE signaling mandatory.
> 
> Instructions:
> -------------
> Title               : GMPLS Signaling Extensions for Control of Evolving G.709
Optical
> Transport Networks