Subject: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

From: [email-masked]
Date: Wed, 30 Apr 2014 15:12:35 +0800

Hi, Xian and CCAMPers

I have one comment on draft-zhang-ccamp-flexible-grid-ospf-ext:

In section 4.3, page 7, the encoding of "Port Label Restriction sub-TLV" 
is listed as follows.

     0                   1                   2                   3 
     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
    | MatrixID      | RstType = TBA |            Reserved           | 
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
    |     C.F.G     |    S.W.G      |   Min Width   |   Max Width   | 
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

In my opinion, it is not necessary to put the field "C.F.G" into this TLV, 
because that: C.F.G could be deduced from S.W.G (C.F.G = S.W.G / 2). Would 
anyone give one example where C.F.G != S.W.G / 2 ?

--------------------------------------------
LeiWang

ZTE
Bearer Network Product Pre_research Department,
Wireline R&D Insititute
Cell phone:+86 13811440067
Email: [email-masked]
       [email-masked]
       [email-masked]
----------------------------------------------

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Wed, 30 Apr 2014 07:42:06 +0000

I agree with LeWang,

I'd also add that the MaxWidth field must be more than 8 bits (e.g. 16 bits).
This is to align this parameter to the recent ITU liaison reply on m value range.

Best Regards,

Gabriele
[http://www.cisco.com/swa/i/logo.gif]

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy
www.cisco.com/global/IT/<http://www.cisco.com/global/IT/>

[email-masked]<mailto:[email-masked]>
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 30, 2014 9:12 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Xian Zhang <[email-masked]<mailto:[email-masked]>>
Subject: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

Hi, Xian and CCAMPers

In section 4.3, page 7, the encoding of "Port Label Restriction sub-TLV" is listed as follows.

     0                   1                   2                   3

In my opinion, it is not necessary to put the field "C.F.G" into this TLV, because that: C.F.G could be deduced from S.W.G (C.F.G = S.W.G / 2).  Would anyone give one example where C.F.G != S.W.G / 2 ?

ZTE
Bearer Network Product Pre_research Department,
Wireline R&D Insititute
Cell phone:+86 13811440067
Email: [email-masked]<mailto:[email-masked]>
      [email-masked]<mailto:[email-masked]>
      [email-masked]<mailto:[email-masked]>
----------------------------------------------

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 30 Apr 2014 08:36:41 +0000

Hi, Lei, Gabriele,

  Thank you for the comments. Please see my reply inline:

From: Gabriele Maria Galimberti (ggalimbe) [mailto:[email-masked]]
Sent: 2014年4月30日 15:42
To: [email-masked]; [email-masked]; Zhangxian (Xian)
Subject: Re: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

I agree with LeWang,

Xian:  I think Lei has made a good point, i.e., CFG and SWG currently has a fixed relationship.  Will remove one field (i.e., CFG) to avoid carrying duplicated information in the next rotation of the draft. If anyone has different opinions, please speak up.

Xian: this point has been raised before and has been agreed with (see: http://www.ietf.org/mail-archive/web/ccamp/current/msg15770.html). This will be reflected in the next update of this draft.

Cheers,
Xian

Best Regards,

Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

Hi, Xian and CCAMPers

     0                   1                   2                   3

ZTE

---

From: Ramon Casellas <[email-masked]>
Date: Wed, 30 Apr 2014 11:00:21 +0200

El 30/04/2014 10:36, Zhangxian (Xian) escribió:
> *From:*Gabriele Maria Galimberti (ggalimbe) [mailto:[email-masked]]
> *Sent:* 2014?4?30?15:42
> *To:* [email-masked]; [email-masked]; Zhangxian (Xian)
> *Subject:* Re: [CCAMP] One comment on 
> draft-zhang-ccamp-flexible-grid-ospf-ext
>
> I agree with LeWang,
>
> Xian:  I think Lei has made a good point, i.e., CFG and SWG currently 
> has a fixed relationship.  Will remove one field (i.e., CFG) to avoid 
> carrying duplicated information in the next rotation of the draft. If 
> anyone has different opinions, please speak up.
>

Ramon> I don't know, I don't have a strong opinion, yet if we check

https://datatracker.ietf.org/documents/LIAISON/liaison-2014-04-23-itu-t-sg-15-ccamp-lsr-on-flexible-grid-reply-to-ietf-ccamp-ls012-attachment-1.pdf

quote
"If such a proposal is made in the future, it is more likely that a 
second flexible grid with different granularity will be defined in 
addition to the existing grid rather than changes made to the current 
flexible grid (...) One of the reasons behind the 2:1 relationship 
between the slot width granularity and the nominal
central frequency granularity in the current flexible grid is to be able 
to describe any of the existing fixed spacing grids in Recommendation 
ITU-T G.694.1 using the flexible grid. If in future a flexible grid with 
finer granularity is introduced, the same 2:1 relationship should not be 
assumed."

so it is a design trade-off? do we stick to the current grid definition 
*only* or we are more future-proof?

Ramon

---

From: Jonas Mårtensson <[email-masked]>
Date: Wed, 30 Apr 2014 09:28:03 +0000

Hi Ramon,

I don’t have a strong opinion either but isn’t the definition of the Port Label Restriction sub-TLV a separate issue from the future-proofing of the flexible grid label encoding? I mean the purpose of this sub-TLV is to describe a port on a switch that supports only a restricted subset of the full flexible grid.

Isn’t there a possibility that a particular switch could be restricted to granularities not following the 2:1 relationship due to some technology limitation?

/Jonas

From: CCAMP [mailto:[email-masked]] On Behalf Of Ramon Casellas
Sent: den 30 april 2014 11:00
To: [email-masked]
Subject: Re: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

From: Gabriele Maria Galimberti (ggalimbe) [mailto:[email-masked]]
Sent: 2014年4月30日 15:42
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Zhangxian (Xian)
Subject: Re: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

I agree with LeWang,

quote
"If such a proposal is made in the future, it is more likely that a second flexible grid with different granularity will be defined in addition to the existing grid rather than changes made to the current flexible grid (...) One of the reasons behind the 2:1 relationship between the slot width granularity and the nominal
central frequency granularity in the current flexible grid is to be able to describe any of the existing fixed spacing grids in Recommendation ITU-T G.694.1 using the flexible grid. If in future a flexible grid with finer granularity is introduced, the same 2:1 relationship should not be assumed."

so it is a design trade-off? do we stick to the current grid definition *only* or we are more future-proof?

Ramon

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Wed, 30 Apr 2014 11:37:29 +0000

Thanks a lot Xian,

Regards,

Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

From: Xian Zhang <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 30, 2014 10:36 AM
To: Gabriele Galimberti <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [CCAMP] One comment on draft-zhang-ccamp-flexible-grid-ospf-ext

Hi, Lei, Gabriele,

I agree with LeWang,

Cheers,
Xian

Best Regards,

Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

Hi, Xian and CCAMPers

     0                   1                   2                   3

ZTE