Subject: [CCAMP] I-D Action: draft-ietf-ccamp-flexigrid-lambda-label-01.txt

From: [email-masked]
Date: Mon, 23 Jun 2014 11:28:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Common Control and Measurement Plane Working Group of the IETF.

        Title           : Generalized Labels for the Flexi-Grid in Lambda Switch Capable (LSC) Label Switching Routers
        Authors         : Adrian Farrel
                          Daniel King
                          Yao Li
                          Fatai Zhang
	Filename        : draft-ietf-ccamp-flexigrid-lambda-label-01.txt
	Pages           : 14
	Date            : 2014-06-23

Abstract:
   GMPLS supports the description of optical switching by identifying
   entries in fixed lists of switchable wavelengths (called grids)
   through the encoding of lambda labels.  Work within the ITU-T Study
   Group 15 has defined a finer granularity grid, and the facility to
   flexibly select different widths of spectrum from the grid.  This
   document defines a new GMPLS lambda label format to support this
   flexi-grid.

   This document updates RFC 3471 and RFC 6205 by introducing a new
   label format.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-flexigrid-lambda-label/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ccamp-flexigrid-lambda-label-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-flexigrid-lambda-label-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 23 Jun 2014 19:32:57 +0100

Since we are down to wordsmithing, I have posted a revision. The bits to look at
are sections 2.1 and 4.3.

Suggestions of replacement text are welcome.

I think that the more formal discussion of media channels and network media
channels and their arrangement for inverse multiplexing belongs in the framework
draft since this document only sets out how to construct a composite label.

Cheers,
Adrian

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: 23 June 2014 19:29
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-ccamp-flexigrid-lambda-label-01.txt
> 
> 
>         Title           : Generalized Labels for the Flexi-Grid in Lambda
Switch Capable
> (LSC) Label Switching Routers
>         Authors         : Adrian Farrel
>                           Daniel King
>                           Yao Li
>                           Fatai Zhang
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Iftekhar Hussain <[email-masked]>
Date: Tue, 24 Jun 2014 21:15:58 +0000

Clarification for the composite label portion:
So does this mean that:
a) we are moving ahead with control plane solution ahead of ITU data plane definitions ?
b) or that the ITU data plane has already defined all the data plane aspects for the composite label use case?

If it is case (b) - no issue.  However, if it is case (a) shouldn't we wait for ITU before proposing solutions? 

 I  disagree with the assertion "more formal discussion of media channels and network media channels and their arrangement for inverse multiplexing belongs in the framework" .  I believe this document should  elaborate on the use case for which the solution is being proposed.

Thanks,
Iftekhar

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Monday, June 23, 2014 11:33 AM
To: [email-masked]
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-flexigrid-lambda-label-01.txt

Since we are down to wordsmithing, I have posted a revision. The bits to look at are sections 2.1 and 4.3.

I think that the more formal discussion of media channels and network media channels and their arrangement for inverse multiplexing belongs in the framework draft since this document only sets out how to construct a composite label.

Cheers,
Adrian

Switch Capable
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt