Subject: [CCAMP] Backward compatibility for Availability sub-TLV

From: Gregory Mirsky <[email-masked]>
Date: Mon, 23 Jun 2014 14:34:17 +0000

Dear All,
on behalf of authors of the RSVP-TE Signaling Extension for Links with Variable Discrete Bandwidth would like to ask for expert opinion. The Availability sub-TLV defined in the draft as a sub-TLV under Ethernet bandwidth profile. The length field in the Ethernet bandwidth profile will be different from the current definition(24), which might cause some backward issues.
Possible way to address this problem:

*         define Availability as TLV that MUST be accompanied by Ethernet BW Profile TLV;

*         define Extended Ethernet BW Profile TLV that includes Ethernet BW TLV and has variable length. Definition of Availability characteristics remains as sub-TLV which MAY be included into Extended Ethernet BW Profile TLV.

Regards,
        Greg

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 25 Jun 2014 08:54:56 +0000

Hi Greg,

I think there were some similar discussions on Bandwidth encoding for [draft-ietf-pce-gmpls-pcep-extensionsin] in PCE WG.

Per RFC3471, Bandwidth encodings are carried in 32 bit number in IEEE floating point format. There were lots of discussions on how to encode the accurate bandwidth information for the transport networks. Consequently, two new types of Bandwidth are being defined in [draft-ietf-pce-gmpls-pcep-extensionsin], which are variable.

Therefore, I would prefer to introduce a new type of BW Profile, which should be the second option you mentioned below if my understanding is correct on your options.

Best Regards

Fatai

From: CCAMP [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Monday, June 23, 2014 10:34 PM
To: CCAMP ([email-masked])
Subject: [CCAMP] Backward compatibility for Availability sub-TLV

Dear All,

Regards,
        Greg