Subject: Re: [CCAMP] Poll on making draft-li-ccamp-grid-property-lmp-03 a WG document

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Mon, 2 Jun 2014 13:29:51 +0000

Yes, support,

Best Regards,

Óscar

De: <BRUNGARD>, DEBORAH A BRUNGARD <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 30 de mayo de 2014 09:24
Para: CCAMP <[email-masked]<mailto:[email-masked]>>
Asunto: [CCAMP] Poll on making draft-li-ccamp-grid-property-lmp-03 a WG document

All,

This is to start a two week poll on making draft-li-ccamp-grid-property-lmp-03 a ccamp working group document. Please send email to the list indicating "yes/support" or "no/do not support". If indicating no, please state your technical reservations with the document.

The poll ends Friday, June 13th.

Thanks,
Deborah and Lou

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Dieter Beller <[email-masked]>
Date: Mon, 02 Jun 2014 17:52:51 +0200

Hi Debora, all,

no/do not support

Here's my rationale:

I is doubtful whether it really makes sense to operate flex grid
nodes together with fix grid nodes in the same

network. This also applies to flex-grid nodes that have different
flex-grid properties.

In the introduction of this I-D it is stated:

Fixed-grid DWDM system is regarded as a special case of Flexi-grid
DWDM. It is expected that fixed-grid optical nodes will be gradually
replaced by flexible nodes and interworking between fixed-grid DWDM
and flexible-grid DWDM nodes will be needed as the network evolves.
Additionally, even two flexible-grid optical nodes may have
different grid properties based on the filtering component
characteristics, thus need to negotiate on the specific parameters
to be used during neighbor discovery process [draft-ietf-ccamp-
flexi-grid-fwk-00]. This document describes the extensions to the
Link Management Protocol (LMP) to negotiate a link grid property
between two adjacent Flexi-grid nodes before the link is brought up.

IMHO, it is hard to imagine how a network(!) can be
operated in a dynamic manner utilizing a GMPLS control

plane  that is composed of nodes that have different capabilities in
terms of spectrum management, i.e., a mix of

fix- and flexi-grid nodes. The only scenario I can imagine is the
following: while the network nodes are being

upgraded/replaced (this requires HW replacement!), the entire
network is still operated in the fix grid mode and

only when all nodes have been upgrade the mode of operation is
changed and the flex-grid feature is enabled

network wide. Mixed fix/flexi-grid operation adds quite some
complexity to the control plane which is only required

during the transition period. I also do not think that it is a good
idea to have nodes with different flex-grid properties

in a network as far as spectrum management capabilities are
concerned.

Thanks,

Dieter

On 30.05.2014 09:24, BRUNGARD, DEBORAH
A wrote:

All,

This is to start a two week poll on making
draft-li-ccamp-grid-property-lmp-03 a ccamp working group
document. Please send email to the list indicating
“yes/support” or “no/do not support”. If indicating no,
please state your technical reservations with
the document.

Thanks,

Deborah and Lou

---

From: "Guoying Zhang" <[email-masked]>
Date: Tue, 3 Jun 2014 16:17:35 +0800

Hi Dieter, 
     Thank you for your question. Here are my thoughts to your doubts and questions.
There are two scenarios in which the grid properties should be negotiated, as stated in our draft.
1.    A mixed network composed with both flexi-grid and fixed grid switching nodes.
 Currently, the 100Gb/s DWDM system just need fixed grid switching with 50GHz grid capability. However, we would expect the 400Gb/s DWDM systems will need flexi-grid switching (e.g., 75GHz switching capability) after around 2017. Since the 100Gb/s DWDM system will have a long life-cycle, we can imagine that both fixed-grid and flexi-grid network will co-exist for a long period of time. The grid property negotiation between the fixed and flexi-grid nodes does not mean the whole network needs to operate in the fixed mode. Instead, only the links between the fixed and flexi-grid nodes are negotiated to work in the fixed mode, other links between flexi-grid nodes are still working in the flexi mode. The OSPF protocol will flood the link grid properties throughout the network, so that the source node can compute the right path to go through when a flexi-grid LSP or a fixed-grid LSP needs to be setup.
2.    The grid property is also important in a flexi-grid network. 
The network operators normally runs a network consisted of different vendor equipment. It is quite possible that different vendor's flexi-grid nodes support different spectrum switching granularities, spectrum tuning ranges, etc. Thus, two adjacent nodes need to negotiate a common granularity and tuning range that can be supported on the link. Again, these properties will be broadcasted by OSPF to facilitate route computation.

Currently, the framework document and OSPF extension document have both defined grid properties (e.g., <Available Frequency Range-List>, <Available Central Frequency Granularity>,<Available Slot Width Granularity>,  <Minimal Slot Width>,<Maximal Slot Width>). The draft-li-ccamp-grid-property-lmp-03 document provides the means to determine these grid properties. So we think it is useful to have this function standardized. 
Hope this can answer you questions.
 
Best, 
Guoying

Dieter Beller 
2014-06-02  23:53:15 
BRUNGARD, DEBORAH A; [email-masked] 
Re: [CCAMP] Poll on making draft-li-ccamp-grid-property-lmp-03 a WGdocument 
 
Hi Debora, all,

no/do not support

Here's my rationale:

I is doubtful whether it really makes sense to operate flex grid nodes together with fix grid nodes in the same
network. This also applies to flex-grid nodes that have different flex-grid properties.

   Fixed-grid DWDM system is regarded as a special case of Flexi-grid
   DWDM. It is expected that fixed-grid optical nodes will be gradually
   replaced by flexible nodes and interworking between fixed-grid DWDM
   and flexible-grid DWDM nodes will be needed as the network evolves.
   Additionally, even two flexible-grid optical nodes may have
   different grid properties based on the filtering component
   characteristics, thus need to negotiate on the specific parameters
   to be used during neighbor discovery process [draft-ietf-ccamp-
   flexi-grid-fwk-00]. This document describes the extensions to the
   Link Management Protocol (LMP) to negotiate a link grid property
   between two adjacent Flexi-grid nodes before the link is brought up.
IMHO, it is hard to imagine how a network(!) can be operated in a dynamic manner utilizing a GMPLS control
plane  that is composed of nodes that have different capabilities in terms of spectrum management, i.e., a mix of
fix- and flexi-grid nodes. The only scenario I can imagine is the following: while the network nodes are being
upgraded/replaced (this requires HW replacement!), the entire network is still operated in the fix grid mode and
only when all nodes have been upgrade the mode of operation is changed and the flex-grid feature is enabled
network wide. Mixed fix/flexi-grid operation adds quite some complexity to the control plane which is only required
during the transition period. I also do not think that it is a good idea to have nodes with different flex-grid properties
in a network as far as spectrum management capabilities are concerned.

Thanks,
Dieter

On 30.05.2014 09:24, BRUNGARD, DEBORAH A wrote:

All,

This is to start a two week poll on making draft-li-ccamp-grid-property-lmp-03 a ccamp working group document. Please send email to the list indicating “yes/support” or “no/do not support”. If indicating no, please state your technical reservations with the document.

Thanks,
Deborah and Lou

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 17 Jun 2014 13:34:26 +0000

All,

This poll is closed. The document is adopted.

Authors,
Please resubmit with name change only to draft-ietf-ccamp-grid-property-lmp.

Thank you,
Deborah and Lou

From: CCAMP [mailto:[email-masked]] On Behalf Of BRUNGARD, DEBORAH A
Sent: Friday, May 30, 2014 3:24 AM
To: [email-masked]
Subject: [CCAMP] Poll on making draft-li-ccamp-grid-property-lmp-03 a WG document

***Security Advisory: This Message Originated Outside of AT&T ***
Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
All,

Thanks,
Deborah and Lou