Subject: [CCAMP] Question you raised on failing to assing WA method.

From: Leeyoung <[email-masked]>
Date: Mon, 21 Jul 2014 19:48:45 +0000

Hi Lou,

Would you be able to re-phrase what you asked in regard to "what happens what wavelength assignment has failed"? Is this the correct statement?

Thanks,
Young

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Mon, 21 Jul 2014 19:52:11 +0000

and even more “if a node cannot allocate the (physical, i.e. a regenerator block) resource, what happens?”

correct?

Cheers
G

On 21 Jul 2014, at 15:48, Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:

Hi Lou,

Would you be able to re-phrase what you asked in regard to “what happens what wavelength assignment has failed”? Is this the correct statement?

Thanks,
Young
_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Leeyoung <[email-masked]>
Date: Mon, 21 Jul 2014 20:01:23 +0000

I was not clear on the question I raised. With Giovanni's comment, let me rephrase the question I think Lou asked:

What happens if a node cannot allocate the resources asked for (e.g., regeneration block or wavelength, etc.)?

Then would a PathErr Message with cause values (one for Regen Block and other for wavelength) be sufficient?

Young

From: Giovanni Martinelli (giomarti) [mailto:[email-masked]]
Sent: Monday, July 21, 2014 2:52 PM
To: Leeyoung
Cc: Lou Berger; [email-masked]
Subject: Re: [CCAMP] Question you raised on failing to assing WA method.

and even more "if a node cannot allocate the (physical, i.e. a regenerator block) resource, what happens?"

correct?

Cheers
G

Hi Lou,

Thanks,
Young

---

From: Lou Berger <[email-masked]>
Date: Tue, 22 Jul 2014 07:38:30 -0400

Young,
The specific comment was related to the final (and parallel) paragraphs
in section 4.3 and 4.4. They both describe what is done on successful
processing of the related sub-TLV but, unless I missed it, don't
describe how a failure is to be handled.

I some other nits that I'll send out as soon as I get the chance.
(Alternatively, catch me in the hall and I'll review them with you.)

Lou

On 7/21/2014 3:48 PM, Leeyoung wrote:
>
> Hi Lou,
>
> Would you be able to re-phrase what you asked in regard to “what
> happens what wavelength assignment has failed”? Is this the correct
> statement?
>
> Thanks,
>
> Young
>