Subject: [CCAMP] IANA-related comments draft-ietf-ccamp-wson-signaling

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Tue, 29 Jul 2014 19:06:22 +0000

Authors,

A couple of things on the IANA section in this doc. I'm not actually sure what the right thing to do is in either case - perhaps the Chairs could offer guidance if need be?

First: in the new "Values for Wavelength Assignment Method field in WavelengthSelection Sub-TLV" registry, would it be worth specifying a small range of values for Experimental Use (or any of the other categories, for that matter)? Note that I don't have any proposal for what might be done with these; I'm just thinking that they may come in useful in the future.

Second: the new Path-error subcodes in this doc have been assigned values already (not even marked as "suggested". Have you got early allocation of these? Or should they become TBD until IANA formally assigns them? Just wondering, since we're going through the same stuff with the SRLG-collection draft...

Cheers

Matt

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Thu, 31 Jul 2014 07:02:23 +0000

Hi Matt,

a couple of initial answers ...

> First: in the new "Values for Wavelength Assignment Method field in WavelengthSelection Sub-TLV" registry, would it be worth specifying a small range of values for Experimental Use (or any of the o…

GM> Very good comment. Btw, during ietf Young and me we were editing to prepare next version 9, our working copy has room for some experimental code points. 

> 
> Second: the new Path-error subcodes in this doc have been assigned values already (not even marked as "suggested". Have you got early allocation of these? Or should they become TBD until IANA formally assigns them? Just wondering, since we're going through the same stuff with the SRLG-collection draft…

GM> Agree 

Much thx for your comments, let Young and/or chairs to complete with additional info.

Cheers
G

---

From: Lou Berger <[email-masked]>
Date: Thu, 31 Jul 2014 07:12:37 -0400

On 7/29/2014 3:06 PM, Matt Hartley (mhartley) wrote:
> ...
> ...

Matt,
    (Since you asked...) I'm inclined to use the same approach I
suggested for draft-ali-ccamp-otn-signal-type-subregistry, i.e.,
Standards Action and Specification Required policies.  It's fairly
straight forward and flexible. I also know of no cases where
Experimental has actually been used by CCAMP or in GMPLS.  The recent
discussion came the closest and, as mentioned in Toronto, clearly isn't
the right answer.

Looking at
http://www.iana.org/assignments/gmpls-sig-parameters/gmpls-sig-parameters.xhtml
you'll see various policies have been used/suggested, including the
combination I mention.  Perhaps we, as a WG, should agree, on default
policy for the GMPLS registry...

Thank you for raising the topic.

Lou

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Thu, 31 Jul 2014 15:17:09 +0000

Lou,

> policy for the GMPLS registry...

I think that might be a good idea. It would be useful to have some solid guidelines for this sort of thing.

Cheers

Matt

---

From: Lou Berger <[email-masked]>
Date: Thu, 31 Jul 2014 23:26:21 -0400

> I think that might be a good idea. It would be useful to have some solid guidelines for this sort of thing.

Something to discuss once we have a WG document on the topic ;-)

Lou

---

From: Leeyoung <[email-masked]>
Date: Fri, 1 Aug 2014 03:30:40 +0000

Hi Matt,

Thanks for your comments. As Giovanni expressed, in the upcoming revision has designated a place for experimental values. And your suggestion on "TBD" for some error subcodes make sense to me as well. There are apparently parallel efforts for similar codes. 

Thanks,
Young

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Matt Hartley (mhartley)
Sent: Tuesday, July 29, 2014 2:06 PM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] IANA-related comments draft-ietf-ccamp-wson-signaling

Authors,

Cheers

Matt 

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp