Subject: Re: [CCAMP] Microwave Radio Link YANG Data Models

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Sat, 2 Apr 2016 08:37:43 +0000

Hi Jonas, all,

What is the reason for duplicating effort in standardizing a Data Model for microwaves? As you point out there is an ongoing effort in other forum, so, why not contributing there instead of fragmenting the effort? I think this kind of situations are more frequent than desired, and we should avoid them.

From your description there is not a clear and substantial differentiation in the approach apart from reducing the scope, which honestly, I do not think is the proper approach, from an operator's perspective. The more open, the better. This is the real trend in the industry, and this is what we are (commercially) asking for.

Best regards

Luis

__________________________________
Luis M. Contreras

Technology and Planning
Transport, IP and Interconnection Networks
Telefónica I+D / Global CTO unit / Telefónica

Distrito Telefónica, Edificio Sur 3, Planta 3
28050 Madrid
España / Spain

+34 680 947 650 new
[email-masked]

> -------- Mensaje Original --------
> Asunto: Re: [CCAMP] Microwave Radio Link YANG Data Models
> Fecha: 31.03.2016 16:02
> De: Jonas Ahlberg <[email-masked]>
> Destinatario: "[email-masked]" <[email-masked]>
>
>
>
> Hi again,
>
> I've understood that some of you have had difficulties to open/read the
> attached text file in my first mail and I'm therefore sending you a version in
> PDF-format. The date in the header & footer has been changed by the tool I
> used to generate the pdf-file, but otherwise the content is identical with the
> text file.
>
> Regards
>
> JonasA
>
> FROM: CCAMP [mailto:[email-masked]] ON BEHALF OF Jonas Ahlberg
> SENT: den 23 mars 2016 21:00
> TO: [email-masked]
> SUBJECT: [CCAMP] Microwave Radio Link YANG Data Models
>
> Hi all,
>
> At IETF 95 on Monday April 4th, 14:50, there will be a presentation about a
> Microwave Radio Link Yang Model.
>
> The draft was unfortunately not properly uploaded in due time and there is
> therefore no link to the document in the CCAMP Agenda For IETF 95.
>
> I've instead used the CCAMP mailing list to reach out with the draft to all of
> you.
>
> The purpose of the draft is to provide a (starting point for a) standardized YANG
> model for configuration, status and statistics for the radio link interface in a
> microwave node.
>
> There is a similar activity to standardize a model for microwave in ONF, but the
> major differences are:
>
> ·         We believe that there are clear benefits to augment the YANG
> Model for Interface Management [RFC 7223] [1] and thereby use the same
> structure for radio  link as for most other interfaces in microwave node
>
>
> ·         Our intention is to cover a selected set of key parameters
> which we believe are enough for managing the core parts of a radio link and
> leave out the product/implementation specific parameters. If required, they
> can always be added as a vendor specific model augmenting the standardized
> radio link model.
>
> I will share more info in my presentation at IETF 95.
>
> Regards
>
> Jonas Ahlberg
>
> Links:
> ------
> [1] http://www.rfc-editor.org/rfc/rfc7223.txt
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Jonas Ahlberg <[email-masked]>
Date: Sun, 3 Apr 2016 20:00:54 +0000

Hi Luis, all,

It is correct that the overall goal to standardize a Data Model for management of microwave radio links is the same and I agree that duplicating standardization effort should be avoided.
In one way, in terms of attributes & use cases supported, our proposal is similar to the ONF model, but in another way it is fundamentally different.
The ONF model is based on the ONF CoreModel whereas our proposal is an extension of the IETF model for Interface Management. We believe that there are clear benefits with that approach and that's why we wanted to bring it to CCAMP WG in order to get feedback from the rest of the industry.

There are two main reasons for focusing on a selected set of key parameters and to propose a structure where vendor/implementation specific extensions can easily incorporated:
- to speed up standardization of a first version of a model. Areas where there are big differences between vendors can thereby be put in vendor specific models extending the standardized model and be introduced into standardization at a later stage once they become more mature.
- NOT to slow down innovation within microwave going forward. Technology evolution and innovation is fast and product introduction should not be dependent upon standardization which in many cases is slow.

Once we have better understanding of which type of structure the industry would like to see for management of microwave radio link, my hope is that ONF & IETF can work together to move the standardization forward in a good and efficient way.

Regards
JonasA

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of LUIS MIGUEL CONTRERAS MURILLO
Sent: den 2 april 2016 10:38
To: [email-masked]
Subject: Re: [CCAMP] Microwave Radio Link YANG Data Models

Hi Jonas, all,

Best regards

Luis

Technology and Planning
Transport, IP and Interconnection Networks Telefónica I+D / Global CTO unit / Telefónica

+34 680 947 650 new

> I've understood that some of you have had difficulties to open/read 
> the attached text file in my first mail and I'm therefore sending you 
> a version in PDF-format. The date in the header & footer has been 
> changed by the tool I used to generate the pdf-file, but otherwise the 
> content is identical with the text file.
>
> Regards
>
> JonasA
>
> At IETF 95 on Monday April 4th, 14:50, there will be a presentation 
> about a Microwave Radio Link Yang Model.
>
> The draft was unfortunately not properly uploaded in due time and 
> there is therefore no link to the document in the CCAMP Agenda For IETF 95.
>
> I've instead used the CCAMP mailing list to reach out with the draft 
> to all of you.
>
> The purpose of the draft is to provide a (starting point for a) 
> standardized YANG model for configuration, status and statistics for 
> the radio link interface in a microwave node.
>
> There is a similar activity to standardize a model for microwave in 
> ONF, but the major differences are:
>
> which we believe are enough for managing the core parts of a radio 
> link and leave out the product/implementation specific parameters. If 
> required, they can always be added as a vendor specific model 
> augmenting the standardized radio link model.
>

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição _______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp