Subject: [CCAMP] Question on referencing frequency slots in draft-ietf-ccamp-flexible-grid-ospf-ext-04.txt

From: Dieter Beller <[email-masked]>
Date: Fri, 24 Jun 2016 15:34:48 +0200

Hi co-authors of draft-ietf-ccamp-flexible-grid-ospf-ext,

I have a question regarding the OSPF spectrum advertisement for flex
grid. The draft states:

3.1. Available Frequency Ranges

In the case of flexi-grids, the central frequency steps from 193.1
THz with 6.25 GHz granularity. The calculation method of central
frequency and the frequency slot width of a frequency slot are
defined in [G.694.1], i.e., by using nominal central frequency n and
the slot width m.

On a DWDM link, the allocated or in-use frequency slots must not
overlap with each other. However, the border frequencies of two
frequency slots may be the same frequency, i.e., the highest
frequency of a frequency slot may be the lowest frequency of the
next frequency slot.

Frequency Slot 1 Frequency Slot 2
+-----------+-----------------------+
| | |
-9 -8 -7 -6 -5 -4 -3 -2 -1 0 1 2 3 4 5 6 7 8 9 10 11
...+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--+--...
------------ ------------------------
^ ^
Central F = 193.1THz Central F = 193.1375 THz
Slot width = 25 GHz Slot width = 50 GHz

Figure 1 - Two Frequency Slots on a Link

Figure 1 shows two adjacent frequency slots on a link. The highest
frequency of frequency slot 1 denoted by n=2 is the lowest frequency
of slot 2. In this example, it means that the frequency range from
n=-2 to n=10 is occupied and is unavailable to other flexi-grid LSPs.

The issue is that we have on one hand the central frequency which is
clearly defined by the n-value and we have on the other

hand the frequency slots defined as a spectrum range from central
frequency n to central frequency n+1 [n,n+1].

The question is now: how is a frequency slot [n, n+1] referenced? If
we define the frequency slot as an open interval on the

upper side: [n, n+1), it would be logical to reference the slot by
the lower endpoint n of the interval.

In the example above, this would mean that the frequency slot range
from n=-2 to n=9 is occupied.  n=-2 to n=10 is IMHO

a bit misleading. So, in the OSPF advertisement, the slot range [-2,
9] should be advertised as occupied.

I think that this should be made very clear in the draft.

Thanks,

Dieter

--

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Fri, 24 Jun 2016 14:17:14 +0000

Hi, Dieter,
   Thank you for the comments.   Please see my reply inline:
From: Dieter Beller [mailto:[email-masked]]
Sent: 2016年6月24日 21:35
To: Zhangxian (Xian); Zhenghaomian; [email-masked]; OSCAR GONZALEZ DE DIOS; Daniele Ceccarelli
Cc: [email-masked]
Subject: Question on referencing frequency slots in draft-ietf-ccamp-flexible-grid-ospf-ext-04.txt

I have a question regarding the OSPF spectrum advertisement for flex grid. The draft states:
3.1<https://tools.ietf.org/html/draft-ietf-ccamp-flexible-grid-ospf-ext-04#section-3.1>. Available Frequency Ranges

   defined in [G.694.1<https://tools.ietf.org/html/draft-ietf-ccamp-flexible-grid-ospf-ext-04#ref-G.694.1>], i.e., by using nominal central frequency n and

   the slot width m.

   next frequency slot.

                           |           |                       |

                                 ^                 ^

The issue is that we have on one hand the central frequency which is clearly defined by the n-value and we have on the other
hand the frequency slots defined as a spectrum range from central frequency n to central frequency n+1 [n,n+1].

The question is now: how is a frequency slot [n, n+1] referenced? If we define the frequency slot as an open interval on the
upper side: [n, n+1), it would be logical to reference the slot by the lower endpoint n of the interval.

In the example above, this would mean that the frequency slot range from n=-2 to n=9 is occupied.  n=-2 to n=10 is IMHO
a bit misleading. So, in the OSPF advertisement, the slot range [-2, 9] should be advertised as occupied.
[Xian]:  First, I think you meant that the frequency slot range from n=-1 and n=9 is occupied. Right?
I agree with you that the way it is described is a bit confusing since on one hand we use (n,m) to identify a label and in this example, we use (n1, n2) to describe the range.  But irrespective of which method, central frequency n=-2 and n=10 is not usable for setting a LSP. Do you agree?
If you remember the vote we have done before sent out by our chair Daniele, we voted out the range and list option and vote to only use bitmap to show available central frequencies. Given this, are you happy if we change it as below?

OLD

In this example, it means that the frequency range from
   n=-2 to n=10 is occupied and is unavailable to other flexi-grid LSPs.
NEW

In this example, it means that the central frequencies from n=-2 to n=10
   is unavailable to other flexi-grid LSPs.
BTW, I think we capture this also in the example provided in Section 4.1.2.
Regards,
Xian

Thanks,
Dieter
--

---

From: Dieter Beller <[email-masked]>
Date: Sat, 25 Jun 2016 12:23:08 +0200

Hi Xian, all,

thanks for your swift response!

I think that I understood now what the semantic of the advertised
available central frequencies is.

If the following sentence could be added to section 3,1, it would be
much clearer for the reader:

Available central frequencies are advertised
for m=1, which means that for an available central frequency n,
the frequency slot

from central frequency n-1 to central frequency n+1 is available.

For the example below, it would indeed mean for the bitmap that
central frequencies <= -3 and >= 11 are available while the

central frequencies in the range of {-2,...,+10} are occupied.

Thanks,

Dieter

On 24.06.2016 16:17, Zhangxian (Xian)
wrote:

Hi, Dieter,

Thank you for the
comments.   Please see my reply inline:

From: Dieter Beller
[mailto:[email-masked]]

Sent: 2016年6月24日 21:35

To: Zhangxian (Xian); Zhenghaomian;
[email-masked]; OSCAR GONZALEZ DE DIOS; Daniele
Ceccarelli

Cc: [email-masked]

Subject: Question on referencing frequency slots
in draft-ietf-ccamp-flexible-grid-ospf-ext-04.txt

Hi co-authors of
draft-ietf-ccamp-flexible-grid-ospf-ext,

I have a question regarding the OSPF spectrum advertisement
for flex grid. The draft states:

3.1.
Available
Frequency Ranges

the slot width m.

next frequency slot.

|           |                       |

^                 ^

The issue is that we have on one hand the
central frequency which is clearly defined by the n-value
and we have on the other

hand the frequency slots defined as a spectrum range from
central frequency n to central frequency n+1 [n,n+1].

The question is now: how is a frequency slot [n, n+1]
referenced? If we define the frequency slot as an open
interval on the

upper side: [n, n+1), it would be logical to reference the
slot by the lower endpoint n of the interval.

In the example above, this would mean that the frequency
slot range from n=-2 to n=9 is occupied.
n=-2 to n=10 is IMHO

a bit misleading. So, in the OSPF advertisement, the slot
range [-2, 9] should be advertised as occupied.

[Xian]:
First, I think you meant that the frequency slot range from
n=-1 and n=9 is occupied. Right?

I agree with you that the
way it is described is a bit confusing since on one hand we
use (n,m) to identify a label and in this example, we use
(n1, n2) to describe the range.  But irrespective of which
method, central frequency n=-2 and n=10 is not usable for
setting a LSP. Do you agree?

If you remember the vote
we have done before sent out by our chair Daniele, we voted
out the range and list option and vote to only use bitmap to
show available central frequencies. Given this, are you
happy if we change it as below?

OLD

n=-2 to n=10 is occupied and is unavailable to other
flexi-grid LSPs.

NEW

is unavailable to
other flexi-grid LSPs.

BTW, I think we capture
this also in the example provided in Section 4.1.2.

Regards,

Xian

Thanks,

Dieter

--

--

Dieter Beller

ASON/GMPLS Project Manager

IP/Optical Networks, Optics, Nokia

t: +49 711 821 43125 | m : +49 175 7266874 | OnNet: 259 43125

[email-masked]

Alcatel-Lucent
Deutschland AG | Lorenzstr. 10 | 70435 Stuttgart

Sitz
der Gesellschaft | Domicile of the Company: Stuttgart ·
Amtsgericht Stuttgart HRB 4026

Vorsitzender des Aufsichtsrates | Chairman of the Supervisory
Board: Prof. J. Menno Harms

Vorstand | Board of Management: Wilhelm Dresselhaus
(Vorsitzender | Chairman) · Hans-Jörg Daub · Ralf Niederberger

This e-mail and its attachments, if any, may contain
confidential information.

If you have received this e-mail in error, please notify us and
delete or destroy the e-mail and its attachments, if any,
immediately.

If you have received this e-mail in error, you must not forward
or make use of the e-mail and its attachments, if any.

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 29 Jun 2016 00:46:10 +0000

Hi, Dieter,

   Sure; We will add your suggested sentence in the next version.

Regards,
Xian

From: Dieter Beller [mailto:[email-masked]]
Sent: 2016年6月25日 18:23
To: Zhangxian (Xian); Zhenghaomian; [email-masked]; OSCAR GONZALEZ DE DIOS; Daniele Ceccarelli
Cc: [email-masked]
Subject: Re: Question on referencing frequency slots in draft-ietf-ccamp-flexible-grid-ospf-ext-04.txt

Hi Xian, all,

I think that I understood now what the semantic of the advertised available central frequencies is.

If the following sentence could be added to section 3,1, it would be much clearer for the reader:

Available central frequencies are advertised for m=1, which means that for an available central frequency n, the frequency slot
from central frequency n-1 to central frequency n+1 is available.

For the example below, it would indeed mean for the bitmap that central frequencies <= -3 and >= 11 are available while the
central frequencies in the range of {-2,...,+10} are occupied.

Thanks,
Dieter
On 24.06.2016 16:17, Zhangxian (Xian) wrote:
Hi, Dieter,
   Thank you for the comments.   Please see my reply inline:
From: Dieter Beller [mailto:[email-masked]]
Sent: 2016年6月24日 21:35
To: Zhangxian (Xian); Zhenghaomian; [email-masked]<mailto:[email-masked]>; OSCAR GONZALEZ DE DIOS; Daniele Ceccarelli
Cc: [email-masked]<mailto:[email-masked]>
Subject: Question on referencing frequency slots in draft-ietf-ccamp-flexible-grid-ospf-ext-04.txt

   the slot width m.

   next frequency slot.

                           |           |                       |

                                 ^                 ^

OLD

Thanks,
Dieter
--

--

Dieter Beller

t: +49 711 821 43125 | m : +49 175 7266874 | OnNet: 259 43125
[email-masked]<mailto:[email-masked]>
Alcatel-Lucent Deutschland AG | Lorenzstr. 10 | 70435 Stuttgart
Sitz der Gesellschaft | Domicile of the Company: Stuttgart · Amtsgericht Stuttgart HRB 4026
Vorsitzender des Aufsichtsrates | Chairman of the Supervisory Board: Prof. J. Menno Harms
Vorstand | Board of Management: Wilhelm Dresselhaus (Vorsitzender | Chairman) · Hans-Jörg Daub · Ralf Niederberger

This e-mail and its attachments, if any, may contain confidential information.
If you have received this e-mail in error, please notify us and delete or destroy the e-mail and its attachments, if any, immediately.
If you have received this e-mail in error, you must not forward or make use of the e-mail and its attachments, if any.