Subject: [CCAMP] Mirja Kühlewind's No Objection on draft-ietf-ccamp-additional-signal-type-g709v3-04: (with COMMENT)

From: "Mirja Kuehlewind" <[email-masked]>
Date: Mon, 13 Jun 2016 06:42:32 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ccamp-additional-signal-type-g709v3-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-additional-signal-type-g709v3/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Shouldn't [G.Sup43] be a normative reference...?

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 13 Jun 2016 18:59:15 +0200

Dear Mirja,

ITU-T Supplements (like G.Sup43) are not normative.
So it can not be referenced as normative.

Best regards, Huub.

----------
On 13-06-16 15:42, Mirja Kuehlewind wrote:
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 14 Jun 2016 21:58:43 +0000

Hi Mirja,

Just to add on top of what Huub correctly pointed out (thanks), ITU-T supplements are non-normative and hence interoperability at the data plane level is not guaranteed.  This is what the text tries to explain:

"These containers are non-standard data plane frame formats (not
   defined in ITU-T Recommendations). They are among some of the
   intra-domain approaches used in networks for transport of
   10GBASE-R signals in optical transport networks. As a
   Supplement, [G.Sup43], does not guarantee interoperability in
   the data plane for these containers."

Is the text clear enough or you think it ca be improved?

Thanks
Daniele

> -----Original Message-----
> From: Huub van Helvoort [mailto:[email-masked]]
> Sent: lunedì 13 giugno 2016 18:59
> To: Mirja Kuehlewind <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: [CCAMP] Mirja Kühlewind's No Objection on draft-ietf-ccamp-
> additional-signal-type-g709v3-04: (with COMMENT)
> 
> Dear Mirja,
> 
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> > Please refer to
> > https://www.ietf.org/iesg/statement/discuss-criteria.html

---

From: "Adrian Farrel \(NomCom\)" <[email-masked]>
Date: Wed, 15 Jun 2016 14:00:31 +0100

I think that Daniele's reasoning is good and explains why G.sup43 is not normatively referenced.

I think Huub provides useful information, but is not correct in his interpretation of what an IETF normative reference is: it is actually a document that needs to be read in order to understand the referencing document. 

Thus a supplement *could*in*theory* be normatively referenced from an IETF document, but in this case it is not a normative reference because it is only used as an example.

Adrian

> From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
> Sent: 14 June 2016 22:59
> To: [email-masked]; Mirja Kuehlewind; The IESG
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Just to add on top of what Huub correctly pointed out (thanks), ITU-T
> supplements are non-normative and hence interoperability at the data plane
> level is not guaranteed.  This is what the text tries to explain:
>

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 15 Jun 2016 18:18:42 +0200

Thanks Adrian,

Apparently I had my wrong hat on.

^_^

Cheers, Huub.

 > Adrian Farrel (NomCom) wrote:
 >

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 20 Jun 2016 11:44:52 +0200

Hi all,

thanks for clarification. I apparently have overlooked the text Daniele cited. I guess the text is fine.

Mirja

> Am 15.06.2016 um 15:00 schrieb Adrian Farrel (NomCom) <[email-masked]>:
>