Subject: [CCAMP] FW: New Version Notification for draft-zhang-ccamp-l1-topo-yang-03.txt

From: "Zhangxian (Xian)" <[email-masked]>
Date: Fri, 8 Jul 2016 06:40:44 +0000

Hi, All, 

  We have now updated this YANG model. The big change is that it now augments from ietf-te-topology.yang, as agreed a while ago.

  Comments are welcome.

Regards,
Xian on behalf of all authors

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 2016年7月7日 15:50
To: Anurag Sharma; Zhangxian (Xian); Raobaoquan; [email-masked]; Xufeng Liu
Subject: New Version Notification for draft-zhang-ccamp-l1-topo-yang-03.txt

A new version of I-D, draft-zhang-ccamp-l1-topo-yang-03.txt
has been successfully submitted by Xian Zhang and posted to the
IETF repository.

Name:		draft-zhang-ccamp-l1-topo-yang
Revision:	03
Title:		A YANG Data Model for Layer 1 (ODU) Network Topology
Document date:	2016-07-08
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/internet-drafts/draft-zhang-ccamp-l1-topo-yang-03.txt
Status:         https://datatracker.ietf.org/doc/draft-zhang-ccamp-l1-topo-yang/
Htmlized:       https://tools.ietf.org/html/draft-zhang-ccamp-l1-topo-yang-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-zhang-ccamp-l1-topo-yang-03

Abstract:
   A transport network is a server-layer network designed to provide
   connectivity services for a client-layer network to carry the client
   traffic opaquely across the server-layer network resources.  A
   transport network may be constructed from equipment utilizing any of
   a number of different transport technologies such as the evolving
   optical transport infrastructure (Synchronous Optical Networking
   (SONET) / Synchronous Digital Hierarchy (SDH) and Optical Transport
   Network (OTN)) or packet transport as epitomized by the MPLS
   Transport Profile (MPLS-TP).

   This draft describes a YANG data model to manipulate the topologies
   of a layer 1 Optical Transport Network (OTN). It is independent of
   control plane protocols and captures topology related information
   pertaining to OTN and also enables manipulation (e.g., obtaining) of
   an OTN network.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 08 Jul 2016 23:12:20 +0200

Dear Xian and other authors,

I have carefully read your draft, and I have a number of comments.

 > URL: 
https://www.ietf.org/internet-drafts/draft-zhang-ccamp-l1-topo-yang-03.txt

I suggest to change the title of this draft into:
"A YANG Data Model for Optical Transport Network (OTN) Topology"

The reason is that OTN has also layer 2 capabilities, and ODU is
only one frame structure in the OTN.

In "Abstract" and "Introduction"
= replace "opaquely" by "transparently"
= remove "evolving" SDH/SONEt are already 25 years in the filed
   and OTN already 15 years
= replace "Networking (SONET)" by "Network (SONET)"
= replace "epitomized" by "provided"
= replace "manipulate" by "manage"
= replace "a layer 1" by "an"
= replace "manipulation" by "management"
= replace "obtaining" by provisioning"

In "Introduction"
= first bullit: remove "maybe"
= second bullit: replave "enforce" by "provision"
= replace "electronic" by "electric"

= question: why is the optical part of OTN not included?

= replace
"Other network layers, such as fixed
    Dense Wavelength Switched Optical Network (WSON) and flexible
    optical networks (a.k.a., flexi-grid networks) are covered in [WSON-
    YANG] and [Flexi-YANG], respectively."
by
"Other optical network technologies, such as fixed Dense Wavelength
  Division Multiplex (DWDM) Switched Optical Network (WSON) and flexible
  DWDM networks (a.k.a., flexi-grid networks) are covered in [WSON-
  YANG] and [Flexi-YANG], respectively."

Section 4:
= replace "Layer 1" by "OTN" (throughout the whole draft)

Section 4.1:
module: ietf-odu-topology
= question: why "fec-enabled" an ODU has no FEC, FEC is part of OTU.

= replace "timeslots" by tributaryslots"

= question: why "distance", ODU transport is independent of distance
= question: why only "oduflex-bw" and not odu-bw, ODU1, ODU2, ODU3 and
   ODU4 have different bandwidth

Section 4.2:
module ietf-odu-topology
= replace "description "TBD"" by "description "SDH/SONET section""

= question: OTN has LO-ODU and HO-ODU, I would expect also
        enum ODU {
          description "Optical Data Unit";
        }

= in "Groupings" replace "l1-network" by "OTN"

= "distance" is a property for the optical port in OTN, not the ODU.

= replace "ODU type scedhuled" by "ODU type scheduled"
= replace "banwidth for ODUflex" by "bandwidth for ODUflex"

= missing ODUk bandwidth

= "fec-enabled" is only applicable to OTUk termination point

= replace "container timeslots" by "container tributaryslots"
= replace "tributary timeslots" by "tributary slots"
= replace "Tributary timeslot value" by "Tributary slot value"

Section 5"
= replace "manipulated" by "managed"

Best regards, Huub.

-- 
=================================================================
Always remember that you are unique... just like everyone else...