Subject: [Cellar] FLAC Repository

From: Andrew Weaver <[email-masked]>
Date: Tue, 8 Jan 2019 09:29:29 -0800

Hello All,

I wanted to float the idea again of the creation of a new more
centralized/obviously CELLAR affiliated repository for the continuation of
the work on FLAC.

This came up at the IETF meeting in 2017, where it was thought that moving
the work to date out of its current location on my personal github (
https://github.com/privatezero/flac_markdown) would facilitate
participation and visibility for the efforts. This should also allow a
little better management of permissions etc.

If there was consensus about this vis-a-vis name etc, I would be happy to
set this up.

All the best,
Andrew

---

From: Ashley Blewer <[email-masked]>
Date: Tue, 8 Jan 2019 12:34:42 -0500

+1, I agree with this. It is probably worth hitting up the FLAC listserv
with some reminders about this too, and keeping them up to date with the
work that happens here.

Ashley

On Tue, Jan 8, 2019 at 12:29 PM Andrew Weaver <[email-masked]> wrote:

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

---

From: Dave Rice <[email-masked]>
Date: Tue, 8 Jan 2019 14:24:50 -0500

Uncertain if the IETF provides specific guidance with this, but I’m okay with the markdown work happening in either your repo or an organization account as long as the repo’s maintainer is active in the group and in the management of pull requests and issues. The working group data tracker is where official versioning will happen, so the github repo is a bit more behind the scenes.
Dave

> On Jan 8, 2019, at 12:34 PM, Ashley Blewer <[email-masked]> wrote:
> 
> +1, I agree with this. It is probably worth hitting up the FLAC listserv with some reminders about this too, and keeping them up to date with the work that happens here.
> 
> Ashley
> 
> On Tue, Jan 8, 2019 at 12:29 PM Andrew Weaver <[email-masked] <mailto:[email-masked]>> wrote:
> Hello All,
> 
> I wanted to float the idea again of the creation of a new more centralized/obviously CELLAR affiliated repository for the continuation of the work on FLAC.
> 
> This came up at the IETF meeting in 2017, where it was thought that moving the work to date out of its current location on my personal github (https://github.com/privatezero/flac_markdown <https://github.com/privatezero/flac_markdown>) would facilitate participation and visibility for the efforts. This should also allow a little better management of permissions etc.
> 
> If there was consensus about this vis-a-vis name etc, I would be happy to set this up.
> 
> All the best,
> Andrew
> 
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>

---

From: Andrew Weaver <[email-masked]>
Date: Tue, 8 Jan 2019 11:35:51 -0800

With regards to maintaining the repo, I would be quite happy to continue
managing that along the lines of what you describe. Additionally I could
then invite the people who are currently 'collaborators' on the repo to
have ownership privileges. That feels to me a little bit more open and
democratic for the work rather than the current version where I have de
facto control.

On Tue, Jan 8, 2019 at 11:24 AM Dave Rice <[email-masked]> wrote:

> Uncertain if the IETF provides specific guidance with this, but I’m okay
> with the markdown work happening in either your repo or an organization
> account as long as the repo’s maintainer is active in the group and in the
> management of pull requests and issues. The working group data tracker is
> where official versioning will happen, so the github repo is a bit more
> behind the scenes.
> Dave
>
>> This came up at the IETF meeting in 2017, where it was thought that
>> moving the work to date out of its current location on my personal github (

---

From: Dave Rice <[email-masked]>
Date: Tue, 8 Jan 2019 14:48:23 -0500

You could add a README.md that expresses that. I see some related boilerplate in this search: https://github.com/search?q=ietf+working+group+readme.md&type=Code <https://github.com/search?q=ietf+working+group+readme.md&type=Code>.
Dave

> On Jan 8, 2019, at 2:35 PM, Andrew Weaver <[email-masked]> wrote:
> 
> With regards to maintaining the repo, I would be quite happy to continue managing that along the lines of what you describe. Additionally I could then invite the people who are currently 'collaborators' on the repo to have ownership privileges. That feels to me a little bit more open and democratic for the work rather than the current version where I have de facto control.
> 
> On Tue, Jan 8, 2019 at 11:24 AM Dave Rice <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jan 8, 2019, at 12:34 PM, Ashley Blewer <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 08 Jan 2019 17:02:11 -0500

Dave Rice <[email-masked]> wrote:
    > Uncertain if the IETF provides specific guidance with this, but I’m
    > okay with the markdown work happening in either your repo or an

The IETF now prefers the repos to be in an organization account.
    e.g:    ROLL has https://github.com/roll-wg
           ANIMA has https://github.com/anima-wg

We haven't created one for CELLAR, and to first order
   https://github.com/Matroska-Org

has provided this.    If the FLAC work just doesn't fit in for some reason I
can create a new org, but I don't see a pressing need.

BTW: I want to point a few internet drafts will expire this week, and
     it would be good to post refreshes this wek.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Dave Rice <[email-masked]>
Date: Wed, 9 Jan 2019 11:49:45 -0500

Hi,

> On Jan 8, 2019, at 5:02 PM, Michael Richardson <[email-masked]> wrote:
> 

I’d prefer to have a https://github.com/cellar-wg <https://github.com/cellar-wg> organizational account to provide the appearance that the work is underway under the context of the IETF rather than the individuals or source communities that are hosting currently. That would allow Andrew to transfer the repository from his account to a shared one of the working group.

>     it would be good to post refreshes this wek.

I see this is happening with the Codec Mappings and Metadata Tags documents for Matroska. I’ll post updates before they expire. I’ll check on the FLAC output as well since that document had already expired.
Dave Rice

---

From: Reto Kromer <[email-masked]>
Date: Wed, 9 Jan 2019 18:45:44 +0100

Dave Rice wrote:

>I’d prefer to have a https://github.com/cellar-wg
>organizational account to provide the appearance that the
>work is underway under the context of the IETF rather than
>the individuals or source communities that are hosting
>currently.

+1

Best regards, Reto

---

From: Andrew Weaver <[email-masked]>
Date: Wed, 9 Jan 2019 10:57:24 -0800

+1 to Dave's suggestions as well (both for repository and development of
the README to include more IETF project info).

Best,
Andrew

---

From: Michael Richardson <[email-masked]>
Date: Wed, 09 Jan 2019 16:05:39 -0500

https://github.com/cellar-wg now exists.

I've invited a few people whose github IDs I could find easily, but
I'm sure that there are another 6-8 that should be invited.

Please unicast github ID to me.

Repos can be moved to the organization, or forked into the organization,
please send me a list: I don't want to surprise anyone.

---

From: Andrew Weaver <[email-masked]>
Date: Wed, 9 Jan 2019 14:28:27 -0800

Quick follow-up, the repository containing the work to date on converting
FLAC to Markdown has been transferred to the new cellar-wg repository.
Thanks for creating that Michael!

Best,
Andrew

---

From: Reto Kromer <[email-masked]>
Date: Thu, 10 Jan 2019 12:12:48 +0100

Andrew Weaver wrote:

>Quick follow-up, the repository containing the work to date on
>converting FLAC to Markdown has been transferred to the new
>cellar-wg repository.

Thank you very much indeed, Andrew! Reto

---

From: Dave Rice <[email-masked]>
Date: Thu, 10 Jan 2019 09:01:28 -0500

Hi Michael, Tim,

> On Jan 9, 2019, at 11:49 AM, Dave Rice <[email-masked]> wrote:
> 

New Matroska documents are posted at:
https://datatracker.ietf.org/doc/draft-ietf-cellar-matroska/
https://datatracker.ietf.org/doc/draft-ietf-cellar-tags/
https://datatracker.ietf.org/doc/draft-ietf-cellar-codec/

The FLAC document is expired at https://datatracker.ietf.org/doc/draft-xiph-cellar-flac/.
I tried to post an update, but get an error since it was never approved and I don’t have access to the full submission url. I think this happened since within the document no one in the working group is listed as an author and the two listed authors, J. Coalson and Xiph.Org Foundation, aren’t listed within the document by email.

When I try to access the submission of draft-xiph-cellar-flac-01 I get this error but no contact.
> You are not allowed to modify or cancel this submission. You can only modify or cancel this submission from the same URL you were redirected to after the submission.
> If you are the submitter check your browser history to find this URL. You can share it with any person you need.
> If you are one of the authors you can request the URL from which you can modify or cancel this submission by clicking the next button. An email will then be sent to the authors and submitter (if submitter email was entered): .

Thus far, Andrew Weaver, has contributed the most of the document beyond what J. Coalson and Xiph have done. Perhaps Andrew should add himself as a co-author so that we can submit this more easily in the future.

Tim,
See the paragraphs above regarding xiph, is there an xiph author email that we can use in this document.

Also one way around the error with draft-xiph-cellar-flac-01 may be that I submit the current state of the document as draft-ietf-cellar-flac-00 if it’s fair to upgrade this to a working group document.
Dave

---

From: Michael Richardson <[email-masked]>
Date: Thu, 10 Jan 2019 12:01:42 -0500

Dave Rice <[email-masked]> wrote:
    > The FLAC document is expired at
    > https://datatracker.ietf.org/doc/draft-xiph-cellar-flac/.  I tried to
    > post an update, but get an error since it was never approved and I
    > don’t have access to the full submission url. I think this happened
    > since within the document no one in the working group is listed as an
    > author and the two listed authors, J. Coalson and Xiph.Org Foundation,
    > aren’t listed within the document by email.

So, basically the new authors and old authors have none in common, so
it gets rejected and nobody who can respond to the approval email.
Can you forward the email you got directly?

Please just upload it with a new name, i.e:
       draft-rice-cellar-flac

and I'll mark it as replacing xiph-cellar-flac.

---

From: Dave Rice <[email-masked]>
Date: Thu, 10 Jan 2019 12:10:06 -0500

Hi Michael,

> On Jan 10, 2019, at 12:01 PM, Michael Richardson <[email-masked]> wrote:
> 

I never received an email since I’m not an author, no author emails were listed in the document. I was only the submitted and my contributions to the document were more about formatting than authoring.

> and I'll mark it as replacing xiph-cellar-flac.

Should I restart the versioning to 00 in that case?
Dave Rice

---

From: Michael Richardson <[email-masked]>
Date: Thu, 10 Jan 2019 12:20:11 -0500

Dave Rice <[email-masked]> wrote:
    >>> author and the two listed authors, J. Coalson and Xiph.Org
    >>> Foundation, aren’t listed within the document by email.
    >>

    > I never received an email since I’m not an author, no author emails
    > were listed in the document. I was only the submitted and my
    > contributions to the document were more about formatting than
    > authoring.

    >> Please just upload it with a new name, i.e: draft-rice-cellar-flac
    >>

    > Should I restart the versioning to 00 in that case?

Yes.

---

From: Andrew Weaver <[email-masked]>
Date: Thu, 10 Jan 2019 13:09:14 -0800

Hi all,

New FLAC documents have been posted at:
https://datatracker.ietf.org/doc/draft-weaver-cellar-flac/

Best,
Andrew