Subject: [Cellar] AGENDA 2019-07-30 Virtual Interim meeting

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 13:25:44 -0400

CELLAR -- DRAFT AGENDA for Virtual Interim Meeting
July 30, 2019        20:00 UTC

INFO:
   https://datatracker.ietf.org/meeting/interim-2019-cellar-06/session/cellar
   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-06-sessa/

WEB CONFERENCE:
   https://appear.in/cellar-interim
   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
   These notes at: https://github.com/cellar-wg/chair-notes

1. Note Well.
2. Accept draft minutes from June 25 meeting (attached below)

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true

   2b) APPEAR.IN for video and screen sharing.
       https://appear.in/cellar-interim

   2c) Roll call

4. WG status update
   * EBML -- still waiting on revised -11 document for AD evaluation.
ACTION from last time:
       	==> issue #257, requested one more day to think about it. The changes
            are fine in general, but want to make sure it precise enough. (MB) 

   * Thank for reposting of draft-ietf-cellar-tags-02,
         draft-ietf-cellar-matroska-03  and draft-ietf-cellar-codec-02
   * The personal draft-weaver-cellar-flac-00 did not get reposted.
     I believe that we adopted it, so it should have been reposted with a
     draft-ietf-cellar-flac-00!

5. Any remining EBML issues.

5. Work on Matroska issues.

6. Any other business.

====
	CELLAR -- DRAFT MINUTES for Virtual Interim Meeting
	June 25, 2019        20:00 UTC
	
	INFO:
	   https://datatracker.ietf.org/meeting/interim-2019-cellar-05/session/cellar
	   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-05-sessa/
	
	WEB CONFERENCE:
	   https://appear.in/cellar-interim
	   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
	   These notes at: https://github.com/cellar-wg/chair-notes

	Present:
		1) Michael Richardson
		2) Moritz Bunkus
		3) Martin Below
		4) Steve Lhomme
		5) Dave Rice
		6) Jérôme Martinez
		
Regrets:
    1) Reto Kromer

	1. Note Well.
	2. Accept draft minutes from May 28 meeting
		accepted without change.
	
	3. Logistics for Meeting.
	   2a) Etherpad for notes
	       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true
	
	   2b) APPEAR.IN for video and screen sharing.
	       https://appear.in/cellar-interim
	
	   2c) Roll call
	
4. WG status update
	   * MCR still need to help Martin on large pull request.
	   * EBML changes... done.
		+ issue #257, requested one more day to think about it. The changes are fine in general, but want to make sure it precise enough. (MB)
	   * ffv1 has been submitted to IESG by AD.
	
5. Work on Matroska issues.
	      48 open issues
	      21 open pull requests
		https://github.com/cellar-wg/matroska-specification/issues
		
		Next time, Steve will walk us through XSLT code to validate the specification.
TAG:
     "format extension"   suggestion that does not have to go into the main spec, because it could be added as separate spec   https://github.com/cellar-wg/matroska-specification/issues?q=is%3Aissue+is%3Aopen+label%3A%22format+extension%22
	"format addition"     something that has to go into main specification.   https://github.com/cellar-wg/matroska-specification/issues?q=is%3Aissue+is%3Aopen+label%3A%22format+addition%22
	
* As the WebM will not be defined, remove all of the WebM specific stuff.
	* MCR suggests removing it from the Matroska document, and leave the history for others.
	* MB: DivX is also not part of Matroska.  Also concerned about how the Matroska project presents the WebM/DiVX vs core Matroska elements.   The spec will be huge, so take things out.

* define how to add unpredictable data to the Matroska, so we could track things that are added.  Not just WebM, but also a libmotrsaka as well.
* extension data would be on their own lines, and revision history would be clearly.

	6. Any other business.

	

	====
	CELLAR -- DRAFT MINUTES for Virtual Interim Meeting
	May 28, 2019        20:00 UTC
	
	INFO:
	   https://datatracker.ietf.org/meeting/interim-2019-cellar-04/session/cellar
	   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-04-sessa/
	
	WEB CONFERENCE:
	   https://appear.in/cellar-interim
	   THERE IS NO TELEPHONE DIALIN
	   You can try this at any time.
	   These notes at: https://github.com/cellar-wg/chair-notes
	
	Present:
	        1) michael richardson
	        2) Steve Lhomme
	        3) Martin Below
	        4) Jerome Martinez
	        5) Dave Rice
	        6)  Michael Niedermayer
	
	Proposed Agenda:
	
	1. Note Well.
	2. Accept draft minutes from April 2 meeting
	
	3. Logistics for Meeting.
	   2a) Etherpad for notes
	       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true
	
	   2b) APPEAR.IN for video and screen sharing.
	       https://appear.in/cellar-interim
	       (as agreed last meeting)
	
	   2c) Roll call
	
	4. WG status update
	   - EBML seems to be getting some additional edits, is it done?
	     These were the issues that are waiting for clarification:
	        https://github.com/Matroska-Org/ebml-specification/issues?q=is%3Aissue+is%3Aopen+label%3Aclarifications
	     We still have a few open.  Can we close them now?
	     Dave Rice expected to push version 10....
	     VERSION 10 released 2019-05-28 (https://datatracker.ietf.org/doc/draft-ietf-cellar-ebml/10/).  Merged many issues.
	     This addresses AD issues from Ben Campbell and Robert Sparks.... remaining 2
	      11.1.11.  XML Schema for EBML Schema (Dave volunteers to complete this)
	            The following "XSD" definition is in <FORMAT> (add W3C citation), and can be used to validate an EBML Schema using <TOOL>
	
	        The use of unknown-size requires to know the EBML Schema. Add an example of unknown-size element.
	
	Michael will contact Martin in the coming days/weeks to work on his large chapter pull request.
	
	5. Matroska document changes since last meeting.
	   https://github.com/cellar-wg/matroska-specification/issues
	   Can we close some of these, and/or get them sorted and prioritized?
	
	   a) Dave Rice to post request for volunteers, offers to mentor.
	   b) MCR to mentor Martin on github-fu
	   c) all to review pull requests on Matroska, look for conflicts and *discussion* (new tag) that we can go through next time.
	   d) MCR to ping Moritz about next time.
	
	6. Started 4-week adopting call for Free Lossless Audio Codec
	      draft-weaver-cellar-flac-00
	   will end at next virtual-interim meeting.
	
	           please post your opinion about the document? Does it fit into what the charter asked for?
	
	Q: ffv1. last meeting new AD?
	A: we are waiting for feedback.
	ACTION: mcr to bug AD about ffv1.
	
	meeting ended 16:55.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Jerome Martinez <[email-masked]>
Date: Tue, 30 Jul 2019 21:43:03 +0200

Apologies but I'll not be able to join the meeting this time.Draft minutes from last meeting are fine for me, and as usual my questions today would be about the follow up of ffv1 spec status.Jérôme Sent from my smartphone
-------- Message d'origine --------De : Michael Richardson <[email-masked]> Date : 29/07/2019  19:25  (GMT+01:00) À : [email-masked] Objet : [Cellar] AGENDA 2019-07-30 Virtual Interim meeting CELLAR -- DRAFT AGENDA for Virtual Interim MeetingJuly 30, 2019        20:00 UTCINFO:   https://datatracker.ietf.org/meeting/interim-2019-cellar-06/session/cellar   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-06-sessa/WEB CONFERENCE:   https://appear.in/cellar-interim   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)   These notes at: https://github.com/cellar-wg/chair-notes1. Note Well.2. Accept draft minutes from June 25 meeting (attached below)3. Logistics for Meeting.   2a) Etherpad for notes       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true   2b) APPEAR.IN for video and screen sharing.       https://appear.in/cellar-interim   2c) Roll call4. WG status update   * EBML -- still waiting on revised -11 document for AD evaluation.ACTION from last time:       	==> issue #257, requested one more day to think about it. The changes            are fine in general, but want to make sure it precise enough. (MB)    * Thank for reposting of draft-ietf-cellar-tags-02,         draft-ietf-cellar-matroska-03  and draft-ietf-cellar-codec-02   * The personal draft-weaver-cellar-flac-00 did not get reposted.     I believe that we adopted it, so it should have been reposted with a     draft-ietf-cellar-flac-00!5. Any remining EBML issues.5. Work on Matroska issues.6. Any other business.====	CELLAR -- DRAFT MINUTES for Virtual Interim Meeting	June 25, 2019        20:00 UTC		INFO:	   https://datatracker.ietf.org/meeting/interim-2019-cellar-05/session/cellar	   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-05-sessa/		WEB CONFERENCE:	   https://appear.in/cellar-interim	   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)	   These notes at: https://github.com/cellar-wg/chair-notes			Present:		1) Michael Richardson		2) Moritz Bunkus		3) Martin Below		4) Steve Lhomme		5) Dave Rice		6) Jérôme Martinez		Regrets:    1) Reto Kromer		1. Note Well.	2. Accept draft minutes from May 28 meeting		accepted without change.		3. Logistics for Meeting.	   2a) Etherpad for notes	       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true		   2b) APPEAR.IN for video and screen sharing.	       https://appear.in/cellar-interim		   2c) Roll call	4. WG status update	   * MCR still need to help Martin on large pull request.	   * EBML changes... done.		+ issue #257, requested one more day to think about it. The changes are fine in general, but want to make sure it precise enough. (MB)	   * ffv1 has been submitted to IESG by AD.	5. Work on Matroska issues.	      48 open issues	      21 open pull requests		https://github.com/cellar-wg/matroska-specification/issues				Next time, Steve will walk us through XSLT code to validate the specification.TAG:     "format extension"   suggestion that does not have to go into the main spec, because it could be added as separate spec   https://github.com/cellar-wg/matroska-specification/issues?q=is%3Aissue+is%3Aopen+label%3A%22format+extension%22	"format addition"     something that has to go into main specification.   https://github.com/cellar-wg/matroska-specification/issues?q=is%3Aissue+is%3Aopen+label%3A%22format+addition%22	* As the WebM will not be defined, remove all of the WebM specific stuff.	* MCR suggests removing it from the Matroska document, and leave the history for others.	* MB: DivX is also not part of Matroska.  Also concerned about how the Matroska project presents the WebM/DiVX vs core Matroska elements.   The spec will be huge, so take things out.* define how to add unpredictable data to the Matroska, so we could track things that are added.  Not just WebM, but also a libmotrsaka as well.* extension data would be on their own lines, and revision history would be clearly.			6. Any other business.												====	CELLAR -- DRAFT MINUTES for Virtual Interim Meeting	May 28, 2019        20:00 UTC		INFO:	   https://datatracker.ietf.org/meeting/interim-2019-cellar-04/session/cellar	   https://datatracker.ietf.org/doc/agenda-interim-2019-cellar-04-sessa/		WEB CONFERENCE:	   https://appear.in/cellar-interim	   THERE IS NO TELEPHONE DIALIN	   You can try this at any time.	   These notes at: https://github.com/cellar-wg/chair-notes		Present:	        1) michael richardson	        2) Steve Lhomme	        3) Martin Below	        4) Jerome Martinez	        5) Dave Rice	        6)  Michael Niedermayer		Proposed Agenda:		1. Note Well.	2. Accept draft minutes from April 2 meeting		3. Logistics for Meeting.	   2a) Etherpad for notes	       https://etherpad.tools.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true		   2b) APPEAR.IN for video and screen sharing.	       https://appear.in/cellar-interim	       (as agreed last meeting)		   2c) Roll call		4. WG status update	   - EBML seems to be getting some additional edits, is it done?	     These were the issues that are waiting for clarification:	        https://github.com/Matroska-Org/ebml-specification/issues?q=is%3Aissue+is%3Aopen+label%3Aclarifications	     We still have a few open.  Can we close them now?	     Dave Rice expected to push version 10....	     VERSION 10 released 2019-05-28 (https://datatracker.ietf.org/doc/draft-ietf-cellar-ebml/10/).  Merged many issues.	     This addresses AD issues from Ben Campbell and Robert Sparks.... remaining 2	      11.1.11.  XML Schema for EBML Schema (Dave volunteers to complete this)	            The following "XSD" definition is in <FORMAT> (add W3C citation), and can be used to validate an EBML Schema using <TOOL>		        The use of unknown-size requires to know the EBML Schema. Add an example of unknown-size element.		Michael will contact Martin in the coming days/weeks to work on his large chapter pull request.		5. Matroska document changes since last meeting.	   https://github.com/cellar-wg/matroska-specification/issues	   Can we close some of these, and/or get them sorted and prioritized?		   a) Dave Rice to post request for volunteers, offers to mentor.	   b) MCR to mentor Martin on github-fu	   c) all to review pull requests on Matroska, look for conflicts and *discussion* (new tag) that we can go through next time.	   d) MCR to ping Moritz about next time.		6. Started 4-week adopting call for Free Lossless Audio Codec	      draft-weaver-cellar-flac-00	   will end at next virtual-interim meeting.		           please post your opinion about the document? Does it fit into what the charter asked for?		Q: ffv1. last meeting new AD?	A: we are waiting for feedback.	ACTION: mcr to bug AD about ffv1.		meeting ended 16:55.				-- Michael Richardson <[email-masked]>, Sandelman Software Works -= IPv6 IoT consulting =-_______________________________________________Cellar mailing [email-masked]://www.ietf.org/mailman/listinfo/cellar

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Jul 2019 18:51:56 -0400

Here are the minutes from today's meeting.
We tried to resolve issue #257 that was keeping us from issuing the EBML-11
document need for the AD review, but wind up creating issue #279.

We tried to resolve Matroska issue #334 and related issue #308, but failed.

An important thing is that we agreed to move the time of the meeting
From "20:00UTC" which right now is 22:00 (10PM) Central European Daylight
Savings Time (CET), to be anchored at 21:00 Amsterdam/Berlin time.

That means that it stays at the same time in Europe, but bounces around
slightly for North American types. (Only Oct. 29 is off)

====

	Present:
		1) Michael Richardson
		2) Timothy B. Terriberry
		3) Steve Lhomme
		4) Martin Below
		5) Dave Rice
		6) Michael Niedermeier
		
Regrets:
	    Jerome Martinez
	
	INFO:
	
	WEB CONFERENCE:
	
	1. Note Well.
		https://www.ietf.org/about/note-well/
		
	2. Accept draft minutes from June 25 meeting (attached below)
		No objections/changes, minutes passed.

	
	   2c) Roll call
	
	4. WG status update
	   * EBML -- still waiting on revised -11 document for AD evaluation.
	ACTION from last time:
	               ==> issue #257, requested one more day to think about it. 
						The changes
	            are fine in general, but want to make sure it precise enough. (MB) 
	
	We created issue #279 to introduce some new text to better explain what a Global Element is, and why it does not end an unlimited size Element.

	
	reposted today, thank you.

	none known.
	
	6. ffv1-07 could be reposted in v3 format.
	ACTION: mcr to ask DataTracker and RSE if they are ready for this.
	
	7. Work on Matroska issues.
	
	Closed issue #325 (merged).
	Discussed issue #334 and related issue #308.
	
	8. Any other business.
	
	Matroska Pull request #318 will be on the agenda for next time.
	
	Meeting will be moved to an hour earlier, until the time changes.
	Currently it is 23:00 Berlin, so we will anchor the meeting to 22:00 Berlin time.
	
	====
	        
	        INFO:
	        
	        WEB CONFERENCE:

	        Present:
	                1) Michael Richardson
	                2) Moritz Bunkus
	                3) Martin Below
	                4) Steve Lhomme
	                5) Dave Rice
	                6) Jérôme Martinez
	                
	Regrets:
	    1) Reto Kromer

	        1. Note Well.

	        
	           2c) Roll call
	        
	4. WG status update

	        

	        6. Any other business.

---

From: Reto Kromer <[email-masked]>
Date: Wed, 31 Jul 2019 07:55:45 +0200

Michael Richardson wrote:

>From "20:00UTC" which right now is 22:00 (10PM) Central
>European Daylight Savings Time (CET), to be anchored at 21:00
>Amsterdam/Berlin time.

Thank you very much indeed! Reto