Subject: [Cellar] A few minor comments on draft-ietf-cellar-ebml-13

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 24 Oct 2019 13:47:05 +0100

Hi,

Thank you for addressing most of my AD review comments. I followed up on a few remaining issues in a separate thread.

I just reviewed changed since version -10 and have a few new minor comments:

I think [W3C.REC-xmlschema-0-20041028] should be a Normative Reference, because of how it is referenced in Section 11.1.15. (I assume the XML Schema there is normative.)

It would be good to have an example of <implementation_note> in the document.

In Section 11.1.5.8 the following test was added:

   An unwritten mandatory
   Element with a declared default value is semantically to that Element

I think the word "equivalent" is missing after "semantically".

   if written with the default value stored as the Element Data.

I would ask editors to address these in the next revision. However the above are not serious enough to delay IETF LC, so I will start it now.

Best Regards,
Alexey

---

From: Dave Rice <[email-masked]>
Date: Thu, 24 Oct 2019 12:25:51 -0400

Thank you Alexey,

> On Oct 24, 2019, at 8:47 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi,
> 
> I would ask editors to address these in the next revision.

I started a pull request to address the noted 3 issues (changing a reference to normative, offering an implementation_note example, and adding the missing word). See: https://github.com/cellar-wg/ebml-specification/pull/297 <https://github.com/cellar-wg/ebml-specification/pull/297>.

> However the above are not serious enough to delay IETF LC, so I will start it now.
> 
> Best Regards,
> Alexey
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar