Subject: [Cellar] 2020-04-28 VIRTUAL INTERIM AGENDA (TOMORROW, TUESDAY)

From: Michael Richardson <[email-masked]>
Date: Mon, 27 Apr 2020 13:48:37 -0400

The DT sometimes posts these on it's own, but it seems not have done so last night.

CELLAR -- DRAFT AGENDA for Virtual Interim Meeting
April  28, 2020        21:00 Amsterdam  ***
                       19:00 UTC
                       15:00 NYC
                       12:00 San Francisco

INFO:
   https://datatracker.ietf.org/meeting/interim-2020-cellar-04/session/cellar
   https://datatracker.ietf.org/doc/agenda-interim-2020-cellar-04-cellar-01/

WEB CONFERENCE:
   https://whereby.com/cellar-interim
   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
   These notes at: https://github.com/cellar-wg/chair-notes

1. Note Well.  https://www.ietf.org/about/note-well/
2. Accept draft minutes from March 31 meeting (attached below)

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true

   2b) APPEAR.IN is now called "whereby.com"
       https://whereby.com/cellar-interim

   2c) Roll call

4. WG status update
   * EBML -- still in RFC-editor queue, waiting to get to top
   * FFV1 -- version 12 was posted 2020-01-28
   *** NEEDS REVISED VERSION ***
       - Can someone help?

5. Extension drafts on Matroska

6. Work on Matroska issues.

NEXT MEETING May 26, 2020.

---- PREVIOUS NOTES

CELLAR -- DRAFT AGENDA for Virtual Interim Meeting
March  31, 2020
				  21:00 Amsterdam  ***
                       19:00 UTC
                       15:00 NYC
                       12:00 San Francisco

Present:
	1. Michael Richardson
	1. Martin Below
	1. Steve Lhomme
	1. Jerome Martinez
	1. Spencer Dawkins
	1. Dave Rice
	1. Adam

INFO:
   https://datatracker.ietf.org/meeting/interim-2020-cellar-03/session/cellar
   https://datatracker.ietf.org/doc/agenda-interim-2020-cellar-03-cellar-01/

WEB CONFERENCE:
   https://whereby.com/cellar-interim
   THERE IS NO TELEPHONE DIALIN (You can try this at any time.)
   These notes at: https://github.com/cellar-wg/chair-notes

1. Note Well.  https://www.ietf.org/about/note-well/
2. Accept draft minutes from January 28 meeting (attached below)
   (Feb. 25 meeting did not achieve quorum)
	   accepted unanimously.

3. Logistics for Meeting.
   2a) Etherpad for notes
       https://etherpad.ietf.org/p/notes-cellar-virtual?useMonospaceFont=true

   2b) APPEAR.IN is now called "whereby.com"
       https://whereby.com/cellar-interim

   2c) Roll call

4. WG status update
   * EBML -- version 17 was posted 2020-01-27
             IESG approved it, and it is now in RFC-editor queue.
             IANA has reviewed it, created registries.
             Guestimate is that RFC-editor will complete work by end of March, maybe sooner.

    proposed Designated Experts: Primary:     Dave Rice
                                Secondary:   Steve Lhomme and Moritz Bunkus

   * FFV1 -- version 12 was posted 2020-01-28, AD waiting for our revisions.
              still waiting for new document.
              - plan to finish this week.
              -

5. FFV1 issues.

6. Work on Matroska issues.
	- reduced pull requests to 7 open, still 51 issues open.

NEXT MEETING April 28, 2020.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Niedermayer <[email-masked]>
Date: Tue, 28 Apr 2020 10:02:48 +0200

> April  28, 2020        21:00 Amsterdam  ***

I did yesterday have some intermittent net connection issues. So if i fail to appear
during that meeting its this time not because i forgot ;)

Also just to use this opertunity, i think we should put more effort into
improving features & compression. This would ensure that by the time the
text is fully polished it is still relevant and also it could attract more
and a different kind of people if we did something like a compression/algorithm
competition for the next version of ffv1 and flac.

thx

[...]

-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

If the United States is serious about tackling the national security threats 
related to an insecure 5G network, it needs to rethink the extent to which it
values corporate profits and government espionage over security.-Bruce Schneier

---

From: Jerome Martinez <[email-masked]>
Date: Tue, 28 Apr 2020 10:15:37 +0200

> competition for the next version of ffv1 and flac.

The text for FFV1 v0-v3 is nearly finished, just some fixes to push, 
which are not fancy and not a technical challenge, but having an IETF 
RFC would also attract more people. It is pretty important for the 
adoption of FFV1 by several entities.

Additionally, the compression ratio is not the main feedback I have, lot 
of people complain about the speed especially on 4K, and there is surely 
already a lot to do on this part without a new version, but this topic 
should also be part of the design of the next version of FFV1 (and 
seeing the limits of FFV1 v3 with the current HW, massively 
parallelized, would be a precondition for the design of FFV1 v4 IMO, lot 
to do :) ).

Jérôme

---

From: Michael Richardson <[email-masked]>
Date: Tue, 28 Apr 2020 09:28:33 -0400

> during that meeting its this time not because i forgot ;)

Understood!

    > competition for the next version of ffv1 and flac.

My understanding is that ffv1 v0-3, which is past WGLC, documents only things
that are already out there.

I'm not sure that ffv1 v4 should include new work either, but the WG could
decide to that.  Alternatively, this competition might make for a good
extension draft.

While more documents are not necessarily better because of the fixed overhead
of getting through the process, given the immense size of our documents, I
think it would be fine.

I note that the flac code is already a separate draft.
I'm not exactly sure how the competition would work.