Subject: [conex] draft-krishnan-6man-header-reserved-bits-00

From: Bob Briscoe <[email-masked]>
Date: Mon, 08 Nov 2010 19:34:16 +0800

Suresh, Joel,

Concerning <draft-krishnan-6man-header-reserved-bits-00>

1/ Firstly, have you had any response from the v6 community on this one?

2/ As well as extra bits, there's a problem of the behaviour of nodes 
that don't understand the bits (as you've identified in your 6man 
uniform v6 extension headers draft). The nice thing about the 
flow-label is most nodes should allow thru anything.

3/ Do you know whether tunnels will copy the flow label to the new 
outer (both whether they should and whether they actually do)?

Bob

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 10 Nov 2010 00:56:54 -0500

Hi Bob,

> -----Original Message-----
> From: Bob Briscoe [mailto:[email-masked]] 
> Sent: Monday, November 08, 2010 7:34 PM
> To: Suresh Krishnan; Joel Halpern
> Cc: ConEx IETF list
> Subject: draft-krishnan-6man-header-reserved-bits-00
> 
> Suresh, Joel,
> 

Yes, and it has not been very positive. The issue seems to be minimizing changes to the flow label field. There have been some backward compatibility concerns brought up, but I do not think they hold water.

> 
> 2/ As well as extra bits, there's a problem of the behaviour 
> of nodes that don't understand the bits (as you've identified 
> in your 6man uniform v6 extension headers draft). The nice 
> thing about the flow-label is most nodes should allow thru anything.

Exactly.

> 
> 3/ Do you know whether tunnels will copy the flow label to 
> the new outer (both whether they should and whether they actually do)?

Neither :-). All the instances of IPv6 tunneling that I have implemented/seen will not copy the flow label. The default behavior would be to set the flow label to 0. That said, there are some efforts to use the flow label for ECMP load balancing. One such effort draft-carpenter-flow-ecmp-03 mandates tunnel ingress points to set the flow label to a pseudo-random value.

Thanks
Suresh