Subject: Re: [conex] additional comment on the use cases drafts

From: Alissa Cooper <[email-masked]>
Date: Sat, 6 Nov 2010 18:11:35 +0800

I may be misreading draft-mcdysan-conex-other-usecases-00.txt, but it  
seems to use a broader concept of what conex will be signaling than  
what is described in draft-mathis-conex-abstract-mech-00 (e.g.,  
signaling a measure of burstiness as described in 4.1 in -other- 
usecases). I like how the -other-usecases draft describes uses of  
conex information that can be made over a longer time interval, but it  
seems like there needs to be clarity on what conex is signaling before  
integrating all the use cases into a single draft.

Alissa

On Oct 29, 2010, at 4:17 PM, Toby Moncaster wrote:

> Seems OK to me too. I'm perfectly happy to try and expand the number  
> of use
> cases, at least to start with. Later on I imagine it will become  
> clearer
> which use cases will really work...
>
> BTW Dave, I will send some comments on your draft by the start of the
> meeting...
>
> Toby
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On  
>> Behalf
>> Of Mcdysan, David E
>> Sent: 28 October 2010 14:03
>> To: marcelo bagnulo braun; [email-masked]
>> Subject: Re: [conex] additional comment on the use cases drafts
>>
>> Works for me.
>>
>> As stated in my draft, the intent was to be complementary to the
>> moncaster draft.
>>
>> Thanks,
>>
>> Dave
>>
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]]
>>> On Behalf Of marcelo bagnulo braun
>>> Sent: Thursday, October 28, 2010 3:29 AM
>>> To: [email-masked]
>>> Subject: [conex] additional comment on the use cases drafts
>>>
>>> Now, we stated that we are planning to ask for adoption of WG
>>> documents for the abstract mechanism and for the use cases.In
>>> the case of the use cases, the situation deserve more
>>> clarification. We have two documents:
>>> draft-moncaster-conex-concepts-uses and
>>> draft-mcdysan-conex-other-usecases-00.txt.
>>> draft-moncaster-conex-concepts-uses was discussed in the
>>> previous meeting and some changes were requested in order to
>>> call for adoption.
>>> The plan is to ask the WG if you feel that the changes have
>>> been made and the draft is in good shape to be the basis for
>>> our deliverable (i.e.
>>> we will ask for adoption of this document)
>>> draft-mcdysan-conex-other-usecases-00.txt otoh, is a new
>>> draft that presents additional use cases. The question that
>>> will be asked to the WG is whether you feel that the use
>>> cases covered in this draft should be covered and in the case
>>> that the answer is affirmative, we will proceed to integrate
>>> these new use cases to the other uses cases we already have.
>>>
>>> Comments?
>>>
>>> Regards, marcelo (on behalf of the co-chairs)
>>>
>>> _______________________________________________
>>> conex mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/conex
>>>
>> _______________________________________________
>> conex mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/conex
>
> _______________________________________________
> conex mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/conex
>

---

From: "Toby Moncaster" <[email-masked]>
Date: Sat, 6 Nov 2010 11:40:59 -0000

Reminds me - I promised to send some comments on this... I will try and get
them done before the WG meeting Tuesday, but am also trying to concentrate
on other things (like getting a job...)

> From: Alissa Cooper [mailto:[email-masked]]
> Sent: 06 November 2010 10:12
> To: Toby Moncaster
> Cc: 'Mcdysan, David E'; 'marcelo bagnulo braun'; [email-masked]

My initial thoughts on the McDysan draft are that it seems to be expanding
the definition of congestion too far. The worry I have is that if we start
to look at things like burstiness as a measure of congestion then some of
the economics that underpin ConEx might start to break down.

Also it is much harder for the network to measure things like burstinesss
without the use of quite complex equipment (certainly simple routers
couldn't do it). By contrast congestion as measured by competition for space
in a queue can be measured in realtime on a packet-by-packet basis...

Toby

---

From: "Mcdysan, David E" <[email-masked]>
Date: Mon, 8 Nov 2010 00:25:14 -0500

Hi Alissa,

My intent was to try and describe the motivation and objectives, and state the use cases to see if the working group believes that a particular use case is warranted to meet objectives in a general way. For use cases where this is true, then the task would be to define appropriate mechanisms (e.g., signaling) that would be needed to meet that objective and particular use case.

I suggest that if a particular objective and use case is of interest to the working group then more specific mechanisms could be proposed and discussed. I did mention some potential mechanisms (e.g., burstiness) at a high level and these could certainly be expanded.

Dave

________________________________________
From: Alissa Cooper [[email-masked]]
Sent: Saturday, November 06, 2010 6:11 AM
To: Toby Moncaster
Cc: Mcdysan, David E; 'marcelo bagnulo braun'; [email-masked]
Subject: Re: [conex] additional comment on the use cases drafts

Alissa