Subject: [core] FW: CORE and draft-struik-6lowapp-security-considerations-00.txt

From: "Rene Struik" <[email-masked]>
Date: Wed, 17 Mar 2010 18:20:14 -0400

Dear Carsten, Cullen:

I just reviewed the agenda for the 6lowapp meeting at IETF-77 and, to my
surprise, noticed that the presentation slot you presumably allocated to
me was not there. Please correct.

Cell: +1 (416) 433-7880

Best regards, Rene

Agenda CORE WG 
IETF-77, Anaheim, CA, USA
-----------------------------------
DRAFT Agenda created March 10

Time:
	Thursday, Mar 25, 9:00 to 11:30

Chairs:
     	Carsten Bormann <[email-masked]>
     	Cullen Jennings <[email-masked]>

Mailing Lists:
     	General Discussion: [email-masked]
     	To Subscribe:       https://www.ietf.org/mailman/listinfo/core

Wiki & Status: 
	http://tools.ietf.org/wg/core/

Agenda Bash and Status          (Chairs 10 min)
	- Note takers
	- Jabber Scribes

CoAP requirements and protocol proposal (Zach Shelby 50 min)
 	draft-shelby-core-coap-req-00.txt
	draft-shelby-core-coap-00.txt

Bootstrap discussion (Colin Oflynn 30 min)
	draft-oflynn-core-bootstrapping-00

Compressed IPfix (Lothar Braun 30 min)
 	draft-braun-core-compressed-ipfix-01.txt

Other Topics (Working Group 30 min)

-----Original Message-----
From: Rene Struik 
Sent: Wednesday, March 17, 2010 11:16 AM
To: Carsten Bormann
Cc: Cullen Jennings; Zach Shelby
Subject: RE: CORE and
draft-struik-6lowapp-security-considerations-00.txt

Any update?

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, March 11, 2010 10:53 AM
To: Rene Struik
Subject: Re: CORE and
draft-struik-6lowapp-security-considerations-00.txt

Rene,

sorry for short-changing you again -- I fell ill yesterday and the
agenda was made up by Cullen.
We'll fix this.

Gruesse, Carsten
-----Original Message-----
From: Rene Struik 
Sent: Wednesday, March 10, 2010 11:24 PM
To: [email-masked]'
Cc: [email-masked]'; [email-masked]'
Subject: Re: CORE and
draft-struik-6lowapp-security-considerations-00.txt

Hi Cullen:

The draft (btw - I submitted rev01 this Monday) discusses a security
architectural design that encompasses the whole system lifecycle and
would apply to 6lowapp, roll, but I wanted to discuss only one aspect of
this at the meeting, viz. configuration/provisioning, since that
unambiguously falls into the 6lowapp/core realm. Please also note my
prior email to Carsten Bormann on this. 

There may be some opportunity to lift this topic out and to do some
joint work with Colin o Flynn, whose bootstrapping doc is a subset of
configuration - will have to see, but guess we could collaborate here.

Rene
Rene Struik
Certicom Research
Cell: +1 (416) 433-7880

-----Original Message-----
From: Rene Struik 
Sent: Wednesday, March 10, 2010 5:30 PM
To: Cullen Jennings; Zach Shelby; Carsten Bormann
Subject: RE: [core] CORE Draft Agenda for IETF 77

Hi Cullen:

I am somewhat confused as to whom to ask timeslots. I asked Carsten
Bormann twice (Tue March 9, 2010; Mon Feb 22, 2009); moreover, I believe
I asked the same for the previous IETF-76 meeting (but was not on the
agenda). I would be really happy if you would allow me some time to
present.

Best regards, Rene

-----Original Message-----
From: Rene Struik 
Sent: Tuesday, March 09, 2010 5:35 PM
To: Carsten Bormann
Cc: Zach Shelby
Subject: RE: [core] Fwd: CORE - Requested session has been scheduled for
IETF 77

Hi Carsten:

I would like to discuss security and ease of use topics
(provisioning/configuration related) and would like to request a
20-minute timeslot for this. Please also cf. my previous request.

Best regards,

Rene

-----Original Message-----
From: Rene Struik 
Sent: Monday, February 22, 2010 9:31 AM
To: Carsten Bormann
Subject: RE: [6lowapp] Agenda in Anaheim

Hi Carsten:

I would potentially (pending travel approval) like to present the
6lowapp draft on security considerations that I posted in October.

Best regards, Rene

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Cullen Jennings
Sent: Wednesday, March 10, 2010 5:23 PM
To: [email-masked]
Subject: [core] CORE Draft Agenda for IETF 77

Hi All, 

Carsten and I are starting to put together the Agenda for our first
meeting. Below if the rough draft proposal and is highly likely to
change but we need input from the group. Are there other things that
need discussion time? What are the hot topics that we need to sort out?
Drop us some email and let us know how to make a great first meeting. 

Thanks, Cullen

Agenda CORE WG 
IETF-77, Anaheim, CA, USA
-----------------------------------
DRAFT Agenda created March 10

Time:
	Thursday, Mar 25, 9:00 to 11:30

Chairs:
     	Carsten Bormann <[email-masked]>
     	Cullen Jennings <[email-masked]>

Mailing Lists:
     	General Discussion: [email-masked]
     	To Subscribe: https://www.ietf.org/mailman/listinfo/core

Wiki & Status: 
	http://tools.ietf.org/wg/core/

Agenda Bash and Status                       (Chairs 10 min)
	- Note takers
	- Jabber Scribes

CoAP requirements and protocol proposal  (Zach Shelby 50 min)
 	draft-shelby-core-coap-req-00.txt
	draft-shelby-core-coap-00.txt

Bootstrap discussion                    (Colin Oflynn 30 min)
	draft-oflynn-core-bootstrapping-00

Compressed IPfix                         (Lothar Braun 30 min)
 	draft-braun-core-compressed-ipfix-01.txt

Other Topics                            (Working Group 30 min)

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 19 Mar 2010 17:43:02 -0700

Ah, It's my fault Rene. I had it on my todo list for a week to go fix this part of the agenda. The questions I'm not sure about is how it to mix/sequence your presentation and Colin's presentation. 

But I'm not really sure the right amount of time to allocate for theses two and I'm not sure the best way to cover both at the same time. I do want to talk about them in one presentation as there is lots over overlap in the discussion. Can you and Colin see if you can figure out a proposal for best way to run the discussion on these two drafts? Perhaps one way would be to have you take 10 minutes before Colin and preset the security big picture then have Colin cover the part from his draft? Thoughts from anyone on best way to structure the time and have a productive discussion? 

Again - new agenda tomorrow. But yes, one way or the other, there will be some time on the agenda for this.

Cullen

---

From: "Oflynn, Colin" <[email-masked]>
Date: Sat, 20 Mar 2010 01:48:27 -0600

Hi Cullen & Rene,

I was going to offer to squeeze up my time slot if needed anyway ;-)

I think it makes more sense for Rene to go first, as I'll build on his security architecture. I would propose the following sort of presentation within the 30min period:

10 mins Rene
10 mins Colin
10 mins Discussion / Extra Material

If you need more time Rene I can squeeze mine down, or we can make it more just a presentation & no questions! I'm not sure how the IETF presentations normally run.

Also: is there projector facilities etc provided? Anything specific we should know?

Regards,

  -Colin

-----Original Message-----
From: [email-masked] on behalf of Cullen Jennings
Sent: Sat 20/03/2010 00:43
To: Rene Struik
Cc: [email-masked]
Subject: Re: [core] CORE anddraft-struik-6lowapp-security-considerations-00.txt

Cullen

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 20 Mar 2010 12:48:35 -0700

Let's make this 15 min, 15 min, 15 minutes. It's really important to be able to get discussion going and find out if there is agreement around ideas and proposals. We will also end up being clarifying questions and such during the presentation. It's really hard to get 7 minutes of material presented in less than 15 minutes of time at IETF so I added more time to this.  If we end up using less time than needed, that's fine. 

> > IETF-77, Anaheim, CA, USA

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html