Subject: [core] Filtering in draft-shelby-core-link-format

From: Cullen Jennings <[email-masked]>
Date: Wed, 29 Sep 2010 08:43:57 -0600

It seems like you should clear up the behavior of devices that do not support filtering receives a request with a filter query. For example what happens when a device that does not do filtering gets 

GET /.well-known/core?n=LightLux

I think the answer should be it ignores it and returns exactly the same things as if it had got 

GET /.well-known/core

Should also deal with what happens with a query with "*" when the device does not support it. This seems a bit harder to specify - I'd almost be tempted to say supporting * is required if you do filtering

I'm a little concerned with the 
  " If no Content-type code attribute is present then text/
   plain is assumed. "

I think it might be better to say that nothing about the type can be assumed if the attribute is not present. 

Cullen <in my individual contributor roll>

---

From: Zach Shelby <[email-masked]>
Date: Wed, 29 Sep 2010 19:15:36 +0300

Thanks Cullen,

These all sound reasonable to me, I will make a ticket for link-format-02 if there are no objections.

Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297