Subject: [core] clarify resource discovery for 6LoWPAN

From: Esteban Damian Gutierrez Mlot <[email-masked]>
Date: Tue, 28 Sep 2010 11:02:48 +0200 (CEST)

In order to apply a Service Oriented Architecture and made resources available for users, I would implement a discovery mechanism. I think this is a point is not clear for 6LoWPAN. Should I use SSLP (draft-daniel-6lowpan-sslp-02.txt) or I should use CoAP (draft-ietf-core-coap-01)?

Could somebody clarify this point or give some advices?

Regards,
Esteban

---

From: Zach Shelby <[email-masked]>
Date: Tue, 28 Sep 2010 12:10:57 +0300

Estaban,

Please see the draft just posted (draft-shelby-core-coap-link-format). This draft does make it possible to discover the list of resources that a CoAP server provides by doing a GET on /.well-known/core. This of course assumes that you are using CoAP and know that a CoAP server exists in your network - if you don't then some sort of service discovery might be needed first (SLP, DNS-SD etc.).  The combination of these depends a lot on your application.

Regards,
Zach

On Sep 28, 2010, at 12:02 PM, Esteban Damian Gutierrez Mlot wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297