Subject: [core] Wed 29, 1500 UTC (Fwd: Meeting invitation: CORE WG)

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Sep 2010 10:56:51 +0200

[I seem to have really bad luck with E-Mail right now.  
This is a resend, because the original message never arrived in the mailing list archive.]

At the last CORE Webex meeting, we discussed having these meetings once a month in the last week of the month.
So I asked for a Webex room/conference/meeting and got it assigned -- unfortunately, I didn't notice that this message only got to me.  Kerry just pointed out to me that this hadn't been announced on the list.

So please find the details below (and please accept my apologies for sitting on this information).
Note that 1500 UTC ("GMT") is 0800 PDT, 1100 EDT, 1700 CEST, 1800 EEST, 2400 JST/KST.

If you have agenda items that you want to bring to this meeting, please give Cullen and me
-- a short subject line,
-- the objective of having that discussion, and
-- pointer(s) to relevant draft(s).
If your item gets scheduled, I'd like your slides on Monday so I can do the usual consolidated set.

Gruesse, Carsten

> Hello , 
> 
> IETF Secretariat invites you to attend this online meeting. 
> 
> Topic: CORE WG 
> Date: Wednesday, September 29, 2010 
> Time: 3:00 pm, (Reykjavik, GMT) 
> Meeting Number: 963 078 535 
> Meeting Password: (This meeting does not require a password.) 
> 
> 
> ------------------------------------------------------- 
> To join the online meeting (Now from the Apple iPhone (R) too!) 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/j.php?ED=147542532&UID=1185791862&RT=MiMyMA%3D%3D 
> 2. If requested, enter your name and email address. 
> 3. If a password is required, enter the meeting password: (This meeting does not require a password.) 
> 4. Click "Join". 
> 
> To view in other time zones or languages, please click the link: 
> https://workgreen.webex.com/workgreen/j.php?ED=147542532&UID=1185791862&ORT=MiMyMA%3D%3D 
> 
> ------------------------------------------------------- 
> To join the audio conference only 
> ------------------------------------------------------- 
> To receive a call back, provide your phone number when you join the meeting, or call the number below and enter the access code. 
> Call-in toll number (US/Canada): 1-408-792-6300 
> Global call-in numbers: https://workgreen.webex.com/workgreen/globalcallin.php?serviceType=MC&ED=147542532&tollFree=0 
> 
> Access code:963 078 535 
> 
> ------------------------------------------------------- 
> For assistance 
> ------------------------------------------------------- 
> 1. Go to https://workgreen.webex.com/workgreen/mc 
> 2. On the left navigation bar, click "Support". 
> 
> You can contact me at: 
> [email-masked] 
> 1-510-492-4081 
> 
> To add this meeting to your calendar program (for example Microsoft Outlook), click this link: 
> https://workgreen.webex.com/workgreen/j.php?ED=147542532&UID=1185791862&ICS=MI&LD=1&RD=2&ST=1&SHA2=vjLz1JtYfKkmL2Gpzw5H1lr7GVJUx0nv3CSfu33a3iU=&RT=MiMyMA%3D%3D 
> 
> The playback of UCF (Universal Communications Format) rich media files requires appropriate players. To view this type of rich media files in the meeting, please check whether you have the players installed on your computer by going to https://workgreen.webex.com/workgreen/systemdiagnosis.php 
> 
> Sign up for a free trial of WebEx 
> http://www.webex.com/go/mcemfreetrial 
> 
> http://www.webex.com 
> 
> 
> 
> IMPORTANT NOTICE: This WebEx service includes a feature that allows audio and any documents and other materials exchanged or viewed during the session to be recorded. By joining this session, you automatically consent to such recordings. If you do not consent to the recording, discuss your concerns with the meeting host prior to the start of the recording or do not join the session. Please note that any such recordings may be subject to discovery in the event of litigation.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Sep 2010 15:33:29 +0200

So you don't have to hunt them down, below are the Webex details for the conference call today.
Note that 1500 UTC is 0800 PDT, 1100 EDT, 1700 CEST, 1800 EEST, 2400 JST/KST, i.e., soon.

We have a pretty short agenda this time:

-- Document status
-- Splitting draft-ietf-core-coap-02 and draft-shelby-link-format-00
-- (Any other comments on
   draft-bormann-core-coap-block-00, draft-hartke-coap-observe-02)
-- Planning ahead of Beijing
   -- Security Bootstrapping
   -- Further Webex meetings (2010-10-27)
   -- I-D deadline at 2010-10-18 (initial) and 2010-10-25 (update)

There is only one slideset, for coap-02/link-format-00, currently at:

      http://6lowapp.net/2010-09-29/

(I know this still isn't the right place...)

Please note that we do intend to record this meeting.

Gruesse, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Sep 2010 23:36:23 +0200

>      http://6lowapp.net/2010-09-29/

... and the minutes are now also up there.
Please tell me if I have misrepresented anyone.

At 90 minutes, this was a short and sweet meeting.  Thanks to everyone who participated, and in particular to Markus Becker who at very short notice volunteered to take notes (all errors in the massaged version are of course mine).

Gruesse, Carsten

---

From: Rene Struik <[email-masked]>
Date: Wed, 29 Sep 2010 18:18:41 -0400

Hi Carsten:

Thanks for the minutes. I just had a quick look and somehow seemed to 
have missed during the conf call your reference to the HIP protocol. 
Could you elaborate a little bit more? To my knowledge, HIP essentially 
does ephemeral Diffie-Hellman key agreement, thus not offering 
authenticated key agreement. In my mind, authenticated key agreement is 
essential to trigger data authentication tied to a unique identifier and 
allow trust lifecycle management to be reduced to management of device 
identities (via use of certificates). See also the brief summary below.

Perhaps, we should discuss this somewhat more early next week.

Best regards,

Rene

[summary of old proposal of mine on trust lifecycle management that 
could be used with bootstrapping document]*
§**1 Proposal summary*

The proposal encompasses an intuitive, yet secure approach to 
provisioning and configuration of sensor networks. The approach hides 
security details from the user, thus allowing ease of device and network 
setup and flexibility of trust lifecycle management, while doing away 
with security hassles that have plagued more conventional approaches.

  The proposal uses public-key cryptography, a security technology that 
allows reduction of trust lifecycle management to the management of 
trusted device identities (via so-called certificates), and security 
policy enforcement techniques based on lifecycle management of device 
roles.

 From a user's perspective, this results in a system where trusted 
lifecycle management appears to be the same as that of an unsecured 
network: it simply comes down to proper identification of devices (e.g., 
reading off a label of a physical module) and proper management of 
device roles (e.g., adding these to, resp. removing these from a white 
list, e.g., via a workstation GUI). No secret information is disclosed 
at any lifecycle stage of a device or a system, nor needs to be, since 
management relies completely on handling of public information. This 
greatly reduces the complexity of lifecycle management and, thereby, 
training requirements for operational personnel. Moreover, it virtually 
removes trust dependencies between different entities involved in the 
value chain, whether OEM, vendor, system integrator, installer, or user. 
Lastly, the approach has the benefit of allowing enforcement of 
standards compliance (by only issuing a certificate to devices from 
vendors that passed conformance testing).

On 29/09/2010 5:36 PM, Carsten Bormann wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
email: [email-masked]
Skype: rstruik
cell: +1 (647) 867-5658
USA Google voice: +1 (415) 690-7363

---

From: Rene Struik <[email-masked]>
Date: Wed, 29 Sep 2010 18:19:00 -0400

Hi Carsten:

Best regards,

Rene

---

From: "Oflynn, Colin" <[email-masked]>
Date: Thu, 30 Sep 2010 02:10:08 -0600

Hello,

Just a note the minutes show the bootstrapping draft was moving towards "More about bootstrapping, less security.". That should have been the other way around - the current draft dealt mostly with bootstrapping, but instead it will be moving to more about security setup.

  -Colin

-----Original Message-----
From: [email-masked] on behalf of Carsten Bormann
Sent: Wed 29/09/2010 22:36
To: core
Subject: Re: [core] Fwd:  Wed 29, 1500 UTC (Fwd: Meeting invitation: CORE WG)

Gruesse, Carsten