Subject: [core] Size of CoAP implementation

From: Markus Becker <[email-masked]>
Date: Mon, 22 Nov 2010 10:28:30 +0100

Hi,

Carsten asked me to give some data points on how big CoAP is right now on 
constrained nodes (here: TinyOS, TelosB).

As a reference: Simple TinyOS application with Radio stack:
(RadioCountToLeds)
           11890 bytes in ROM
             329 bytes in RAM

Sample TinyOS blip 6LoWPAN application with a shell and echo service
(UDPEcho, not optimized aka ntop6 support included, debugging):
           29474 bytes in ROM
            5062 bytes in RAM
(same, ntop6 support removed, debugging)
           28794 bytes in ROM
            5062 bytes in RAM

Simple CoAP server based on Olaf's libcoap and TinyOS blip 6lowpan stack
(no sensors pulled in, ntop6 support removed, NO debugging)
           31866 bytes in ROM
            5492 bytes in RAM

Simple CoAP server based on Olaf's libcoap and TinyOS blip 6lowpan stack
(not optimized, 2 async sensor resources being served, debugging):
           40730 bytes in ROM
            5802 bytes in RAM

As a reference: TelosB motes are equipped with 48k ROM, 10k RAM

Markus

------------------------------------------------
| Dipl.-Ing. Markus Becker
| Communication Networks
| Mobile Research Center
| TZI - Center for Computing Technologies
| University Bremen
| Germany
------------------------------------------------
| web: http://www.comnets.uni-bremen.de/~mab/
| mailto: [email-masked]
| telephone: +49 421 218 62379
| building: NW1 room: N2260
------------------------------------------------

---

From: Markus Becker <[email-masked]>
Date: Mon, 22 Nov 2010 16:31:22 +0100

> Hi,
> 
> Could you specify exactly what parts include these implementations ?
> CoAP only, or CoAP and 6lowpan/uIP stack and radio stack, routing, etc... ?
Those numbers are for TinyOS. uIP would be Contiki.
The TinyOS 6LoWPAN stack in use here is the Berkeley Low-Power IP (blip) 
stack, version 1.0, which uses HYDRO routing protocol (not RPL). More 
information inline.
> Thanks,
> 
> N.
> 
> On Mon, Nov 22, 2010 at 10:28 AM, Markus Becker
> 
> <[email-masked]>wrote:
> > Hi,
> > 
Usual TinyOS radio stack, not 6LoWPAN, no CoAP, no multi-hop.
> > Sample TinyOS blip 6LoWPAN application with a shell and echo service
TinyOS 6LoWPAN Berkeley Low-Power IP (blip) stack, no CoAP.
> > (no sensors pulled in, ntop6 support removed, NO debugging)
TinyOS 6LoWPAN Berkeley Low-Power IP (blip) stack + CoAP.
> > Simple CoAP server based on Olaf's libcoap and TinyOS blip 6lowpan stack
TinyOS 6LoWPAN Berkeley Low-Power IP (blip) stack + CoAP + Sensor drivers.
> > _______________________________________________
> > core mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/core

---

From: noblomov <[email-masked]>
Date: Mon, 22 Nov 2010 16:12:14 +0100

Hi,

Thanks,

N.