Subject: [core] Memento TimeMaps, again

From: Herbert van de Sompel <[email-masked]>
Date: Tue, 9 Nov 2010 08:00:31 -0700

Hi again,

Since there have been some problems with the link to a TimeMap I sent in
yesterday's mail, I have posted a TimeMap at a URI that should not cause
confusion:

http://dl.dropbox.com/u/2114080/ugent_timemap.txt

TimeMaps are introduced in the Memento framework (http://mementoweb.org) and
are formatted according to the link-value construction rule of the BNF of
RFC 5988.

I would like to repeat the questions I posted yesterday:

We are currently finalizing the first version of an Internet Draft for
Memento, and we are in need of a special-purpose MIME type as the text/csv
that we currently use is inaccurate. In that context, I was wondering about
the following:

(1) Is it appropriate for us to use "application/link-format" for our
TimeMaps? Note that our TimeMaps strictly adhere to the link-value
construction rule of RFC 5988, i.e. we are not using any of the extensions
that you propose.

(2) Why the path was chosen to define extensions as part of the basic
"application/link-format"
MIME type, i.e. why is "application/link-format" not introduced to identify
documents strictly formatted according to RFC 5988's link-value rule, and
why are extensions not handled like, for example, in XML, e.g. "
application/core+link-format"?

My apologies for the confusion caused by yesterday's link. I am looking
forward to your feedback.

Greetings

Herbert Van de Sompel

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/

==

---

From: Zach Shelby <[email-masked]>
Date: Wed, 10 Nov 2010 01:15:22 +0800

Hi Herbert,

Sorry I am slow answering right now, IETF week... We are actually discussing link-format in tomorrow's WG meeting and I will mention your case. See answers to your questions below:

On Nov 9, 2010, at 11:00 PM, Herbert van de Sompel wrote:

> Hi again,
> 
> Since there have been some problems with the link to a TimeMap I sent in yesterday's mail, I have posted a TimeMap at a URI that should not cause confusion:
> 
> TimeMaps are introduced in the Memento framework (http://mementoweb.org) and are formatted according to the link-value construction rule of the BNF of RFC 5988. 
> 
> We are currently finalizing the first version of an Internet Draft for Memento, and we are in need of a special-purpose MIME type as the text/csv that we currently use is inaccurate. In that context, I was wondering about the following:
> 
> (1) Is it appropriate for us to use "application/link-format" for our TimeMaps? Note that our TimeMaps strictly adhere to the link-value construction rule of RFC 5988, i.e. we are not using any of the extensions that you propose.

Sure, I don't see why not. application/link-format does not require use of any link-extensions. 

> 
> (2) Why the path was chosen to define extensions as part of the basic "application/link-format" MIME type, i.e. why is "application/link-format" not introduced to identify documents strictly formatted according to RFC 5988's link-value rule, and why are extensions not handled like, for example, in XML, e.g. "application/core+link-format"?

This is because we are conforming to RFC5988, and link-extensions are optional. Thus I think you can reference this document as-is and you are good to go. 

Regards,
Zach

> 
> My apologies for the confusion caused by yesterday's link. I am looking forward to your feedback.
> 
> Greetings
> 
> Herbert Van de Sompel
> 
> -- 
> Herbert Van de Sompel
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297