Subject: [core] Help me with CoAP Demo

From: Thanh Ngoc <[email-masked]>
Date: Mon, 22 Nov 2010 10:13:01 +0900

Dear evey one,

now i am starting with CoAP and have to make a demo.

do you know where i should start ? and does it have any demo is available
for CoAP (in tinyos or contiki).

could you give me some guide for CoAP Demo?

thank you very much,

        Ngoc Thanh

---

From: Markus Becker <[email-masked]>
Date: Mon, 22 Nov 2010 10:05:36 +0100

> could you give me some guide for CoAP Demo?

Probably you would want to start with Olaf's C implementation libcoap [1] or 
Peter's Python implementation coappy [2] on a usual computer and not start 
directly on WSN nodes.

[1] http://sourceforge.net/projects/libcoap/
[2] http://coapy.sourceforge.net/

We are currently working on a port of libcoap to TinyOS.

Markus

>         Ngoc Thanh
------------------------------------------------
| Dipl.-Ing. Markus Becker
| Communication Networks
| Mobile Research Center
| TZI - Center for Computing Technologies
| University Bremen
| Germany
------------------------------------------------
| web: http://www.comnets.uni-bremen.de/~mab/
| mailto: [email-masked]
| telephone: +49 421 218 62379
| building: NW1 room: N2260
------------------------------------------------

---

From: dogan yazar <[email-masked]>
Date: Mon, 22 Nov 2010 02:10:59 -0800 (PST)

There is a COAP implementation in the upcoming version of Contiki (version 2.5). 
There is also a REST layer written on top of it to ease the development of 
RESTful applications.

Regards
Dogan Yazar

________________________________
From: Thanh Ngoc <[email-masked]>
To: [email-masked]
Sent: Mon, November 22, 2010 2:13:01 AM
Subject: [core] Help me with CoAP Demo

Dear evey one,

do you know where i should start ? and does it have any demo is available for 
CoAP (in tinyos or contiki).

thank you very much,

        Ngoc Thanh