Subject: Re: [core] coap #56 (new): Distinguishing DTLS, CoAP and STUN

From: "core issue tracker" <[email-masked]>
Date: Thu, 02 Dec 2010 21:40:09 -0000

#56: Distinguishing DTLS, CoAP and STUN

Changes (by zach@…):

  * owner:  => cabo@…

-- 
--------------------------------+-------------------------------------------
 Reporter:  zach@…              |       Owner:  cabo@…      
     Type:  enhancement         |      Status:  new         
 Priority:  trivial             |   Milestone:              
Component:  coap                |     Version:              
 Severity:  -                   |    Keywords:              
--------------------------------+-------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/56#comment:2>
core <http://tools.ietf.org/core/>

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 2 Dec 2010 15:31:39 -0700

Peter, I personally like the ability to run the secure and none secure version of a protocol on separate ports. However the transport people don't like that and are considering changing the IANA policy so you *have* to use one port. You might want to send the IESG email if you think that is a bad idea. 

On Nov 8, 2010, at 10:59 AM, Peter Bigot wrote:

> I missed the working group discussion during which it was decided to carry both secure and non-secure packets over the same protocol on the same port.
> 
> Following the general URI concept that the authority and hier-part define the resource, while the scheme defines how you talk to the resource owner, it is more natural (and consistent with http/https) that an alternative scheme denote encrypted CoAP traffic.  Since the scheme would be encrypted, use of a distinct port to disambiguate the content is also more clear.  This would also decouple CoAP from being impacted by evolutionary decisions made within DTLS.
> 
> On what basis was the decision made to diverge from the way it's done in HTTP?
> 
> Peter
> 
> On Sat, Nov 6, 2010 at 11:15 AM, core issue tracker <[email-masked]> wrote:
>  Section 10.2 need a discussion on how to tell the difference between DTLS
>  and CoAP messages as the same port is used by default.
> 
> --
>  Reporter:  zach@…              |       Owner:
> Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/56>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core