Subject: Re: [core] Review of draft-ietf-core-coap-03.txt

From: "Kovatsch Matthias" <[email-masked]>
Date: Wed, 1 Dec 2010 11:47:28 +0000

Hi

To me, Table 2 in "3.2. Header options" appears to have some flaws:

- option type 3 columns displaced: "Reserved" under data type while stating C for critical
- option type 7: completely blank, not reserved?
- option type 8: missing

Maybe also types 14, 28, etc. should be listed as reserved or otherwise marked here?
I personally was also missing a table for the transaction types which always help with the implementation.

Best regards
Matthias

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Dec 2010 13:07:48 +0100

Thanks, Matthias.
Yes, we need to clean up that table.

> - option type 3 columns displaced: "Reserved" under data type while stating C for critical

That is actually not a flaw -- option type 3 is reserved (and probably will be resurrected as "Uri-Scheme" in coap-04).
It is Critical because the option number is odd.  Critical means that an implementation that does not understand the option cannot properly handle a message that uses it.

> - option type 7: completely blank, not reserved?

(There is a proposal lingering to use this for Uri-Authority-Binary -- coap-misc section 3.2.  
Yes, the intention here in core-coap appears to be to make it reserved for now.)

> - option type 8: missing

This is actually unassigned (was Date and Accept in various previous versions).
I don't think we need to list all unassigned codes.

> Maybe also types 14, 28, etc. should be listed as reserved or otherwise marked here?

Indeed, these should be listed in the table
(see also coap-misc section 4.5).

> I personally was also missing a table for the transaction types which always help with the implementation.

Good point.  It's buried in the definition of "T" in section 3.1 right now.
(The nibble-spotters among us tend to see the hex values of 4=CON, 5=NON, 6=ACK, 7=RST in the packet dumps, maybe even that should be mentioned somewhere.)

	T field	   resulting first nibble (Ver||T)
CON	0		4
NON	1		5
ACK	2		6
RST	3		7

Gruesse, Carsten