Subject: [core] koster-core-coap-pubsub

From: peter van der Stok <[email-masked]>
Date: Thu, 12 Mar 2015 09:55:29 +0100

Hi Michael,

thanks for publishing a new version of your draft.
In my opinion it is much more readable and more to the point than the 
earlier draft. Good work.

A few editing remarks:
Figure 1: "Pubsub" stands for "pubsub interface" I assume?

sec 3.2
The PubSub broker exposes the pubsusb interface AND stores the Pubsub 
messages (they are never stored elsewhere, correct?)

I think you need a section before section 4 (replacing section 6) in 
which you present an high level overview of the Functions
Explain how PUBLISH may be used and why CON is not always wanted
Explain how SUBSCRIBE is used and why OBS is compulsory
Explain the use of READ and when use of CON is recommended.

It is in this section that you can show where the sleepy nodes come in 
and where the devices with limited reachability come in.

Hope this helps.

Greetings,
Peter

---

From: Michael Koster <[email-masked]>
Date: Thu, 12 Mar 2015 06:18:21 -0700

Thanks, Peter! 

On Mar 12, 2015, at 1:55 AM, peter van der Stok <[email-masked]> wrote:

> In my opinion it is much more readable and more to the point than the earlier draft. Good work.

Thanks, we received some good insights during the process. Your earlier comments from December were particularly helpful.
> Figure 1: "Pubsub" stands for "pubsub interface" I assume?

Yes, thanks.
> 
> sec 3.2
> The PubSub broker exposes the pubsusb interface AND stores the Pubsub messages (they are never stored elsewhere, correct?)

Yes, good point.
> 
> I think you need a section before section 4 (replacing section 6) in which you present an high level overview of the Functions
> It is in this section that you can show where the sleepy nodes come in and where the devices with limited reachability come in.

That’s a great idea. We put all the normative text into the function set definition, but still could use an informative section for high level functional description. Maybe some flows for illustration in this section. 
> 
> Hope this helps.
> 
> Greetings,
> Peter
> 
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core