Subject: [core] CoAP Confirmable Messages? Is Using TCP enough ito implement a CoAP confirmable message?

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 12 Mar 2015 14:51:28 +0000

Team,

In another thread (Message support in draft-tschofenig-core-coap-tcp-tls-02) there is an assumption made that if the underlying transport protocol is reliable - that the transport layer is sufficient to confirm receipt of a message to the originator by the receiving Application.

Did I understand that correctly? If so is this really true in practice especially when the recipient of the message is placed under heavy load?

I'm not talking about the TCP protocol reliability but the hand-off of the message from the socket to the CoAP layer.

Is the hand-off between layers reliable enough in implementations that there isn't a need for a CoAP message layer confirmable message?

Is there a problem with a successful message delivery indication from TCP layer when the receiving CoAP layer has errored?

I have seen the hand-off fail many times when the recipient of the message is under stress.

In fact the TCP draft is absolutely correct about this -  TCP can only provide reliable delivery of Non-confirmable messages in theory.

The confirmable part has to lie in the CoAP layer if you want to inform the originator of the delivery through the hand-off.

Thoughts?

BR,
Tim

---

From: Maciej Wasilak <[email-masked]>
Date: Wed, 18 Mar 2015 11:45:56 +0100

Dear Tim,

I believe your concern is justified. Increasing number of devices (GSM
modems, or CC3000 WiFi chips) provide TCP/IP stacks. In systems using
such devices there is an actual hardware SPI bus between TCP layer and
application layer (possibly CoAP). Hand-off fail is definitely
possible.

Best Regards
Maciej Wasilak

2015-03-12 15:51 GMT+01:00 Carey, Timothy (Timothy)
<[email-masked]>:
> Team,
>
>
>
> In another thread (Message support in draft-tschofenig-core-coap-tcp-tls-02)
> there is an assumption made that if the underlying transport protocol is
> reliable – that the transport layer is sufficient to confirm receipt of a
> message to the originator by the receiving Application.
>
>
>
> Did I understand that correctly? If so is this really true in practice
> especially when the recipient of the message is placed under heavy load?
>
>
>
> I’m not talking about the TCP protocol reliability but the hand-off of the
> message from the socket to the CoAP layer.
>
>
>
> Is the hand-off between layers reliable enough in implementations that there
> isn’t a need for a CoAP message layer confirmable message?
>
>
>
> Is there a problem with a successful message delivery indication from TCP
> layer when the receiving CoAP layer has errored?
>
>
>
> In fact the TCP draft is absolutely correct about this -  TCP can only
> provide reliable delivery of Non-confirmable messages in theory.
>
>
>
> The confirmable part has to lie in the CoAP layer if you want to inform the
> originator of the delivery through the hand-off.
>
>
>
> Thoughts?
>
>
>
> BR,
>
> Tim
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>