Subject: [core] Two CoAP over WebSockets related publications

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Wed, 25 Mar 2015 09:42:51 +0000

Hi all,

I'd like to share pointers to two CoAP over WebSockets related publications, in case some of you are interested. The first one is a paper where me and Bill are authoring, and the second one is something we just came across:

Measuring energy consumption for RESTful interactions in 3GPP IoT nodes
http://ieeexplore.ieee.org/xpl/articleDetails.jsp?tp=&arnumber=6878863

SCoAP: An integration of CoAP protocol with web-based application
http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=6831474

Unfortunately both are behind IEEE paywall.

In our measurements we found, for example, that in 3GPP networks, in our test scenario of RESTful interactions, CoAP over WebSockets and CoAP over Secure WebSockets were power-consumption wise very similar to CoAP, and often provided power savings when compared to HTTP (and never consumed more than HTTP). This indicated that web-based applications would help terminals to save power if they'd use CoAP over WebSockets for small transactions. For example, in 4G network with DRX enabled, CoAP, CoAP over WebSocket, and CoAP over Secure Websockets consumed the same amount of power, while HTTP consumed about 40% more. The consumption characteristics in 3GPP access are mostly characterized by 3GPP radio's properties, and in our case it often occurred that with small amounts of payload data CoAP over WebSockets and CoAP over UDP managed got similar handling, while HTTP often triggered more power consuming states (e.g. in 3G HTTP triggered DCH state while CoAP over WS&UDP managed to stay in FACH).

The data point here being that while CoAP over WebSockets requires more code than CoAP over UDP to implement, at least in some cellular scenarios CoAP over WebSockets does not really increase mobile node's power consumption, but does save when compared to use of plain HTTP.

Best regards,

                Teemu

---

From: "weigengyu" <[email-masked]>
Date: Thu, 26 Mar 2015 12:41:00 +0800

Hi Teemu,

Have downloaded and read your paper. 
We are interested in your work and think it important.

I have two problems about your work:

1 Although the mobile communication facility, especially LTE, is considered to support IoT application,  
the wireless communication link seems be better than that of constrained networks of RFC7252.
How about the loss rate, symbol or data rate you got in your experiments? 

2 From your experiments results, the main reason to cost power is the indication of channel shift that is from the application layer protocol , such as HTTP push. This seems to be implelementation specific, is it? 

Best regards, 

Gengyu WEI
Network Technology Center
School of Computer 
Beijing University of Posts and Telecommunications

From: Savolainen Teemu (Nokia-TECH/Tampere) 
Sent: Wednesday, March 25, 2015 5:42 PM
To: core WG 
Subject: [core] Two CoAP over WebSockets related publications

Hi all,

I’d like to share pointers to two CoAP over WebSockets related publications, in case some of you are interested. The first one is a paper where me and Bill are authoring, and the second one is something we just came across:

In our measurements we found, for example, that in 3GPP networks, in our test scenario of RESTful interactions, CoAP over WebSockets and CoAP over Secure WebSockets were power-consumption wise very similar to CoAP, and often provided power savings when compared to HTTP (and never consumed more than HTTP). This indicated that web-based applications would help terminals to save power if they’d use CoAP over WebSockets for small transactions. For example, in 4G network with DRX enabled, CoAP, CoAP over WebSocket, and CoAP over Secure Websockets consumed the same amount of power, while HTTP consumed about 40% more. The consumption characteristics in 3GPP access are mostly characterized by 3GPP radio’s properties, and in our case it often occurred that with small amounts of payload data CoAP over WebSockets and CoAP over UDP managed got similar handling, while HTTP often triggered more power consuming states (e.g. in 3G HTTP triggered DCH state while CoAP over WS&UDP managed to stay in FACH).

The data point here being that while CoAP over WebSockets requires more code than CoAP over UDP to implement, at least in some cellular scenarios CoAP over WebSockets does not really increase mobile node’s power consumption, but does save when compared to use of plain HTTP.

Best regards,

                Teemu

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Thu, 26 Mar 2015 08:15:10 +0000

Hi Gengyu,

We compared CoAP+UDP, COAP+WS, COAP+WSS, and HTTP with each other, and also how power consumption differs between 2G/3G/4G – in the live network we had hereby. The radio properties were the same for all of those protocol combinations, hence transmission rates were not of interest. We looked at each measurement sample and those samples that contained excess retransmissions (of CoAP, or TCP) were retaken.

While cellular links are not “constrained” in the sense of 802.15.4 or Bluetooth Smart, and mobile devices are not “constrained” in sense of RFC7228, they are still power constrained as about any smartphone user can probably agree on☺ Hence idea to check if there’d be benefits for performing some actions with CoAP rather than HTTP.

The main reason for power cost is simply number of bytes transmitted and cellular network making decisions based on bytes passing through. It is the network that decides pushing the radio to DCH, in 3G, for example. As  you can see from Table 1 of our paper, the main reason of HTTP being costly is high number of bytes required for each transaction during long lived session. So even if in our scenario CoAP+WSS requires most bytes to setup due to TLS handshake,  once the connection is setup, it is often cheaper to perform CoAP GET/reply over WSS than do HTTP GET/reply (and never more expensive, in our tests).

Then in some cases, like in 4G, the used protocol had smaller impact, as radio/network was optimized for high throughput actions and power consumption is dominated by other things than those few bytes required for tested REST action☺

In any case, network parameter selection impacts heavily on nodes’ power consumption (like in 4G, is DRX enabled, what timer values are used for short and long DRX cycle, how quickly idle mode is entered, and so).

It would be interesting to repeat the comparison with HTTP/2.

Best regards,

Teemu

From: ext weigengyu [mailto:[email-masked]]
Sent: 26. maaliskuuta 2015 6:41
To: Savolainen Teemu (Nokia-TECH/Tampere)
Cc: [email-masked]
Subject: Re: [core] Two CoAP over WebSockets related publications

Hi Teemu,

Best regards,

Gengyu WEI

From: Savolainen Teemu (Nokia-TECH/Tampere)<mailto:[email-masked]>
Sent: Wednesday, March 25, 2015 5:42 PM
To: core WG<mailto:[email-masked]>
Subject: [core] Two CoAP over WebSockets related publications

Hi all,

Best regards,

                Teemu
________________________________
_______________________________________________
core mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/core

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 26 Mar 2015 14:21:59 +0000

Hi Teemu,

see in line

On 26 Mar 2015, at 03:15, Savolainen Teemu (Nokia-TECH/Tampere) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Gengyu,

I do think that this is an interesting point
I have been thinking about how to use CoAP to improve performances
to some web functionality and I am happy to see I was not alone

sorry for asking, but I haven’t had yet the time to read your paper:
do you have done from an abstract protocol functionalities or do you have performed the
test with a specific “web” future in mind?
like streaming video, or caching content etc…

that would be fantastic!

br
/Sal

Best regards,

Teemu

Cc: [email-masked]<mailto:[email-masked]>

Hi Teemu,

Best regards,

Gengyu WEI

Hi all,

Best regards,

                Teemu

---

From: "weigengyu" <[email-masked]>
Date: Sat, 28 Mar 2015 00:09:42 +0800

Hi Teemu,

Thank you for your reply and explanation. 
As cellular links are adopted  for IoT applications, it is useful to compare CoAP, HTTP and web socket over mobile communication networks.

As you said that network parameter selection impacts heavily on nodes’ power consumption,
it is probable that some cross layer mechanism could help to get better optimization for certain applications.

Regards,

Gengyu WEI

From: Savolainen Teemu (Nokia-TECH/Tampere) 
Sent: Thursday, March 26, 2015 4:15 PM
To: ext weigengyu 
Cc: [email-masked] 
Subject: RE: [core] Two CoAP over WebSockets related publications

Hi Gengyu,

While cellular links are not “constrained” in the sense of 802.15.4 or Bluetooth Smart, and mobile devices are not “constrained” in sense of RFC7228, they are still power constrained as about any smartphone user can probably agree onJ Hence idea to check if there’d be benefits for performing some actions with CoAP rather than HTTP.

Then in some cases, like in 4G, the used protocol had smaller impact, as radio/network was optimized for high throughput actions and power consumption is dominated by other things than those few bytes required for tested REST actionJ 

Best regards,

Teemu

Hi Teemu,

 

Best regards, 

Gengyu WEI

To: core WG 

Hi all,

Best regards,

                Teemu

---

From: "Savolainen Teemu (Nokia-TECH/Tampere)" <[email-masked]>
Date: Tue, 31 Mar 2015 19:15:24 +0000

Hi Salvatore,

>to some web functionality and I am happy to see I was not alone

We were also thinking that in some cases “less-constrained” nodes might wish to perform RESTful interactions more efficiently (on some regard) using CoAP. So not only we wanted to measure CoAP over WebSockets, but also CoAP vs HTTP.

>test with a specific “web” future in mind?

We were not comparing abstract protocol features, just power consumption performance for small payloads that are sent periodically. For continuously streaming data the difference between protocols would be small, as such traffic pattern would certainly amount enough data to avoid triggering cellular radio’s power save features..

            Teemu