Subject: [core] OSCORE Interop

From: Francesca Palombini <[email-masked]>
Date: Wed, 25 Jul 2018 17:21:55 +0000

Hi all,

We are preparing for the interop of OSCORE v-13 (with updates from review comments).

The test spec for this coming interop are available here: https://ericssonresearch.github.io/OSCOAP/test-spec5.html

Thanks Malisa for pointing out 2 issues with the previous spec! They should be solved now. A couple additional tests are added as well (Observe and ID Context), while some other are slightly modified (Observe)

If you are interested in participating, let me know, the interop will happen either at the end of this week or the week of the 6th of August. I will send more details when the date is set.

Thanks,
Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 26 Jul 2018 08:56:59 +0000

Hi,

So the OSCORE interop will take place tomorrow 27th of July at 17:00 CEST (8:00 PDT, 11:00 EDT): https://www.worldtimebuddy.com/?qm=1&lid=2673730,5,8&h=5&date=2018-7-27&sln=11-12

The implementation draft is the newly submitted v-14: https://tools.ietf.org/html/draft-ietf-core-object-security-14
The test specifications are here: https://ericssonresearch.github.io/OSCOAP/test-spec5.html

We will use Jitsi: Link: https://meet.jit.si/OSCOREinterop (Dial-in: +1.512.402.2718 PIN: 4021790411#)
(Hangout link for backup: https://hangouts.google.com/call/uddAQ95d1wmuxZKdW-VKAAEI )

Thanks,
Francesca

From: Francesca Palombini <[email-masked]>
Sent: den 25 juli 2018 19:22
To: 'Core' <[email-masked]>; [email-masked]
Cc: Jim Schaad <[email-masked]>; Christian Amsüss <[email-masked]>; Mališa Vučinić <[email-masked]>
Subject: OSCORE Interop

Hi all,

Thanks,
Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Fri, 27 Jul 2018 18:11:16 +0000

Hi all,

The 6th interop for OSCORE was run successfully, big thanks to Jim and Christian for participating, short notice and all!

I compiled a report: https://ericssonresearch.github.io/OSCOAP/interop6.html

Moreover, I also recorded the session that can be now "seen" (it is actually audio only, you will need the test specifications to follow) on youtube: https://www.youtube.com/watch?v=uf4sBRlEYH0

Thanks to Jim and Christian for providing the pcap files, as usual you can find all of it in the "OSCORE interop" github: https://github.com/EricssonResearch/OSCOAP

There will be a (possibly shorter) follow up interop later in August to test the last Observe code, that was not functional yet. I will announce it here, but let me know if you'd like to participate, so that we can decide a time that fits.

Have a good (although burning hot) summer,
Francesca

Hi all,

Thanks,
Francesca