Subject: [core] ietf-comi:sid and draft-ietf-core-sid-04.txt

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 9 Jul 2018 17:31:19 +0200

Hi,

I see that ietf-sid-file (defined in draft-ietf-core-sid-04.txt) imports
ietf-comi in order to use ietf-comi:sid, which is defined as:

     typedef sid {
       type uint64;
       description
         "YANG Schema Item iDentifier";
       reference
         "[I-D.ietf-core-sid] YANG Schema Item iDentifier (SID)";
     }

I think it would be better if the sid type would be defined as part of
I-D.ietf-core-sid instead of being defined in ietf-comi. (I assume I
could use YANG/CBOR/SID with RESTCONF without having a dependency on
COMI.)

[It seems this is another case where people use YANG to define data
 that is not implemented in a datastore. Too bad we still have no
 proper way to do this.]

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Alexander Pelov <[email-masked]>
Date: Sun, 15 Jul 2018 21:25:39 -0400

Hi Juergen,

Good catch on that!

Also agree with you that it would be best to define SID in  draft-ietf-core-sid-04.txt and import it from CoMI.

Cheers,
Alexander

> On 9 Jul 2018, at 11:31, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Alexander Pelov <[email-masked]>
Date: Sun, 15 Jul 2018 21:27:59 -0400

Hi Juergen,

Good catch on that!

Cheers,
Alexander