Subject: [core] CoAP x HTTP Cross proxy (Was Re: CoRE Tools)

From: John Carter <[email-masked]>
Date: Wed, 25 Jul 2018 14:32:11 +1200

So I started to poke at what it would take to revive Copper addon for
firefox....

Then I backed off and decided that is probably the _wrong_ approach.

I now believe the correct approach is to use a vanilla web browser and a
CoAP to HTTP cross proxy.

This is likely to be the more compelling demonstrator.

The CoAP.technology site doesn't list any implementations.

I see rfc8075 exists which suggests someone has done it.

I have found https://github.com/ibm-security-innovation/crosscoap which,
unfortunately is the wrong way round.... ie. It presents a coap view of
http services.

Is anyone aware of any open source cross proxies that present a http view
of coap services?

Thank you,

-- 
John Carter
Phone : (64)(3) 358 6639
Tait Electronics
PO Box 1645 Christchurch
New Zealand

-- 
This Communication is Confidential. We only send and receive email on the

basis of the terms set out at www.taitradio.com/email_disclaimer 
<http://www.taitradio.com/email_disclaimer>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 25 Jul 2018 08:06:22 +0200

On Jul 25, 2018, at 04:32, John Carter <[email-masked]> wrote:
> 
> Is anyone aware of any open source cross proxies that present a http view of coap services?

I never open-sourced the code behind coap.me (which is just that) because it is based on some highly outdated HTTP server libraries and thus hard to install.  (I also never updated the specialized CoAP library behind it to what is now github.com/nning/coap.)

(FYI, coap.me is about 1500 lines of code, about 100 of which is the PCAP decoding support, plus some 400 lines of HTML templates.)

Grüße, Carsten

---

From: "Kraus Achim (INST/ECS4)" <[email-masked]>
Date: Wed, 25 Jul 2018 08:09:35 +0000

Hi John,

the californium eclipse project includes a coap-http proxy.
It has been update to use newer http libraries last autumn, see.
https://github.com/eclipse/californium/pull/479

If you’re interested, you may search for related issues e.g.
https://github.com/eclipse/californium/issues/678
or create new issues on github, if you need support.

Some "exotic issues" are not addressed right now,
but that should not be a "too large real world problem".

e.g.
https://tools.ietf.org/html/rfc7252#section-10.2.2

“Conditional HTTP GET requests that include an "If-Match" or "If-None-Match" request-header field can be mapped to a corresponding CoAP request.”

Either the http-options are mapped to the coap-options, which then causes conflicts with the different definitions of " If-None-Match" (http with arguments, coap without). Or the requests are mapped, potentially exchanging the options to achieve the same effect (but then, I would prefer to have that mapping more explicit).

See https://github.com/eclipse/californium/issues/664#issuecomment-399021467

Mit freundlichen Grüßen / Best regards 

Achim Kraus

(INST/ECS4) 
Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332 Waiblingen | GERMANY | http://www.bosch-si.com 

Sitz: Berlin, Registergericht: Amtsgericht Charlottenburg; HRB 148411 B
Aufsichtsratsvorsitzender: Dr.-Ing. Thorsten Lücke; Geschäftsführung: Dr. Stefan Ferber, Michael Hahn

From: core <[email-masked]> On Behalf Of John Carter
Sent: Mittwoch, 25. Juli 2018 04:32
To: [email-masked]
Subject: [core] CoAP x HTTP Cross proxy (Was Re: CoRE Tools)

So I started to poke at what it would take to revive Copper addon for firefox....

I now believe the correct approach is to use a vanilla web browser and a CoAP to HTTP cross proxy.

I have found https://github.com/ibm-security-innovation/crosscoap which, unfortunately is the wrong way round.... ie. It presents a coap view of http services.

Thank you,

-- 
John Carter
Phone : (64)(3) 358 6639
Tait Electronics                         
PO Box 1645 Christchurch
New Zealand

________________________________________
This Communication is Confidential. We only send and receive email on the
basis of the terms set out at http://www.taitradio.com/email_disclaimer
________________________________________

---

From: Olaf Bergmann <[email-masked]>
Date: Wed, 25 Jul 2018 10:35:10 +0200

Carsten Bormann <[email-masked]> writes:

> I never open-sourced the code behind coap.me (which is just that)
> because it is based on some highly outdated HTTP server libraries and
> thus hard to install.  (I also never updated the specialized CoAP
> library behind it to what is now github.com/nning/coap.)

Actually, the david fork in [1] might be useful here as it now supports
multiple sockets (i.e., you do not have to choose between HTTP and CoAP
exclusively). The CoAP client side is missing, though.

  [1] https://github.com/ruby-dtls

Grüße
Olaf