Subject: [core] Questions/comments on draft-ietf-core-sid-04

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 17 Jul 2018 18:05:51 +0000

Hi,

For “list items”:

  1.  It is a list with composite key namespace and identifier, why not have 2 levels instead, i.e. a namespace list (keyed on namespace) and each namespace has a list of identifiers (keyed on identifier)
  2.  Would it be useful to have another key based on sid?

Regards,
Reshad.

---

From: Michel Veillette <[email-masked]>
Date: Tue, 17 Jul 2018 18:35:33 +0000

Hi Reshad

About "why not have 2 levels instead"

The current single list solution has been selected for its simplicity to implement the sip.py pyang plugin.
The size of this module was not a concern since we had no intents to implement this module in the constrained device itself.
'yang-data' might be used in the next version to clarify this point.

About "Would it be useful to have another key based on sid".

Unless I'm wrong, YANG allow a single 'key' statement per list.
However, a 'unique' statement can be added to verify the uniqueness of this leaf.

Regards,
Michel

From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Tuesday, July 17, 2018 2:06 PM
To: [email-masked]
Cc: [email-masked]
Subject: Questions/comments on draft-ietf-core-sid-04

Hi,

For “list items”:

Regards,
Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 17 Jul 2018 18:58:03 +0000

Hi Michel,

Sorry you are right, it’s 1 key per list. Adding unique would be good.

Regards,
Reshad.

From: Michel Veillette <[email-masked]>
Date: Tuesday, July 17, 2018 at 2:35 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Questions/comments on draft-ietf-core-sid-04

Hi Reshad

Regards,
Michel

Hi,

For “list items”:

Regards,
Reshad.