Subject: [core] I-D Action: draft-ietf-core-too-many-reqs-04.txt

From: [email-masked]
Date: Tue, 24 Jul 2018 06:52:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments WG of the IETF.

        Title           : Too Many Requests Response Code for the Constrained Application Protocol
        Author          : Ari Keranen
	Filename        : draft-ietf-core-too-many-reqs-04.txt
	Pages           : 5
	Date            : 2018-07-24

Abstract:
   A Constrained Application Protocol (CoAP) server can experience
   temporary overload because one or more clients are sending requests
   to the server at a higher rate than the server is capable or willing
   to handle.  This document defines a new CoAP Response Code for a
   server to indicate that a client should reduce the rate of requests.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-core-too-many-reqs/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-core-too-many-reqs-04
https://datatracker.ietf.org/doc/html/draft-ietf-core-too-many-reqs-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-core-too-many-reqs-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ari Keränen <[email-masked]>
Date: Tue, 24 Jul 2018 13:54:31 +0000

This version addresses the WGLC comment from Jim about the potential "unexpected" 4.29 responses to first request.

Cheers,
Ari

> On 24 Jul 2018, at 16.52, [email-masked] wrote:
> 
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Jim Schaad <[email-masked]>
Date: Tue, 24 Jul 2018 08:21:59 -0700

I believe that this document is ready to progress.

> -----Original Message-----
> From: core <[email-masked]> On Behalf Of Ari Keränen
> Sent: Tuesday, July 24, 2018 6:55 AM
> To: core <[email-masked]>
> Subject: Re: [core] I-D Action: draft-ietf-core-too-many-reqs-04.txt
> 
> This version addresses the WGLC comment from Jim about the potential
> "unexpected" 4.29 responses to first request.
> 
> 
> Cheers,
> Ari
> 
> > This draft is a work item of the Constrained RESTful Environments WG of
the
> IETF.
> >
> >        Title           : Too Many Requests Response Code for the
Constrained
> Application Protocol
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: Klaus Hartke <[email-masked]>
Date: Tue, 24 Jul 2018 18:44:23 +0200

> I believe that this document is ready to progress.

+1

---

From: Benjamin Damm <[email-masked]>
Date: Tue, 24 Jul 2018 13:43:00 -0700

+1

If this document was standard we'd be using it today. We have this
problem is spades because proxy based throttling of CoAP transmissions
is turning into a big focus for us.  Today, we use 5.03 Service
Unavailable to handle this case of a client pushing too many requests
for a specific endpoint through a proxy. 4.29 is much preferred as it
more accurately describes the reason for the error.

The language added about the proxy is particularly relevant in our case.
Thanks for adding it.

-Ben

The 07/24/2018 08:21, Jim Schaad wrote:
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dcore-2Dtoo-2Dmany-2Dreqs_&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=WlnpPmykhIa64yCk6yt8hI_ETb61GTJMFlr7rfT1KUE&e=
> > >
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dcore-2Dtoo-2Dmany-2Dreqs-2D04&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=f2KxEosouR3KwV8Ob8hfhOMjVIGvPFmvZKie0mmgRgg&e=
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dcore-2Dtoo-2Dmany-2Dreqs-2D04&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=e1vsgQN0oLH15cyAn20MnMshBT70vPNOIkKe7-H28IM&e=
> > >
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dcore-2Dtoo-2Dmany-2Dreqs-2D04&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=UC0sa1wd1p7ievcQI4Ow-So0Q4gnOKx_QRi_FmJ8FzY&e=
> > >
> > >
> > > https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=CPAcV557eRgvQ3JqSakUmqJSWTHI1iRRMiIe01r1T6g&e=
> > >
> > > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_core&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=Twumogh3q7WSx2VRtnGlWUrd-ciuDcAa7POjM3YMuko&e=
> > 
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_core&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=Twumogh3q7WSx2VRtnGlWUrd-ciuDcAa7POjM3YMuko&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_core&d=DwIFAw&c=pqcuzKEN_84c78MOSc5_fw&r=GYGBKg0XeEBnyXmKSs4zZ6DBOYB5tLwwWSrFtYahCvs&m=6u-_cWKLHAItbJXiNqhsNXhwd3RWx1Bvs4ORCvkvB2I&s=Twumogh3q7WSx2VRtnGlWUrd-ciuDcAa7POjM3YMuko&e=

--

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Wed, 25 Jul 2018 10:07:13 +0530

+1

On Tue, 24 Jul 2018, 19:24 Ari Keränen, <[email-masked]> wrote:

> the IETF.
> Constrained Application Protocol
> >        Author          : Ari Keranen
> submission