Subject: [core] Upcoming virtual interim meetings (Re: CoRE@IETF102: Summary)

From: Carsten Bormann <[email-masked]>
Date: Wed, 8 Aug 2018 08:36:09 +0200

On Jul 20, 2018, at 15:15, Carsten Bormann <[email-masked]> wrote:
> 
> * CoRE will hold regular virtual interims starting from Aug 15.  The
>  regular date envisioned is every second Wednesday (with some gaps)
>  at 0800 California time.

I have requested the scheduling of these interim meetings now.
I expect we will be able to use IETF’s Webex system.

We should be doing the per-call agendas in near-time.
For the next meeting, I think we should focus on small housekeeping drafts and requests from other WGs/SDOs.

Specifically, this could be:
— DOTS: Hop-Limit option
— DOTS: Redirect response code
— echo/request-tag — can we have (and then discuss) the promised reviews, please?
— multipart-ct and CoAPs-EST early allocations
- 6tisch minimal security stateless proxy support (token extension vs. extended token option)

Please send in additional topics (remember that we have only one hour per call, though).

The first few of these regular calls are in a vacation period, so we have to be a bit flexible.
If we don’t get a good quorum on a subject (no reporter can be found for the call; key authors not available), we’ll postpone.

If you do want to lead a slot, please holler now and send in slides by Monday before the meeting.

Grüße, Carsten

---

From: Klaus Hartke <[email-masked]>
Date: Thu, 9 Aug 2018 10:22:45 +0200

> Please send in additional topics (remember that we have only one hour per

draft-ietf-lpwan-coap-static-context-hc-04

Klaus

---

From: Klaus Hartke <[email-masked]>
Date: Thu, 9 Aug 2018 14:50:30 +0200

> Please send in additional topics (remember that we have only one hour per

https://datatracker.ietf.org/ipr/3241/

Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Aug 2018 15:41:30 +0200

> https://datatracker.ietf.org/ipr/3241/

Right.  Not sure that we need to spend time on this in the interim.

At the next main meeting, the chairs plan to have a short segment on timely patent claim (“IPR”) disclosures.

{“chair-hat”: “off”, “discussion”: “

(Warning: The following lines are not legal advice, I’m not a lawyer.
Please stop reading here if you don’t want to be encumbered by the discussion; yes: in some jurisdictions what you know can be used against you.
As a general piece of advice that I’m not going to further detail, it is usually counterproductive to discuss validity of patent claims on an open mailing list.  I’m making an exception here for a reason.)

I don’t read patent claims, but made an exception here because of the surprise moment.

The priority date on this patent is March 2011, which is when we discussed having a way to communicate the total size of the representation of a resource that is accessed via the Block protocol.  At the time, one of the inventors listed on the patent had a draft describing a Size option for this(*).  These morphed into Size1, Size2, and eventually became a separate, independent part of the overall block-wise transfer protocol.

I personally don’t see a need for the WG to act here, for the following reasons:

— the licensing conditions seem fine to this non-lawyer (defensive/reciprocal only, no charge).
— the part of the block-wise protocol that could be affected (the Size1/Size2 options) are optimizations one can live without (and, as far as I am aware, are not widely implemented).
— frankly, if my hypothesis that there was no patent claim disclosure (“IPR disclosure”) at the time, and for seven more years, is true, that might weaken any claims.
— both a bug and a feature: This is a Chinese patent, so for many people any juridical handling of this may be harder to predict than for patent claims closer to home.  But then, this seems to be relevant for the Chinese market only.

All that said, of course, the patent claim is one more little thing someone might have to look at who wants to productize a full-function implementation of the block-wise transfer protocol, increasing transaction costs.

“}.  WG chair hat back on: 

I applaud Huawei for making this disclosure; late is better than never.
In the unlikely event that WG members do see a need for the WG to act on this disclosure, please converse in private with the chairs first: [email-masked]

Grüße, Carsten

(*) I cannot find a patent claim (“IPR”) disclosure on this: https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-li-core-coap-size-option — but maybe I’m not looking at the right place.