Subject: [core] progressing ietf-core-yang-cbor and ietf-core-sid

From: Michael Richardson <[email-masked]>
Date: Tue, 24 Dec 2019 18:50:46 -0500

{trying to clear out my inbox}

Michel Veillette <[email-masked]> laments:
    > The file "[email-masked]" is constructed with
    > an "import ietf-voucher" and a "uses v:voucher-artifact-grouping". For
    > this reason, part of the "yang-data voucher-constrained-artifact" is
    > defined in "ietf-voucher" with SIDs assigned within the scope of this
    > module.

    > This example raises an interesting point. "ietf-voucher" have been
    > defined without considering a possible constrained implementation and
    > have no SID list or .sid file included in RFC 8366. SIDs has been
    > assigned after the fact, as allowed by
    > https://tools.ietf.org/html/draft-ietf-core-sid-07#section-3. If we
    > include a SID list or .sid file for
    > "[email-masked]", part of the SIDs will be in
    > a RFC, the rest won't. To avoid such situation, we should rely entirely
    > on an IANA registry for all .sid files defined by RFCs.

I am still uncertain how this is going to work.

I have not seen any progress on:
  1) https://datatracker.ietf.org/doc/draft-ietf-core-yang-cbor/
  2) https://datatracker.ietf.org/doc/draft-ietf-core-sid/

At IETF105, it seemed that the documents were unstuck, and would progress
to WGLC soon.  Is there something holding this up other than author time?

I think that allocations were made for ietf-anima-constrained-voucher, but I
guess that was in the github version only.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Peter van der Stok <[email-masked]>
Date: Mon, 30 Dec 2019 11:08:07 +0100

> I also want to express my concern about the VERY slow progress of these documents.
> It is quite possible and understandable that the authors are occupied with too many other tasks.
> 
> An additional author may be the answer to unstick the progress.
> 
> Greetings,
> 
> Peter