Subject: [core] draft-ietf-core-sid-11: YANG Issues

From: Andy Bierman <[email-masked]>
Date: Tue, 10 Mar 2020 10:05:29 -0700

Hi,

I think this draft is very close but the YANG module still needs some
changes.
The JSON example does not match the YANG rc:yang-data definition yet.
There needs to be a JSON object for the top-level container so the JSON
conforms to RFC 7951.

rc:yang-data sid-file {
      uses sid-file;
}

grouping sid-file {
   container sid-file {
       // existing YANG objects inserted here
   }
}

JSON:

{  "ietf-sid-file:sid-file" : {
       //  existing JSON objects inserted here
    }
}

Minor YANG Issues (suggestions)
1) move the object definitions to a grouping so they can be reused
2) name the container "sid-file" instead of "content"
3) change the order of the objects so the "header" fields will be first
   (module-name, module-revision, sid-file-version)
4) consider adding a "description" leaf to the header.  JSON does not
   support comments or annotations, but this JSON file is really intended
   to be used by automation tools.  IMO, JSON is not a very good choice
   as a source code document, but a description string can help a little.
  It can also contain extra metadata such as the SID file creation time.

Andy

---

From: Ivaylo Petrov <[email-masked]>
Date: Wed, 11 Mar 2020 09:51:11 +0100

Hello, Andy,

Thank you for your review! I believe all your suggestions make sense and
I/we are going to implement them in the following days.

Best regards,
Ivaylo

On Tue, Mar 10, 2020 at 6:05 PM Andy Bierman <[email-masked]> wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>