Subject: Re: [core] Proposed new SenML Units

From: Jaime Jiménez <[email-masked]>
Date: Tue, 26 Jan 2021 16:31:01 +0200

Dear all,

pinging on this. Is it there anything else that needs to be done to add this to the secondary registry?
It's something we need for IPSO as we have new objects coming.

Ciao!
-- 
Jaime Jiménez

On Tue, Nov 17, 2020, at 12:16 AM, Carsten Bormann wrote:
> On 2020-11-16, at 22:59, Jaime Jiménez <[email-masked]> wrote:
> > 
> > intriduce new errors:
> 
> Something weird happened with the table lines.
> 
> The units need to be singular, i.e., milligram, not milligrams.
> 
> (For ppb, ppt we probably want to stay with “parts per…” as this is 
> vernacular anyway.)
> 
> Grüße, Carsten
> 
> 
> 
>

---

From: Jaime Jiménez <[email-masked]>
Date: Tue, 26 Jan 2021 17:32:39 +0200

Hi again, 

this is the last version I have of the table.

On the SenML Units registry:

+===========+================================+=======+                      
| Symbol    | Description                    | Type  |
+===========+================================+=======+
| NTU       | Nephelometric Turbidity Unit   | Float |                     
+-----------+--------------------------------+-------+

On the Secondary Units registry:

+=========+======================+======+==========+======+
|Secondary| Description          |SenML |   Scale  |Offset|
| Unit    |                      | Unit |          |      |
+=========+======================+======+==========+======+
| ppb     | parts per billion    | /    |   1e-9   |    0 |
+---------+----------------------+------+----------+------+
| ppt     | parts per trillion   | /    |   1e-12  |    0 |
+---------+----------------------+------+----------+------+
| VAh     | volt-ampere hour     | VAs  |   3600   |    0 |
+---------+----------------------+------+----------+------+
| mg/l    | milligram per liter  | kg/m3|   1/1000 |    0 |
+---------+----------------------+------+----------+------+
| ug/l    | microgram per liter  | kg/m3|   1e-6   |    0 | 
+---------+----------------------+------+----------+------+
| g/l     | gram per liter       | kg/m3|     1    |    0 |
+---------+----------------------+------+----------+------+

A reference for NTU can be found here for example: https://www.iso.org/standard/62801.html
If someone has more experience and knows better references, please let me know.

Ciao!
-- 
Jaime Jiménez

On Tue, Jan 26, 2021, at 4:31 PM, Jaime Jiménez wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 Jan 2021 16:54:26 +0100

This looks good to me.
The reference should probably say that it points to ISO 7027-1:2016.

I don’t know why we used both “volt-ampere second” (one hyphen) and "kilovolt-ampere-hour” (two hyphens) in RFC 8798, so “volt-ampere hour” isn’t more inconsistent than RFC 8798 already is to itself, but I would still write “volt-ampere-hour”.

The next step would be for you to ask IANA to register these, based on https://mailarchive.ietf.org/arch/msg/core/I7u1kV6VXIrU7wjfRhghlTplfxA/

(The expert for the secondary registry opened in RFC 8798 is unassigned; I’m sure IANA will get that fixed in the process.)

Grüße, Carsten

> On 2021-01-26, at 16:32, Jaime Jiménez <[email-masked]> wrote:
> 
> Hi again, 
>

---

From: Jaime Jiménez <[email-masked]>
Date: Tue, 26 Jan 2021 18:47:02 +0200

Great!! I’ll send it now then, thanks!

-- 
Jaime Jiménez

On Tue, Jan 26, 2021, at 5:54 PM, Carsten Bormann wrote:
> I don’t know why we used both “volt-ampere second” (one hyphen) and 
> "kilovolt-ampere-hour” (two hyphens) in RFC 8798, so “volt-ampere hour” 
> isn’t more inconsistent than RFC 8798 already is to itself, but I would 
> still write “volt-ampere-hour”.
> 
> The next step would be for you to ask IANA to register these, based on 
> https://mailarchive.ietf.org/arch/msg/core/I7u1kV6VXIrU7wjfRhghlTplfxA/
> 
> (The expert for the secondary registry opened in RFC 8798 is 
> unassigned; I’m sure IANA will get that fixed in the process.)
> 
> Grüße, Carsten
> 
>