Subject: [core] Review of draft-ietf-core-senml-versions-01

From: Jaime Jiménez <[email-masked]>
Date: Fri, 12 Feb 2021 10:39:30 +0200

Dear authors,

first of all I'd like to apologise for the delay when providing the review.

While I did not find any mistakes, there are few additions to the document that *could* help clarify it for the benefit of the readers:

- Mention somewhere in the text that the maximum amount of features is 53 and that therefore the highest version number is 2**53-1 in decimal notation. Therefore readers should not expect the usual linear semantic versioning for each version (1,2,3,4...) but rather (10, 26, 42, 58...).

- Give an example of the current bitmap -for example in a double or float representation- providing all features that are currently supported for bver=26.

00000000 00000000
00000000 00000000
00000000 00000000
00000000 00011010

- The limitation to 53 versions in total as well as potential feature deprecation was already discussed in various IETFs and neither authors nor the group see that as a limitation. I agree with that providing that expert review is conservative when adding new features. Potentially we could also think about bundling some future features if they are related before publication; but it is very hard to forecast that.

Note that, ahead of the shepherd writeup, it would be good to document existing implementations out there.

Editorial:

"Network Working Group" should be CoRE.

independently selectable "features"
Use of quotes for features seems unnecessary, as those literally are features.                       
   
Ciao!
-- 
Jaime Jiménez

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 12 Feb 2021 10:48:31 +0100

> - Mention somewhere in the text that the maximum amount of features is 53 and that therefore the highest version number is 2**53-1 in decimal notation. Therefore readers should not expect the usual…

Actually, that is already mentioned in the IANA Considerations.
I have now added a subsection “Discussion” to Section 2 .

> - Give an example of the current bitmap -for example in a double or float representation- providing all features that are currently supported for bver=26.

This example has 64 bits; we only have 53…
I’ve put in 0b00000000000000000000000000000000000000000000000001010 as an example.

> - The limitation to 53 versions in total as well as potential feature deprecation was already discussed in various IETFs and neither authors nor the group see that as a limitation. I agree with tha…

Added discussion of an allocation rate limit of about two codes per year or less.

> "Network Working Group" should be CoRE.

(Will go away in the RFC.)

> Use of quotes for features seems unnecessary, as those literally are features.                       

Went for italic (but not in the abstract, where fonts are more easily lost).

Thanks!

Now https://github.com/core-wg/senml-versions/pull/1
(WG members: Please review and approve and/or comment!)

Grüße, Carsten

---

From: Jaime Jiménez <[email-masked]>
Date: Fri, 12 Feb 2021 12:18:19 +0200

Thanks Carsten,

much more clear now, I added the review on GitHub.

BTW there seems to be some travis-ci issue. 
https://travis-ci.org/github/core-wg/senml-versions/jobs/758663186

I have replicated the same error on other repos. It seems the container is not launched for some reason. 

Also, in few weeks we might have to spend some time migrating from travis-ci.org to .com. I don't think it will be fully automatic.

Ciao!
-- 
Jaime Jiménez

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 21 Feb 2021 19:05:46 +0100

> https://travis-ci.org/github/core-wg/senml-versions/jobs/758663186

Generally, travis seems to have problems and we are moving to github workflows anyway.

The docker image that I-d-template currently uses does not support the kind of math(*) that is used in the document, so right now builds need to be manual.

Grüße, Carsten

(*) Yes, one can have math in plaintext and HTML I-Ds and RFCs!