Subject: [core] Endpoint type (et) vs. resource type (rt)

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Feb 2021 14:42:37 +0100

CoRE RD defines an endpoint type (et).

https://w3c.github.io/wot-discovery/#introduction-core-rd
… uses the endpoint type as if it were a replacement for RFC 6990 rt (resource type).

Is this replacement where we want to steer people to?

Grüße, Carsten

---

From: Christian Amsüss <[email-masked]>
Date: Tue, 16 Feb 2021 21:23:04 +0100

> Is this replacement where we want to steer people to?

No -- but it's not so much the et/rt that bugs me, but rather that they
intend to do endpoint lookups rather than resource lookups.

Opened <https://github.com/w3c/wot-discovery/issues/120>; maybe the
reactions also give a clue on why that turn was taken.

thx
c

-- 
Build a man a fire, and he'll be warm for a day. Set a man on fire, and
he'll be warm for the rest of his life.
  -- Terry Pratchett (attributed)