Subject: [core] Content-Format size for yang-cbor

From: Carsten Bormann <[email-masked]>
Date: Tue, 16 Mar 2021 21:10:36 +0100

In the IANA review of draft-ietf-core-yang-cbor, the question was raised what allocation range should be used for the content-format number for 

application/yang-data+cbor;id=name

I believe this content-type will be used mostly for less size-sensitive applications, as a name is used for YANG identifiers and not a YANG SID.
So I think we are fine in the range:

   256-9999    IETF Review or IESG Approval

e.g., 260.

Any disagreement (or support)?

Grüße, Carsten

---

From: Alexander Pelov <[email-masked]>
Date: Tue, 16 Mar 2021 22:47:44 +0100

Dear Carsten,

I agree with you on the proposed allocation - 260 should do well.

Cheers,
Alexander

On Tue, Mar 16, 2021 at 9:10 PM Carsten Bormann <[email-masked]> wrote:

> In the IANA review of draft-ietf-core-yang-cbor, the question was raised
> what allocation range should be used for the content-format number for
>
> I believe this content-type will be used mostly for less size-sensitive
> applications, as a name is used for YANG identifiers and not a YANG SID.
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Mar 2021 21:10:36 +0100

And, of course the same thing for draft-ietf-core-sid and application/yang-data+cbor;id=sid.

In this case, I believe that YANG-based data structures will not just be used in the context of the larger interchanges typical of CORECONF, but also for data structures specified in YANG and interchanged separately.
Some of these will be rather small and will benefit from YANG-CBOR’s delta compression.
So I believe going for a one-byte value is more appropriate in this case.

So that the two allocations for id=sid and id=name are a bit more memorable, I now propose:

264 application/yang-data+cbor;id=name
 64 application/yang-data+cbor;id=sid

Again, comments welcome.

Grüße, Carsten

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 18 Mar 2021 11:00:27 +0100

Dear Carsten,

Thanks for reading the IANA remarks so quickly and for the proposal.
Seems perfect to me.

Cheers,
Alexander

On Wed, Mar 17, 2021 at 9:10 PM Carsten Bormann <[email-masked]> wrote:

> In this case, I believe that YANG-based data structures will not just be
> used in the context of the larger interchanges typical of CORECONF, but
> also for data structures specified in YANG and interchanged separately.