Subject: [core] CoRE WG Virtual Interim 2021-04-28

From: Marco Tiloca <[email-masked]>
Date: Wed, 21 Apr 2021 18:07:26 +0200

Dear all,

Just a reminder that we'll have a virtual interim meeting on Wednesday, 
April 28th at 14:00 UTC. The agenda is available at [1].

Best,
Marco and Jaime

[1] https://datatracker.ietf.org/meeting/interim-2021-core-04/session/core

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System
Department: Computer Science
Unit: Cybersecurity

RISE Research Institutes of Sweden
https://www.ri.se

Phone: +46 (0)70 60 46 501
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)

---

From: Marco Tiloca <[email-masked]>
Date: Wed, 28 Apr 2021 14:04:05 +0200

Dear all,

Just a reminder that we are having our virtual interim meeting in 
slightly less than 2 hours [1].

Please find below the information to join.

Best,
Marco and Jaime

=== Meeting Information ===

Jabber: [email-masked]

Etherpad: https://codimd.ietf.org/notes-ietf-interim-2021-core-04-core

Meeting link: 
https://ietf.webex.com/ietf/j.php?MTID=m888a990760425271a1327f53c6714b07

Meeting number: 185 248 9231
Password: constrained

More ways to join

Join by video system
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

Join by phone
1-650-479-3208 Call-in number (US/Canada)
Access code: 185 248 9231

On 2021-04-21 18:07, Marco Tiloca wrote:
> Dear all,
>
> Just a reminder that we'll have a virtual interim meeting on 
> Wednesday, April 28th at 14:00 UTC. The agenda is available at [1].
>
> Best,
> Marco and Jaime
>
> [1] 
> https://datatracker.ietf.org/meeting/interim-2021-core-04/session/core
>

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System

---

From: John Mattsson <[email-masked]>
Date: Thu, 29 Apr 2021 09:57:45 +0000

Hi,

Below are my thoughts after the interim yesterday:

- Two equally important reasons to rekey, AEAD limits and forward secrecy. A document
  updating OSCORE should treat both with equal weight.
- Frequent rekeying require efficient rekeying, should be published together.
- Other questions like error messages etc., needs to be specified at the same time.
- The limit setting process used in TLS is flawed and should probably not be used at all.
- The limits in TLS are secure, any limits equal or lower does not need motivation.
- Poly1305 v, GCM v, ChaCha20 q does not need any AEAD limits at all.
- CCM v, CCM q, GCM q should be rekeyed around 2^23 - 2^24.5 like in TLS
- CCM_8 v could be used much longer, maybe 2^35 
- Should consider lowering l and CCM q compared to TLS to make CCM_8 behave even more like perfect MAC (right now the attacker can look at 2^23 messages and then send a single forgery attempt). This single forgery attempt succeds with probability 2^60.
- Might be easier to set simple limit of q, v = 2^20 or 2^23 for all algorithms.
- The limit l = 2^10 is measured in blocks (worst case), In bytes the limit is
  2^10 * 2^4 = 2^14 bytes = 16 kB.
- Can be discussed which limits should be MUST or SHOULD.
- Focus on discussion needs to be on how q,v,l limits and rekeying affect applications.

Cheers,
John

-----Original Message-----
From: core <[email-masked]> on behalf of Marco Tiloca <[email-masked]>
Date: Wednesday, 28 April 2021 at 14:04
To: "[email-masked] WG ([email-masked])" <[email-masked]>
Subject: Re: [core] CoRE WG Virtual Interim 2021-04-28

Dear all,

Best,
Marco and Jaime

Meeting link: 

More ways to join

Join by video system

Join by phone

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System

RISE Research Institutes of Sweden
https://protect2.fireeye.com/v1/url?k=4c4a5987-13d16165-4c4a191c-86073b36ea28-2adec21f03723771&q=1&e=dc609331-6b2f-490c-b545-f937c703f065&u=https%3A%2F%2Fwww.ri.se%2F