Subject: [core] AD review of draft-ietf-core-senml-versions-02

From: Francesca Palombini <[email-masked]>
Date: Sun, 18 Apr 2021 19:01:47 +0000

Thanks for the work on this document. Two very minor comments below, to take or leave as you see fit. Please handle these comments together with the Last Call comments.

Francesca

1. -----
                __ 52                      fc
   version  =  \          present(fc) ⋅ 2
               /__ fc = 0

FP: Creative way to express a sumation in text. Maybe a sentence about the fact that sigma is represented this way in the text might be good. Also, the terminology section states that exponentiation is expressed with superscript notation X^(Y), but that is not used here.

2. -----

Since the Secondary Units is defined in RFC 8798, it would make sense in my opinion to add that RFC to the Specification column. In practice, it would make sense to me to add to the specification column not only the document where the feature code number is defined, but also the specification where the feature indicated is defined.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 19 Apr 2021 13:53:05 +0200

On 2021-04-18, at 21:01, Francesca Palombini <[email-masked]> wrote:
> FP: Creative way to express a sumation in text.

Thanks to asciitex, as suggested (and now maintained) by Lars Eggert…

Looks much better in SVG, https://www.ietf.org/archive/id/draft-ietf-core-senml-versions-02.html#section-2-3.1

But the text in the paragraph above already talks about the sum and taking 2 to the power, so the display math is just an illustration.

> Maybe a sentence about the fact that sigma is represented this way in the text might be good. Also, the terminology section states that exponentiation is expressed with superscript notation X^(Y), but that is not used here.

We don’t have a good way to handle the discrepancies between TXT and HTML.
I added a note about the superscript notation to 1.1, but not about the sigma, which is just ascii-art...

> Since the Secondary Units is defined in RFC 8798, it would make sense in my opinion to add that RFC to the Specification column. In practice, it would make sense to me to add to the specification c…

Added.

Also added:

> Where the specification of the feature code is provided in a document
> that is separate from the specification of the feature itself (as with
> feature code 4 above), both specifications should be listed.

Changes are now in https://github.com/core-wg/senml-versions/commit/105c346

Thank you!

Grüße, Carsten